- Update to 4.85

This commit is contained in:
Bastien Nocera 2011-01-13 14:52:36 +00:00
parent 9befcf2c86
commit 91d0f563d5
6 changed files with 32 additions and 28 deletions

1
.gitignore vendored
View File

@ -11,3 +11,4 @@ bluez-4.70.tar.gz
/bluez-4.80.tar.gz
/bluez-4.81.tar.gz
/bluez-4.82.tar.gz
/bluez-4.85.tar.gz

View File

@ -1,7 +1,7 @@
From 14d6380cb9921ea09dc63d9401cb31c8f691449e Mon Sep 17 00:00:00 2001
From cdf56c93397ebd284b7f7d369af389d5b82919f5 Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Tue, 1 Sep 2009 17:32:48 +0100
Subject: [PATCH] Add sixaxis cable-pairing plugin
Subject: [PATCH 1/3] Add sixaxis cable-pairing plugin
Implement the old "sixpair" using libudev and libusb-1.0.
@ -108,7 +108,7 @@ index 287f07d..aab0c15 100644
+ AM_CONDITIONAL(CABLE, test "${cable_enable}" = "yes" && test "${cable_found}" = "yes")
])
diff --git a/configure.ac b/configure.ac
index 5f09cb6..0f73314 100644
index 1ec2dfd..b4c2482 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,6 +40,7 @@ AC_PATH_GLIB
@ -508,10 +508,10 @@ index 0000000..e8cff76
+BLUETOOTH_PLUGIN_DEFINE(cable, VERSION,
+ BLUETOOTH_PLUGIN_PRIORITY_DEFAULT, cable_init, cable_exit)
diff --git a/src/adapter.c b/src/adapter.c
index 5118306..6318d12 100644
index 87a8beb..6851b23 100644
--- a/src/adapter.c
+++ b/src/adapter.c
@@ -1056,6 +1056,25 @@ static struct btd_device *adapter_create_device(DBusConnection *conn,
@@ -1072,6 +1072,25 @@ static struct btd_device *adapter_create_device(DBusConnection *conn,
return device;
}
@ -538,25 +538,25 @@ index 5118306..6318d12 100644
struct btd_device *device,
gboolean remove_storage)
diff --git a/src/adapter.h b/src/adapter.h
index a02f61c..472cc0e 100644
index 250c65e..32725eb 100644
--- a/src/adapter.h
+++ b/src/adapter.h
@@ -133,6 +133,9 @@ int adapter_remove_found_device(struct btd_adapter *adapter, bdaddr_t *bdaddr);
@@ -145,6 +145,9 @@ void adapter_update_found_devices(struct btd_adapter *adapter, bdaddr_t *bdaddr,
int adapter_remove_found_device(struct btd_adapter *adapter, bdaddr_t *bdaddr);
void adapter_emit_device_found(struct btd_adapter *adapter,
struct remote_dev_info *dev,
uint8_t *eir_data, size_t eir_length);
struct remote_dev_info *dev);
+void adapter_create_device_for_device(DBusConnection *conn,
+ struct btd_adapter *adapter,
+ struct btd_device *device);
void adapter_mode_changed(struct btd_adapter *adapter, uint8_t scan_mode);
void adapter_update_local_name(struct btd_adapter *adapter, const char *name);
void adapter_service_insert(const bdaddr_t *bdaddr, void *rec);
void adapter_service_insert(struct btd_adapter *adapter, void *rec);
diff --git a/src/manager.c b/src/manager.c
index c8ec7e5..1bfc021 100644
index e805e0c..254ace4 100644
--- a/src/manager.c
+++ b/src/manager.c
@@ -245,6 +245,11 @@ static void manager_update_adapters(void)
g_free(array);
@@ -262,6 +262,11 @@ static void manager_set_default_adapter(int id)
DBUS_TYPE_INVALID);
}
+struct btd_adapter *manager_get_default_adapter(void)
@ -568,17 +568,17 @@ index c8ec7e5..1bfc021 100644
{
uint16_t dev_id = adapter_get_dev_id(adapter);
diff --git a/src/manager.h b/src/manager.h
index e6d5dd9..894dcb7 100644
index 05c38b3..4f92d2f 100644
--- a/src/manager.h
+++ b/src/manager.h
@@ -35,6 +35,7 @@ struct btd_adapter *manager_find_adapter(const bdaddr_t *sba);
struct btd_adapter *manager_find_adapter_by_address(const char *address);
struct btd_adapter *manager_find_adapter_by_path(const char *path);
@@ -35,6 +35,7 @@ void manager_cleanup(DBusConnection *conn, const char *path);
const char *manager_get_base_path(void);
struct btd_adapter *manager_find_adapter(const bdaddr_t *sba);
struct btd_adapter *manager_find_adapter_by_id(int id);
+struct btd_adapter *manager_get_default_adapter(void);
void manager_foreach_adapter(adapter_cb func, gpointer user_data);
GSList *manager_get_adapters(void);
int manager_register_adapter(int id, gboolean devup);
int manager_unregister_adapter(int id);
struct btd_adapter *btd_manager_register_adapter(int id);
--
1.7.3.2

View File

@ -1,7 +1,7 @@
From a4d043bc4c36b9dfff664d36ff724927d5817774 Mon Sep 17 00:00:00 2001
From 1dea0eac302036bd165f9e3e386c40da25512005 Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Mon, 8 Nov 2010 16:43:42 +0000
Subject: [PATCH] Handle ISO8859-1 device names
Subject: [PATCH 3/3] Handle ISO8859-1 device names
http://thread.gmane.org/gmane.linux.bluez.kernel/1687
https://bugzilla.redhat.com/show_bug.cgi?id=450081
@ -10,10 +10,10 @@ https://bugzilla.redhat.com/show_bug.cgi?id=450081
1 files changed, 10 insertions(+), 3 deletions(-)
diff --git a/src/event.c b/src/event.c
index 47b50c4..1dbcad3 100644
index 5d0bf6d..dc58dbd 100644
--- a/src/event.c
+++ b/src/event.c
@@ -478,9 +478,16 @@ void btd_event_remote_name(bdaddr_t *local, bdaddr_t *peer, uint8_t status,
@@ -652,9 +652,16 @@ void btd_event_remote_name(bdaddr_t *local, bdaddr_t *peer, uint8_t status,
/* It's ok to cast end between const and non-const since
* we know it points to inside of name which is non-const */

View File

@ -1,7 +1,7 @@
From d3cf8827053a239009d35995c0e06744d2bd331a Mon Sep 17 00:00:00 2001
From d205c2e05061a3f3502cccd0b157348cdc6e1071 Mon Sep 17 00:00:00 2001
From: Lennart Poettering <lennart@poettering.net>
Date: Wed, 21 Jul 2010 19:20:44 +0200
Subject: [PATCH] systemd: install systemd unit files
Subject: [PATCH 2/3] systemd: install systemd unit files
This also enables bus activation for bluetoothd, but only if systemd is
running. Only if that's the case we can make sure in a race-free fashion
@ -65,7 +65,7 @@ index 6044082..3ed5bcc 100644
MAINTAINERCLEANFILES = Makefile.in \
aclocal.m4 configure config.h.in config.sub config.guess \
diff --git a/configure.ac b/configure.ac
index 3348ee8..5244f73 100644
index b4c2482..a807830 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,5 +56,14 @@ if (test "${enable_capng}" = "yes"); then

View File

@ -1,6 +1,6 @@
Summary: Bluetooth utilities
Name: bluez
Version: 4.82
Version: 4.85
Release: 1%{?dist}
License: GPLv2+
Group: Applications/System
@ -288,6 +288,9 @@ fi
%{_mandir}/man1/pand.1.gz
%changelog
* Thu Jan 13 2011 Bastien Nocera <bnocera@redhat.com> 4.85-1
- Update to 4.85
* Sun Dec 19 2010 Bastien Nocera <bnocera@redhat.com> 4.82-1
- Update to 4.82

View File

@ -1 +1 @@
b9e5de607e5e43c868c35c68fe6f189f bluez-4.82.tar.gz
8d201d31fc6d28d46d5a2000d3b3eb07 bluez-4.85.tar.gz