fix build with gcc 4.7, cleanup spec
This commit is contained in:
parent
2c0b61ebc4
commit
891fff9e78
26
.gitignore
vendored
26
.gitignore
vendored
@ -1,25 +1 @@
|
||||
bluez-4.69.tar.gz
|
||||
bluez-4.70.tar.gz
|
||||
/bluez-4.71.tar.gz
|
||||
/bluez-4.72.tar.gz
|
||||
/bluez-4.73.tar.gz
|
||||
/bluez-4.74.tar.gz
|
||||
/bluez-4.76.tar.gz
|
||||
/bluez-4.77.tar.gz
|
||||
/bluez-4.78.tar.gz
|
||||
/bluez-4.79.tar.gz
|
||||
/bluez-4.80.tar.gz
|
||||
/bluez-4.81.tar.gz
|
||||
/bluez-4.82.tar.gz
|
||||
/bluez-4.85.tar.gz
|
||||
/bluez-4.86.tar.gz
|
||||
/bluez-4.87.tar.gz
|
||||
/bluez-4.88.tar.gz
|
||||
/bluez-4.89.tar.gz
|
||||
/bluez-4.90.tar.gz
|
||||
/bluez-4.93.tar.gz
|
||||
/bluez-4.94.tar.gz
|
||||
/bluez-4.95.tar.gz
|
||||
/bluez-4.96.tar.gz
|
||||
/bluez-4.97.tar.gz
|
||||
/bluez-4.98.tar.gz
|
||||
/bluez-4.*.tar.gz
|
||||
|
25
bluez.spec
25
bluez.spec
@ -1,9 +1,11 @@
|
||||
Summary: Bluetooth utilities
|
||||
Name: bluez
|
||||
Version: 4.98
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
URL: http://www.bluez.org/
|
||||
|
||||
Source: http://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.gz
|
||||
Source3: dund.init
|
||||
Source4: dund.conf
|
||||
@ -19,7 +21,7 @@ Patch5: 0001-Add-sixaxis-cable-pairing-plugin.patch
|
||||
# http://thread.gmane.org/gmane.linux.bluez.kernel/8645
|
||||
Patch6: 0001-systemd-install-systemd-unit-files.patch
|
||||
|
||||
URL: http://www.bluez.org/
|
||||
Patch7: sbc_mmx.patch
|
||||
|
||||
BuildRequires: flex
|
||||
BuildRequires: dbus-devel >= 0.90
|
||||
@ -38,8 +40,8 @@ BuildRequires: udev
|
||||
# For rebuild
|
||||
BuildRequires: libtool autoconf automake
|
||||
|
||||
Obsoletes: bluez-pan < 4.0, bluez-sdp < 4.0
|
||||
Requires: initscripts, bluez-libs = %{version}
|
||||
Requires: bluez-libs = %{version}-%{release}
|
||||
Requires: initscripts
|
||||
Requires: dbus >= 0.60
|
||||
Requires: hwdata >= 0.215
|
||||
%ifnarch s390 s390x
|
||||
@ -49,9 +51,6 @@ Requires: udev >= 143-2
|
||||
Requires(preun): /sbin/chkconfig, /sbin/service
|
||||
Requires(post): /sbin/chkconfig, /sbin/service
|
||||
|
||||
Obsoletes: bluez-utils < 4.5-2
|
||||
Provides: bluez-utils = %{version}-%{release}
|
||||
|
||||
%description
|
||||
Utilities for use in Bluetooth applications:
|
||||
- hcitool
|
||||
@ -73,27 +72,20 @@ Summary: Development libraries for Bluetooth applications
|
||||
Group: Development/Libraries
|
||||
Requires: bluez-libs = %{version}-%{release}
|
||||
Requires: pkgconfig
|
||||
Obsoletes: bluez-sdp-devel < 4.0
|
||||
|
||||
%package cups
|
||||
Summary: CUPS printer backend for Bluetooth printers
|
||||
Group: System Environment/Daemons
|
||||
Obsoletes: bluez-utils-cups < 4.5-2
|
||||
Provides: bluez-utils-cups = %{version}-%{release}
|
||||
Requires: bluez-libs = %{version}-%{release}
|
||||
Requires: cups
|
||||
|
||||
%package gstreamer
|
||||
Summary: GStreamer support for SBC audio format
|
||||
Group: System Environment/Daemons
|
||||
Obsoletes: bluez-utils-gstreamer < 4.5-2
|
||||
Provides: bluez-utils-gstreamer = %{version}-%{release}
|
||||
Requires: bluez-libs = %{version}-%{release}
|
||||
|
||||
%package alsa
|
||||
Summary: ALSA support for Bluetooth audio devices
|
||||
Obsoletes: bluez-utils-alsa < 4.5-2
|
||||
Provides: bluez-utils-alsa = %{version}-%{release}
|
||||
Group: System Environment/Daemons
|
||||
Requires: bluez-libs = %{version}-%{release}
|
||||
|
||||
@ -154,6 +146,7 @@ and mouse.
|
||||
%patch4 -p1 -b .socket-mobile
|
||||
%patch5 -p1 -b .cable-pairing
|
||||
%patch6 -p1 -b .systemd
|
||||
%patch7 -p1 -b .mmx
|
||||
|
||||
%build
|
||||
libtoolize -f -c
|
||||
@ -315,6 +308,10 @@ fi
|
||||
%{_mandir}/man8/hid2hci.8*
|
||||
|
||||
%changelog
|
||||
* Fri Feb 24 2012 Peter Robinson <pbrobinson@fedoraproject.org> 4.98-2
|
||||
- Add mmx patch to fix build of sbc component
|
||||
- clean up spec, drop ancient obsoletes
|
||||
|
||||
* Fri Jan 13 2012 Bastien Nocera <bnocera@redhat.com> 4.98-1
|
||||
- Update to 4.98
|
||||
|
||||
|
13
sbc_mmx.patch
Normal file
13
sbc_mmx.patch
Normal file
@ -0,0 +1,13 @@
|
||||
Index: bluez/sbc/sbc_primitives_mmx.c
|
||||
===================================================================
|
||||
--- bluez.orig/sbc/sbc_primitives_mmx.c 2012-01-04 12:06:47.231873000 -0500
|
||||
+++ bluez/sbc/sbc_primitives_mmx.c 2012-01-04 12:07:34.748103759 -0500
|
||||
@@ -318,7 +318,7 @@
|
||||
"movl %k0, 4(%3)\n"
|
||||
: "+r" (blk)
|
||||
: "r" (&sb_sample_f[0][ch][sb]),
|
||||
- "i" ((char *) &sb_sample_f[1][0][0] -
|
||||
+ "r" ((char *) &sb_sample_f[1][0][0] -
|
||||
(char *) &sb_sample_f[0][0][0]),
|
||||
"r" (&scale_factor[ch][sb]),
|
||||
"r" (&consts),
|
Loading…
Reference in New Issue
Block a user