Update downstream patches
This commit is contained in:
parent
d6c4f0817c
commit
87f5376d5c
@ -1,4 +1,4 @@
|
||||
From 930d4ff4c8ce7344cd8c69c149bb695d82fa9548 Mon Sep 17 00:00:00 2001
|
||||
From aab7b43b4ad63b97a0f00c1fdf030390c42c8a5f Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Tue, 1 Sep 2009 17:32:48 +0100
|
||||
Subject: [PATCH] Add sixaxis cable-pairing plugin
|
||||
@ -17,11 +17,11 @@ address, and added to the database of the current default adapter.
|
||||
create mode 100644 plugins/cable.c
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 7895be2..8bf6c88 100644
|
||||
index b3aa25e..d0814a3 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -192,6 +192,11 @@ builtin_sources += attrib/main.c \
|
||||
attrib/example.h attrib/example.c
|
||||
@@ -204,6 +204,11 @@ builtin_sources += health/hdp_main.c health/hdp_types.h \
|
||||
health/hdp_util.h health/hdp_util.c
|
||||
endif
|
||||
|
||||
+if CABLE
|
||||
@ -32,7 +32,7 @@ index 7895be2..8bf6c88 100644
|
||||
builtin_modules += hciops
|
||||
builtin_sources += plugins/hciops.c
|
||||
|
||||
@@ -237,7 +242,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
|
||||
@@ -249,7 +254,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
|
||||
src/dbus-common.c src/dbus-common.h \
|
||||
src/dbus-hci.h src/dbus-hci.c
|
||||
src_bluetoothd_LDADD = lib/libbluetooth.la @GLIB_LIBS@ @DBUS_LIBS@ \
|
||||
@ -41,7 +41,7 @@ index 7895be2..8bf6c88 100644
|
||||
src_bluetoothd_LDFLAGS = -Wl,--export-dynamic \
|
||||
-Wl,--version-script=src/bluetooth.ver
|
||||
src_bluetoothd_DEPENDENCIES = src/bluetooth.ver lib/libbluetooth.la
|
||||
@@ -352,7 +357,7 @@ EXTRA_DIST += doc/manager-api.txt \
|
||||
@@ -364,7 +369,7 @@ EXTRA_DIST += doc/manager-api.txt \
|
||||
|
||||
AM_YFLAGS = -d
|
||||
|
||||
@ -51,7 +51,7 @@ index 7895be2..8bf6c88 100644
|
||||
|
||||
INCLUDES = -I$(builddir)/lib -I$(builddir)/src -I$(srcdir)/src \
|
||||
diff --git a/acinclude.m4 b/acinclude.m4
|
||||
index a4e5e2f..eb0936a 100644
|
||||
index 287f07d..aab0c15 100644
|
||||
--- a/acinclude.m4
|
||||
+++ b/acinclude.m4
|
||||
@@ -146,6 +146,12 @@ AC_DEFUN([AC_PATH_USB], [
|
||||
@ -97,14 +97,14 @@ index a4e5e2f..eb0936a 100644
|
||||
AM_CONDITIONAL(SNDFILE, test "${sndfile_enable}" = "yes" && test "${sndfile_found}" = "yes")
|
||||
AM_CONDITIONAL(USB, test "${usb_enable}" = "yes" && test "${usb_found}" = "yes")
|
||||
AM_CONDITIONAL(SBC, test "${alsa_enable}" = "yes" || test "${gstreamer_enable}" = "yes" ||
|
||||
@@ -371,4 +386,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||
@@ -372,4 +387,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||
AM_CONDITIONAL(UDEVRULES, test "${udevrules_enable}" = "yes")
|
||||
AM_CONDITIONAL(CONFIGFILES, test "${configfiles_enable}" = "yes")
|
||||
AM_CONDITIONAL(MAEMO6PLUGIN, test "${maemo6_enable}" = "yes")
|
||||
+ AM_CONDITIONAL(CABLE, test "${cable_enable}" = "yes" && test "${cable_found}" = "yes")
|
||||
])
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 6fda7fe..0ef9d4c 100644
|
||||
index 5d31dc4..225c6f2 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -40,6 +40,7 @@ AC_PATH_GLIB
|
||||
|
@ -1,4 +1,4 @@
|
||||
From bbdb8577cae7446865840ced5b007b9b39b548a3 Mon Sep 17 00:00:00 2001
|
||||
From cc8bd9b5fe227d22786fcb34f3a484b2c27d33b7 Mon Sep 17 00:00:00 2001
|
||||
From: Lennart Poettering <lennart@poettering.net>
|
||||
Date: Wed, 21 Jul 2010 19:20:44 +0200
|
||||
Subject: [PATCH] systemd: install systemd unit files
|
||||
@ -18,10 +18,10 @@ that bluetoothd is not started twice at the same time.
|
||||
create mode 100644 scripts/org.bluez.service
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 65d4312..a2b53e8 100644
|
||||
index d0814a3..73499dc 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -301,7 +301,8 @@ endif
|
||||
@@ -352,7 +352,8 @@ endif
|
||||
CLEANFILES += $(rules_DATA)
|
||||
|
||||
EXTRA_DIST += scripts/bluetooth.rules \
|
||||
@ -31,7 +31,7 @@ index 65d4312..a2b53e8 100644
|
||||
|
||||
if PCMCIA
|
||||
udevdir = $(libexecdir)/udev
|
||||
@@ -309,6 +310,20 @@ udevdir = $(libexecdir)/udev
|
||||
@@ -360,6 +361,20 @@ udevdir = $(libexecdir)/udev
|
||||
dist_udev_SCRIPTS = scripts/bluetooth_serial
|
||||
endif
|
||||
|
||||
@ -52,7 +52,7 @@ index 65d4312..a2b53e8 100644
|
||||
EXTRA_DIST += doc/manager-api.txt \
|
||||
doc/adapter-api.txt doc/device-api.txt \
|
||||
doc/service-api.txt doc/agent-api.txt doc/attribute-api.txt \
|
||||
@@ -328,9 +343,9 @@ pkgconfigdir = $(libdir)/pkgconfig
|
||||
@@ -384,9 +399,9 @@ pkgconfigdir = $(libdir)/pkgconfig
|
||||
|
||||
pkgconfig_DATA = bluez.pc
|
||||
|
||||
@ -65,10 +65,10 @@ index 65d4312..a2b53e8 100644
|
||||
MAINTAINERCLEANFILES = Makefile.in \
|
||||
aclocal.m4 configure config.h.in config.sub config.guess \
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index b004f6e..86b398f 100644
|
||||
index 225c6f2..bc0f6fe 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -64,5 +64,14 @@ if (test "${enable_netlink}" = "yes"); then
|
||||
@@ -66,5 +66,14 @@ if (test "${enable_netlink}" = "yes"); then
|
||||
fi
|
||||
AM_CONDITIONAL(NETLINK, test "${enable_netlink}" = "yes")
|
||||
|
||||
@ -81,7 +81,7 @@ index b004f6e..86b398f 100644
|
||||
+AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
|
||||
+AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir"])
|
||||
+
|
||||
AC_OUTPUT(Makefile scripts/bluetooth.rules doc/version.xml
|
||||
AC_OUTPUT(Makefile scripts/bluetooth.rules doc/version.xml src/bluetooth.ver
|
||||
src/bluetoothd.8 bluez.pc)
|
||||
diff --git a/scripts/.gitignore b/scripts/.gitignore
|
||||
new file mode 100644
|
||||
@ -120,5 +120,5 @@ index 0000000..2a3b057
|
||||
+User=root
|
||||
+SystemdService=bluetooth.service
|
||||
--
|
||||
1.7.0.1
|
||||
1.7.2.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user