- Update to 5.30
- Use %%license - Minor cleanups to spec - Drop README as it's only details of how to build
This commit is contained in:
parent
4d3bfbe1d0
commit
7ee65edf50
14
.gitignore
vendored
14
.gitignore
vendored
@ -1,14 +1,2 @@
|
||||
/bluez-4.*.tar.gz
|
||||
/bluez-5.9.tar.xz
|
||||
/bluez-5.10.tar.xz
|
||||
/bluez-5.11.tar.xz
|
||||
/bluez-5.12.tar.xz
|
||||
/bluez-5.13.tar.xz
|
||||
/bluez-5.14.tar.xz
|
||||
/bluez-5.16.tar.xz
|
||||
/bluez-5.17.tar.xz
|
||||
/bluez-5.18.tar.xz
|
||||
/bluez-5.23.tar.xz
|
||||
/bluez-5.25.tar.xz
|
||||
/bluez-5.28.tar.xz
|
||||
/bluez-5.29.tar.xz
|
||||
/bluez-5.*.tar.xz
|
||||
|
@ -1,29 +0,0 @@
|
||||
From 11e92de1808451e2811a38ca8e398457574b2f84 Mon Sep 17 00:00:00 2001
|
||||
From: Fedora Bluez maintainers <bluez-owner@fedoraproject.org>
|
||||
Date: Sun, 29 Mar 2015 18:28:48 +0200
|
||||
Subject: [PATCH] fix invalid conversion
|
||||
|
||||
error: invalid conversion from 'const void*' to 'const uint8_t* {aka
|
||||
const unsigned char*}' [-fpermissive]
|
||||
---
|
||||
lib/bluetooth.h | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/lib/bluetooth.h b/lib/bluetooth.h
|
||||
index 6ca64b6..852a6b2 100644
|
||||
--- a/lib/bluetooth.h
|
||||
+++ b/lib/bluetooth.h
|
||||
@@ -345,8 +345,8 @@ typedef struct {
|
||||
|
||||
static inline void bswap_128(const void *src, void *dst)
|
||||
{
|
||||
- const uint8_t *s = src;
|
||||
- uint8_t *d = dst;
|
||||
+ const uint8_t *s = (const uint8_t *) src;
|
||||
+ uint8_t *d = (uint8_t *) dst;
|
||||
int i;
|
||||
|
||||
for (i = 0; i < 16; i++)
|
||||
--
|
||||
2.3.4
|
||||
|
35
bluez.spec
35
bluez.spec
@ -2,8 +2,8 @@
|
||||
|
||||
Summary: Bluetooth utilities
|
||||
Name: bluez
|
||||
Version: 5.29
|
||||
Release: 2%{?dist}
|
||||
Version: 5.30
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
URL: http://www.bluez.org/
|
||||
@ -12,16 +12,15 @@ Source0: http://www.kernel.org/pub/linux/bluetooth/bluez-%{version}.tar.xz
|
||||
Source1: bluez.gitignore
|
||||
|
||||
## Ubuntu patches
|
||||
Patch2: 0001-work-around-Logitech-diNovo-Edge-keyboard-firmware-i.patch
|
||||
Patch1: 0001-work-around-Logitech-diNovo-Edge-keyboard-firmware-i.patch
|
||||
# Non-upstream
|
||||
Patch3: 0001-Allow-using-obexd-without-systemd-in-the-user-sessio.patch
|
||||
Patch4: 0001-obex-Use-GLib-helper-function-to-manipulate-paths.patch
|
||||
Patch5: 0002-autopair-Don-t-handle-the-iCade.patch
|
||||
Patch7: 0004-agent-Assert-possible-infinite-loop.patch
|
||||
Patch8: 0001-fix-invalid-conversion.patch
|
||||
Patch2: 0001-Allow-using-obexd-without-systemd-in-the-user-sessio.patch
|
||||
Patch3: 0001-obex-Use-GLib-helper-function-to-manipulate-paths.patch
|
||||
Patch4: 0002-autopair-Don-t-handle-the-iCade.patch
|
||||
Patch5: 0004-agent-Assert-possible-infinite-loop.patch
|
||||
|
||||
BuildRequires: git
|
||||
BuildRequires: dbus-devel >= 0.90
|
||||
BuildRequires: dbus-devel >= 1.6
|
||||
BuildRequires: glib2-devel
|
||||
BuildRequires: libical-devel
|
||||
BuildRequires: readline-devel
|
||||
@ -30,10 +29,7 @@ BuildRequires: systemd-devel
|
||||
# For cups
|
||||
BuildRequires: cups-devel
|
||||
|
||||
# For rebuild
|
||||
BuildRequires: libtool autoconf automake
|
||||
|
||||
Requires: dbus >= 0.60
|
||||
Requires: dbus >= 1.6
|
||||
|
||||
Requires(post): systemd
|
||||
Requires(preun): systemd
|
||||
@ -133,8 +129,6 @@ git commit -a -q -m "%{version} baseline."
|
||||
git am -p1 %{patches} < /dev/null
|
||||
|
||||
%build
|
||||
libtoolize -f -c
|
||||
autoreconf -f -i
|
||||
%configure --enable-cups --enable-tools --enable-library \
|
||||
--enable-sixaxis \
|
||||
--with-systemdsystemunitdir=%{_unitdir} \
|
||||
@ -182,7 +176,9 @@ mkdir -p $RPM_BUILD_ROOT/%{_libdir}/bluetooth/
|
||||
/sbin/udevadm trigger --subsystem-match=usb
|
||||
|
||||
%files
|
||||
%doc AUTHORS COPYING ChangeLog README
|
||||
%{!?_licensedir:%global license %%doc}
|
||||
%license COPYING
|
||||
%doc AUTHORS ChangeLog
|
||||
%{_bindir}/ciptool
|
||||
%{_bindir}/hcitool
|
||||
%{_bindir}/l2ping
|
||||
@ -223,7 +219,8 @@ mkdir -p $RPM_BUILD_ROOT/%{_libdir}/bluetooth/
|
||||
%{_userunitdir}/obex.service
|
||||
|
||||
%files libs
|
||||
%doc COPYING
|
||||
%{!?_licensedir:%global license %%doc}
|
||||
%license COPYING
|
||||
%{_libdir}/libbluetooth.so.*
|
||||
|
||||
%files libs-devel
|
||||
@ -241,6 +238,10 @@ mkdir -p $RPM_BUILD_ROOT/%{_libdir}/bluetooth/
|
||||
/lib/udev/rules.d/97-hid2hci.rules
|
||||
|
||||
%changelog
|
||||
* Wed Apr 29 2015 Peter Robinson <pbrobinson@fedoraproject.org>
|
||||
- Update to 5.30
|
||||
- Use %%license
|
||||
|
||||
* Sun Mar 29 2015 David Tardon <dtardon@redhat.com> - 5.29-2
|
||||
- fix header file
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user