Update patches to apply
This commit is contained in:
parent
8cf435ffbc
commit
7be5a35dc5
@ -1,7 +1,7 @@
|
||||
From aab7b43b4ad63b97a0f00c1fdf030390c42c8a5f Mon Sep 17 00:00:00 2001
|
||||
From 25e16a281dc158660c03fa475ffdc4b575642f5b Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Tue, 1 Sep 2009 17:32:48 +0100
|
||||
Subject: [PATCH] Add sixaxis cable-pairing plugin
|
||||
Subject: [PATCH 1/3] Add sixaxis cable-pairing plugin
|
||||
|
||||
Implement the old "sixpair" using libudev and libusb-1.0.
|
||||
|
||||
@ -17,10 +17,10 @@ address, and added to the database of the current default adapter.
|
||||
create mode 100644 plugins/cable.c
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index b3aa25e..d0814a3 100644
|
||||
index 8f9f5d3..e855713 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -204,6 +204,11 @@ builtin_sources += health/hdp_main.c health/hdp_types.h \
|
||||
@@ -195,6 +195,11 @@ builtin_sources += health/hdp_main.c health/hdp_types.h \
|
||||
health/hdp_util.h health/hdp_util.c
|
||||
endif
|
||||
|
||||
@ -32,16 +32,16 @@ index b3aa25e..d0814a3 100644
|
||||
builtin_modules += hciops
|
||||
builtin_sources += plugins/hciops.c
|
||||
|
||||
@@ -249,7 +254,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
|
||||
@@ -240,7 +245,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
|
||||
src/dbus-common.c src/dbus-common.h \
|
||||
src/dbus-hci.h src/dbus-hci.c
|
||||
src_bluetoothd_LDADD = lib/libbluetooth.la @GLIB_LIBS@ @DBUS_LIBS@ \
|
||||
- @CAPNG_LIBS@ -ldl
|
||||
+ @CAPNG_LIBS@ @CABLE_LIBS@ -ldl
|
||||
src_bluetoothd_LDFLAGS = -Wl,--export-dynamic \
|
||||
-Wl,--version-script=src/bluetooth.ver
|
||||
src_bluetoothd_DEPENDENCIES = src/bluetooth.ver lib/libbluetooth.la
|
||||
@@ -364,7 +369,7 @@ EXTRA_DIST += doc/manager-api.txt \
|
||||
-Wl,--version-script=$(srcdir)/src/bluetooth.ver
|
||||
|
||||
@@ -356,7 +361,7 @@ EXTRA_DIST += doc/manager-api.txt \
|
||||
|
||||
AM_YFLAGS = -d
|
||||
|
||||
@ -104,7 +104,7 @@ index 287f07d..aab0c15 100644
|
||||
+ AM_CONDITIONAL(CABLE, test "${cable_enable}" = "yes" && test "${cable_found}" = "yes")
|
||||
])
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 5d31dc4..225c6f2 100644
|
||||
index 6ffeb20..d375ac9 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -40,6 +40,7 @@ AC_PATH_GLIB
|
||||
@ -507,5 +507,5 @@ index 0000000..d74c771
|
||||
+BLUETOOTH_PLUGIN_DEFINE(cable, VERSION,
|
||||
+ BLUETOOTH_PLUGIN_PRIORITY_DEFAULT, cable_init, cable_exit)
|
||||
--
|
||||
1.7.2.3
|
||||
1.7.3.1
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
From cc8bd9b5fe227d22786fcb34f3a484b2c27d33b7 Mon Sep 17 00:00:00 2001
|
||||
From b3483ab0b821d29bbeb6aa5630b36bc126a89441 Mon Sep 17 00:00:00 2001
|
||||
From: Lennart Poettering <lennart@poettering.net>
|
||||
Date: Wed, 21 Jul 2010 19:20:44 +0200
|
||||
Subject: [PATCH] systemd: install systemd unit files
|
||||
Subject: [PATCH 3/3] systemd: install systemd unit files
|
||||
|
||||
This also enables bus activation for bluetoothd, but only if systemd is
|
||||
running. Only if that's the case we can make sure in a race-free fashion
|
||||
@ -18,10 +18,10 @@ that bluetoothd is not started twice at the same time.
|
||||
create mode 100644 scripts/org.bluez.service
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index d0814a3..73499dc 100644
|
||||
index e855713..1edd6a2 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -352,7 +352,8 @@ endif
|
||||
@@ -344,7 +344,8 @@ endif
|
||||
CLEANFILES += $(rules_DATA)
|
||||
|
||||
EXTRA_DIST += scripts/bluetooth.rules \
|
||||
@ -31,7 +31,7 @@ index d0814a3..73499dc 100644
|
||||
|
||||
if PCMCIA
|
||||
udevdir = $(libexecdir)/udev
|
||||
@@ -360,6 +361,20 @@ udevdir = $(libexecdir)/udev
|
||||
@@ -352,6 +353,20 @@ udevdir = $(libexecdir)/udev
|
||||
dist_udev_SCRIPTS = scripts/bluetooth_serial
|
||||
endif
|
||||
|
||||
@ -52,7 +52,7 @@ index d0814a3..73499dc 100644
|
||||
EXTRA_DIST += doc/manager-api.txt \
|
||||
doc/adapter-api.txt doc/device-api.txt \
|
||||
doc/service-api.txt doc/agent-api.txt doc/attribute-api.txt \
|
||||
@@ -384,9 +399,9 @@ pkgconfigdir = $(libdir)/pkgconfig
|
||||
@@ -376,9 +391,9 @@ pkgconfigdir = $(libdir)/pkgconfig
|
||||
|
||||
pkgconfig_DATA = bluez.pc
|
||||
|
||||
@ -65,12 +65,12 @@ index d0814a3..73499dc 100644
|
||||
MAINTAINERCLEANFILES = Makefile.in \
|
||||
aclocal.m4 configure config.h.in config.sub config.guess \
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 225c6f2..bc0f6fe 100644
|
||||
index d375ac9..6619a42 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -66,5 +66,14 @@ if (test "${enable_netlink}" = "yes"); then
|
||||
@@ -56,5 +56,14 @@ if (test "${enable_capng}" = "yes"); then
|
||||
AC_DEFINE(HAVE_CAPNG, 1, [Define to 1 if you have capabilities library.])
|
||||
fi
|
||||
AM_CONDITIONAL(NETLINK, test "${enable_netlink}" = "yes")
|
||||
|
||||
+# systemd
|
||||
+
|
||||
@ -81,7 +81,7 @@ index 225c6f2..bc0f6fe 100644
|
||||
+AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
|
||||
+AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir"])
|
||||
+
|
||||
AC_OUTPUT(Makefile scripts/bluetooth.rules doc/version.xml src/bluetooth.ver
|
||||
AC_OUTPUT(Makefile scripts/bluetooth.rules doc/version.xml
|
||||
src/bluetoothd.8 bluez.pc)
|
||||
diff --git a/scripts/.gitignore b/scripts/.gitignore
|
||||
new file mode 100644
|
||||
@ -120,5 +120,5 @@ index 0000000..2a3b057
|
||||
+User=root
|
||||
+SystemdService=bluetooth.service
|
||||
--
|
||||
1.7.2.3
|
||||
1.7.3.1
|
||||
|
||||
|
@ -12,6 +12,8 @@ Source6: pand.conf
|
||||
Source7: rfcomm.init
|
||||
Source8: bluez-uinput.modules
|
||||
|
||||
# http://thread.gmane.org/gmane.linux.bluez.kernel/8645
|
||||
Patch1: 0002-build-Fix-parallel-build.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=450081
|
||||
# http://thread.gmane.org/gmane.linux.bluez.kernel/1687
|
||||
Patch2: bluez-try-utf8-harder.patch
|
||||
@ -19,6 +21,7 @@ Patch2: bluez-try-utf8-harder.patch
|
||||
Patch4: bluez-socket-mobile-cf-connection-kit.patch
|
||||
# http://thread.gmane.org/gmane.linux.bluez.kernel/2396
|
||||
Patch5: 0001-Add-sixaxis-cable-pairing-plugin.patch
|
||||
# http://thread.gmane.org/gmane.linux.bluez.kernel/8645
|
||||
Patch6: 0001-systemd-install-systemd-unit-files.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
|
Loading…
Reference in New Issue
Block a user