Fix patch application

This commit is contained in:
Bastien Nocera 2010-07-17 15:17:31 +00:00
parent 83bff84265
commit 775e26d0cb

View File

@ -1,4 +1,4 @@
From 5e78f3524c73fe5041bf88dada41f5dd3105e9fc Mon Sep 17 00:00:00 2001
From 1927d7c37f761236eb9dfc90456444d6b01ad313 Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Tue, 1 Sep 2009 17:32:48 +0100
Subject: [PATCH] Add sixaxis cable-pairing plugin
@ -17,7 +17,7 @@ address, and added to the database of the current default adapter.
create mode 100644 plugins/cable.c
diff --git a/Makefile.am b/Makefile.am
index 36ffde3..1e3ff96 100644
index 65d4312..0c284b9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -168,6 +168,11 @@ builtin_modules += service
@ -32,7 +32,7 @@ index 36ffde3..1e3ff96 100644
builtin_modules += hciops
builtin_sources += plugins/hciops.c
@@ -198,7 +203,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
@@ -203,7 +208,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
src/dbus-common.c src/dbus-common.h \
src/dbus-hci.h src/dbus-hci.c
src_bluetoothd_LDADD = lib/libbluetooth.la @GLIB_LIBS@ @DBUS_LIBS@ \
@ -41,7 +41,7 @@ index 36ffde3..1e3ff96 100644
src_bluetoothd_LDFLAGS = -Wl,--export-dynamic \
-Wl,--version-script=src/bluetooth.ver
src_bluetoothd_DEPENDENCIES = src/bluetooth.ver lib/libbluetooth.la
@@ -312,7 +317,7 @@ EXTRA_DIST += doc/manager-api.txt \
@@ -317,7 +322,7 @@ EXTRA_DIST += doc/manager-api.txt \
AM_YFLAGS = -d
@ -51,7 +51,7 @@ index 36ffde3..1e3ff96 100644
INCLUDES = -I$(builddir)/lib -I$(builddir)/src -I$(srcdir)/src \
diff --git a/acinclude.m4 b/acinclude.m4
index f7bb047..25005c0 100644
index f5fdd66..0a25e7a 100644
--- a/acinclude.m4
+++ b/acinclude.m4
@@ -146,6 +146,24 @@ AC_DEFUN([AC_PATH_USB], [
@ -92,7 +92,7 @@ index f7bb047..25005c0 100644
alsa_enable=${alsa_found}
gstreamer_enable=${gstreamer_found}
audio_enable=yes
@@ -231,6 +252,14 @@ AC_DEFUN([AC_ARG_BLUEZ], [
@@ -232,6 +253,14 @@ AC_DEFUN([AC_ARG_BLUEZ], [
usb_enable=${enableval}
])
@ -107,7 +107,7 @@ index f7bb047..25005c0 100644
AC_ARG_ENABLE(tracer, AC_HELP_STRING([--enable-tracer], [install Tracing daemon]), [
tracer_enable=${enableval}
])
@@ -314,6 +343,14 @@ AC_DEFUN([AC_ARG_BLUEZ], [
@@ -319,6 +348,14 @@ AC_DEFUN([AC_ARG_BLUEZ], [
AC_DEFINE(HAVE_LIBUSB, 1, [Define to 1 if you have USB library.])
fi
@ -122,14 +122,14 @@ index f7bb047..25005c0 100644
AM_CONDITIONAL(SNDFILE, test "${sndfile_enable}" = "yes" && test "${sndfile_found}" = "yes")
AM_CONDITIONAL(USB, test "${usb_enable}" = "yes" && test "${usb_found}" = "yes")
AM_CONDITIONAL(SBC, test "${alsa_enable}" = "yes" || test "${gstreamer_enable}" = "yes" ||
@@ -340,4 +377,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
AM_CONDITIONAL(DFUTOOL, test "${dfutool_enable}" = "yes" && test "${usb_found}" = "yes")
@@ -346,4 +383,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
AM_CONDITIONAL(UDEVRULES, test "${udevrules_enable}" = "yes")
AM_CONDITIONAL(CONFIGFILES, test "${configfiles_enable}" = "yes")
AM_CONDITIONAL(MAEMO6PLUGIN, test "${maemo6_enable}" = "yes")
+ AM_CONDITIONAL(CABLE, test "${cable_enable}" = "yes" && test "${cable_found}" = "yes")
])
diff --git a/configure.ac b/configure.ac
index 154d0dc..0e7084f 100644
index b004f6e..f997c5a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,7 +40,10 @@ AC_PATH_GLIB