Add patch for udev change to fix FTBFS on rawhide, Drop sbc patch as fixed in gcc 4.7 final
This commit is contained in:
parent
ecd72f6532
commit
6f3d555c65
26
bluez-udev-deprecated.patch
Normal file
26
bluez-udev-deprecated.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
From 35beaaa5b39d50eabd54563804182bb01a5d7ff4 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Tom Gundersen <teg@jklm.no>
|
||||||
|
Date: Sun, 27 May 2012 01:07:57 +0200
|
||||||
|
Subject: [PATCH] udev: remove deprecated function
|
||||||
|
|
||||||
|
This function has in the past returned "/sys" unconditionally. As of
|
||||||
|
udev-183 it is gone, so just replace it with the string.
|
||||||
|
---
|
||||||
|
tools/hid2hci.c | 2 +-
|
||||||
|
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/tools/hid2hci.c b/tools/hid2hci.c
|
||||||
|
index 45a3a3d..e3a5b2e 100644
|
||||||
|
--- a/tools/hid2hci.c
|
||||||
|
+++ b/tools/hid2hci.c
|
||||||
|
@@ -291,7 +291,7 @@ int main(int argc, char *argv[])
|
||||||
|
if (udev == NULL)
|
||||||
|
goto exit;
|
||||||
|
|
||||||
|
- snprintf(syspath, sizeof(syspath), "%s/%s", udev_get_sys_path(udev), devpath);
|
||||||
|
+ snprintf(syspath, sizeof(syspath), "/sys/%s", devpath);
|
||||||
|
udev_dev = udev_device_new_from_syspath(udev, syspath);
|
||||||
|
if (udev_dev == NULL) {
|
||||||
|
fprintf(stderr, "error: could not find '%s'\n", devpath);
|
||||||
|
--
|
||||||
|
1.7.7.6
|
10
bluez.spec
10
bluez.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: Bluetooth utilities
|
Summary: Bluetooth utilities
|
||||||
Name: bluez
|
Name: bluez
|
||||||
Version: 4.99
|
Version: 4.99
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
URL: http://www.bluez.org/
|
URL: http://www.bluez.org/
|
||||||
@ -20,6 +20,7 @@ Patch4: bluez-socket-mobile-cf-connection-kit.patch
|
|||||||
Patch5: 0001-Add-sixaxis-cable-pairing-plugin.patch
|
Patch5: 0001-Add-sixaxis-cable-pairing-plugin.patch
|
||||||
# http://thread.gmane.org/gmane.linux.bluez.kernel/8645
|
# http://thread.gmane.org/gmane.linux.bluez.kernel/8645
|
||||||
Patch6: 0001-systemd-install-systemd-unit-files.patch
|
Patch6: 0001-systemd-install-systemd-unit-files.patch
|
||||||
|
Patch7: bluez-udev-deprecated.patch
|
||||||
|
|
||||||
BuildRequires: flex
|
BuildRequires: flex
|
||||||
BuildRequires: dbus-devel >= 0.90
|
BuildRequires: dbus-devel >= 0.90
|
||||||
@ -144,6 +145,7 @@ and mouse.
|
|||||||
%patch4 -p1 -b .socket-mobile
|
%patch4 -p1 -b .socket-mobile
|
||||||
%patch5 -p1 -b .cable-pairing
|
%patch5 -p1 -b .cable-pairing
|
||||||
%patch6 -p1 -b .systemd
|
%patch6 -p1 -b .systemd
|
||||||
|
%patch7 -p1 -b .udev
|
||||||
|
|
||||||
%build
|
%build
|
||||||
libtoolize -f -c
|
libtoolize -f -c
|
||||||
@ -182,6 +184,8 @@ install -D -m0755 %{SOURCE8} $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/modules/bl
|
|||||||
|
|
||||||
install -d -m0755 $RPM_BUILD_ROOT/%{_localstatedir}/lib/bluetooth
|
install -d -m0755 $RPM_BUILD_ROOT/%{_localstatedir}/lib/bluetooth
|
||||||
|
|
||||||
|
mkdir -p $RPM_BUILD_ROOT/%{_libdir}/bluetooth/
|
||||||
|
|
||||||
%post libs -p /sbin/ldconfig
|
%post libs -p /sbin/ldconfig
|
||||||
|
|
||||||
%post
|
%post
|
||||||
@ -308,6 +312,10 @@ fi
|
|||||||
%exclude /usr/lib/udev/rules.d/97-bluetooth-hid2hci.rules
|
%exclude /usr/lib/udev/rules.d/97-bluetooth-hid2hci.rules
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 1 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 4.99-2
|
||||||
|
- Add patch for udev change to fix FTBFS on rawhide
|
||||||
|
- Drop sbc patch as fixed in gcc 4.7 final
|
||||||
|
|
||||||
* Tue Mar 06 2012 Bastien Nocera <bnocera@redhat.com> 4.99-1
|
* Tue Mar 06 2012 Bastien Nocera <bnocera@redhat.com> 4.99-1
|
||||||
- Update to 4.99
|
- Update to 4.99
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user