Remove obsolete patches
This commit is contained in:
parent
a1abfa2a4f
commit
6bfa1dbc3c
@ -1,4 +1,4 @@
|
|||||||
From 2977a39aad96cb3f2be90c6291169a25c9965fc9 Mon Sep 17 00:00:00 2001
|
From 78030d9dae0ab1e06b408c6f8e12df4a1dddbca8 Mon Sep 17 00:00:00 2001
|
||||||
From: Bastien Nocera <hadess@hadess.net>
|
From: Bastien Nocera <hadess@hadess.net>
|
||||||
Date: Fri, 30 Dec 2011 12:34:29 +0100
|
Date: Fri, 30 Dec 2011 12:34:29 +0100
|
||||||
Subject: [PATCH] Add sixaxis cable-pairing plugin
|
Subject: [PATCH] Add sixaxis cable-pairing plugin
|
||||||
@ -19,13 +19,13 @@ address, and added to the database of the current default adapter.
|
|||||||
create mode 100644 plugins/cable.c
|
create mode 100644 plugins/cable.c
|
||||||
|
|
||||||
diff --git a/Makefile.am b/Makefile.am
|
diff --git a/Makefile.am b/Makefile.am
|
||||||
index cafb4cc..4ccf4f0 100644
|
index 53fcbe9..9cbafbc 100644
|
||||||
--- a/Makefile.am
|
--- a/Makefile.am
|
||||||
+++ b/Makefile.am
|
+++ b/Makefile.am
|
||||||
@@ -244,6 +244,11 @@ builtin_sources += thermometer/main.c \
|
@@ -238,6 +238,11 @@ builtin_sources += thermometer/main.c \
|
||||||
thermometer/thermometer.h thermometer/thermometer.c
|
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
|
||||||
+if CABLE
|
+if CABLE
|
||||||
+builtin_modules += cable
|
+builtin_modules += cable
|
||||||
+builtin_sources += plugins/cable.c
|
+builtin_sources += plugins/cable.c
|
||||||
@ -34,29 +34,29 @@ index cafb4cc..4ccf4f0 100644
|
|||||||
builtin_modules += hciops mgmtops
|
builtin_modules += hciops mgmtops
|
||||||
builtin_sources += plugins/hciops.c plugins/mgmtops.c
|
builtin_sources += plugins/hciops.c plugins/mgmtops.c
|
||||||
|
|
||||||
@@ -311,7 +316,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
|
@@ -306,7 +311,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
|
||||||
src/event.h src/event.c \
|
src/event.h src/event.c \
|
||||||
src/oob.h src/oob.c src/eir.h src/eir.c
|
src/oob.h src/oob.c src/eir.h src/eir.c
|
||||||
src_bluetoothd_LDADD = lib/libbluetooth-private.la @GLIB_LIBS@ @DBUS_LIBS@ \
|
src_bluetoothd_LDADD = lib/libbluetooth-private.la @GLIB_LIBS@ @DBUS_LIBS@ \
|
||||||
- @CAPNG_LIBS@ -ldl -lrt
|
- -ldl -lrt
|
||||||
+ @CAPNG_LIBS@ @CABLE_LIBS@ -ldl -lrt
|
+ -@CABLE_LIBS@ ldl -lrt
|
||||||
src_bluetoothd_LDFLAGS = -Wl,--export-dynamic \
|
src_bluetoothd_LDFLAGS = $(AM_LDFLAGS) -Wl,--export-dynamic \
|
||||||
-Wl,--version-script=$(srcdir)/src/bluetooth.ver
|
-Wl,--version-script=$(srcdir)/src/bluetooth.ver
|
||||||
|
|
||||||
@@ -447,7 +452,7 @@ EXTRA_DIST += doc/manager-api.txt \
|
@@ -428,7 +433,7 @@ EXTRA_DIST += doc/manager-api.txt \
|
||||||
|
|
||||||
AM_YFLAGS = -d
|
AM_YFLAGS = -d
|
||||||
|
|
||||||
-AM_CFLAGS = @DBUS_CFLAGS@ @GLIB_CFLAGS@ @CAPNG_CFLAGS@
|
-AM_CFLAGS += @DBUS_CFLAGS@ @GLIB_CFLAGS@
|
||||||
+AM_CFLAGS = @DBUS_CFLAGS@ @GLIB_CFLAGS@ @CAPNG_CFLAGS@ @CABLE_CFLAGS@
|
+AM_CFLAGS += @DBUS_CFLAGS@ @GLIB_CFLAGS@ @CABLE_CFLAGS@
|
||||||
|
|
||||||
INCLUDES = -I$(builddir)/lib -I$(builddir)/src -I$(srcdir)/src \
|
INCLUDES = -I$(builddir)/lib -I$(builddir)/src -I$(srcdir)/src \
|
||||||
-I$(srcdir)/audio -I$(srcdir)/sbc -I$(srcdir)/gdbus \
|
-I$(srcdir)/audio -I$(srcdir)/sbc -I$(srcdir)/gdbus \
|
||||||
diff --git a/acinclude.m4 b/acinclude.m4
|
diff --git a/acinclude.m4 b/acinclude.m4
|
||||||
index b0f790c..20a930c 100644
|
index 6505ad3..3f59989 100644
|
||||||
--- a/acinclude.m4
|
--- a/acinclude.m4
|
||||||
+++ b/acinclude.m4
|
+++ b/acinclude.m4
|
||||||
@@ -152,6 +152,12 @@ AC_DEFUN([AC_PATH_UDEV], [
|
@@ -139,6 +139,12 @@ AC_DEFUN([AC_PATH_UDEV], [
|
||||||
AC_SUBST(UDEV_LIBS)
|
AC_SUBST(UDEV_LIBS)
|
||||||
])
|
])
|
||||||
|
|
||||||
@ -69,7 +69,7 @@ index b0f790c..20a930c 100644
|
|||||||
AC_DEFUN([AC_PATH_SNDFILE], [
|
AC_DEFUN([AC_PATH_SNDFILE], [
|
||||||
PKG_CHECK_MODULES(SNDFILE, sndfile, sndfile_found=yes, sndfile_found=no)
|
PKG_CHECK_MODULES(SNDFILE, sndfile, sndfile_found=yes, sndfile_found=no)
|
||||||
AC_SUBST(SNDFILE_CFLAGS)
|
AC_SUBST(SNDFILE_CFLAGS)
|
||||||
@@ -189,6 +195,7 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
@@ -176,6 +182,7 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||||
sndfile_enable=${sndfile_found}
|
sndfile_enable=${sndfile_found}
|
||||||
hal_enable=no
|
hal_enable=no
|
||||||
usb_enable=${usb_found}
|
usb_enable=${usb_found}
|
||||||
@ -77,7 +77,7 @@ index b0f790c..20a930c 100644
|
|||||||
alsa_enable=${alsa_found}
|
alsa_enable=${alsa_found}
|
||||||
gstreamer_enable=${gstreamer_found}
|
gstreamer_enable=${gstreamer_found}
|
||||||
audio_enable=yes
|
audio_enable=yes
|
||||||
@@ -298,6 +305,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
@@ -265,6 +272,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||||
usb_enable=${enableval}
|
usb_enable=${enableval}
|
||||||
])
|
])
|
||||||
|
|
||||||
@ -88,7 +88,7 @@ index b0f790c..20a930c 100644
|
|||||||
AC_ARG_ENABLE(tools, AC_HELP_STRING([--enable-tools], [install Bluetooth utilities]), [
|
AC_ARG_ENABLE(tools, AC_HELP_STRING([--enable-tools], [install Bluetooth utilities]), [
|
||||||
tools_enable=${enableval}
|
tools_enable=${enableval}
|
||||||
])
|
])
|
||||||
@@ -393,6 +404,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
@@ -366,6 +377,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||||
AC_DEFINE(HAVE_LIBUSB, 1, [Define to 1 if you have USB library.])
|
AC_DEFINE(HAVE_LIBUSB, 1, [Define to 1 if you have USB library.])
|
||||||
fi
|
fi
|
||||||
|
|
||||||
@ -99,14 +99,14 @@ index b0f790c..20a930c 100644
|
|||||||
AM_CONDITIONAL(SNDFILE, test "${sndfile_enable}" = "yes" && test "${sndfile_found}" = "yes")
|
AM_CONDITIONAL(SNDFILE, test "${sndfile_enable}" = "yes" && test "${sndfile_found}" = "yes")
|
||||||
AM_CONDITIONAL(USB, test "${usb_enable}" = "yes" && test "${usb_found}" = "yes")
|
AM_CONDITIONAL(USB, test "${usb_enable}" = "yes" && test "${usb_found}" = "yes")
|
||||||
AM_CONDITIONAL(SBC, test "${alsa_enable}" = "yes" || test "${gstreamer_enable}" = "yes" ||
|
AM_CONDITIONAL(SBC, test "${alsa_enable}" = "yes" || test "${gstreamer_enable}" = "yes" ||
|
||||||
@@ -429,4 +444,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
@@ -398,4 +413,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||||
AM_CONDITIONAL(DBUSOOBPLUGIN, test "${dbusoob_enable}" = "yes")
|
AM_CONDITIONAL(DBUSOOBPLUGIN, test "${dbusoob_enable}" = "yes")
|
||||||
AM_CONDITIONAL(WIIMOTEPLUGIN, test "${wiimote_enable}" = "yes")
|
AM_CONDITIONAL(WIIMOTEPLUGIN, test "${wiimote_enable}" = "yes")
|
||||||
AM_CONDITIONAL(THERMOMETERPLUGIN, test "${thermometer_enable}" = "yes")
|
AM_CONDITIONAL(GATTMODULES, test "${gatt_enable}" = "yes")
|
||||||
+ AM_CONDITIONAL(CABLE, test "${cable_enable}" = "yes" && test "${cable_found}" = "yes")
|
+ AM_CONDITIONAL(CABLE, test "${cable_enable}" = "yes" && test "${cable_found}" = "yes")
|
||||||
])
|
])
|
||||||
diff --git a/configure.ac b/configure.ac
|
diff --git a/configure.ac b/configure.ac
|
||||||
index cd0f1cf..c61f230 100644
|
index 48b181e..45a4b15 100644
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -46,6 +46,7 @@ AC_PATH_GSTREAMER
|
@@ -46,6 +46,7 @@ AC_PATH_GSTREAMER
|
||||||
@ -506,7 +506,7 @@ index 0000000..b974b4c
|
|||||||
+BLUETOOTH_PLUGIN_DEFINE(cable, VERSION,
|
+BLUETOOTH_PLUGIN_DEFINE(cable, VERSION,
|
||||||
+ BLUETOOTH_PLUGIN_PRIORITY_DEFAULT, cable_init, cable_exit)
|
+ BLUETOOTH_PLUGIN_PRIORITY_DEFAULT, cable_init, cable_exit)
|
||||||
diff --git a/src/adapter.c b/src/adapter.c
|
diff --git a/src/adapter.c b/src/adapter.c
|
||||||
index acb845e..478a8fb 100644
|
index 6e04faf..0488891 100644
|
||||||
--- a/src/adapter.c
|
--- a/src/adapter.c
|
||||||
+++ b/src/adapter.c
|
+++ b/src/adapter.c
|
||||||
@@ -952,6 +952,25 @@ static struct btd_device *adapter_create_device(DBusConnection *conn,
|
@@ -952,6 +952,25 @@ static struct btd_device *adapter_create_device(DBusConnection *conn,
|
||||||
@ -536,10 +536,10 @@ index acb845e..478a8fb 100644
|
|||||||
struct btd_device *device,
|
struct btd_device *device,
|
||||||
gboolean remove_storage)
|
gboolean remove_storage)
|
||||||
diff --git a/src/adapter.h b/src/adapter.h
|
diff --git a/src/adapter.h b/src/adapter.h
|
||||||
index ceebb97..b0a0461 100644
|
index b7ea62b..ac0aa2e 100644
|
||||||
--- a/src/adapter.h
|
--- a/src/adapter.h
|
||||||
+++ b/src/adapter.h
|
+++ b/src/adapter.h
|
||||||
@@ -123,6 +123,9 @@ void adapter_update_found_devices(struct btd_adapter *adapter,
|
@@ -114,6 +114,9 @@ void adapter_update_found_devices(struct btd_adapter *adapter,
|
||||||
uint8_t *data, uint8_t data_len);
|
uint8_t *data, uint8_t data_len);
|
||||||
void adapter_emit_device_found(struct btd_adapter *adapter,
|
void adapter_emit_device_found(struct btd_adapter *adapter,
|
||||||
struct remote_dev_info *dev);
|
struct remote_dev_info *dev);
|
||||||
@ -550,5 +550,5 @@ index ceebb97..b0a0461 100644
|
|||||||
int adapter_set_name(struct btd_adapter *adapter, const char *name);
|
int adapter_set_name(struct btd_adapter *adapter, const char *name);
|
||||||
void adapter_name_changed(struct btd_adapter *adapter, const char *name);
|
void adapter_name_changed(struct btd_adapter *adapter, const char *name);
|
||||||
--
|
--
|
||||||
1.7.7.6
|
1.7.10.2
|
||||||
|
|
||||||
|
@ -1,121 +0,0 @@
|
|||||||
From 0080ce8a37152b0ee7750799e01de3bf810f8caf Mon Sep 17 00:00:00 2001
|
|
||||||
From: Lennart Poettering <lennart@poettering.net>
|
|
||||||
Date: Wed, 21 Jul 2010 19:20:44 +0200
|
|
||||||
Subject: [PATCH] systemd: install systemd unit files
|
|
||||||
|
|
||||||
This also enables bus activation for bluetoothd, but only if systemd is
|
|
||||||
running. Only if that's the case we can make sure in a race-free fashion
|
|
||||||
that bluetoothd is not started twice at the same time.
|
|
||||||
---
|
|
||||||
Makefile.am | 21 ++++++++++++++++++---
|
|
||||||
configure.ac | 9 +++++++++
|
|
||||||
scripts/.gitignore | 1 +
|
|
||||||
scripts/bluetooth.service.in | 13 +++++++++++++
|
|
||||||
scripts/org.bluez.service | 5 +++++
|
|
||||||
5 files changed, 46 insertions(+), 3 deletions(-)
|
|
||||||
create mode 100644 scripts/.gitignore
|
|
||||||
create mode 100644 scripts/bluetooth.service.in
|
|
||||||
create mode 100644 scripts/org.bluez.service
|
|
||||||
|
|
||||||
diff --git a/Makefile.am b/Makefile.am
|
|
||||||
index aecc8f2..6e18003 100644
|
|
||||||
--- a/Makefile.am
|
|
||||||
+++ b/Makefile.am
|
|
||||||
@@ -387,10 +387,25 @@ endif
|
|
||||||
rules_DATA = $(foreach file,$(udev_files), scripts/97-$(notdir $(file)))
|
|
||||||
endif
|
|
||||||
|
|
||||||
+if HAVE_SYSTEMD
|
|
||||||
+systemdsystemunit_DATA = \
|
|
||||||
+ scripts/bluetooth.service
|
|
||||||
+
|
|
||||||
+scripts/bluetooth.service: scripts/bluetooth.service.in
|
|
||||||
+ @$(SED) -e "s|\@sbindir\@|$(sbindir)|" $< >$@
|
|
||||||
+
|
|
||||||
+dbussystemservicesdir = $(datadir)/dbus-1/system-services
|
|
||||||
+
|
|
||||||
+dbussystemservices_DATA = \
|
|
||||||
+ scripts/org.bluez.service
|
|
||||||
+
|
|
||||||
+endif
|
|
||||||
+
|
|
||||||
CLEANFILES += $(rules_DATA)
|
|
||||||
|
|
||||||
EXTRA_DIST += scripts/bluetooth.rules \
|
|
||||||
- scripts/bluetooth-hid2hci.rules scripts/bluetooth-serial.rules
|
|
||||||
+ scripts/bluetooth-hid2hci.rules scripts/bluetooth-serial.rules \
|
|
||||||
+ scripts/bluetooth.service.in scripts/org.bluez.service
|
|
||||||
|
|
||||||
EXTRA_DIST += doc/manager-api.txt \
|
|
||||||
doc/adapter-api.txt doc/device-api.txt \
|
|
||||||
@@ -417,9 +432,9 @@ pkgconfigdir = $(libdir)/pkgconfig
|
|
||||||
|
|
||||||
pkgconfig_DATA = bluez.pc
|
|
||||||
|
|
||||||
-DISTCHECK_CONFIGURE_FLAGS = --disable-datafiles
|
|
||||||
+DISTCHECK_CONFIGURE_FLAGS = --disable-datafiles --with-systemdsystemunitdir=
|
|
||||||
|
|
||||||
-DISTCLEANFILES = $(pkgconfig_DATA)
|
|
||||||
+DISTCLEANFILES = $(pkgconfig_DATA) scripts/bluetooth.service
|
|
||||||
|
|
||||||
MAINTAINERCLEANFILES = Makefile.in \
|
|
||||||
aclocal.m4 configure config.h.in config.sub config.guess \
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index bc2658c..b4502ab 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -71,5 +71,14 @@ if (test -n "${path_systemdunit}"); then
|
|
||||||
fi
|
|
||||||
AM_CONDITIONAL(SYSTEMD, test -n "${path_systemdunit}")
|
|
||||||
|
|
||||||
+# systemd
|
|
||||||
+
|
|
||||||
+AC_ARG_WITH([systemdsystemunitdir],
|
|
||||||
+ AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
|
|
||||||
+ [],
|
|
||||||
+ [with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
|
|
||||||
+AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
|
|
||||||
+AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir"])
|
|
||||||
+
|
|
||||||
AC_OUTPUT(Makefile scripts/bluetooth.rules doc/version.xml
|
|
||||||
src/bluetoothd.8 src/bluetooth.service bluez.pc)
|
|
||||||
diff --git a/scripts/.gitignore b/scripts/.gitignore
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..4b9f765
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/scripts/.gitignore
|
|
||||||
@@ -0,0 +1 @@
|
|
||||||
+bluetooth.service
|
|
||||||
diff --git a/scripts/bluetooth.service.in b/scripts/bluetooth.service.in
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..d0089ea
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/scripts/bluetooth.service.in
|
|
||||||
@@ -0,0 +1,13 @@
|
|
||||||
+[Unit]
|
|
||||||
+Description=Bluetooth Manager
|
|
||||||
+After=syslog.target
|
|
||||||
+
|
|
||||||
+[Service]
|
|
||||||
+Type=dbus
|
|
||||||
+BusName=org.bluez
|
|
||||||
+ExecStart=@sbindir@/bluetoothd -n
|
|
||||||
+StandardOutput=syslog
|
|
||||||
+
|
|
||||||
+[Install]
|
|
||||||
+WantedBy=bluetooth.target
|
|
||||||
+Alias=dbus-org.bluez.service
|
|
||||||
diff --git a/scripts/org.bluez.service b/scripts/org.bluez.service
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..dd7ae8f
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/scripts/org.bluez.service
|
|
||||||
@@ -0,0 +1,5 @@
|
|
||||||
+[D-BUS Service]
|
|
||||||
+Name=org.bluez
|
|
||||||
+Exec=/bin/false
|
|
||||||
+User=root
|
|
||||||
+SystemdService=dbus-org.bluez.service
|
|
||||||
--
|
|
||||||
1.7.6
|
|
||||||
|
|
@ -1,26 +0,0 @@
|
|||||||
From 35beaaa5b39d50eabd54563804182bb01a5d7ff4 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Tom Gundersen <teg@jklm.no>
|
|
||||||
Date: Sun, 27 May 2012 01:07:57 +0200
|
|
||||||
Subject: [PATCH] udev: remove deprecated function
|
|
||||||
|
|
||||||
This function has in the past returned "/sys" unconditionally. As of
|
|
||||||
udev-183 it is gone, so just replace it with the string.
|
|
||||||
---
|
|
||||||
tools/hid2hci.c | 2 +-
|
|
||||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/tools/hid2hci.c b/tools/hid2hci.c
|
|
||||||
index 45a3a3d..e3a5b2e 100644
|
|
||||||
--- a/tools/hid2hci.c
|
|
||||||
+++ b/tools/hid2hci.c
|
|
||||||
@@ -291,7 +291,7 @@ int main(int argc, char *argv[])
|
|
||||||
if (udev == NULL)
|
|
||||||
goto exit;
|
|
||||||
|
|
||||||
- snprintf(syspath, sizeof(syspath), "%s/%s", udev_get_sys_path(udev), devpath);
|
|
||||||
+ snprintf(syspath, sizeof(syspath), "/sys/%s", devpath);
|
|
||||||
udev_dev = udev_device_new_from_syspath(udev, syspath);
|
|
||||||
if (udev_dev == NULL) {
|
|
||||||
fprintf(stderr, "error: could not find '%s'\n", devpath);
|
|
||||||
--
|
|
||||||
1.7.7.6
|
|
@ -18,9 +18,6 @@ Source8: bluez-uinput.modules
|
|||||||
Patch4: bluez-socket-mobile-cf-connection-kit.patch
|
Patch4: bluez-socket-mobile-cf-connection-kit.patch
|
||||||
# http://thread.gmane.org/gmane.linux.bluez.kernel/2396
|
# http://thread.gmane.org/gmane.linux.bluez.kernel/2396
|
||||||
Patch5: 0001-Add-sixaxis-cable-pairing-plugin.patch
|
Patch5: 0001-Add-sixaxis-cable-pairing-plugin.patch
|
||||||
# http://thread.gmane.org/gmane.linux.bluez.kernel/8645
|
|
||||||
Patch6: 0001-systemd-install-systemd-unit-files.patch
|
|
||||||
Patch7: bluez-udev-deprecated.patch
|
|
||||||
|
|
||||||
BuildRequires: flex
|
BuildRequires: flex
|
||||||
BuildRequires: dbus-devel >= 0.90
|
BuildRequires: dbus-devel >= 0.90
|
||||||
@ -144,8 +141,6 @@ and mouse.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch4 -p1 -b .socket-mobile
|
%patch4 -p1 -b .socket-mobile
|
||||||
%patch5 -p1 -b .cable-pairing
|
%patch5 -p1 -b .cable-pairing
|
||||||
%patch6 -p1 -b .systemd
|
|
||||||
%patch7 -p1 -b .udev
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
libtoolize -f -c
|
libtoolize -f -c
|
||||||
|
Loading…
Reference in New Issue
Block a user