Update to 5.77
This commit is contained in:
parent
7b3d1506aa
commit
50d217530c
28
bluez.spec
28
bluez.spec
@ -5,17 +5,13 @@
|
||||
%endif
|
||||
|
||||
Name: bluez
|
||||
Version: 5.72
|
||||
Release: 5%{?dist}
|
||||
Version: 5.77
|
||||
Release: 1%{?dist}
|
||||
Summary: Bluetooth utilities
|
||||
License: GPL-2.0-or-later
|
||||
URL: http://www.bluez.org/
|
||||
|
||||
Source0: http://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.xz
|
||||
Source1: bluez.gitignore
|
||||
|
||||
# https://lore.kernel.org/linux-bluetooth/20220901110719.176944-1-hadess@hadess.net/T/#m9c08d004cd5422783ee1d93154f42303bba9169f
|
||||
Patch2: power-state-adapter-property.patch
|
||||
Source0: https://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.xz
|
||||
|
||||
BuildRequires: dbus-devel >= 1.6
|
||||
BuildRequires: glib2-devel
|
||||
@ -51,10 +47,7 @@ Utilities for use in Bluetooth applications:
|
||||
- btattach
|
||||
- btmon
|
||||
- hex2hcd
|
||||
- l2ping
|
||||
- l2test
|
||||
- mpris-proxy
|
||||
- rctest
|
||||
|
||||
The BLUETOOTH trademarks are owned by Bluetooth SIG, Inc., U.S.A.
|
||||
|
||||
@ -82,6 +75,7 @@ be dropped by upstream. Utilities include:
|
||||
- hciconfig
|
||||
- hcidump
|
||||
- hcitool
|
||||
- meshctl
|
||||
- rfcomm
|
||||
- sdptool
|
||||
%endif
|
||||
@ -193,14 +187,12 @@ install -d -m0755 $RPM_BUILD_ROOT/%{_localstatedir}/lib/bluetooth/mesh
|
||||
|
||||
mkdir -p $RPM_BUILD_ROOT/%{_libdir}/bluetooth/
|
||||
|
||||
#copy bluetooth config file and setup auto enable
|
||||
#copy bluetooth config files
|
||||
install -D -p -m0644 src/main.conf ${RPM_BUILD_ROOT}/etc/bluetooth/main.conf
|
||||
install -D -p -m0644 mesh/mesh-main.conf ${RPM_BUILD_ROOT}/etc/bluetooth/mesh-main.conf
|
||||
install -D -p -m0644 profiles/input/input.conf ${RPM_BUILD_ROOT}/etc/bluetooth/input.conf
|
||||
install -D -p -m0644 profiles/network/network.conf ${RPM_BUILD_ROOT}/etc/bluetooth/network.conf
|
||||
|
||||
sed -i 's/#\[Policy\]$/\[Policy\]/; s/#AutoEnable=false/AutoEnable=true/' ${RPM_BUILD_ROOT}/%{_sysconfdir}/bluetooth/main.conf
|
||||
|
||||
# Install the HCI emulator, useful for testing
|
||||
install emulator/btvirt ${RPM_BUILD_ROOT}/%{_libexecdir}/bluetooth/
|
||||
|
||||
@ -249,14 +241,12 @@ install emulator/btvirt ${RPM_BUILD_ROOT}/%{_libexecdir}/bluetooth/
|
||||
%{_bindir}/btmgmt
|
||||
%{_bindir}/btmon
|
||||
%{_bindir}/hex2hcd
|
||||
%{_bindir}/l2ping
|
||||
%{_bindir}/mpris-proxy
|
||||
%{_mandir}/man1/bluetoothctl.1.*
|
||||
%{_mandir}/man1/bluetoothctl-*.1.*
|
||||
%{_mandir}/man1/btmgmt.1.*
|
||||
%{_mandir}/man1/btattach.1.*
|
||||
%{_mandir}/man1/btmon.1.*
|
||||
%{_mandir}/man1/l2ping.1.*
|
||||
%{_mandir}/man8/bluetoothd.8.*
|
||||
%dir %{_libexecdir}/bluetooth
|
||||
%{_libexecdir}/bluetooth/bluetoothd
|
||||
@ -298,10 +288,14 @@ install emulator/btvirt ${RPM_BUILD_ROOT}/%{_libexecdir}/bluetooth/
|
||||
%doc doc/*txt
|
||||
%{_bindir}/isotest
|
||||
%{_bindir}/l2test
|
||||
%{_bindir}/l2ping
|
||||
%{_bindir}/rctest
|
||||
%{_mandir}/man1/isotest.1.*
|
||||
%{_mandir}/man1/l2ping.1.*
|
||||
%{_mandir}/man1/rctest.1.*
|
||||
%{_mandir}/man5/org.bluez.*.5.*
|
||||
%{_mandir}/man7/l2cap.7.*
|
||||
%{_mandir}/man7/rfcomm.7.*
|
||||
%{_libdir}/libbluetooth.so
|
||||
%{_includedir}/bluetooth
|
||||
%{_libdir}/pkgconfig/bluez.pc
|
||||
@ -330,9 +324,13 @@ install emulator/btvirt ${RPM_BUILD_ROOT}/%{_libexecdir}/bluetooth/
|
||||
%files obexd
|
||||
%{_libexecdir}/bluetooth/obexd
|
||||
%{_datadir}/dbus-1/services/org.bluez.obex.service
|
||||
/usr/lib/systemd/user/dbus-org.bluez.obex.service
|
||||
%{_userunitdir}/obex.service
|
||||
|
||||
%changelog
|
||||
* Mon Aug 05 2024 Bastien Nocera <bnocera@redhat.com> - 5.77-1
|
||||
- Update to 5.77
|
||||
|
||||
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 5.72-5
|
||||
- Bump release for June 2024 mass rebuild
|
||||
|
||||
|
@ -1,28 +0,0 @@
|
||||
From 70309219acd4c81e3a9e2b3652d2d93eb08b0aee Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Wed, 31 Aug 2022 11:16:34 +0200
|
||||
Subject: [PATCH 6/6] adapter: Remove experimental flag for PowerState
|
||||
|
||||
Now that the feature has been tested, that the API is deemed adequate
|
||||
and the reliability sufficient.
|
||||
---
|
||||
src/adapter.c | 3 +--
|
||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/adapter.c b/src/adapter.c
|
||||
index 8fb2acdc8..841096d7f 100644
|
||||
--- a/src/adapter.c
|
||||
+++ b/src/adapter.c
|
||||
@@ -3864,8 +3864,7 @@ static const GDBusPropertyTable adapter_properties[] = {
|
||||
{ "Alias", "s", property_get_alias, property_set_alias },
|
||||
{ "Class", "u", property_get_class },
|
||||
{ "Powered", "b", property_get_powered, property_set_powered },
|
||||
- { "PowerState", "s", property_get_power_state, NULL, NULL,
|
||||
- G_DBUS_PROPERTY_FLAG_EXPERIMENTAL },
|
||||
+ { "PowerState", "s", property_get_power_state },
|
||||
{ "Discoverable", "b", property_get_discoverable,
|
||||
property_set_discoverable },
|
||||
{ "DiscoverableTimeout", "u", property_get_discoverable_timeout,
|
||||
--
|
||||
2.37.2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (bluez-5.72.tar.xz) = 1c6560f60ac0654d7c25ed8ab2f0f3a3a9ca8688ee28e1c476ffc7ae38737e739d27bbb88789c86b03fc600a8a68496d90a7b395ec393dd2bbf69be62357991a
|
||||
SHA512 (bluez-5.77.tar.xz) = cf0faba4ddbfe6cc3c2d86cbd809483ed82327cbd7e4970ef53cf19053de7b355a505cab88844aebe7a6aa1947ec7a366250d3cbf48cf309db413d287289ff99
|
||||
|
Loading…
Reference in New Issue
Block a user