Remove unnecessary patch
We now use a systemd --user session, so no need for this work-around.
This commit is contained in:
parent
88e5001cf2
commit
4730eabcd1
@ -1,49 +0,0 @@
|
||||
From 0f8d9e85f264f653fc255fabc06eb5b5c9f9f1e6 Mon Sep 17 00:00:00 2001
|
||||
From: Giovanni Campagna <gcampagna@src.gnome.org>
|
||||
Date: Sat, 12 Oct 2013 17:45:25 +0200
|
||||
Subject: [PATCH 2/2] obex: Allow using obexd w/o systemd user session
|
||||
|
||||
Not all sessions run systemd --user (actually, the majority
|
||||
doesn't), so the dbus daemon must be able to spawn obexd
|
||||
directly, and to do so it needs the full path of the daemon.
|
||||
---
|
||||
Makefile.obexd | 4 ++--
|
||||
obexd/src/{org.bluez.obex.service => org.bluez.obex.service.in} | 2 +-
|
||||
2 files changed, 3 insertions(+), 3 deletions(-)
|
||||
rename obexd/src/{org.bluez.obex.service => org.bluez.obex.service.in} (76%)
|
||||
|
||||
diff --git a/Makefile.obexd b/Makefile.obexd
|
||||
index 2e33cbc72..d5d858c85 100644
|
||||
--- a/Makefile.obexd
|
||||
+++ b/Makefile.obexd
|
||||
@@ -2,12 +2,12 @@
|
||||
if SYSTEMD
|
||||
systemduserunitdir = @SYSTEMD_USERUNITDIR@
|
||||
systemduserunit_DATA = obexd/src/obex.service
|
||||
+endif
|
||||
|
||||
dbussessionbusdir = @DBUS_SESSIONBUSDIR@
|
||||
dbussessionbus_DATA = obexd/src/org.bluez.obex.service
|
||||
-endif
|
||||
|
||||
-EXTRA_DIST += obexd/src/obex.service.in obexd/src/org.bluez.obex.service
|
||||
+EXTRA_DIST += obexd/src/obex.service.in obexd/src/org.bluez.obex.service.in
|
||||
|
||||
obex_plugindir = $(libdir)/obex/plugins
|
||||
|
||||
diff --git a/obexd/src/org.bluez.obex.service b/obexd/src/org.bluez.obex.service.in
|
||||
similarity index 76%
|
||||
rename from obexd/src/org.bluez.obex.service
|
||||
rename to obexd/src/org.bluez.obex.service.in
|
||||
index a53808884..9c815f246 100644
|
||||
--- a/obexd/src/org.bluez.obex.service
|
||||
+++ b/obexd/src/org.bluez.obex.service.in
|
||||
@@ -1,4 +1,4 @@
|
||||
[D-BUS Service]
|
||||
Name=org.bluez.obex
|
||||
-Exec=/bin/false
|
||||
+Exec=@libexecdir@/obexd
|
||||
SystemdService=dbus-org.bluez.obex.service
|
||||
--
|
||||
2.14.1
|
||||
|
@ -16,8 +16,6 @@ Patch3: 0004-obex-Work-around-compilation-failure.patch
|
||||
|
||||
# https://github.com/hadess/bluez/commits/obex-5.46
|
||||
Patch4: 0001-obex-Use-GLib-helper-function-to-manipulate-paths.patch
|
||||
# Should not be necessary anymore
|
||||
# Patch5: 0002-obex-Allow-using-obexd-w-o-systemd-user-session.patch
|
||||
|
||||
# https://github.com/hadess/bluez/commits/autopair-5.46
|
||||
Patch5: 0001-autopair-Don-t-handle-the-iCade.patch
|
||||
|
Loading…
Reference in New Issue
Block a user