Update to 5.11
This commit is contained in:
parent
f77da253b0
commit
42ca3a0f34
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
|||||||
/bluez-4.*.tar.gz
|
/bluez-4.*.tar.gz
|
||||||
/bluez-5.9.tar.xz
|
/bluez-5.9.tar.xz
|
||||||
/bluez-5.10.tar.xz
|
/bluez-5.10.tar.xz
|
||||||
|
/bluez-5.11.tar.xz
|
||||||
|
@ -1,58 +0,0 @@
|
|||||||
From 3027cb7141fb65cf3eeda69c688db8c4045e2d3f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Giovanni Campagna <gcampagna-cNUdlRotFMnNLxjTenLetw@public.gmane.org>
|
|
||||||
Date: Sat, 12 Oct 2013 17:45:25 +0200
|
|
||||||
Subject: [PATCH] Allow using obexd without systemd in the user session
|
|
||||||
|
|
||||||
Not all sessions run systemd --user (actually, the majority
|
|
||||||
doesn't), so the dbus daemon must be able to spawn obexd
|
|
||||||
directly, and to do so it needs the full path of the daemon.
|
|
||||||
---
|
|
||||||
Makefile.obexd | 4 ++--
|
|
||||||
obexd/src/org.bluez.obex.service | 4 ----
|
|
||||||
obexd/src/org.bluez.obex.service.in | 4 ++++
|
|
||||||
3 files changed, 6 insertions(+), 6 deletions(-)
|
|
||||||
delete mode 100644 obexd/src/org.bluez.obex.service
|
|
||||||
create mode 100644 obexd/src/org.bluez.obex.service.in
|
|
||||||
|
|
||||||
diff --git a/Makefile.obexd b/Makefile.obexd
|
|
||||||
index 3760867..142e7c3 100644
|
|
||||||
--- a/Makefile.obexd
|
|
||||||
+++ b/Makefile.obexd
|
|
||||||
@@ -2,12 +2,12 @@
|
|
||||||
if SYSTEMD
|
|
||||||
systemduserunitdir = @SYSTEMD_USERUNITDIR@
|
|
||||||
systemduserunit_DATA = obexd/src/obex.service
|
|
||||||
+endif
|
|
||||||
|
|
||||||
dbussessionbusdir = @DBUS_SESSIONBUSDIR@
|
|
||||||
dbussessionbus_DATA = obexd/src/org.bluez.obex.service
|
|
||||||
-endif
|
|
||||||
|
|
||||||
-EXTRA_DIST += obexd/src/obex.service.in obexd/src/org.bluez.obex.service
|
|
||||||
+EXTRA_DIST += obexd/src/obex.service.in obexd/src/org.bluez.obex.service.in
|
|
||||||
|
|
||||||
obex_plugindir = $(libdir)/obex/plugins
|
|
||||||
|
|
||||||
diff --git a/obexd/src/org.bluez.obex.service b/obexd/src/org.bluez.obex.service
|
|
||||||
deleted file mode 100644
|
|
||||||
index a538088..0000000
|
|
||||||
--- a/obexd/src/org.bluez.obex.service
|
|
||||||
+++ /dev/null
|
|
||||||
@@ -1,4 +0,0 @@
|
|
||||||
-[D-BUS Service]
|
|
||||||
-Name=org.bluez.obex
|
|
||||||
-Exec=/bin/false
|
|
||||||
-SystemdService=dbus-org.bluez.obex.service
|
|
||||||
diff --git a/obexd/src/org.bluez.obex.service.in b/obexd/src/org.bluez.obex.service.in
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..9c815f2
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/obexd/src/org.bluez.obex.service.in
|
|
||||||
@@ -0,0 +1,4 @@
|
|
||||||
+[D-BUS Service]
|
|
||||||
+Name=org.bluez.obex
|
|
||||||
+Exec=@libexecdir@/obexd
|
|
||||||
+SystemdService=dbus-org.bluez.obex.service
|
|
||||||
--
|
|
||||||
1.8.3.1
|
|
||||||
|
|
@ -2,8 +2,8 @@
|
|||||||
|
|
||||||
Summary: Bluetooth utilities
|
Summary: Bluetooth utilities
|
||||||
Name: bluez
|
Name: bluez
|
||||||
Version: 5.10
|
Version: 5.11
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
URL: http://www.bluez.org/
|
URL: http://www.bluez.org/
|
||||||
@ -17,8 +17,6 @@ Patch1: playstation-peripheral-pugin-v5.x.patch
|
|||||||
Patch2: 0001-work-around-Logitech-diNovo-Edge-keyboard-firmware-i.patch
|
Patch2: 0001-work-around-Logitech-diNovo-Edge-keyboard-firmware-i.patch
|
||||||
# Non-upstream
|
# Non-upstream
|
||||||
Patch3: 0001-Allow-using-obexd-without-systemd-in-the-user-sessio.patch
|
Patch3: 0001-Allow-using-obexd-without-systemd-in-the-user-sessio.patch
|
||||||
# Upstream patch
|
|
||||||
Patch4: 0001-obex-Use-user-s-cache-dir-as-a-default-root.patch
|
|
||||||
|
|
||||||
BuildRequires: git
|
BuildRequires: git
|
||||||
BuildRequires: dbus-devel >= 0.90
|
BuildRequires: dbus-devel >= 0.90
|
||||||
@ -230,6 +228,9 @@ mkdir -p $RPM_BUILD_ROOT/%{_libdir}/bluetooth/
|
|||||||
/lib/udev/rules.d/97-hid2hci.rules
|
/lib/udev/rules.d/97-hid2hci.rules
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 18 2013 Bastien Nocera <bnocera@redhat.com> 5.11-1
|
||||||
|
- Update to 5.11
|
||||||
|
|
||||||
* Tue Nov 12 2013 Bastien Nocera <bnocera@redhat.com> 5.10-4
|
* Tue Nov 12 2013 Bastien Nocera <bnocera@redhat.com> 5.10-4
|
||||||
- Default to the XDG cache dir for receiving files
|
- Default to the XDG cache dir for receiving files
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user