More udev rules fixes

This commit is contained in:
Bastien Nocera 2009-06-21 14:07:19 +00:00
parent 30896f6d63
commit 310ff0c586
2 changed files with 28 additions and 19 deletions

View File

@ -1,28 +1,17 @@
From 830639ae0f3421a9d7c7366854925e32001771b5 Mon Sep 17 00:00:00 2001
From f723fb9f588a987bfaba94cfb2c1acb6c89c926c Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Sun, 21 Jun 2009 14:37:32 +0100
Subject: [PATCH] Add udev rules to start bluetooth on-demand
Those rules call bluetoothd --udev when a new dongle is inserted.
---
scripts/96-bluez.rules | 5 +++++
scripts/Makefile.am | 2 ++
2 files changed, 7 insertions(+), 0 deletions(-)
create mode 100644 scripts/96-bluez.rules
scripts/Makefile.am | 4 +++-
scripts/bluetooth.rules | 5 +++++
2 files changed, 8 insertions(+), 1 deletions(-)
create mode 100644 scripts/bluetooth.rules
diff --git a/scripts/96-bluez.rules b/scripts/96-bluez.rules
new file mode 100644
index 0000000..f3034b5
--- /dev/null
+++ b/scripts/96-bluez.rules
@@ -0,0 +1,5 @@
+# Run helper every time a Bluetooth device appears
+# On remove actions, bluetoothd should go away by itself
+
+ACTION=="add", SUBSYSTEM=="bluetooth", RUN+="/usr/sbin/bluetoothd --udev"
+
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 494a9c2..d87295d 100644
index 494a9c2..d06f95e 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -11,6 +11,8 @@ endif
@ -30,10 +19,30 @@ index 494a9c2..d87295d 100644
rules_DATA += bluetooth-serial.rules
endif
+
+rules_DATA += 96-bluez.rules
+rules_DATA += bluetooth.rules
endif
if PCMCIARULES
@@ -20,7 +22,7 @@ udev_SCRIPTS = bluetooth_serial
endif
EXTRA_DIST = bluetooth.init bluetooth.default bluetooth-hid2hci.rules \
- bluetooth-serial.rules bluetooth_serial
+ bluetooth-serial.rules bluetooth_serial bluetooth.rules
MAINTAINERCLEANFILES = Makefile.in
diff --git a/scripts/bluetooth.rules b/scripts/bluetooth.rules
new file mode 100644
index 0000000..f3034b5
--- /dev/null
+++ b/scripts/bluetooth.rules
@@ -0,0 +1,5 @@
+# Run helper every time a Bluetooth device appears
+# On remove actions, bluetoothd should go away by itself
+
+ACTION=="add", SUBSYSTEM=="bluetooth", RUN+="/usr/sbin/bluetoothd --udev"
+
--
1.6.2.2

View File

@ -165,7 +165,7 @@ fi
rm -f ${RPM_BUILD_ROOT}/%{_sysconfdir}/udev/*.rules
install -D -m0644 scripts/bluetooth-serial.rules ${RPM_BUILD_ROOT}/%{_sysconfdir}/udev/rules.d/97-bluetooth-serial.rules
install -D -m0755 scripts/bluetooth_serial ${RPM_BUILD_ROOT}/lib/udev/bluetooth_serial
install -D -m0644 %{SOURCE9} ${RPM_BUILD_ROOT}/lib/udev/rules.d/96-bluez.rules
install -D -m0644 scripts/bluetooth.rules ${RPM_BUILD_ROOT}/lib/udev/rules.d/bluetooth.rules
install -D -m0755 %{SOURCE8} $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/modules/bluez-uinput.modules