5.51
This commit is contained in:
parent
1102d27909
commit
234ae94fa0
@ -1,43 +0,0 @@
|
||||
From 74174217fc3f15255be875659d1e1d9403646bba Mon Sep 17 00:00:00 2001
|
||||
From: Tom Gundersen <teg@jklm.no>
|
||||
Date: Tue, 6 Nov 2018 12:07:17 +0100
|
||||
Subject: [PATCH] bluetooth.conf: remove deprecated at_console statement
|
||||
|
||||
As described in [0], this likely did not have the intended effect, so
|
||||
simply remove it. The change in behavior is that up until this patch
|
||||
it would be possible for root, lp, and any non-system user to potentially
|
||||
gain access to bluez' dbus interface. Now this is extended to also allow
|
||||
any system user.
|
||||
|
||||
[0]: <https://www.spinics.net/lists/linux-bluetooth/msg75267.html>
|
||||
---
|
||||
src/bluetooth.conf | 12 +-----------
|
||||
1 file changed, 1 insertion(+), 11 deletions(-)
|
||||
|
||||
diff --git a/src/bluetooth.conf b/src/bluetooth.conf
|
||||
index 0c0b221bb..05f407d1a 100644
|
||||
--- a/src/bluetooth.conf
|
||||
+++ b/src/bluetooth.conf
|
||||
@@ -21,18 +21,8 @@
|
||||
<allow send_interface="org.freedesktop.DBus.Properties"/>
|
||||
</policy>
|
||||
|
||||
- <policy at_console="true">
|
||||
- <allow send_destination="org.bluez"/>
|
||||
- </policy>
|
||||
-
|
||||
- <!-- allow users of lp group (printing subsystem) to
|
||||
- communicate with bluetoothd -->
|
||||
- <policy group="lp">
|
||||
- <allow send_destination="org.bluez"/>
|
||||
- </policy>
|
||||
-
|
||||
<policy context="default">
|
||||
- <deny send_destination="org.bluez"/>
|
||||
+ <allow send_destination="org.bluez"/>
|
||||
</policy>
|
||||
|
||||
</busconfig>
|
||||
--
|
||||
2.21.0
|
||||
|
@ -1,35 +1,35 @@
|
||||
From 69d2e7bebb79f500179298c6c51fafbc217df6c8 Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Wed, 20 Sep 2017 12:49:10 +0200
|
||||
From d0c73c6ce1ab9dc21f6a94be70475c90068e4acc Mon Sep 17 00:00:00 2001
|
||||
From: Peter Robinson <pbrobinson@gmail.com>
|
||||
Date: Fri, 20 Sep 2019 14:53:03 +0100
|
||||
Subject: [PATCH 1/4] build: Always define confdir and statedir
|
||||
|
||||
As we will need those paths to lock down on them.
|
||||
---
|
||||
Makefile.am | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
Makefile.am | 5 +++--
|
||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 555f301ca..1c38d94e5 100644
|
||||
index 404e6a460..033faf3bf 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -30,14 +30,14 @@ include_HEADERS =
|
||||
AM_CFLAGS = $(WARNING_CFLAGS) $(MISC_CFLAGS)
|
||||
@@ -31,14 +31,15 @@ pkginclude_HEADERS =
|
||||
AM_CFLAGS = $(WARNING_CFLAGS) $(MISC_CFLAGS) $(UDEV_CFLAGS) $(ell_cflags)
|
||||
AM_LDFLAGS = $(MISC_LDFLAGS)
|
||||
|
||||
+confdir = $(sysconfdir)/bluetooth
|
||||
+statedir = $(localstatedir)/lib/bluetooth
|
||||
+
|
||||
if DATAFILES
|
||||
dbusdir = @DBUS_CONFDIR@/dbus-1/system.d
|
||||
dbusdir = $(DBUS_CONFDIR)/dbus-1/system.d
|
||||
dbus_DATA = src/bluetooth.conf
|
||||
|
||||
-confdir = $(sysconfdir)/bluetooth
|
||||
conf_DATA =
|
||||
-
|
||||
|
||||
-statedir = $(localstatedir)/lib/bluetooth
|
||||
state_DATA =
|
||||
endif
|
||||
|
||||
--
|
||||
2.14.1
|
||||
2.21.0
|
||||
|
||||
|
@ -1,31 +0,0 @@
|
||||
From e45c8fdcb3d7cdb654f6819c02d1bbb5b40b6116 Mon Sep 17 00:00:00 2001
|
||||
From: Florian Weimer <fweimer@redhat.com>
|
||||
Date: Thu, 7 Nov 2013 09:23:35 +0100
|
||||
Subject: [PATCH 1/4] build: Enable BIND_NOW
|
||||
|
||||
Partial RELRO means that the object is GNU_RELRO but not BIND_NOW. This
|
||||
reduces the effectiveness of RELRO. bluez triggers this because it
|
||||
enables PIE during the build, and rpmdiff takes this as an indicator
|
||||
that the best possible hardening is desired.
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=983161
|
||||
---
|
||||
acinclude.m4 | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/acinclude.m4 b/acinclude.m4
|
||||
index bc39c6d73..efce2f3cb 100644
|
||||
--- a/acinclude.m4
|
||||
+++ b/acinclude.m4
|
||||
@@ -50,7 +50,7 @@ AC_DEFUN([MISC_FLAGS], [
|
||||
if (test "${enableval}" = "yes" &&
|
||||
test "${ac_cv_prog_cc_pie}" = "yes"); then
|
||||
misc_cflags="$misc_cflags -fPIC"
|
||||
- misc_ldflags="$misc_ldflags -pie"
|
||||
+ misc_ldflags="$misc_ldflags -pie -Wl,-z,now"
|
||||
fi
|
||||
])
|
||||
if (test "$enable_coverage" = "yes"); then
|
||||
--
|
||||
2.14.1
|
||||
|
@ -1,72 +0,0 @@
|
||||
From 477ecca127c529611adbc53f08039cefaf86305d Mon Sep 17 00:00:00 2001
|
||||
From: Luiz Augusto von Dentz <luiz.von.dentz@intel.com>
|
||||
Date: Tue, 26 Jun 2018 13:37:33 +0300
|
||||
Subject: [PATCH] policy: Add logic to connect a Sink
|
||||
|
||||
If HFP/HSP HS connects and the device also supports a Sink connect it
|
||||
as well since some devices (e.g. Sony MW600) may not connect it
|
||||
automatically.
|
||||
---
|
||||
plugins/policy.c | 39 +++++++++++++++++++++++++++++++++++++++
|
||||
1 file changed, 39 insertions(+)
|
||||
|
||||
diff --git a/plugins/policy.c b/plugins/policy.c
|
||||
index 1f5a506a2..de51e58b9 100644
|
||||
--- a/plugins/policy.c
|
||||
+++ b/plugins/policy.c
|
||||
@@ -297,6 +297,42 @@ static void sink_cb(struct btd_service *service, btd_service_state_t old_state,
|
||||
}
|
||||
}
|
||||
|
||||
+static void hs_cb(struct btd_service *service, btd_service_state_t old_state,
|
||||
+ btd_service_state_t new_state)
|
||||
+{
|
||||
+ struct btd_device *dev = btd_service_get_device(service);
|
||||
+ struct policy_data *data;
|
||||
+ struct btd_service *sink;
|
||||
+
|
||||
+ /* If the device supports Sink set a timer to connect it as well */
|
||||
+ sink = btd_device_get_service(dev, A2DP_SINK_UUID);
|
||||
+ if (sink == NULL)
|
||||
+ return;
|
||||
+
|
||||
+ data = policy_get_data(dev);
|
||||
+
|
||||
+ switch (new_state) {
|
||||
+ case BTD_SERVICE_STATE_UNAVAILABLE:
|
||||
+ break;
|
||||
+ case BTD_SERVICE_STATE_DISCONNECTED:
|
||||
+ break;
|
||||
+ case BTD_SERVICE_STATE_CONNECTING:
|
||||
+ break;
|
||||
+ case BTD_SERVICE_STATE_CONNECTED:
|
||||
+ /* Check if service initiate the connection then proceed
|
||||
+ * immediately otherwise set timer
|
||||
+ */
|
||||
+ if (old_state == BTD_SERVICE_STATE_CONNECTING)
|
||||
+ policy_connect(data, sink);
|
||||
+ else if (btd_service_get_state(sink) !=
|
||||
+ BTD_SERVICE_STATE_CONNECTED)
|
||||
+ policy_set_sink_timer(data);
|
||||
+ break;
|
||||
+ case BTD_SERVICE_STATE_DISCONNECTING:
|
||||
+ break;
|
||||
+ }
|
||||
+}
|
||||
+
|
||||
static gboolean policy_connect_tg(gpointer user_data)
|
||||
{
|
||||
struct policy_data *data = user_data;
|
||||
@@ -615,6 +651,9 @@ static void service_cb(struct btd_service *service,
|
||||
controller_cb(service, old_state, new_state);
|
||||
else if (g_str_equal(profile->remote_uuid, AVRCP_TARGET_UUID))
|
||||
target_cb(service, old_state, new_state);
|
||||
+ else if (g_str_equal(profile->remote_uuid, HFP_HS_UUID) ||
|
||||
+ g_str_equal(profile->remote_uuid, HSP_HS_UUID))
|
||||
+ hs_cb(service, old_state, new_state);
|
||||
|
||||
/*
|
||||
* Return if the reconnection feature is not enabled (all
|
||||
--
|
||||
2.17.1
|
||||
|
@ -1,63 +0,0 @@
|
||||
From 3a8cc80e916bd9b88a33cd08ccbd99e43113d530 Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Fri, 7 Jun 2019 09:25:12 +0200
|
||||
Subject: [PATCH] tools: Fix build after y2038 changes in glibc
|
||||
|
||||
The 32-bit SIOCGSTAMP has been deprecated. Use the deprecated name
|
||||
to fix the build.
|
||||
---
|
||||
tools/l2test.c | 6 +++++-
|
||||
tools/rctest.c | 6 +++++-
|
||||
2 files changed, 10 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tools/l2test.c b/tools/l2test.c
|
||||
index e755ac881..e787c2ce2 100644
|
||||
--- a/tools/l2test.c
|
||||
+++ b/tools/l2test.c
|
||||
@@ -55,6 +55,10 @@
|
||||
#define BREDR_DEFAULT_PSM 0x1011
|
||||
#define LE_DEFAULT_PSM 0x0080
|
||||
|
||||
+#ifndef SIOCGSTAMP_OLD
|
||||
+#define SIOCGSTAMP_OLD SIOCGSTAMP
|
||||
+#endif
|
||||
+
|
||||
/* Test modes */
|
||||
enum {
|
||||
SEND,
|
||||
@@ -907,7 +911,7 @@ static void recv_mode(int sk)
|
||||
if (timestamp) {
|
||||
struct timeval tv;
|
||||
|
||||
- if (ioctl(sk, SIOCGSTAMP, &tv) < 0) {
|
||||
+ if (ioctl(sk, SIOCGSTAMP_OLD, &tv) < 0) {
|
||||
timestamp = 0;
|
||||
memset(ts, 0, sizeof(ts));
|
||||
} else {
|
||||
diff --git a/tools/rctest.c b/tools/rctest.c
|
||||
index 94490f462..bc8ed875d 100644
|
||||
--- a/tools/rctest.c
|
||||
+++ b/tools/rctest.c
|
||||
@@ -50,6 +50,10 @@
|
||||
|
||||
#include "src/shared/util.h"
|
||||
|
||||
+#ifndef SIOCGSTAMP_OLD
|
||||
+#define SIOCGSTAMP_OLD SIOCGSTAMP
|
||||
+#endif
|
||||
+
|
||||
/* Test modes */
|
||||
enum {
|
||||
SEND,
|
||||
@@ -505,7 +509,7 @@ static void recv_mode(int sk)
|
||||
if (timestamp) {
|
||||
struct timeval tv;
|
||||
|
||||
- if (ioctl(sk, SIOCGSTAMP, &tv) < 0) {
|
||||
+ if (ioctl(sk, SIOCGSTAMP_OLD, &tv) < 0) {
|
||||
timestamp = 0;
|
||||
memset(ts, 0, sizeof(ts));
|
||||
} else {
|
||||
--
|
||||
2.21.0
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 4570164f0c90603bd07eb9e7c07e17bbafb5b5da Mon Sep 17 00:00:00 2001
|
||||
From 4e027d3c019846e216c6f76496d71c89f063ed59 Mon Sep 17 00:00:00 2001
|
||||
From: Craig Andrews <candrews@integralblue.com>
|
||||
Date: Wed, 13 Sep 2017 15:23:09 +0200
|
||||
Subject: [PATCH 2/4] systemd: Add PrivateTmp and NoNewPrivileges options
|
||||
@ -15,7 +15,7 @@ possible privilege escalations.
|
||||
1 file changed, 6 insertions(+)
|
||||
|
||||
diff --git a/src/bluetooth.service.in b/src/bluetooth.service.in
|
||||
index f799f65f0..a6f3030f9 100644
|
||||
index f9faaa452..7c2f60bb4 100644
|
||||
--- a/src/bluetooth.service.in
|
||||
+++ b/src/bluetooth.service.in
|
||||
@@ -12,8 +12,14 @@ NotifyAccess=main
|
||||
@ -34,5 +34,5 @@ index f799f65f0..a6f3030f9 100644
|
||||
[Install]
|
||||
WantedBy=bluetooth.target
|
||||
--
|
||||
2.14.1
|
||||
2.21.0
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
From 73a9c0902e7c97adf96e735407a75033152c04a9 Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Wed, 13 Sep 2017 15:37:11 +0200
|
||||
From 5a65aa9b9d4035f94cee1016a256cec017a42aad Mon Sep 17 00:00:00 2001
|
||||
From: Peter Robinson <pbrobinson@gmail.com>
|
||||
Date: Fri, 20 Sep 2019 14:55:28 +0100
|
||||
Subject: [PATCH 3/4] systemd: Add more filesystem lockdown
|
||||
|
||||
We can only access the configuration file as read-only and read-write
|
||||
@ -11,20 +11,20 @@ to the Bluetooth cache directory and sub-directories.
|
||||
2 files changed, 6 insertions(+)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 1c38d94e5..13ccf9079 100644
|
||||
index 033faf3bf..f6347a14b 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -478,6 +478,8 @@ MAINTAINERCLEANFILES = Makefile.in \
|
||||
@@ -563,6 +563,8 @@ MAINTAINERCLEANFILES = Makefile.in \
|
||||
|
||||
SED_PROCESS = $(AM_V_GEN)$(MKDIR_P) $(dir $@) && \
|
||||
$(SED) -e 's,@libexecdir\@,$(libexecdir),g' \
|
||||
$(SED) -e 's,@pkglibexecdir\@,$(pkglibexecdir),g' \
|
||||
+ -e 's,@statedir\@,$(statedir),g' \
|
||||
+ -e 's,@confdir\@,$(confdir),g' \
|
||||
< $< > $@
|
||||
|
||||
%.service: %.service.in Makefile
|
||||
diff --git a/src/bluetooth.service.in b/src/bluetooth.service.in
|
||||
index a6f3030f9..7e55b5043 100644
|
||||
index 7c2f60bb4..4daedef2a 100644
|
||||
--- a/src/bluetooth.service.in
|
||||
+++ b/src/bluetooth.service.in
|
||||
@@ -17,6 +17,10 @@ LimitNPROC=1
|
||||
@ -39,5 +39,5 @@ index a6f3030f9..7e55b5043 100644
|
||||
# Privilege escalation
|
||||
NoNewPrivileges=true
|
||||
--
|
||||
2.14.1
|
||||
2.21.0
|
||||
|
||||
|
@ -1,41 +0,0 @@
|
||||
From 07a12a6685ea57be18f39e349dbc42e4af3744ed Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Tue, 5 Sep 2017 10:32:15 +0200
|
||||
Subject: [PATCH 3/4] tools/csr_usb: Fix compilation failure
|
||||
|
||||
GCC's "format-nonliteral" security check is enabled as an error in
|
||||
recent versions of Fedora. Given the reduced scope of use, mark the
|
||||
error as ignorable through pragma.
|
||||
|
||||
tools/csr_usb.c: In function 'read_value':
|
||||
tools/csr_usb.c:82:2: error: format not a string literal, argument types not checked [-Werror=format-nonliteral]
|
||||
n = fscanf(file, format, &value);
|
||||
^
|
||||
---
|
||||
tools/csr_usb.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/tools/csr_usb.c b/tools/csr_usb.c
|
||||
index a1d7324f7..33e9968a2 100644
|
||||
--- a/tools/csr_usb.c
|
||||
+++ b/tools/csr_usb.c
|
||||
@@ -67,6 +67,8 @@ struct usbfs_bulktransfer {
|
||||
#define USBFS_IOCTL_CLAIMINTF _IOR('U', 15, unsigned int)
|
||||
#define USBFS_IOCTL_RELEASEINTF _IOR('U', 16, unsigned int)
|
||||
|
||||
+#pragma GCC diagnostic push
|
||||
+#pragma GCC diagnostic ignored "-Wformat-nonliteral"
|
||||
static int read_value(const char *name, const char *attr, const char *format)
|
||||
{
|
||||
char path[PATH_MAX];
|
||||
@@ -88,6 +90,7 @@ static int read_value(const char *name, const char *attr, const char *format)
|
||||
fclose(file);
|
||||
return value;
|
||||
}
|
||||
+#pragma GCC diagnostic pop
|
||||
|
||||
static char *check_device(const char *name)
|
||||
{
|
||||
--
|
||||
2.14.1
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 171d812218883281fed57b57fafd5c18eac441ac Mon Sep 17 00:00:00 2001
|
||||
From b3ba84d0327cdda5621f3b4bde7d4cfa496d7c4a Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Wed, 13 Sep 2017 15:38:26 +0200
|
||||
Subject: [PATCH 4/4] systemd: More lockdown
|
||||
@ -10,7 +10,7 @@ access, so block those.
|
||||
1 file changed, 6 insertions(+)
|
||||
|
||||
diff --git a/src/bluetooth.service.in b/src/bluetooth.service.in
|
||||
index 7e55b5043..e8267b338 100644
|
||||
index 4daedef2a..f18801866 100644
|
||||
--- a/src/bluetooth.service.in
|
||||
+++ b/src/bluetooth.service.in
|
||||
@@ -22,9 +22,15 @@ ProtectControlGroups=true
|
||||
@ -30,5 +30,5 @@ index 7e55b5043..e8267b338 100644
|
||||
WantedBy=bluetooth.target
|
||||
Alias=dbus-org.bluez.service
|
||||
--
|
||||
2.14.1
|
||||
2.21.0
|
||||
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,81 +0,0 @@
|
||||
From b83e617e98ddfce94f3209399c290c8a764ffe3e Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Mon, 27 Nov 2017 16:26:50 +0100
|
||||
Subject: [PATCH 1/2] autopair: Add more common PIN codes for audio devices
|
||||
|
||||
PIN codes "1111", and "1234" are fairly common PIN codes used for audio
|
||||
devices such as speakers and headsets. This replaces similar quirks
|
||||
already present in gnome-bluetooth's PIN database.
|
||||
---
|
||||
plugins/autopair.c | 18 ++++++++++++++----
|
||||
1 file changed, 14 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/plugins/autopair.c b/plugins/autopair.c
|
||||
index 6980b0a64..70e19930e 100644
|
||||
--- a/plugins/autopair.c
|
||||
+++ b/plugins/autopair.c
|
||||
@@ -92,10 +92,20 @@ static ssize_t autopair_pincb(struct btd_adapter *adapter,
|
||||
case 0x06: /* Headphones */
|
||||
case 0x07: /* Portable Audio */
|
||||
case 0x0a: /* HiFi Audio Device */
|
||||
- if (attempt > 1)
|
||||
- return 0;
|
||||
- memcpy(pinbuf, "0000", 4);
|
||||
- return 4;
|
||||
+ {
|
||||
+ const char *pincodes[] = {
|
||||
+ "0000",
|
||||
+ "1234",
|
||||
+ "1111"
|
||||
+ };
|
||||
+ const char *pincode;
|
||||
+
|
||||
+ if (attempt > G_N_ELEMENTS(pincodes))
|
||||
+ return 0;
|
||||
+ pincode = pincodes[attempt - 1];
|
||||
+ memcpy(pinbuf, pincode, strlen(pincode));
|
||||
+ return strlen(pincode);
|
||||
+ }
|
||||
}
|
||||
break;
|
||||
|
||||
--
|
||||
2.21.0
|
||||
|
||||
|
||||
From 62d8a8237e3cb5bea5333d485416cc8d8b92556c Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Mon, 27 Nov 2017 16:26:51 +0100
|
||||
Subject: [PATCH 2/2] autopair: Add pin codes to try for gaming input devices
|
||||
|
||||
As well as remote controls.
|
||||
---
|
||||
plugins/autopair.c | 12 ++++++++++++
|
||||
1 file changed, 12 insertions(+)
|
||||
|
||||
diff --git a/plugins/autopair.c b/plugins/autopair.c
|
||||
index 70e19930e..043bd9b9d 100644
|
||||
--- a/plugins/autopair.c
|
||||
+++ b/plugins/autopair.c
|
||||
@@ -111,6 +111,18 @@ static ssize_t autopair_pincb(struct btd_adapter *adapter,
|
||||
|
||||
case 0x05: /* Peripheral */
|
||||
switch ((class & 0xc0) >> 6) {
|
||||
+ case 0x00:
|
||||
+ switch ((class & 0x1e) >> 2) {
|
||||
+ case 0x01: /* Joystick */
|
||||
+ case 0x02: /* Gamepad */
|
||||
+ case 0x03: /* Remote Control */
|
||||
+ if (attempt > 1)
|
||||
+ return 0;
|
||||
+ memcpy(pinbuf, "0000", 4);
|
||||
+ return 4;
|
||||
+ }
|
||||
+
|
||||
+ break;
|
||||
case 0x01: /* Keyboard */
|
||||
case 0x03: /* Combo keyboard/pointing device */
|
||||
/* For keyboards rejecting the first random code
|
||||
--
|
||||
2.21.0
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,60 +0,0 @@
|
||||
From f12e00b5127589589d476817cb528d442c30b2c7 Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Thu, 6 Jun 2019 18:42:42 +0200
|
||||
Subject: [PATCH 1/2] sixaxis: Fix another problem with already setup devices
|
||||
|
||||
If the device went through any kind of pairing once, it might have been
|
||||
set as trusted. Make sure to set the device as untrusted before starting
|
||||
the cable pairing authorization so that we don't exit early from
|
||||
process_auth_queue() (which considers trusted devices to be paired).
|
||||
---
|
||||
plugins/sixaxis.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/plugins/sixaxis.c b/plugins/sixaxis.c
|
||||
index fed68d2d8..12638829b 100644
|
||||
--- a/plugins/sixaxis.c
|
||||
+++ b/plugins/sixaxis.c
|
||||
@@ -365,6 +365,7 @@ static bool setup_device(int fd, const char *sysfs_path,
|
||||
|
||||
btd_device_device_set_name(device, cp->name);
|
||||
btd_device_set_pnpid(device, cp->source, cp->vid, cp->pid, cp->version);
|
||||
+ btd_device_set_trusted(device, false);
|
||||
btd_device_set_temporary(device, true);
|
||||
|
||||
closure = g_new0(struct authentication_closure, 1);
|
||||
--
|
||||
2.21.0
|
||||
|
||||
|
||||
From 32f6e03823970796b7e08718fe28c76c96de32ac Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Thu, 6 Jun 2019 18:46:23 +0200
|
||||
Subject: [PATCH 2/2] sixaxis: Throw an error when cable setup fails
|
||||
|
||||
If btd_request_authorization_cable_configured() fails, throw an error
|
||||
and free resources.
|
||||
---
|
||||
plugins/sixaxis.c | 6 ++++++
|
||||
1 file changed, 6 insertions(+)
|
||||
|
||||
diff --git a/plugins/sixaxis.c b/plugins/sixaxis.c
|
||||
index 12638829b..939fed759 100644
|
||||
--- a/plugins/sixaxis.c
|
||||
+++ b/plugins/sixaxis.c
|
||||
@@ -384,6 +384,12 @@ static bool setup_device(int fd, const char *sysfs_path,
|
||||
adapter_bdaddr, &device_bdaddr,
|
||||
HID_UUID, agent_auth_cb, closure);
|
||||
|
||||
+ if (closure->auth_id == 0) {
|
||||
+ error("sixaxis: could not request cable authorization");
|
||||
+ auth_closure_destroy(closure, true);
|
||||
+ return false;
|
||||
+ }
|
||||
+
|
||||
g_hash_table_insert(pending_auths, closure->sysfs_path, closure);
|
||||
|
||||
return true;
|
||||
--
|
||||
2.21.0
|
||||
|
65
bluez.spec
65
bluez.spec
@ -1,7 +1,7 @@
|
||||
Name: bluez
|
||||
Version: 5.51
|
||||
Release: 1%{?dist}
|
||||
Summary: Bluetooth utilities
|
||||
Version: 5.50
|
||||
Release: 9%{?dist}
|
||||
License: GPLv2+
|
||||
URL: http://www.bluez.org/
|
||||
|
||||
@ -14,35 +14,14 @@ Source2: 69-btattach-bcm.rules
|
||||
Source3: btattach-bcm@.service
|
||||
Source4: btattach-bcm-service.sh
|
||||
|
||||
# https://github.com/hadess/bluez/commits/build-fixes-5.46
|
||||
Patch1: 0001-build-Enable-BIND_NOW.patch
|
||||
Patch2: 0003-tools-csr_usb-Fix-compilation-failure.patch
|
||||
|
||||
# https://github.com/hadess/bluez/commits/obex-5.46
|
||||
Patch3: 0001-obex-Use-GLib-helper-function-to-manipulate-paths.patch
|
||||
Patch1: 0001-obex-Use-GLib-helper-function-to-manipulate-paths.patch
|
||||
|
||||
# https://github.com/hadess/bluez/commits/systemd-hardening
|
||||
Patch20: 0001-build-Always-define-confdir-and-statedir.patch
|
||||
Patch21: 0002-systemd-Add-PrivateTmp-and-NoNewPrivileges-options.patch
|
||||
Patch22: 0003-systemd-Add-more-filesystem-lockdown.patch
|
||||
Patch23: 0004-systemd-More-lockdown.patch
|
||||
|
||||
# Fix A2DP disconnection with some headsets
|
||||
Patch30: 0001-policy-Add-logic-to-connect-a-Sink.patch
|
||||
|
||||
# Backports:
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1711594
|
||||
Patch40: 0001-bluetooth.conf-remove-deprecated-at_console-statemen.patch
|
||||
# autopair enhancements
|
||||
Patch41: bluez-5.50-autopair-backports.patch
|
||||
# Discoverable filters support, as used in gnome-bluetooth
|
||||
Patch42: bluez-5.50-discoverability-backports.patch
|
||||
# a2dp fixes for newer codecs
|
||||
Patch43: bluez-5.50-a2dp-backports.patch
|
||||
# sixaxis pairing fixes
|
||||
Patch44: bluez-5.50-sixaxis-fixes.patch
|
||||
# y2038 build fix
|
||||
Patch45: 0001-tools-Fix-build-after-y2038-changes-in-glibc.patch
|
||||
Patch10: 0001-build-Always-define-confdir-and-statedir.patch
|
||||
Patch11: 0002-systemd-Add-PrivateTmp-and-NoNewPrivileges-options.patch
|
||||
Patch12: 0003-systemd-Add-more-filesystem-lockdown.patch
|
||||
Patch13: 0004-systemd-More-lockdown.patch
|
||||
|
||||
BuildRequires: git-core
|
||||
BuildRequires: dbus-devel >= 1.6
|
||||
@ -103,6 +82,10 @@ Requires: cups
|
||||
Summary: Put HID proxying bluetooth HCI's into HCI mode
|
||||
Requires: bluez%{?_isa} = %{version}-%{release}
|
||||
|
||||
%package mesh
|
||||
Summary: Bluetooth mesh
|
||||
Requires: bluez-libs%{?_isa} = %{version}-%{release}
|
||||
|
||||
%package obexd
|
||||
Summary: Object Exchange daemon for sharing content
|
||||
Requires: bluez%{?_isa} = %{version}-%{release}
|
||||
@ -137,6 +120,9 @@ them again. Since you cannot use your bluetooth keyboard and mouse until
|
||||
they are paired, this will require the use of a regular (wired) USB keyboard
|
||||
and mouse.
|
||||
|
||||
%description mesh
|
||||
Services for bluetooth mesh
|
||||
|
||||
%description obexd
|
||||
Object Exchange daemon for sharing files, contacts etc over bluetooth
|
||||
|
||||
@ -151,10 +137,10 @@ autoreconf -f -i
|
||||
--with-systemdsystemunitdir=%{_unitdir} \
|
||||
--with-systemduserunitdir=%{_userunitdir}
|
||||
|
||||
make %{?_smp_mflags} V=1
|
||||
%{make_build}
|
||||
|
||||
%install
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
%{make_install}
|
||||
|
||||
# "make install" fails to install gatttool, necessary for Bluetooth Low Energy
|
||||
# Red Hat Bugzilla bug #1141909
|
||||
@ -207,6 +193,12 @@ install -D -p -m0755 %{SOURCE4} ${RPM_BUILD_ROOT}/%{_libexecdir}/bluetooth/
|
||||
%post hid2hci
|
||||
/sbin/udevadm trigger --subsystem-match=usb
|
||||
|
||||
%post mesh
|
||||
%systemd_user_post bluetooth-mesh.service
|
||||
|
||||
%preun mesh
|
||||
%systemd_user_preun bluetooth-mesh.service
|
||||
|
||||
%post obexd
|
||||
%systemd_user_post obex.service
|
||||
|
||||
@ -214,7 +206,6 @@ install -D -p -m0755 %{SOURCE4} ${RPM_BUILD_ROOT}/%{_libexecdir}/bluetooth/
|
||||
%systemd_user_preun obex.service
|
||||
|
||||
%files
|
||||
%{!?_licensedir:%global license %%doc}
|
||||
%license COPYING
|
||||
%doc AUTHORS ChangeLog
|
||||
%config %{_sysconfdir}/dbus-1/system.d/bluetooth.conf
|
||||
@ -234,7 +225,6 @@ install -D -p -m0755 %{SOURCE4} ${RPM_BUILD_ROOT}/%{_libexecdir}/bluetooth/
|
||||
%{_bindir}/hcidump
|
||||
%{_bindir}/l2test
|
||||
%{_bindir}/hex2hcd
|
||||
%{_bindir}/meshctl
|
||||
%{_bindir}/mpris-proxy
|
||||
%{_bindir}/gatttool
|
||||
%{_bindir}/rctest
|
||||
@ -259,6 +249,7 @@ install -D -p -m0755 %{SOURCE4} ${RPM_BUILD_ROOT}/%{_libexecdir}/bluetooth/
|
||||
%{_unitdir}/bluetooth.service
|
||||
%{_unitdir}/btattach-bcm@.service
|
||||
%{_udevrulesdir}/69-btattach-bcm.rules
|
||||
%{_datadir}/zsh/site-functions/_bluetoothctl
|
||||
|
||||
%files libs
|
||||
%{!?_licensedir:%global license %%doc}
|
||||
@ -279,12 +270,22 @@ install -D -p -m0755 %{SOURCE4} ${RPM_BUILD_ROOT}/%{_libexecdir}/bluetooth/
|
||||
%{_mandir}/man1/hid2hci.1*
|
||||
%{_udevrulesdir}/97-hid2hci.rules
|
||||
|
||||
%files mesh
|
||||
%config %{_sysconfdir}/dbus-1/system.d/bluetooth-mesh.conf
|
||||
%{_bindir}/meshctl
|
||||
%{_datadir}/dbus-1/system-services/org.bluez.mesh.service
|
||||
%{_libexecdir}/bluetooth/bluetooth-meshd
|
||||
%{_unitdir}/bluetooth-mesh.service
|
||||
|
||||
%files obexd
|
||||
%{_libexecdir}/bluetooth/obexd
|
||||
%{_datadir}/dbus-1/services/org.bluez.obex.service
|
||||
%{_userunitdir}/obex.service
|
||||
|
||||
%changelog
|
||||
* Fri Sep 20 2019 Peter Robinson <pbrobinson@fedoraproject.org> 5.51-1
|
||||
+ bluez 5.51
|
||||
|
||||
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.50-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (bluez-5.50.tar.xz) = 64a680e4b3c270bc2439610c91ad2aef36131d84401e4bbdf6c2b7ec8708a19dfc942b31b9189c38a97ca072c761c669ae1aace5f4ff5d06de3ccbf33184be45
|
||||
SHA512 (bluez-5.51.tar.xz) = 8b14eea98f541b981162abce728e0f917654ad3c990721ec398fe41bdd68069fe55ff64b61bc3c3b9f813facf42c995b07619f6d5d153965de27154b1a7b578f
|
||||
|
Loading…
Reference in New Issue
Block a user