- Update to 4.43
This commit is contained in:
parent
48f733757f
commit
1fb2c4d6d8
@ -1 +1 @@
|
|||||||
bluez-4.42.tar.gz
|
bluez-4.43.tar.gz
|
||||||
|
@ -17,59 +17,6 @@ address, and added to the database of the current default adapter.
|
|||||||
4 files changed, 388 insertions(+), 1 deletions(-)
|
4 files changed, 388 insertions(+), 1 deletions(-)
|
||||||
create mode 100644 plugins/cable.c
|
create mode 100644 plugins/cable.c
|
||||||
|
|
||||||
diff --git a/acinclude.m4 b/acinclude.m4
|
|
||||||
index eb7cdeb..dac1120 100644
|
|
||||||
--- a/acinclude.m4
|
|
||||||
+++ b/acinclude.m4
|
|
||||||
@@ -159,6 +159,12 @@ AC_DEFUN([AC_PATH_USB], [
|
|
||||||
[Define to 1 if you need the usb_interrupt_read() function.]))
|
|
||||||
])
|
|
||||||
|
|
||||||
+AC_DEFUN([AC_PATH_CABLE], [
|
|
||||||
+ PKG_CHECK_MODULES(CABLE, gudev-1.0 libusb-1.0, cable_found=yes, cable_found=no)
|
|
||||||
+ AC_SUBST(CABLE_CFLAGS)
|
|
||||||
+ AC_SUBST(CABLE_LIBS)
|
|
||||||
+])
|
|
||||||
+
|
|
||||||
AC_DEFUN([AC_PATH_NETLINK], [
|
|
||||||
PKG_CHECK_MODULES(NETLINK, libnl-1, netlink_found=yes, netlink_found=no)
|
|
||||||
AC_SUBST(NETLINK_CFLAGS)
|
|
||||||
@@ -179,6 +185,7 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
|
||||||
netlink_enable=no
|
|
||||||
hal_enable=${hal_found}
|
|
||||||
usb_enable=${usb_found}
|
|
||||||
+ cable_enable=${cable_found}
|
|
||||||
alsa_enable=${alsa_found}
|
|
||||||
gstreamer_enable=${gstreamer_found}
|
|
||||||
audio_enable=yes
|
|
||||||
@@ -241,6 +248,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
|
||||||
usb_enable=${enableval}
|
|
||||||
])
|
|
||||||
|
|
||||||
+ AC_ARG_ENABLE(cable, AC_HELP_STRING([--enable-cable], [enable DeviceKit support]), [
|
|
||||||
+ cable_enable=${enableval}
|
|
||||||
+ ])
|
|
||||||
+
|
|
||||||
AC_ARG_ENABLE(netlink, AC_HELP_STRING([--enable-netlink], [enable NETLINK support]), [
|
|
||||||
netlink_enable=${enableval}
|
|
||||||
])
|
|
||||||
@@ -324,6 +335,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
|
||||||
AC_DEFINE(HAVE_LIBUSB, 1, [Define to 1 if you have USB library.])
|
|
||||||
fi
|
|
||||||
|
|
||||||
+ if (test "${cable_enable}" = "yes" && test "${cable_found}" = "yes"); then
|
|
||||||
+ AC_DEFINE(HAVE_CABLE, 1, [Define to 1 if you have libcable.])
|
|
||||||
+ fi
|
|
||||||
+
|
|
||||||
AC_SUBST([BLUEZ_CFLAGS], ['-I$(top_builddir)/include'])
|
|
||||||
AC_SUBST([BLUEZ_LIBS], ['$(top_builddir)/lib/libbluetooth.la'])
|
|
||||||
|
|
||||||
@@ -357,4 +372,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
|
||||||
AM_CONDITIONAL(CONFIGFILES, test "${configfiles_enable}" = "yes")
|
|
||||||
AM_CONDITIONAL(INITSCRIPTS, test "${initscripts_enable}" = "yes")
|
|
||||||
AM_CONDITIONAL(PCMCIARULES, test "${pcmciarules_enable}" = "yes")
|
|
||||||
+ AM_CONDITIONAL(CABLE, test "${cable_enable}" = "yes" && test "${cable_found}" = "yes")
|
|
||||||
])
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
diff --git a/configure.ac b/configure.ac
|
||||||
index 1686d18..339d45c 100644
|
index 1686d18..339d45c 100644
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
@ -502,3 +449,54 @@ index 0000000..9f24b55
|
|||||||
--
|
--
|
||||||
1.6.0.6
|
1.6.0.6
|
||||||
|
|
||||||
|
--- bluez-4.43.old/acinclude.m4 2009-07-02 23:43:14.000000000 +0100
|
||||||
|
+++ bluez-4.43/acinclude.m4 2009-07-03 12:18:46.000000000 +0100
|
||||||
|
@@ -162,6 +162,12 @@ AC_DEFUN([AC_PATH_USB], [
|
||||||
|
[Define to 1 if you need the usb_interrupt_read() function.]))
|
||||||
|
])
|
||||||
|
|
||||||
|
+AC_DEFUN([AC_PATH_CABLE], [
|
||||||
|
+ PKG_CHECK_MODULES(CABLE, gudev-1.0 libusb-1.0, cable_found=yes, cable_found=no)
|
||||||
|
+ AC_SUBST(CABLE_CFLAGS)
|
||||||
|
+ AC_SUBST(CABLE_LIBS)
|
||||||
|
+])
|
||||||
|
+
|
||||||
|
AC_DEFUN([AC_PATH_NETLINK], [
|
||||||
|
PKG_CHECK_MODULES(NETLINK, libnl-1, netlink_found=yes, netlink_found=no)
|
||||||
|
AC_SUBST(NETLINK_CFLAGS)
|
||||||
|
@@ -182,6 +188,7 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||||
|
netlink_enable=no
|
||||||
|
hal_enable=${hal_found}
|
||||||
|
usb_enable=${usb_found}
|
||||||
|
+ cable_enable=${cable_found}
|
||||||
|
alsa_enable=${alsa_found}
|
||||||
|
gstreamer_enable=${gstreamer_found}
|
||||||
|
audio_enable=yes
|
||||||
|
@@ -244,6 +251,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||||
|
usb_enable=${enableval}
|
||||||
|
])
|
||||||
|
|
||||||
|
+ AC_ARG_ENABLE(cable, AC_HELP_STRING([--enable-cable], [enable DeviceKit support]), [
|
||||||
|
+ cable_enable=${enableval}
|
||||||
|
+ ])
|
||||||
|
+
|
||||||
|
AC_ARG_ENABLE(netlink, AC_HELP_STRING([--enable-netlink], [enable NETLINK support]), [
|
||||||
|
netlink_enable=${enableval}
|
||||||
|
])
|
||||||
|
@@ -327,6 +338,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||||
|
AC_DEFINE(HAVE_LIBUSB, 1, [Define to 1 if you have USB library.])
|
||||||
|
fi
|
||||||
|
|
||||||
|
+ if (test "${cable_enable}" = "yes" && test "${cable_found}" = "yes"); then
|
||||||
|
+ AC_DEFINE(HAVE_CABLE, 1, [Define to 1 if you have libcable.])
|
||||||
|
+ fi
|
||||||
|
+
|
||||||
|
AC_SUBST([BLUEZ_CFLAGS], ['-I$(top_builddir)/include'])
|
||||||
|
AC_SUBST([BLUEZ_LIBS], ['$(top_builddir)/lib/libbluetooth.la'])
|
||||||
|
|
||||||
|
@@ -360,4 +375,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||||
|
AM_CONDITIONAL(MANPAGES, test "${manpages_enable}" = "yes")
|
||||||
|
AM_CONDITIONAL(UDEVRULES, test "${udevrules_enable}" = "yes")
|
||||||
|
AM_CONDITIONAL(CONFIGFILES, test "${configfiles_enable}" = "yes")
|
||||||
|
+ AM_CONDITIONAL(CABLE, test "${cable_enable}" = "yes" && test "${cable_found}" = "yes")
|
||||||
|
])
|
||||||
|
@ -1,48 +0,0 @@
|
|||||||
From f723fb9f588a987bfaba94cfb2c1acb6c89c926c Mon Sep 17 00:00:00 2001
|
|
||||||
From: Bastien Nocera <hadess@hadess.net>
|
|
||||||
Date: Sun, 21 Jun 2009 14:37:32 +0100
|
|
||||||
Subject: [PATCH] Add udev rules to start bluetooth on-demand
|
|
||||||
|
|
||||||
Those rules call bluetoothd --udev when a new dongle is inserted.
|
|
||||||
---
|
|
||||||
scripts/Makefile.am | 4 +++-
|
|
||||||
scripts/bluetooth.rules | 5 +++++
|
|
||||||
2 files changed, 8 insertions(+), 1 deletions(-)
|
|
||||||
create mode 100644 scripts/bluetooth.rules
|
|
||||||
|
|
||||||
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
|
|
||||||
index 494a9c2..d06f95e 100644
|
|
||||||
--- a/scripts/Makefile.am
|
|
||||||
+++ b/scripts/Makefile.am
|
|
||||||
@@ -11,6 +11,8 @@ endif
|
|
||||||
if PCMCIARULES
|
|
||||||
rules_DATA += bluetooth-serial.rules
|
|
||||||
endif
|
|
||||||
+
|
|
||||||
+rules_DATA += bluetooth.rules
|
|
||||||
endif
|
|
||||||
|
|
||||||
if PCMCIARULES
|
|
||||||
@@ -20,7 +22,7 @@ udev_SCRIPTS = bluetooth_serial
|
|
||||||
endif
|
|
||||||
|
|
||||||
EXTRA_DIST = bluetooth.init bluetooth.default bluetooth-hid2hci.rules \
|
|
||||||
- bluetooth-serial.rules bluetooth_serial
|
|
||||||
+ bluetooth-serial.rules bluetooth_serial bluetooth.rules
|
|
||||||
|
|
||||||
MAINTAINERCLEANFILES = Makefile.in
|
|
||||||
|
|
||||||
diff --git a/scripts/bluetooth.rules b/scripts/bluetooth.rules
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..f3034b5
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/scripts/bluetooth.rules
|
|
||||||
@@ -0,0 +1,5 @@
|
|
||||||
+# Run helper every time a Bluetooth device appears
|
|
||||||
+# On remove actions, bluetoothd should go away by itself
|
|
||||||
+
|
|
||||||
+ACTION=="add", SUBSYSTEM=="bluetooth", RUN+="/usr/sbin/bluetoothd --udev"
|
|
||||||
+
|
|
||||||
--
|
|
||||||
1.6.2.2
|
|
||||||
|
|
@ -1,9 +1,9 @@
|
|||||||
diff --git a/src/security.c b/src/security.c
|
diff --git a/src/security.c b/src/security.c
|
||||||
index a61d75f..75908ba 100644
|
index 905cf61..67fd266 100644
|
||||||
--- a/src/security.c
|
--- a/src/security.c
|
||||||
+++ b/src/security.c
|
+++ b/src/security.c
|
||||||
@@ -600,8 +600,16 @@ static inline void remote_name_information(int dev, bdaddr_t *sba, void *ptr)
|
@@ -705,8 +705,16 @@ static inline void remote_name_information(int dev, bdaddr_t *sba, void *ptr)
|
||||||
memcpy(name, evt->name, 248);
|
memcpy(name, evt->name, MAX_NAME_LENGTH);
|
||||||
/* It's ok to cast end between const and non-const since
|
/* It's ok to cast end between const and non-const since
|
||||||
* we know it points to inside of name which is non-const */
|
* we know it points to inside of name which is non-const */
|
||||||
- if (!g_utf8_validate(name, -1, (const char **) &end))
|
- if (!g_utf8_validate(name, -1, (const char **) &end))
|
||||||
|
10
bluez.spec
10
bluez.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: Bluetooth utilities
|
Summary: Bluetooth utilities
|
||||||
Name: bluez
|
Name: bluez
|
||||||
Version: 4.42
|
Version: 4.43
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
Source: http://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.gz
|
Source: http://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.gz
|
||||||
@ -24,8 +24,6 @@ Patch3: bluez-activate-wacom-mode2.patch
|
|||||||
Patch4: bluez-socket-mobile-cf-connection-kit.patch
|
Patch4: bluez-socket-mobile-cf-connection-kit.patch
|
||||||
# http://thread.gmane.org/gmane.linux.bluez.kernel/2396
|
# http://thread.gmane.org/gmane.linux.bluez.kernel/2396
|
||||||
Patch5: 0001-Add-sixaxis-cable-pairing-plugin.patch
|
Patch5: 0001-Add-sixaxis-cable-pairing-plugin.patch
|
||||||
# http://thread.gmane.org/gmane.linux.bluez.kernel/2579
|
|
||||||
Patch6: 0001-Add-udev-rules-to-start-bluetooth-on-demand.patch
|
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
URL: http://www.bluez.org/
|
URL: http://www.bluez.org/
|
||||||
@ -131,7 +129,6 @@ This includes hidd, dund and pand.
|
|||||||
%patch3 -p1 -b .wacom
|
%patch3 -p1 -b .wacom
|
||||||
%patch4 -p1 -b .socket-mobile
|
%patch4 -p1 -b .socket-mobile
|
||||||
%patch5 -p1 -b .cable-pairing
|
%patch5 -p1 -b .cable-pairing
|
||||||
%patch6 -p1 -b .udev
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
libtoolize -f -c
|
libtoolize -f -c
|
||||||
@ -272,6 +269,9 @@ fi
|
|||||||
%config(noreplace) %{_sysconfdir}/sysconfig/pand
|
%config(noreplace) %{_sysconfdir}/sysconfig/pand
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 03 2009 Bastien Nocera <bnocera@redhat.com> 4.43-1
|
||||||
|
- Update to 4.43
|
||||||
|
|
||||||
* Sun Jun 21 2009 Bastien Nocera <bnocera@redhat.com> 4.42-2
|
* Sun Jun 21 2009 Bastien Nocera <bnocera@redhat.com> 4.42-2
|
||||||
- Update to 4.42
|
- Update to 4.42
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user