Update sixaxis patch

This commit is contained in:
Bastien Nocera 2012-01-13 12:41:55 +00:00
parent cbcd1be14c
commit 1553020a3e

View File

@ -1,4 +1,4 @@
From ed744e12108008e6be2f7ec811c6969f9ed08405 Mon Sep 17 00:00:00 2001
From 3e999539978919395af19ac1b554ca997ab1b3d1 Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Fri, 30 Dec 2011 12:34:29 +0100
Subject: [PATCH] Add sixaxis cable-pairing plugin
@ -19,10 +19,10 @@ address, and added to the database of the current default adapter.
create mode 100644 plugins/cable.c
diff --git a/Makefile.am b/Makefile.am
index f907f41..5646f7f 100644
index 102ee62..63d7198 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -249,6 +249,11 @@ builtin_sources += thermometer/main.c \
@@ -244,6 +244,11 @@ builtin_sources += thermometer/main.c \
thermometer/thermometer.h thermometer/thermometer.c
endif
@ -34,7 +34,7 @@ index f907f41..5646f7f 100644
builtin_modules += hciops mgmtops
builtin_sources += plugins/hciops.c plugins/mgmtops.c
@@ -316,7 +321,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
@@ -311,7 +316,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
src/event.h src/event.c \
src/oob.h src/oob.c src/eir.h src/eir.c
src_bluetoothd_LDADD = lib/libbluetooth-private.la @GLIB_LIBS@ @DBUS_LIBS@ \
@ -43,7 +43,7 @@ index f907f41..5646f7f 100644
src_bluetoothd_LDFLAGS = -Wl,--export-dynamic \
-Wl,--version-script=$(srcdir)/src/bluetooth.ver
@@ -452,7 +457,7 @@ EXTRA_DIST += doc/manager-api.txt \
@@ -432,7 +437,7 @@ EXTRA_DIST += doc/manager-api.txt \
AM_YFLAGS = -d
@ -53,10 +53,10 @@ index f907f41..5646f7f 100644
INCLUDES = -I$(builddir)/lib -I$(builddir)/src -I$(srcdir)/src \
-I$(srcdir)/audio -I$(srcdir)/sbc -I$(srcdir)/gdbus \
diff --git a/acinclude.m4 b/acinclude.m4
index 2097d77..3cfe3e3 100644
index 57fc5e0..90582ba 100644
--- a/acinclude.m4
+++ b/acinclude.m4
@@ -155,6 +155,12 @@ AC_DEFUN([AC_PATH_UDEV], [
@@ -149,6 +149,12 @@ AC_DEFUN([AC_PATH_UDEV], [
AC_SUBST(UDEV_LIBS)
])
@ -99,24 +99,24 @@ index 2097d77..3cfe3e3 100644
AM_CONDITIONAL(SNDFILE, test "${sndfile_enable}" = "yes" && test "${sndfile_found}" = "yes")
AM_CONDITIONAL(USB, test "${usb_enable}" = "yes" && test "${usb_found}" = "yes")
AM_CONDITIONAL(SBC, test "${alsa_enable}" = "yes" || test "${gstreamer_enable}" = "yes" ||
@@ -433,4 +448,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
@@ -432,4 +447,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
AM_CONDITIONAL(DBUSOOBPLUGIN, test "${dbusoob_enable}" = "yes")
AM_CONDITIONAL(WIIMOTEPLUGIN, test "${wiimote_enable}" = "yes")
AM_CONDITIONAL(THERMOMETERPLUGIN, test "${thermometer_enable}" = "yes")
+ AM_CONDITIONAL(CABLE, test "${cable_enable}" = "yes" && test "${cable_found}" = "yes")
])
diff --git a/configure.ac b/configure.ac
index 581b222..524b179 100644
index 5b81f28..0e0dd9d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,6 +48,7 @@ AC_PATH_GSTREAMER
@@ -46,6 +46,7 @@ AC_PATH_GSTREAMER
AC_PATH_USB
AC_PATH_UDEV
AC_PATH_SNDFILE
+AC_PATH_CABLE
AC_PATH_OUI
AC_PATH_READLINE
AC_PATH_CHECK
diff --git a/plugins/cable.c b/plugins/cable.c
new file mode 100644
index 0000000..e8cff76
@ -506,10 +506,10 @@ index 0000000..e8cff76
+BLUETOOTH_PLUGIN_DEFINE(cable, VERSION,
+ BLUETOOTH_PLUGIN_PRIORITY_DEFAULT, cable_init, cable_exit)
diff --git a/src/adapter.c b/src/adapter.c
index a776997..9c6d1e3 100644
index 7e4bbb6..012f632 100644
--- a/src/adapter.c
+++ b/src/adapter.c
@@ -1098,6 +1098,25 @@ static struct btd_device *adapter_create_device(DBusConnection *conn,
@@ -1014,6 +1014,25 @@ static struct btd_device *adapter_create_device(DBusConnection *conn,
return device;
}
@ -536,11 +536,11 @@ index a776997..9c6d1e3 100644
struct btd_device *device,
gboolean remove_storage)
diff --git a/src/adapter.h b/src/adapter.h
index 23bc8a5..88b625c 100644
index fb1dcdf..4c3d148 100644
--- a/src/adapter.h
+++ b/src/adapter.h
@@ -116,6 +116,9 @@ void adapter_update_found_devices(struct btd_adapter *adapter,
int adapter_remove_found_device(struct btd_adapter *adapter, bdaddr_t *bdaddr);
@@ -108,6 +108,9 @@ void adapter_update_found_devices(struct btd_adapter *adapter,
uint8_t *data, uint8_t data_len);
void adapter_emit_device_found(struct btd_adapter *adapter,
struct remote_dev_info *dev);
+void adapter_create_device_for_device(DBusConnection *conn,
@ -550,5 +550,5 @@ index 23bc8a5..88b625c 100644
int adapter_set_name(struct btd_adapter *adapter, const char *name);
void adapter_name_changed(struct btd_adapter *adapter, const char *name);
--
1.7.7.3
1.7.6.4