- Update to 4.61
- Remove Wacom tablet enabler, now in the kernel
This commit is contained in:
parent
81234be9ba
commit
00d211e9ae
@ -1 +1 @@
|
|||||||
bluez-4.60.tar.gz
|
bluez-4.61.tar.gz
|
||||||
|
@ -1,24 +0,0 @@
|
|||||||
diff --git a/input/device.c b/input/device.c
|
|
||||||
index 0090bd4..8d65148 100644
|
|
||||||
--- a/input/device.c
|
|
||||||
+++ b/input/device.c
|
|
||||||
@@ -658,6 +658,19 @@ static int hidp_add_connection(const struct input_device *idev,
|
|
||||||
err = write(sk, buf, sizeof(buf));
|
|
||||||
}
|
|
||||||
|
|
||||||
+ if (req->vendor == 0x056a && req->product == 0x81) {
|
|
||||||
+ unsigned char buf[3];
|
|
||||||
+ int sk = g_io_channel_unix_get_fd(iconn->ctrl_io);
|
|
||||||
+
|
|
||||||
+ buf[0] = 0x53; /* HIDP_TRANS_SET_REPORT | HIDP_DATA_RTYPE_FEATURE */
|
|
||||||
+ buf[1] = 0x03; buf[2] = 0x00;
|
|
||||||
+ write(sk, buf, sizeof(buf));
|
|
||||||
+
|
|
||||||
+ buf[0] = 0x71; /* HIDP_TRANS_SET_REPORT | HIDP_DATA_RTYPE_FEATURE */
|
|
||||||
+ /* 0x06 - high reporting speed, 0x05 - low speed */
|
|
||||||
+ buf[1] = 0x06; buf[2] = 0x00;
|
|
||||||
+ write(sk, buf, sizeof(buf));
|
|
||||||
+ }
|
|
||||||
err = ioctl_connadd(req);
|
|
||||||
|
|
||||||
cleanup:
|
|
11
bluez.spec
11
bluez.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: Bluetooth utilities
|
Summary: Bluetooth utilities
|
||||||
Name: bluez
|
Name: bluez
|
||||||
Version: 4.60
|
Version: 4.61
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
Source: http://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.gz
|
Source: http://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.gz
|
||||||
@ -17,8 +17,6 @@ Patch1: bluez-utils-oui-usage.patch
|
|||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=450081
|
# https://bugzilla.redhat.com/show_bug.cgi?id=450081
|
||||||
# http://thread.gmane.org/gmane.linux.bluez.kernel/1687
|
# http://thread.gmane.org/gmane.linux.bluez.kernel/1687
|
||||||
Patch2: bluez-try-utf8-harder.patch
|
Patch2: bluez-try-utf8-harder.patch
|
||||||
# http://thread.gmane.org/gmane.linux.bluez.kernel/1754
|
|
||||||
Patch3: bluez-activate-wacom-mode2.patch
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=498756
|
# https://bugzilla.redhat.com/show_bug.cgi?id=498756
|
||||||
Patch4: bluez-socket-mobile-cf-connection-kit.patch
|
Patch4: bluez-socket-mobile-cf-connection-kit.patch
|
||||||
# http://thread.gmane.org/gmane.linux.bluez.kernel/2396
|
# http://thread.gmane.org/gmane.linux.bluez.kernel/2396
|
||||||
@ -130,7 +128,6 @@ This includes hidd, dund and pand.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p0 -b .oui
|
%patch1 -p0 -b .oui
|
||||||
%patch2 -p1 -b .non-utf8-name
|
%patch2 -p1 -b .non-utf8-name
|
||||||
%patch3 -p1 -b .wacom
|
|
||||||
%patch4 -p1 -b .socket-mobile
|
%patch4 -p1 -b .socket-mobile
|
||||||
%patch5 -p1 -b .cable-pairing
|
%patch5 -p1 -b .cable-pairing
|
||||||
|
|
||||||
@ -273,6 +270,10 @@ fi
|
|||||||
%config(noreplace) %{_sysconfdir}/sysconfig/pand
|
%config(noreplace) %{_sysconfdir}/sysconfig/pand
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 15 2010 Bastien Nocera <bnocera@redhat.com> 4.61-1
|
||||||
|
- Update to 4.61
|
||||||
|
- Remove Wacom tablet enabler, now in the kernel
|
||||||
|
|
||||||
* Mon Feb 15 2010 Bastien Nocera <bnocera@redhat.com> 4.60-2
|
* Mon Feb 15 2010 Bastien Nocera <bnocera@redhat.com> 4.60-2
|
||||||
- Fix typo in init script (#558993)
|
- Fix typo in init script (#558993)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user