Initial package version
This commit is contained in:
parent
f5a5ab19d6
commit
bd318a270a
@ -0,0 +1 @@
|
|||||||
|
blktrace-git-20070730162628.tar.gz
|
40
blktrace-cflags.patch
Normal file
40
blktrace-cflags.patch
Normal file
@ -0,0 +1,40 @@
|
|||||||
|
--- blktrace/btt/Makefile.orig 2007-08-15 12:00:39.260464020 -0500
|
||||||
|
+++ blktrace/btt/Makefile 2007-08-15 12:01:29.568789170 -0500
|
||||||
|
@@ -6,10 +6,11 @@
|
||||||
|
#
|
||||||
|
|
||||||
|
CC = gcc
|
||||||
|
+CFLAGS = -O2 -Wall -W -g
|
||||||
|
INCS = -I. -I..
|
||||||
|
OCFLAGS = -UCOUNT_IOS -UDEBUG -DNDEBUG
|
||||||
|
-XCFLAGS = -Wall -W -g -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
|
||||||
|
-CFLAGS = $(INCS) -O2 $(XCFLAGS) $(OCFLAGS)
|
||||||
|
+XCFLAGS = -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
|
||||||
|
+ALL_CFLAGS = $(CFLAGS) $(INCS) $(XCFLAGS) $(OCFLAGS)
|
||||||
|
|
||||||
|
PROGS = btt
|
||||||
|
LIBS = $(PLIBS) $(ELIBS)
|
||||||
|
@@ -21,19 +22,19 @@
|
||||||
|
all: depend $(PROGS)
|
||||||
|
|
||||||
|
rbtree.o: ../rbtree.c
|
||||||
|
- $(CC) -o $*.o -c $(CFLAGS) $<
|
||||||
|
+ $(CC) -o $*.o -c $(ALL_CFLAGS) $<
|
||||||
|
|
||||||
|
depend:
|
||||||
|
- @$(CC) -MM $(CFLAGS) -I.. *.c 1> .depend
|
||||||
|
+ @$(CC) -MM $(ALL_CFLAGS) -I.. *.c 1> .depend
|
||||||
|
|
||||||
|
clean: docsclean
|
||||||
|
-rm -f *.o $(PROGS) .depend
|
||||||
|
|
||||||
|
%.o: %.c
|
||||||
|
- $(CC) -o $*.o -c $(CFLAGS) $<
|
||||||
|
+ $(CC) -o $*.o -c $(ALL_CFLAGS) $<
|
||||||
|
|
||||||
|
btt: $(OBJS)
|
||||||
|
- $(CC) $(CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
|
||||||
|
+ $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
|
||||||
|
|
||||||
|
docs:
|
||||||
|
$(MAKE) -C doc all
|
55
blktrace.spec
Normal file
55
blktrace.spec
Normal file
@ -0,0 +1,55 @@
|
|||||||
|
Summary: Utilities for performing block layer IO tracing in the linux kernel
|
||||||
|
Name: blktrace
|
||||||
|
Version: 0.0
|
||||||
|
Release: 0.4.20070730162628git%{?dist}
|
||||||
|
License: GPLv2+
|
||||||
|
Group: Development/System
|
||||||
|
Source: http://brick.kernel.dk/snaps/blktrace-git-20070730162628.tar.gz
|
||||||
|
Url: http://brick.kernel.dk/snaps
|
||||||
|
|
||||||
|
Patch1: blktrace-cflags.patch
|
||||||
|
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
|
%description
|
||||||
|
blktrace is a block layer IO tracing mechanism which provides detailed
|
||||||
|
information about request queue operations to user space. This package
|
||||||
|
includes both blktrace, a utility which gathers event traces from the kernel;
|
||||||
|
and blkparse, a utility which formats trace data collected by blktrace.
|
||||||
|
|
||||||
|
You should install the blktrace package if you need to gather detailed
|
||||||
|
information about IO patterns.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n blktrace
|
||||||
|
%patch1 -p1 -b .cflags
|
||||||
|
|
||||||
|
%build
|
||||||
|
make CFLAGS="%{optflags}" all
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf %{buildroot}
|
||||||
|
make dest=%{buildroot} prefix=%{buildroot}/%{_prefix} mandir=%{buildroot}/usr/share/man install
|
||||||
|
|
||||||
|
%clean
|
||||||
|
rm -rf %{buildroot}
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%doc README COPYING
|
||||||
|
/usr/bin/*
|
||||||
|
%attr(0644,root,root) /usr/share/man/man1/*
|
||||||
|
%attr(0644,root,root) /usr/share/man/man8/*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Aug 15 2007 Eric Sandeen <sandeen@redhat.com> - 0.0-0.4.20070730162628git
|
||||||
|
- Fix up btt/Makefile to accept rpm's CFLAGS
|
||||||
|
|
||||||
|
* Tue Aug 14 2007 Eric Sandeen <sandeen@redhat.com> - 0.0-0.3.20070730162628git
|
||||||
|
- Just drop the pdf build, bloats the buildroot for such a simple tool
|
||||||
|
|
||||||
|
* Wed Aug 01 2007 Eric Sandeen <sandeen@redhat.com> - 0.0-0.2.20070730162628git
|
||||||
|
- Add ghostscript to BuildRequires, use attr macro for man pages
|
||||||
|
|
||||||
|
* Wed Aug 01 2007 Eric Sandeen <sandeen@redhat.com> - 0.0-0.1.20070730162628git
|
||||||
|
- New package, initial build.
|
Loading…
Reference in New Issue
Block a user