Backport patch from upstream to fix parallel builds
This commit is contained in:
parent
b53fdd9331
commit
b867386cc0
70
0001-fix-parallel-build-failures.patch
Normal file
70
0001-fix-parallel-build-failures.patch
Normal file
@ -0,0 +1,70 @@
|
|||||||
|
From 519fd9a5d08d85f3d9cb4192d624fe8351e40232 Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Robin H. Johnson" <robbat2@gentoo.org>
|
||||||
|
Date: Tue, 23 Jan 2018 17:57:55 -0500
|
||||||
|
Subject: [PATCH] fix parallel build failures
|
||||||
|
|
||||||
|
When building in parallel, the btreplay/btrecord and btreplay/btreplay
|
||||||
|
targets cause make to kick off two jobs for `make -C btreplay` and they
|
||||||
|
sometimes end up clobbering each other. We could fix this by making one
|
||||||
|
a dependency of the other, but it's a bit cleaner to refactor things to
|
||||||
|
be based on subdirs. This way changes in subdirs also get noticed:
|
||||||
|
$ touch btreplay/*.[ch]
|
||||||
|
$ make
|
||||||
|
<btreplay is now correctly updated>
|
||||||
|
|
||||||
|
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
|
||||||
|
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
|
||||||
|
Signed-off-by: Jens Axboe <axboe@kernel.dk>
|
||||||
|
---
|
||||||
|
Makefile | 24 ++++++++++--------------
|
||||||
|
1 file changed, 10 insertions(+), 14 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile b/Makefile
|
||||||
|
index 68de591..5917814 100644
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -4,23 +4,19 @@ ALL_CFLAGS = $(CFLAGS) -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
|
||||||
|
PROGS = blkparse blktrace verify_blkparse blkrawverify blkiomon
|
||||||
|
LIBS = -lpthread
|
||||||
|
SCRIPTS = btrace
|
||||||
|
+SUBDIRS = btreplay btt iowatcher
|
||||||
|
|
||||||
|
-ALL = $(PROGS) $(SCRIPTS) btt/btt btreplay/btrecord btreplay/btreplay \
|
||||||
|
+ALL = $(PROGS) $(SCRIPTS)
|
||||||
|
+INSTALL_ALL = $(ALL) btt/btt btreplay/btrecord btreplay/btreplay \
|
||||||
|
btt/bno_plot.py iowatcher/iowatcher
|
||||||
|
|
||||||
|
-all: $(ALL)
|
||||||
|
+all: $(ALL) $(SUBDIRS)
|
||||||
|
|
||||||
|
-btt/btt:
|
||||||
|
- $(MAKE) -C btt
|
||||||
|
-
|
||||||
|
-iowatcher/iowatcher:
|
||||||
|
- $(MAKE) -C iowatcher
|
||||||
|
-
|
||||||
|
-btreplay/btrecord:
|
||||||
|
- $(MAKE) -C btreplay
|
||||||
|
-
|
||||||
|
-btreplay/btreplay:
|
||||||
|
- $(MAKE) -C btreplay
|
||||||
|
+# We always descend into subdirs because they contain their own dependency
|
||||||
|
+# information which we don't track in this top level Makefile.
|
||||||
|
+$(SUBDIRS):
|
||||||
|
+ $(MAKE) -C $@
|
||||||
|
+.PHONY: $(SUBDIRS)
|
||||||
|
|
||||||
|
%.o: %.c
|
||||||
|
$(CC) -o $*.o -c $(ALL_CFLAGS) $<
|
||||||
|
@@ -85,7 +81,7 @@ install: all
|
||||||
|
$(INSTALL) -m 755 -d $(DESTDIR)$(bindir)
|
||||||
|
$(INSTALL) -m 755 -d $(DESTDIR)$(mandir)/man1
|
||||||
|
$(INSTALL) -m 755 -d $(DESTDIR)$(mandir)/man8
|
||||||
|
- $(INSTALL) -m 755 $(ALL) $(DESTDIR)$(bindir)
|
||||||
|
+ $(INSTALL) -m 755 $(INSTALL_ALL) $(DESTDIR)$(bindir)
|
||||||
|
$(INSTALL) -m 644 doc/*.1 $(DESTDIR)$(mandir)/man1
|
||||||
|
$(INSTALL) -m 644 doc/*.8 $(DESTDIR)$(mandir)/man8
|
||||||
|
|
||||||
|
--
|
||||||
|
2.25.3
|
||||||
|
|
38
0001-fix-parallel-build-of-btt-and-blkiomon.patch
Normal file
38
0001-fix-parallel-build-of-btt-and-blkiomon.patch
Normal file
@ -0,0 +1,38 @@
|
|||||||
|
From f4f8ef7cdea138cfaa2f3ca0ee31fa23d3bcf1cc Mon Sep 17 00:00:00 2001
|
||||||
|
From: Gwendal Grignou <gwendal@chromium.org>
|
||||||
|
Date: Thu, 16 Jan 2020 12:33:26 -0800
|
||||||
|
Subject: [PATCH] fix parallel build of btt and blkiomon
|
||||||
|
|
||||||
|
rbtree.c is used by both binaries. It is possible that when make -C btt
|
||||||
|
is invoked rbtree.o does not exist yet, but is already schedule by the
|
||||||
|
compilation of blkiomon. That could result in recompiling rbtree.o again
|
||||||
|
for btt/btt.
|
||||||
|
In that case, at install time, make will recompile blkiomon which can
|
||||||
|
fail in gentoo, because CC variable is not overriden by ebuild script at
|
||||||
|
install time. (see https://bugs.gentoo.org/705594)
|
||||||
|
|
||||||
|
Add a dependency on SUBDIRS to wait for all binary in . to be compiled.
|
||||||
|
It will guarante rbtree.o exists.
|
||||||
|
|
||||||
|
Signed-off-by: Gwendal Grignou <gwendal@chromium.org>
|
||||||
|
Signed-off-by: Jens Axboe <axboe@kernel.dk>
|
||||||
|
---
|
||||||
|
Makefile | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile b/Makefile
|
||||||
|
index 5917814..eb3c6a1 100644
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -14,7 +14,7 @@ all: $(ALL) $(SUBDIRS)
|
||||||
|
|
||||||
|
# We always descend into subdirs because they contain their own dependency
|
||||||
|
# information which we don't track in this top level Makefile.
|
||||||
|
-$(SUBDIRS):
|
||||||
|
+$(SUBDIRS): $(PROGS)
|
||||||
|
$(MAKE) -C $@
|
||||||
|
.PHONY: $(SUBDIRS)
|
||||||
|
|
||||||
|
--
|
||||||
|
2.25.3
|
||||||
|
|
@ -1,7 +1,7 @@
|
|||||||
Summary: Utilities for performing block layer IO tracing in the Linux kernel
|
Summary: Utilities for performing block layer IO tracing in the Linux kernel
|
||||||
Name: blktrace
|
Name: blktrace
|
||||||
Version: 1.2.0
|
Version: 1.2.0
|
||||||
Release: 13%{?dist}
|
Release: 14%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Source: http://brick.kernel.dk/snaps/blktrace-%{version}.tar.bz2
|
Source: http://brick.kernel.dk/snaps/blktrace-%{version}.tar.bz2
|
||||||
Url: http://brick.kernel.dk/snaps
|
Url: http://brick.kernel.dk/snaps
|
||||||
@ -13,6 +13,8 @@ BuildRequires: gcc, libaio-devel, librsvg2-devel
|
|||||||
|
|
||||||
Patch0: blktrace-fix-btt-overflow.patch
|
Patch0: blktrace-fix-btt-overflow.patch
|
||||||
Patch1: blktrace-python3.patch
|
Patch1: blktrace-python3.patch
|
||||||
|
Patch2: 0001-fix-parallel-build-failures.patch
|
||||||
|
Patch3: 0001-fix-parallel-build-of-btt-and-blkiomon.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
blktrace is a block layer IO tracing mechanism which provides detailed
|
blktrace is a block layer IO tracing mechanism which provides detailed
|
||||||
@ -27,12 +29,14 @@ information about IO patterns.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
|
||||||
sed -i '1s=^#!/usr/bin/python3=#!%{__python3}=' \
|
sed -i '1s=^#!/usr/bin/python3=#!%{__python3}=' \
|
||||||
btt/{btt_plot.py,bno_plot.py}
|
btt/{btt_plot.py,bno_plot.py}
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%make_build CFLAGS="%{optflags} %{build_ldflags}" all
|
%{make_build} CFLAGS="%{optflags} %{build_ldflags}" all
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf %{buildroot}
|
rm -rf %{buildroot}
|
||||||
@ -80,6 +84,9 @@ information about IO patterns.
|
|||||||
%{_mandir}/man1/iowatcher.*
|
%{_mandir}/man1/iowatcher.*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 05 2020 Tom Stellard <tstellar@redhat.com> - 1.2.0-14
|
||||||
|
- Backport patches from upstream to fix parallel builds
|
||||||
|
|
||||||
* Mon Feb 03 2020 Tom Stellard <tstellar@redhat.com> - 1.2.0-13
|
* Mon Feb 03 2020 Tom Stellard <tstellar@redhat.com> - 1.2.0-13
|
||||||
- Use make_build macro instead of plain make
|
- Use make_build macro instead of plain make
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user