- New upstream version

This commit is contained in:
Eric Sandeen 2007-10-24 22:36:55 +00:00
parent bd318a270a
commit 9d60eac149
4 changed files with 7 additions and 47 deletions

View File

@ -1 +1 @@
blktrace-git-20070730162628.tar.gz
blktrace-git-20071010202719.tar.gz

View File

@ -1,40 +0,0 @@
--- blktrace/btt/Makefile.orig 2007-08-15 12:00:39.260464020 -0500
+++ blktrace/btt/Makefile 2007-08-15 12:01:29.568789170 -0500
@@ -6,10 +6,11 @@
#
CC = gcc
+CFLAGS = -O2 -Wall -W -g
INCS = -I. -I..
OCFLAGS = -UCOUNT_IOS -UDEBUG -DNDEBUG
-XCFLAGS = -Wall -W -g -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
-CFLAGS = $(INCS) -O2 $(XCFLAGS) $(OCFLAGS)
+XCFLAGS = -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
+ALL_CFLAGS = $(CFLAGS) $(INCS) $(XCFLAGS) $(OCFLAGS)
PROGS = btt
LIBS = $(PLIBS) $(ELIBS)
@@ -21,19 +22,19 @@
all: depend $(PROGS)
rbtree.o: ../rbtree.c
- $(CC) -o $*.o -c $(CFLAGS) $<
+ $(CC) -o $*.o -c $(ALL_CFLAGS) $<
depend:
- @$(CC) -MM $(CFLAGS) -I.. *.c 1> .depend
+ @$(CC) -MM $(ALL_CFLAGS) -I.. *.c 1> .depend
clean: docsclean
-rm -f *.o $(PROGS) .depend
%.o: %.c
- $(CC) -o $*.o -c $(CFLAGS) $<
+ $(CC) -o $*.o -c $(ALL_CFLAGS) $<
btt: $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
+ $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
docs:
$(MAKE) -C doc all

View File

@ -1,14 +1,12 @@
Summary: Utilities for performing block layer IO tracing in the linux kernel
Name: blktrace
Version: 0.0
Release: 0.4.20070730162628git%{?dist}
Release: 0.5.20071010202719git%{?dist}
License: GPLv2+
Group: Development/System
Source: http://brick.kernel.dk/snaps/blktrace-git-20070730162628.tar.gz
Source: http://brick.kernel.dk/snaps/blktrace-git-20071010202719.tar.gz
Url: http://brick.kernel.dk/snaps
Patch1: blktrace-cflags.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
%description
@ -22,7 +20,6 @@ information about IO patterns.
%prep
%setup -q -n blktrace
%patch1 -p1 -b .cflags
%build
make CFLAGS="%{optflags}" all
@ -42,6 +39,9 @@ rm -rf %{buildroot}
%attr(0644,root,root) /usr/share/man/man8/*
%changelog
* Wed Oct 24 2007 Eric Sandeen <sandeen@redhat.com> - 0.0-0.5.20071010202719git
- New upstream version
* Wed Aug 15 2007 Eric Sandeen <sandeen@redhat.com> - 0.0-0.4.20070730162628git
- Fix up btt/Makefile to accept rpm's CFLAGS

View File

@ -1 +1 @@
74d9ba563e07eeb3d662c6735cbcdaa0 blktrace-git-20070730162628.tar.gz
6ce80a11ea09861b79bc19b9e948e8da blktrace-git-20071010202719.tar.gz