import biosdevname-0.7.3-2.el8
This commit is contained in:
commit
f2dc40ff96
1
.biosdevname.metadata
Normal file
1
.biosdevname.metadata
Normal file
@ -0,0 +1 @@
|
||||
a31985f5cc19bd0a2bed7a32567d06f5ec72c0af SOURCES/biosdevname-0.7.3.tar.gz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/biosdevname-0.7.3.tar.gz
|
27
SOURCES/0001-Add-support-for-ExaNIC-network-cards-5.patch
Normal file
27
SOURCES/0001-Add-support-for-ExaNIC-network-cards-5.patch
Normal file
@ -0,0 +1,27 @@
|
||||
From 4257dbad671fd1080231483c1891f46ed9ea7107 Mon Sep 17 00:00:00 2001
|
||||
From: Ka-Shu Wong <31426385+kashuwong@users.noreply.github.com>
|
||||
Date: Fri, 1 Sep 2017 15:33:56 +1000
|
||||
Subject: [PATCH] Add support for ExaNIC network cards (#5)
|
||||
|
||||
ExaNIC cards have multiple physical ports on the same PCI function and
|
||||
need to be numbered using the dev_port attribute.
|
||||
---
|
||||
src/bios_device.c | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/src/bios_device.c b/src/bios_device.c
|
||||
index e9d5177..3cc528b 100644
|
||||
--- a/src/bios_device.c
|
||||
+++ b/src/bios_device.c
|
||||
@@ -221,6 +221,8 @@ int ismultiport(const char *driver)
|
||||
return 1;
|
||||
if (!strncmp(driver, "cxgb", 4))
|
||||
return 1;
|
||||
+ if (!strncmp(driver, "exanic", 6))
|
||||
+ return 1;
|
||||
return 0;
|
||||
}
|
||||
|
||||
--
|
||||
2.14.3
|
||||
|
@ -0,0 +1,29 @@
|
||||
From d6fa84f8a80d5e1c526fe675c345f709a700e33e Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Josef=20M=C3=B6llers?= <josef.moellers@suse.com>
|
||||
Date: Fri, 20 Jul 2018 08:56:48 +0200
|
||||
Subject: [PATCH] Prevent infinite recursion in dmidecode.c::smbios_setslot by
|
||||
(#7)
|
||||
|
||||
Checking that subordinate bus has a number greater than the
|
||||
current bus.
|
||||
Fixes SUSE bug#1093625
|
||||
---
|
||||
src/dmidecode/dmidecode.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/dmidecode/dmidecode.c b/src/dmidecode/dmidecode.c
|
||||
index 1d805bb..a01a6ce 100644
|
||||
--- a/src/dmidecode/dmidecode.c
|
||||
+++ b/src/dmidecode/dmidecode.c
|
||||
@@ -153,7 +153,7 @@ void smbios_setslot(const struct libbiosdevname_state *state,
|
||||
}
|
||||
|
||||
/* Found a PDEV, now is it a bridge? */
|
||||
- if (pdev->sbus != -1) {
|
||||
+ if (pdev->sbus != -1 && pdev->sbus > bus) {
|
||||
smbios_setslot(state, domain, pdev->sbus, -1, -1, type, slot, index, label);
|
||||
}
|
||||
}
|
||||
--
|
||||
2.17.2
|
||||
|
187
SOURCES/0003-Netronome-biosdevname-support-8.patch
Normal file
187
SOURCES/0003-Netronome-biosdevname-support-8.patch
Normal file
@ -0,0 +1,187 @@
|
||||
From 8f2d9991d50e09ba9af842fb592b37d0c2021a06 Mon Sep 17 00:00:00 2001
|
||||
From: dirkjacobus <dirkjacobus@gmail.com>
|
||||
Date: Sun, 11 Nov 2018 23:29:24 -0800
|
||||
Subject: [PATCH] Netronome biosdevname support (#8)
|
||||
|
||||
* Add support for Netronome netdevices
|
||||
|
||||
Netronome netdevices also provide multiple ports through the same
|
||||
function.
|
||||
|
||||
* Set devID with phys_port_name index for nfp devices
|
||||
|
||||
Netronome netdevices should rather use the index from the phys_port_name
|
||||
attribute instead of the dev_port/dev_id
|
||||
attributes.
|
||||
|
||||
* Exclude naming Netronome logical devices
|
||||
|
||||
Some drivers, like the Netronome nfp driver, expose logical devices such
|
||||
as representors and switchdev uplink devices.
|
||||
|
||||
There isn't currently a naming scheme for such devices, so exclude them
|
||||
from the biosdevname naming policy.
|
||||
|
||||
Split ports also don't have a naming scheme defined for biosdevname, so
|
||||
its better to exclude them from naming.
|
||||
|
||||
Identification of such devices will always be driver dependent.
|
||||
At the moment, only 'nfp' driver devices are considered for exclusion.
|
||||
---
|
||||
src/bios_device.c | 6 ++++-
|
||||
src/eths.c | 65 ++++++++++++++++++++++++++++++++++++++++-------
|
||||
src/eths.h | 6 +++++
|
||||
3 files changed, 67 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/src/bios_device.c b/src/bios_device.c
|
||||
index 3cc528b..4882513 100644
|
||||
--- a/src/bios_device.c
|
||||
+++ b/src/bios_device.c
|
||||
@@ -214,7 +214,7 @@ static void sort_device_list(struct libbiosdevname_state *state)
|
||||
list_splice(&sorted_devices, &state->bios_devices);
|
||||
}
|
||||
|
||||
-/* Check for Mellanox/Chelsio drivers */
|
||||
+/* Check for multiport drivers */
|
||||
int ismultiport(const char *driver)
|
||||
{
|
||||
if (!strncmp(driver, "mlx4", 4))
|
||||
@@ -223,6 +223,8 @@ int ismultiport(const char *driver)
|
||||
return 1;
|
||||
if (!strncmp(driver, "exanic", 6))
|
||||
return 1;
|
||||
+ if (!strncmp(driver, "nfp", 3))
|
||||
+ return 1;
|
||||
return 0;
|
||||
}
|
||||
|
||||
@@ -248,6 +250,8 @@ static void match_pci_and_eth_devs(struct libbiosdevname_state *state)
|
||||
/* Ignore if devtype is fcoe */
|
||||
if (netdev_devtype_is_fcoe(n))
|
||||
continue;
|
||||
+ if (!netdev_is_eligible(n))
|
||||
+ continue;
|
||||
b = malloc(sizeof(*b));
|
||||
if (!b)
|
||||
continue;
|
||||
diff --git a/src/eths.c b/src/eths.c
|
||||
index d2c4d36..688c3af 100644
|
||||
--- a/src/eths.c
|
||||
+++ b/src/eths.c
|
||||
@@ -35,21 +35,67 @@ char *pr_ether(char *buf, const int size, const unsigned char *s)
|
||||
return (buf);
|
||||
}
|
||||
|
||||
-static void eths_get_devid(const char *devname, int *devid)
|
||||
+static int eths_get_phys_port_name_id(const char *devname)
|
||||
+{
|
||||
+ char *portstr = NULL;
|
||||
+ char path[PATH_MAX];
|
||||
+ int index = -1;
|
||||
+
|
||||
+ /* Only devices that have a phys_port_name of 'pX' are considered here,
|
||||
+ * with the index 'X' extracted.
|
||||
+ */
|
||||
+ snprintf(path, sizeof(path), "/sys/class/net/%s/phys_port_name", devname);
|
||||
+ if (sysfs_read_file(path, &portstr) == 0) {
|
||||
+ char *res = NULL;
|
||||
+
|
||||
+ if (portstr[0] == 'p') {
|
||||
+ index = strtol(&portstr[1], &res, 10);
|
||||
+ /* Reset to invalid if the format is unexpected. */
|
||||
+ if (*res)
|
||||
+ index = -1;
|
||||
+ }
|
||||
+
|
||||
+ free(portstr);
|
||||
+ }
|
||||
+
|
||||
+ return index;
|
||||
+}
|
||||
+
|
||||
+static void eths_get_dev_eligible(struct network_device *dev)
|
||||
+{
|
||||
+ /* By default, all network devices are eligible for naming. Some may
|
||||
+ * opt-out explicitly below.
|
||||
+ */
|
||||
+ dev->is_eligible = 1;
|
||||
+
|
||||
+ if (dev->drvinfo_valid && strcmp(dev->drvinfo.driver, "nfp") == 0) {
|
||||
+ dev->is_eligible = (eths_get_phys_port_name_id(dev->kernel_name) >= 0 ? 1 : 0);
|
||||
+ }
|
||||
+}
|
||||
+
|
||||
+static void eths_get_devid(struct network_device *dev)
|
||||
{
|
||||
char path[PATH_MAX];
|
||||
char *devidstr = NULL;
|
||||
|
||||
- *devid = -1;
|
||||
- snprintf(path, sizeof(path), "/sys/class/net/%s/dev_port", devname);
|
||||
- if (sysfs_read_file(path, &devidstr) == 0) {
|
||||
- sscanf(devidstr, "%i", devid);
|
||||
- free(devidstr);
|
||||
+ dev->devid = -1;
|
||||
+
|
||||
+ /* For some drivers, the phys_port_name index, e.g. pX, is the correct
|
||||
+ * dev ID to use instead of the dev_port attribute.
|
||||
+ */
|
||||
+ if (dev->drvinfo_valid && strcmp(dev->drvinfo.driver, "nfp") == 0) {
|
||||
+ dev->devid = eths_get_phys_port_name_id(dev->kernel_name);
|
||||
} else {
|
||||
- snprintf(path, sizeof(path), "/sys/class/net/%s/dev_id", devname);
|
||||
+ snprintf(path, sizeof(path), "/sys/class/net/%s/dev_port", dev->kernel_name);
|
||||
if (sysfs_read_file(path, &devidstr) == 0) {
|
||||
- sscanf(devidstr, "%i", devid);
|
||||
+ sscanf(devidstr, "%i", &dev->devid);
|
||||
free(devidstr);
|
||||
+ } else {
|
||||
+ snprintf(path, sizeof(path), "/sys/class/net/%s/dev_id", dev->kernel_name);
|
||||
+ if (sysfs_read_file(path, &devidstr) == 0) {
|
||||
+ sscanf(devidstr, "%i", &dev->devid);
|
||||
+ free(devidstr);
|
||||
+ }
|
||||
}
|
||||
}
|
||||
}
|
||||
@@ -224,13 +270,14 @@ static void fill_eth_dev(struct network_device *dev)
|
||||
eths_get_ifindex(dev->kernel_name, &dev->ifindex);
|
||||
eths_get_hwaddr(dev->kernel_name, dev->dev_addr, sizeof(dev->dev_addr), &dev->arphrd_type);
|
||||
eths_get_permaddr(dev->kernel_name, dev->perm_addr, sizeof(dev->perm_addr));
|
||||
- eths_get_devid(dev->kernel_name, &dev->devid);
|
||||
devtype = eths_get_devtype(dev);
|
||||
if (devtype > 0)
|
||||
dev->devtype_is_fcoe = 1;
|
||||
rc = eths_get_info(dev->kernel_name, &dev->drvinfo);
|
||||
if (rc == 0)
|
||||
dev->drvinfo_valid = 1;
|
||||
+ eths_get_devid(dev);
|
||||
+ eths_get_dev_eligible(dev);
|
||||
}
|
||||
|
||||
void free_eths(struct libbiosdevname_state *state)
|
||||
diff --git a/src/eths.h b/src/eths.h
|
||||
index b695d3d..49e399d 100644
|
||||
--- a/src/eths.h
|
||||
+++ b/src/eths.h
|
||||
@@ -30,6 +30,7 @@ struct network_device {
|
||||
int devid;
|
||||
int devtype_is_fcoe;
|
||||
char *devtype;
|
||||
+ int is_eligible:1; /* not eligible for naming when 0 */
|
||||
};
|
||||
|
||||
extern void get_eths(struct libbiosdevname_state *state);
|
||||
@@ -68,4 +69,9 @@ static inline int netdev_arphrd_type_is_eth(const struct network_device *dev)
|
||||
return (dev->arphrd_type == ARPHRD_ETHER);
|
||||
}
|
||||
|
||||
+static inline int netdev_is_eligible(const struct network_device *dev)
|
||||
+{
|
||||
+ return (!!dev->is_eligible);
|
||||
+}
|
||||
+
|
||||
#endif /* __ETHS_H_INCLUDED */
|
||||
--
|
||||
2.17.2
|
||||
|
25
SOURCES/0999-Place-udev-rules-to-usr-lib.patch
Normal file
25
SOURCES/0999-Place-udev-rules-to-usr-lib.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From 6e29eb19cfec3b657eb6ed8121898e80c1c39e6b Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?V=C3=A1clav=20Pavl=C3=ADn?= <vpavlin@redhat.com>
|
||||
Date: Mon, 23 Sep 2013 14:05:59 +0200
|
||||
Subject: [PATCH] Place udev rules to /usr/lib
|
||||
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 177f54a..474c064 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -68,7 +68,7 @@ AC_CHECK_FUNCS([dup2 gettimeofday memset munmap select socket strcasecmp strchr
|
||||
|
||||
# this is ugly, but accounts for SLES 10, Red Hat/Fedora, and Ubuntu
|
||||
# handles default udev rules as of udev 114 or thereabouts
|
||||
-RULEDEST=/lib/udev/rules.d/71-biosdevname.rules
|
||||
+RULEDEST=${prefix}/lib/udev/rules.d/71-biosdevname.rules
|
||||
|
||||
if [[ -e /etc/udev/rules.d/60-net.rules ]]; then
|
||||
# RHEL 5 / Fedora
|
||||
--
|
||||
2.14.3
|
||||
|
@ -0,0 +1,25 @@
|
||||
From e63b3589e0ded7078b2f02546fc0b0a2a10223be Mon Sep 17 00:00:00 2001
|
||||
From: Michal Sekletar <msekleta@redhat.com>
|
||||
Date: Mon, 17 Dec 2018 10:52:51 +0100
|
||||
Subject: [PATCH] rules: disable pirq and force minimal smbios version
|
||||
|
||||
Related: #1623621
|
||||
---
|
||||
biosdevname.rules.in | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/biosdevname.rules.in b/biosdevname.rules.in
|
||||
index 0a32aa5..105ef5a 100644
|
||||
--- a/biosdevname.rules.in
|
||||
+++ b/biosdevname.rules.in
|
||||
@@ -19,6 +19,6 @@ LABEL="netdevicename_start"
|
||||
|
||||
# using NAME= instead of setting INTERFACE_NAME, so that persistent
|
||||
# names aren't generated for these devices, they are "named" on each boot.
|
||||
-SUBSYSTEMS=="pci", PROGRAM="/sbin/biosdevname --policy physical -i %k", NAME="%c", OPTIONS+="string_escape=replace"
|
||||
+SUBSYSTEMS=="pci", PROGRAM="/sbin/biosdevname --smbios 2.6 --nopirq --policy physical -i %k", NAME="%c" OPTIONS+="string_escape=replace"
|
||||
|
||||
LABEL="netdevicename_end"
|
||||
--
|
||||
2.17.2
|
||||
|
27
SOURCES/1001-rules-disable-biosdevname-by-default.patch
Normal file
27
SOURCES/1001-rules-disable-biosdevname-by-default.patch
Normal file
@ -0,0 +1,27 @@
|
||||
From c4771922d64cb1540968ab4b5a9bfbe1148cb211 Mon Sep 17 00:00:00 2001
|
||||
From: Michal Sekletar <msekleta@redhat.com>
|
||||
Date: Tue, 18 Dec 2018 11:34:56 +0100
|
||||
Subject: [PATCH] rules: disable biosdevname by default
|
||||
|
||||
---
|
||||
biosdevname.rules.in | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/biosdevname.rules.in b/biosdevname.rules.in
|
||||
index 31b003c..1dcca74 100644
|
||||
--- a/biosdevname.rules.in
|
||||
+++ b/biosdevname.rules.in
|
||||
@@ -12,8 +12,8 @@ ENV{biosdevname}=="?*", ENV{UDEV_BIOSDEVNAME}="$env{biosdevname}"
|
||||
ENV{UDEV_BIOSDEVNAME}=="0", GOTO="netdevicename_end"
|
||||
ENV{UDEV_BIOSDEVNAME}=="1", GOTO="netdevicename_start"
|
||||
|
||||
-# uncomment the next line for biosdevname to be off by default
|
||||
-# GOTO="netdevicename_end"
|
||||
+# off by default
|
||||
+GOTO="netdevicename_end"
|
||||
|
||||
LABEL="netdevicename_start"
|
||||
|
||||
--
|
||||
2.17.2
|
||||
|
245
SPECS/biosdevname.spec
Normal file
245
SPECS/biosdevname.spec
Normal file
@ -0,0 +1,245 @@
|
||||
Name: biosdevname
|
||||
Version: 0.7.3
|
||||
Release: 2%{?dist}
|
||||
Summary: Udev helper for naming devices per BIOS names
|
||||
|
||||
Group: System Environment/Base
|
||||
License: GPLv2
|
||||
URL: http://linux.dell.com/files/%{name}
|
||||
# SMBIOS only exists on these arches. It's also likely that other
|
||||
# arches don't expect the PCI bus to be sorted breadth-first, or of
|
||||
# so, there haven't been any comments about that on LKML.
|
||||
ExclusiveArch: %{ix86} x86_64
|
||||
Source0: http://linux.dell.com/files/%{name}/%{name}-%{version}/%{name}-%{version}.tar.gz
|
||||
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
BuildRequires: pciutils-devel
|
||||
BuildRequires: zlib-devel
|
||||
|
||||
Patch0001: 0001-Add-support-for-ExaNIC-network-cards-5.patch
|
||||
Patch0002: 0002-Prevent-infinite-recursion-in-dmidecode.c-smbios_set.patch
|
||||
Patch0003: 0003-Netronome-biosdevname-support-8.patch
|
||||
|
||||
Patch0999: 0999-Place-udev-rules-to-usr-lib.patch
|
||||
Patch1000: 1000-rules-disable-pirq-and-force-minimal-smbios-version.patch
|
||||
Patch1001: 1001-rules-disable-biosdevname-by-default.patch
|
||||
|
||||
%description
|
||||
biosdevname in its simplest form takes a kernel device name as an
|
||||
argument, and returns the BIOS-given name it "should" be. This is necessary
|
||||
on systems where the BIOS name for a given device (e.g. the label on
|
||||
the chassis is "Gb1") doesn't map directly and obviously to the kernel
|
||||
name (e.g. eth0).
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%autopatch -p1
|
||||
|
||||
%build
|
||||
autoreconf -fiv
|
||||
%configure --prefix=%{_prefix}
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
make install install-data DESTDIR=%{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING README
|
||||
%{_sbindir}/%{name}
|
||||
%{_prefix}/lib/udev/rules.d/*.rules
|
||||
%{_mandir}/man1/%{name}.1*
|
||||
|
||||
%changelog
|
||||
* Mon Dec 17 2018 Michal Sekletár <msekleta@redhat.com> - 0.7.3-2
|
||||
- make biosdevname optional even on Dell servers (#1623621)
|
||||
- prevent infinite recursion in smbios_setslot() (#1499458)
|
||||
- Netronome biosdevname support (#1649036)
|
||||
|
||||
* Fri Mar 23 2018 Michal Sekletar <msekleta@redhat.com> - 0.7.3-1
|
||||
- rebase to biosdevname 0.7.3
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.2-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.2-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Fri Jun 26 2015 Michal Sekletar <msekleta@redhat.com> - 0.6.2-1
|
||||
- Rebase to 0.6.2
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon Sep 02 2013 Harald Hoyer <harald@redhat.com> 0.5.0-2
|
||||
- not only NAME KERNEL=="eth*", but every ethernet device
|
||||
|
||||
* Tue Jul 30 2013 Václav Pavlín <vpavlin@redhat.com> - 0.5.0-1
|
||||
- Updating the sources to 0.5.0 version. Following are the changes:
|
||||
- Change scan of SMBIOS slot <-> PCI methods, recurse to set SMBIOS slot field
|
||||
- Save off secondary bus of PCI device for PCI tree traversal
|
||||
- Add version number to biosdevname
|
||||
|
||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Wed Nov 14 2012 Václav Pavlín <vpavlin@redhat.com> - 0.4.1-3
|
||||
- Source link update
|
||||
|
||||
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Wed Jul 18 2012 Praveen K Paladugu <praveen_paladugu@dell.com> - 0.4.1-1
|
||||
- Fix autoconfig for Fedora systems
|
||||
- Make sure that vpd scan only runs on Dell systems, also blacklist Atheros
|
||||
wireless cards which hang when vpd is read.
|
||||
- Add fixes to biosdevname to support cards that export multiple network
|
||||
ports per PCI device (chelsio/mellanox).
|
||||
|
||||
|
||||
|
||||
* Thu May 3 2012 Praveen K Paladugu <praveen_paladugu@dell.com> - 0.4.0-1
|
||||
- Create detached signature
|
||||
- Fix man page to use new naming convention
|
||||
- Remove unused variables from Stephen Hemminger [shemminger@vyatta.com]
|
||||
- Use Physical device for slot numbering for embedded SR-IOV cards
|
||||
- Add tracking of ifindex to eths structure
|
||||
- Fix naming for add-in network adapters when SMBIOS version is invalid
|
||||
- Read VPD-R on Dell systems only
|
||||
|
||||
* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.11-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Tue Oct 4 2011 Praveen K Paladugu <praveen_paladugu@dell.com> - 0.3.11-5
|
||||
- Added automake as a build dependency
|
||||
|
||||
* Tue Oct 4 2011 Praveen K Paladugu <praveen_paladugu@dell.com> - 0.3.11-4
|
||||
- Added autoconf as a build dependency
|
||||
|
||||
* Tue Oct 4 2011 Praveen K Paladugu <praveen_paladugu@dell.com> - 0.3.11-3
|
||||
- Generating the configure script if it doesn't exist
|
||||
|
||||
* Tue Oct 4 2011 Praveen K Paladugu <praveen_paladugu@dell.com> - 0.3.11-2
|
||||
- Fixed the dir structure inside the archive
|
||||
|
||||
* Tue Oct 4 2011 Praveen K Paladugu <praveen_paladugu@dell.com> - 0.3.11-1
|
||||
- Updating the sources to 0.3.11 version. Following are the changes:
|
||||
- Fix man page for PCI slot naming
|
||||
- Fix clearing of buffer for NPAR/SRIOV naming
|
||||
- Add --nopirq and --smbios options to manpage.
|
||||
- Verify length of VPD on network device
|
||||
- Close file handle on sysfs read
|
||||
- Fix naming policy for NPAR devices.
|
||||
Match each PCI device to its VPD 'physical' device to get correct index
|
||||
- Exclude building on ia64 arch
|
||||
- Add support functions for determining PCIE slot
|
||||
- Scan full path to parent when getting PCIE slot
|
||||
- Fix NPAR naming for add-in cards
|
||||
- Don't display _vf suffix on NPAR devices with single function
|
||||
- Fix PCIe/PIRQ slot mapping
|
||||
|
||||
* Thu Apr 21 2011 Praveen K Paladugu <praveen_paladugu@dell.com> - 0.3.8-1
|
||||
- Add changes to parse VPD structure for device mapping on NPAR devices
|
||||
- Fix pathname
|
||||
- Cleanup and comment NPAR code
|
||||
- Fix debian packaging rules to regenerate configure script
|
||||
- Change pciX to pX for shortened names for PCI add-on devices
|
||||
- Fix manpage typo
|
||||
- Delete CR-LF in script
|
||||
- Change default signing key
|
||||
- Add command line arguments for checking SMBIOS version and ignore $PIRQ.
|
||||
|
||||
* Thu Feb 17 2011 Matt Domsch <Matt_Domsch@dell.com> - 0.3.7-1
|
||||
- drop dump_pirq, suggest use biosdecode instead
|
||||
- don't use '#' in names, use 'p' instead, by popular demand
|
||||
- properly look for SMBIOS, then $PIR, then recurse
|
||||
- Add kernel command line parameter "biosdevname={0|1}" to turn off/on biosdevname
|
||||
- Fix segfault when BIOS advertises zero sized PIRQ Routing Table
|
||||
- Add 'bonding' and 'openvswitch' to the virtual devices list
|
||||
- fail PIRQ lookups if device domain is not 0
|
||||
- Don't suggest names if running in a virtual machine (Xen, KVM,
|
||||
VMware tested, but should work on others)
|
||||
- Typo fixes
|
||||
|
||||
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Tue Jan 25 2011 Matt Domsch <Matt_Domsch@dell.com> - 0.3.6-1
|
||||
- drop biosdevnameS, it's unused and fails to build on F15
|
||||
|
||||
* Tue Jan 25 2011 Matt Domsch <Matt_Domsch@dell.com> - 0.3.5-1
|
||||
- install dump_pirq into /usr/sbin
|
||||
- fix udev rule, skip running if NAME is already set
|
||||
- move udev rule to /lib/udev/rules.d by default
|
||||
|
||||
* Thu Dec 16 2010 Matt Domsch <mdomsch@fedoraproject.org> - 0.3.4-1
|
||||
- drop unnecessary explicit version requirement on udev
|
||||
- bugfix: start indices at 1 not 0, to match Dell and HP server port designations
|
||||
- bugfix: don't assign names to unknown devices
|
||||
- bugfix: don't assign duplicate names
|
||||
|
||||
* Thu Dec 9 2010 Matt Domsch <Matt_Domsch@dell.com> - 0.3.3-1
|
||||
- add back in use of PCI IRQ Routing Table, if info is not provided by
|
||||
sysfs or SMBIOS
|
||||
|
||||
* Thu Dec 2 2010 Matt Domsch <Matt_Domsch@dell.com> - 0.3.2-1
|
||||
- fix for multi-port cards with bridges
|
||||
- removal of code for seriously obsolete systems
|
||||
|
||||
* Sun Nov 28 2010 Matt Domsch <Matt_Domsch@dell.com> 0.3.1-1
|
||||
- remove all policies except 'physical' and 'all_ethN'
|
||||
- handle SR-IOV devices properly
|
||||
|
||||
* Wed Nov 10 2010 Matt Domsch <Matt_Domsch@dell.com> 0.3.0-1
|
||||
- add --policy=loms, make it default
|
||||
- read index and labels from sysfs if available
|
||||
|
||||
* Mon Jul 27 2009 Jordan Hargrave <Jordan_Hargrave@dell.com> 0.2.5-1
|
||||
- fix mmap error checking
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.4-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.4-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Tue May 06 2008 Matt Domsch <Matt_Domsch@dell.com> 0.2.4-5
|
||||
- use policy=all_names to find breakage
|
||||
|
||||
* Sun Feb 10 2008 Matt Domsch <Matt_Domsch@dell.com> 0.2.4-4
|
||||
- rebuild for gcc43
|
||||
|
||||
* Fri Sep 21 2007 Matt Domsch <Matt_Domsch@dell.com> 0.2.4-3
|
||||
- fix manpage entry in files
|
||||
|
||||
* Fri Sep 21 2007 Matt Domsch <Matt_Domsch@dell.com> 0.2.4-2
|
||||
- rebuild with Requires: udev > 115-3.20070920git
|
||||
|
||||
* Fri Sep 21 2007 Matt Domsch <Matt_Domsch@dell.com> 0.2.4-1
|
||||
- coordinate udev rules usage with udev maintainer
|
||||
- fix crashes in pcmcia search, in_ethernet(), and incorrect command
|
||||
line parsing.
|
||||
|
||||
* Mon Aug 27 2007 Matt Domsch <Matt_Domsch@dell.com> 0.2.3-1
|
||||
- eliminate libbiosdevname.*, pre and post scripts
|
||||
|
||||
* Fri Aug 24 2007 Matt Domsch <Matt_Domsch@dell.com> 0.2.2-1
|
||||
- ExclusiveArch those arches with SMBIOS and PCI IRQ Routing tables
|
||||
- eliminate libsysfs dependency, move app to / for use before /usr is mounted.
|
||||
- build static
|
||||
|
||||
* Mon Aug 20 2007 Matt Domsch <Matt_Domsch@dell.com> 0.2.1-1
|
||||
- initial release
|
Loading…
Reference in New Issue
Block a user