Fix typos which were preventing the linker tests from running

This commit is contained in:
Nick Clifton 2022-06-08 11:59:39 +01:00
parent fae26da53a
commit 2d6725c1a9
3 changed files with 9 additions and 34 deletions

View File

@ -881,7 +881,7 @@ diff -rup binutils.orig/ld/testsuite/ld-plugin/plugin.exp binutils-2.38/ld/tests
$testobjfiles tmpdir/libempty.a $libs" "" "" "" {{ld plugin-30.d}} "main.x" ] \
]
+if { [istarget "powerpc*-*-linux*"] }
+if { [istarget "powerpc*-*-linux*"] } {
+ return
+}
+
@ -921,7 +921,7 @@ diff -rup binutils.orig/ld/testsuite/ld-elf/linux-x86.exp binutils-2.38/ld/tests
] \
]
+if { [istarget "i[3-6]86-*-*"] } {
+if { [istarget "i?86-*-*"] } {
+ return
+}
+
@ -959,7 +959,7 @@ diff -rup binutils.orig/ld/testsuite/ld-vsb/vsb.exp binutils-2.38/ld/testsuite/l
}
}
+if { [istarget "i[3-6]86-*-*"] } {
+if { [istarget "i?86-*-*"] } {
+ set support_protected "no"
+}
+
@ -973,7 +973,7 @@ diff -rup binutils.orig/ld/testsuite/lib/ld-lib.exp binutils-2.38/ld/testsuite/l
return 1
}
+ if [istarget "i[3-6]86-*-*"] {
+ if { [istarget "i?86-*-*"] } {
+ return 1
+ }
+

View File

@ -39,7 +39,7 @@
Summary: A GNU collection of binary utilities
Name: binutils%{?name_cross}%{?_with_debug:-debug}
Version: 2.38
Release: 14%{?dist}
Release: 15%{?dist}
License: GPLv3+
URL: https://sourceware.org/binutils
@ -283,7 +283,7 @@ Patch18: binutils-autoconf-version.patch
# Purpose: Stop libtool from inserting useless runpaths into binaries.
# Lifetime: Who knows.
Patch19: gcc12-libtool-no-rpath.patch
Patch19: binutils-libtool-no-rpath.patch
# Purpose: Add support for specifying section types in linker scripts.
# Lifetime: Fixed in 2.39
@ -933,6 +933,9 @@ exit 0
#----------------------------------------------------------------------------
%changelog
* Wed Jun 08 2022 Nick Clifton <nickc@redhat.comn> - 2.38-14
- Fix bugs preventing the linker tests from running.
* Fri May 27 2022 Nick Clifton <nickc@redhat.comn> - 2.38-14
- Fix bug in binutils.spec file that was causing the wrong linker flags to be used.

View File

@ -1,28 +0,0 @@
diff -rup binutils.orig/ltmain.sh binutils-2.37/ltmain.sh
--- binutils.orig/ltmain.sh 2022-01-27 16:23:09.304207432 +0000
+++ binutils-2.37/ltmain.sh 2022-01-27 16:23:18.380143759 +0000
@@ -7103,6 +7103,7 @@ EOF
rpath="$finalize_rpath"
test "$mode" != relink && rpath="$compile_rpath$rpath"
for libdir in $rpath; do
+ case "$libdir" in /usr/lib|/usr/lib64|/usr/lib/../lib|/usr/lib/../lib64) continue;; esac
if test -n "$hardcode_libdir_flag_spec"; then
if test -n "$hardcode_libdir_separator"; then
if test -z "$hardcode_libdirs"; then
@@ -7798,6 +7799,7 @@ EOF
rpath=
hardcode_libdirs=
for libdir in $compile_rpath $finalize_rpath; do
+ case "$libdir" in /usr/lib|/usr/lib64|/usr/lib/../lib|/usr/lib/../lib64) continue;; esac
if test -n "$hardcode_libdir_flag_spec"; then
if test -n "$hardcode_libdir_separator"; then
if test -z "$hardcode_libdirs"; then
@@ -7849,6 +7851,7 @@ EOF
rpath=
hardcode_libdirs=
for libdir in $finalize_rpath; do
+ case "$libdir" in /usr/lib|/usr/lib64|/usr/lib/../lib|/usr/lib/../lib64) continue;; esac
if test -n "$hardcode_libdir_flag_spec"; then
if test -n "$hardcode_libdir_separator"; then
if test -z "$hardcode_libdirs"; then
Only in binutils-2.37: ltmain.sh.orig