Rebase on GNU Binutils 2.38.

This commit is contained in:
Nick Clifton 2022-02-10 11:51:11 +00:00
parent c13a28efbc
commit 24c5f0f956
5 changed files with 27 additions and 296 deletions

1
.gitignore vendored
View File

@ -67,3 +67,4 @@ stamp-*
/binutils-2.35.1.tar.xz
/binutils-2.36.1.tar.xz
/binutils-2.37.tar.xz
/binutils-2.38.tar.xz

View File

@ -101,149 +101,6 @@ diff -rup binutils.orig/ld/testsuite/ld-plugin/plugin-9.d binutils-2.36.1/ld/tes
#...
hook called: cleanup.
diff -rup binutils.orig/ld/testsuite/ld-x86-64/x86-64.exp binutils-2.36.1/ld/testsuite/ld-x86-64/x86-64.exp
--- binutils.orig/ld/testsuite/ld-x86-64/x86-64.exp 2021-02-12 10:13:11.177049047 +0000
+++ binutils-2.36.1/ld/testsuite/ld-x86-64/x86-64.exp 2021-02-12 10:57:23.339975059 +0000
@@ -1437,22 +1437,6 @@ if { [isnative] && [check_compiler_avail
} else {
run_cc_link_tests [list \
[list \
- "Build pr22001-1b" \
- "$NOPIE_LDFLAGS -Wl,-z,nocopyreloc,--no-as-needed,-z,notext tmpdir/pr22001-1.so" \
- "$NOPIE_CFLAGS -Wa,-mx86-used-note=yes" \
- { pr22001-1c.c } \
- {{error_output "pr22001-1b.err"}} \
- "pr22001-1b" \
- ] \
- [list \
- "Build pr21997-1b" \
- "$NOPIE_LDFLAGS -Wl,--no-as-needed,-z,notext tmpdir/pr21997-1.so" \
- "$NOPIE_CFLAGS -Wa,-mx86-used-note=yes" \
- { pr21997-1c.c } \
- {{error_output "pr21997-1b.err"}} \
- "pr21997-1b" \
- ] \
- [list \
"Build lam-u48.so" \
"-shared -Wl,-z,lam-u48" \
"" \
@@ -1766,49 +1750,6 @@ if { [isnative] && [check_compiler_avail
if { [istarget "x86_64-*-linux*"] \
&& ![istarget "x86_64-*-linux*-gnux32"]} {
- run_cc_link_tests [list \
- [list \
- "Build plt-main with -z bndplt" \
- "tmpdir/plt-main1.o tmpdir/plt-main2.o tmpdir/plt-main3.o \
- tmpdir/plt-main4.o tmpdir/libplt-lib.so -z bndplt \
- -z noseparate-code -z max-page-size=0x200000" \
- "-Wa,-mx86-used-note=yes $NOCF_PROTECTION_CFLAGS" \
- { plt-main5.c } \
- {{objdump {-drw} plt-main-bnd.dd}} \
- "plt-main-bnd" \
- ] \
- [list \
- "Build plt-main with PIE and -z bndplt" \
- "tmpdir/plt-main1.o tmpdir/plt-main2.o tmpdir/plt-main3.o \
- tmpdir/plt-main4.o tmpdir/libplt-lib.so -z bndplt -pie \
- -z noseparate-code -z max-page-size=0x200000" \
- "-fPIC -Wa,-mx86-used-note=yes $NOCF_PROTECTION_CFLAGS" \
- { plt-main5.c } \
- {{objdump {-drw} plt-main-bnd.dd}} \
- "plt-main-pie-bnd" \
- ] \
- [list \
- "Build plt-main with -z bndplt -z now" \
- "tmpdir/plt-main1.o tmpdir/plt-main2.o tmpdir/plt-main3.o \
- tmpdir/plt-main4.o tmpdir/libplt-lib.so -z bndplt -z now \
- -z noseparate-code -z max-page-size=0x200000" \
- "-Wa,-mx86-used-note=yes $NOCF_PROTECTION_CFLAGS" \
- { plt-main5.c } \
- {{readelf {-SW} plt-main-bnd-now.rd} {objdump {-drw} plt-main-bnd.dd}} \
- "plt-main-bnd-now" \
- ] \
- [list \
- "Build plt-main with PIE and -z bndplt -z now" \
- "tmpdir/plt-main1.o tmpdir/plt-main2.o tmpdir/plt-main3.o \
- tmpdir/plt-main4.o tmpdir/libplt-lib.so -z bndplt -z now -pie \
- -z noseparate-code -z max-page-size=0x200000" \
- "-fPIC -Wa,-mx86-used-note=yes $NOCF_PROTECTION_CFLAGS" \
- { plt-main5.c } \
- {{readelf {-SW} plt-main-bnd-now.rd} {objdump {-drw} plt-main-bnd.dd}} \
- "plt-main-pie-bnd-now" \
- ] \
- ]
-
run_ld_link_exec_tests [list \
[list \
"Run plt-main with -z bndplt" \
@@ -1893,66 +1834,6 @@ if { [isnative] && [check_compiler_avail
set pltdump {{objdump {-drw} plt-main-ibt.dd}}
set pltsecdump {{readelf {-SW} plt-main-ibt-now.rd} {objdump {-drw} plt-main-ibt.dd}}
}
- run_cc_link_tests [list \
- [list \
- "Build plt-main with -z ibtplt" \
- "tmpdir/plt-main1.o tmpdir/plt-main2.o tmpdir/plt-main3.o \
- tmpdir/plt-main4.o tmpdir/libplt-lib.so -z ibtplt \
- -z noseparate-code -z max-page-size=0x200000" \
- "-Wa,-mx86-used-note=yes" \
- { plt-main5.c } \
- $pltdump \
- "plt-main-ibt" \
- ] \
- [list \
- "Build plt-main with PIE and -z ibtplt" \
- "tmpdir/plt-main1.o tmpdir/plt-main2.o tmpdir/plt-main3.o \
- tmpdir/plt-main4.o tmpdir/libplt-lib.so -z ibtplt -pie \
- -z noseparate-code -z max-page-size=0x200000" \
- "-fPIC -Wa,-mx86-used-note=yes" \
- { plt-main5.c } \
- $pltdump \
- "plt-main-pie-ibt" \
- ] \
- [list \
- "Build plt-main with -z ibtplt -z now" \
- "tmpdir/plt-main1.o tmpdir/plt-main2.o tmpdir/plt-main3.o \
- tmpdir/plt-main4.o tmpdir/libplt-lib.so -z ibtplt -z now \
- -z noseparate-code -z max-page-size=0x200000" \
- "-Wa,-mx86-used-note=yes" \
- { plt-main5.c } \
- $pltsecdump \
- "plt-main-ibt-now" \
- ] \
- [list \
- "Build plt-main with PIE and -z ibtplt -z now" \
- "tmpdir/plt-main1.o tmpdir/plt-main2.o tmpdir/plt-main3.o \
- tmpdir/plt-main4.o tmpdir/libplt-lib.so -z ibtplt -z now -pie \
- -z noseparate-code -z max-page-size=0x200000" \
- "-fPIC -Wa,-mx86-used-note=yes" \
- { plt-main5.c } \
- $pltsecdump \
- "plt-main-pie-ibt-now" \
- ] \
- [list \
- "Build libibtplt-lib.so with -z ibtplt" \
- "-shared -z ibtplt \
- -z noseparate-code -z max-page-size=0x200000" \
- "-fPIC -Wa,-mx86-used-note=yes" \
- { plt-main1.c plt-main2.c plt-main3.c plt-main4.c} \
- $pltdump \
- "libibtplt-lib.so" \
- ] \
- [list \
- "Build libibtplt--now-lib.so with -z ibtplt -z now" \
- "-shared -z ibtplt -z now \
- -z noseparate-code -z max-page-size=0x200000" \
- "-fPIC -Wa,-mx86-used-note=yes" \
- { plt-main1.c plt-main2.c plt-main3.c plt-main4.c} \
- $pltdump \
- "libibtplt-now-lib.so" \
- ] \
- ]
run_ld_link_exec_tests [list \
[list \
diff -rup binutils.orig/ld/testsuite/ld-x86-64/x86-64.exp binutils-2.36.1/ld/testsuite/ld-x86-64/x86-64.exp
--- binutils.orig/ld/testsuite/ld-x86-64/x86-64.exp 2021-02-12 11:44:39.121364751 +0000
+++ binutils-2.36.1/ld/testsuite/ld-x86-64/x86-64.exp 2021-02-12 11:46:27.505597689 +0000
@@ -1878,24 +1878,6 @@ if { [isnative] && [check_compiler_avail
@ -595,54 +452,6 @@ diff -rup binutils.orig/ld/testsuite/ld-x86-64/x86-64.exp binutils-2.36.1/ld/tes
# The pr23169 testcase is not valid. In general, you can't call ifunc
# resolvers in another binary unless you know what you're doing. In
--- binutils.orig/ld/testsuite/ld-plugin/plugin.exp 2021-07-20 09:55:20.326674591 +0100
+++ binutils-2.37/ld/testsuite/ld-plugin/plugin.exp 2021-07-20 10:20:38.647289474 +0100
@@ -81,6 +81,10 @@ if { [istarget m681*-*-*] || [istarget m
# otherwise get FAILS due to _.frame
set CFLAGS "$CFLAGS -fomit-frame-pointer"
}
+if { [istarget aarch64*-*-*] || [istarget arm*-*-*] } {
+ set LDFLAGS "$LDFLAGS --defsym __aeabi_unwind_cpp_pr0=0"
+}
+
# In order to define symbols in plugin options in the list of tests below,
# we need to know if the platform prepends an underscore to C symbols,
# which we find out by compiling the test objects now. If there is any
--- binutils-2.37/ld/testsuite/ld-plugin/plugin.exp 2021-07-20 12:04:23.815709733 +0100
+++ binutils.new/ld/testsuite/ld-plugin/plugin.exp 2021-07-20 12:04:16.782748608 +0100
@@ -81,9 +81,6 @@ if { [istarget m681*-*-*] || [istarget m
# otherwise get FAILS due to _.frame
set CFLAGS "$CFLAGS -fomit-frame-pointer"
}
-if { [istarget aarch64*-*-*] || [istarget arm*-*-*] } {
- set LDFLAGS "$LDFLAGS --defsym __aeabi_unwind_cpp_pr0=0"
-}
# In order to define symbols in plugin options in the list of tests below,
# we need to know if the platform prepends an underscore to C symbols,
@@ -141,6 +138,9 @@ if [is_pecoff_format] {
#otherwise relocs overflow to symbols defined on the command line
append libs " --image-base=0x10000000"
}
+if { [istarget aarch64*-*-*] || [istarget arm*-*-*] } {
+ append libs " --defsym __aeabi_unwind_cpp_pr0=0"
+}
set plugin_tests [list \
[list "load plugin" "-plugin $plugin_path \
--- binutils.orig/ld/testsuite/ld-elfvsb/elfvsb.exp 2021-07-20 13:28:42.151614203 +0100
+++ binutils-2.37/ld/testsuite/ld-elfvsb/elfvsb.exp 2021-07-20 13:32:09.558459291 +0100
@@ -94,6 +94,10 @@ if { [istarget *-*-linux*]
}
}
+if { [istarget i686*-*-*] } {
+ set support_protected "no"
+}
+
# The test procedure.
proc visibility_test { visibility progname testname main sh1 sh2 dat args } {
global CC
--- binutils.orig/ld/testsuite/ld-i386/i386.exp 2021-07-20 13:28:42.211613869 +0100
+++ binutils-2.37/ld/testsuite/ld-i386/i386.exp 2021-07-20 13:40:00.116839084 +0100
@@ -1057,15 +1057,6 @@ if { [isnative]
@ -760,16 +569,6 @@ diff -rup binutils.orig/ld/testsuite/ld-x86-64/x86-64.exp binutils-2.36.1/ld/tes
|| [istarget score*-*-*]
|| [istarget sh*-*-*]
|| [istarget tic6x-*-*]
--- binutils.orig/ld/testsuite/ld-plugin/plugin.exp 2021-07-20 15:22:27.819562158 +0100
+++ binutils-2.37/ld/testsuite/ld-plugin/plugin.exp 2021-07-20 15:31:38.814487994 +0100
@@ -308,6 +308,7 @@ if { !$can_compile || $failed_compile }
run_ld_link_tests $plugin_tests
if { [is_elf_format] \
+ && ! [istarget ppc64*-*-*]
&& [ld_compile "$CC $CFLAGS" $srcdir/$subdir/func1p.c tmpdir/func1p.o] \
&& [ld_compile "$CC $CFLAGS" $srcdir/$subdir/func2i.c tmpdir/func2i.o] \
&& [ld_compile "$CC $CFLAGS" $srcdir/$subdir/func3h.c tmpdir/func3h.o] } {
diff -rup binutils.orig/ld/testsuite/ld-powerpc/group1.sym binutils-2.37/ld/testsuite/ld-powerpc/group1.sym
--- binutils.orig/ld/testsuite/ld-powerpc/group1.sym 2021-07-20 15:22:27.827562114 +0100
+++ binutils-2.37/ld/testsuite/ld-powerpc/group1.sym 2021-07-20 15:39:57.916703418 +0100
@ -867,17 +666,6 @@ diff -rup binutils.orig/ld/testsuite/ld-powerpc/tlsso32.r binutils-2.37/ld/tests
|| [istarget ppc*-*-*]
|| [istarget score*-*-*]
|| [istarget sh*-*-*]
--- binutils.orig/ld/testsuite/ld-plugin/plugin.exp 2021-07-20 16:24:17.380869020 +0100
+++ binutils-2.37/ld/testsuite/ld-plugin/plugin.exp 2021-07-20 16:25:58.558304600 +0100
@@ -308,7 +308,7 @@ if { !$can_compile || $failed_compile }
run_ld_link_tests $plugin_tests
if { [is_elf_format] \
- && ! [istarget ppc64*-*-*]
+ && ! [istarget ppc64*-*-*] && ! [istarget powerpc*-*-*]
&& [ld_compile "$CC $CFLAGS" $srcdir/$subdir/func1p.c tmpdir/func1p.o] \
&& [ld_compile "$CC $CFLAGS" $srcdir/$subdir/func2i.c tmpdir/func2i.o] \
&& [ld_compile "$CC $CFLAGS" $srcdir/$subdir/func3h.c tmpdir/func3h.o] } {
--- binutils.orig/ld/testsuite/ld-powerpc/group1.sym 2021-07-20 16:24:17.384868997 +0100
+++ binutils-2.37/ld/testsuite/ld-powerpc/group1.sym 2021-07-20 16:27:36.604757678 +0100
@@ -1,2 +1 @@
@ -950,14 +738,3 @@ diff -rup binutils.orig/ld/testsuite/ld-powerpc/tlsso32.r binutils-2.37/ld/tests
}
if {[is_elf_format]} then {
--- binutils.orig/ld/testsuite/ld-plugin/lto.exp 2021-10-13 13:21:02.540433685 +0100
+++ binutils-2.37/ld/testsuite/ld-plugin/lto.exp 2021-10-13 13:37:08.559139599 +0100
@@ -31,8 +31,6 @@ if { ![check_plugin_api_available]
set saved_CFLAGS "$CFLAGS"
set saved_CXXFLAGS "$CXXFLAGS"
-regsub -all "(\\-Wp,)?-D_FORTIFY_SOURCE=\[0-9\]+" $CFLAGS "" CFLAGS
-regsub -all "(\\-Wp,)?-D_FORTIFY_SOURCE=\[0-9\]+" $CXXFLAGS "" CXXFLAGS
proc restore_notify { } {
global saved_CFLAGS

View File

@ -1,9 +1,10 @@
--- binutils-2.26.orig/bfd/Makefile.am 2016-01-25 10:11:33.505289018 +0000
+++ binutils-2.26/bfd/Makefile.am 2016-01-25 10:13:23.489964145 +0000
@@ -1043,8 +1043,8 @@ DISTCLEANFILES = $(BUILD_CFILES) $(BUILD
diff -rup binutils.orig/bfd/Makefile.am binutils-2.38/bfd/Makefile.am
--- binutils.orig/bfd/Makefile.am 2022-02-09 14:10:42.659300681 +0000
+++ binutils-2.38/bfd/Makefile.am 2022-02-09 14:12:40.562532916 +0000
@@ -977,8 +977,8 @@ DISTCLEANFILES = $(BUILD_CFILES) $(BUILD
bfdver.h: $(srcdir)/version.h $(srcdir)/development.sh $(srcdir)/Makefile.in
@echo "creating $@"
@bfd_version=`echo "$(VERSION)" | $(SED) -e 's/\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\).*/\1.00\2.00\3.00\4.00\5/' -e 's/\([^\.]*\)\..*\(..\)\..*\(..\)\..*\(..\)\..*\(..\)$$/\1\2\3\4\5/'` ;\
$(AM_V_GEN)\
bfd_version=`echo "$(VERSION)" | $(SED) -e 's/\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\).*/\1.00\2.00\3.00\4.00\5/' -e 's/\([^\.]*\)\..*\(..\)\..*\(..\)\..*\(..\)\..*\(..\)$$/\1\2\3\4\5/'` ;\
- bfd_version_string="\"$(VERSION)\"" ;\
- bfd_soversion="$(VERSION)" ;\
+ bfd_version_string="\"$(VERSION)-%{release}\"" ;\
@ -11,7 +12,7 @@
bfd_version_package="\"$(PKGVERSION)\"" ;\
report_bugs_to="\"$(REPORT_BUGS_TO)\"" ;\
. $(srcdir)/development.sh ;\
@@ -1055,7 +1055,7 @@ bfdver.h: $(srcdir)/version.h $(srcdir)/
@@ -989,7 +989,7 @@ bfdver.h: $(srcdir)/version.h $(srcdir)/
fi ;\
$(SED) -e "s,@bfd_version@,$$bfd_version," \
-e "s,@bfd_version_string@,$$bfd_version_string," \
@ -20,12 +21,13 @@
-e "s,@report_bugs_to@,$$report_bugs_to," \
< $(srcdir)/version.h > $@; \
echo "$${bfd_soversion}" > libtool-soversion
--- binutils-2.26.orig/bfd/Makefile.in 2016-01-25 10:11:33.505289018 +0000
+++ binutils-2.26/bfd/Makefile.in 2016-01-25 10:14:17.818297941 +0000
@@ -2111,8 +2111,8 @@ stmp-lcoff-h: $(LIBCOFF_H_FILES)
diff -rup binutils.orig/bfd/Makefile.in binutils-2.38/bfd/Makefile.in
--- binutils.orig/bfd/Makefile.in 2022-02-09 14:10:42.653300720 +0000
+++ binutils-2.38/bfd/Makefile.in 2022-02-09 14:19:03.362040188 +0000
@@ -2094,8 +2094,8 @@ stmp-lcoff-h: $(LIBCOFF_H_FILES) $(MKDOC
bfdver.h: $(srcdir)/version.h $(srcdir)/development.sh $(srcdir)/Makefile.in
@echo "creating $@"
@bfd_version=`echo "$(VERSION)" | $(SED) -e 's/\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\).*/\1.00\2.00\3.00\4.00\5/' -e 's/\([^\.]*\)\..*\(..\)\..*\(..\)\..*\(..\)\..*\(..\)$$/\1\2\3\4\5/'` ;\
$(AM_V_GEN)\
bfd_version=`echo "$(VERSION)" | $(SED) -e 's/\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\).*/\1.00\2.00\3.00\4.00\5/' -e 's/\([^\.]*\)\..*\(..\)\..*\(..\)\..*\(..\)\..*\(..\)$$/\1\2\3\4\5/'` ;\
- bfd_version_string="\"$(VERSION)\"" ;\
- bfd_soversion="$(VERSION)" ;\
+ bfd_version_string="\"$(VERSION)-%{release}\"" ;\
@ -33,7 +35,7 @@
bfd_version_package="\"$(PKGVERSION)\"" ;\
report_bugs_to="\"$(REPORT_BUGS_TO)\"" ;\
. $(srcdir)/development.sh ;\
@@ -2123,7 +2123,7 @@ bfdver.h: $(srcdir)/version.h $(srcdir)/
@@ -2106,7 +2106,7 @@ bfdver.h: $(srcdir)/version.h $(srcdir)/
fi ;\
$(SED) -e "s,@bfd_version@,$$bfd_version," \
-e "s,@bfd_version_string@,$$bfd_version_string," \

View File

@ -38,8 +38,8 @@
Summary: A GNU collection of binary utilities
Name: binutils%{?name_cross}%{?_with_debug:-debug}
Version: 2.37
Release: 25%{?dist}
Version: 2.38
Release: 1%{?dist}
License: GPLv3+
URL: https://sourceware.org/binutils
@ -276,66 +276,14 @@ Patch16: binutils-testsuite-fixes.patch
# Lifetime: Fixed in 2.38 maybe
Patch17: binutils-gold-i386-gnu-property-notes.patch
# Purpose: Ensure that the 0'th entry in DWARF-5 directory tables generated
# by gas contains the current working directory.
# Lifetime: Fixed in 2.38
Patch18: binutils-dwarf-5-dir0.patch
# Purpose: Ensure that the manual pages are generated.
# Lifetime: Fixed in 2.38
Patch19: binutils-missing-man-pages.patch
# Purpose: Close the file descriptor if there is no archive plugin file
# descriptor to avoid running out of file descriptors on thin archives
# with many archive members.
# Lifetime: Fixed in 2.38
Patch20: binutils-bfd-close-fds.patch
# Purpose: Allow the binutils to be configured with any (recent) version of
# autoconf.
# Lifetime: Fixed in 2.38 (maybe ?)
Patch21: binutils-autoconf-version.patch
# Purpose: Set the entry address of shared libraries to 0, so that they can
# be detected by the loader and not run as an executable.
# Lifetime: Permanent.
Patch22: binutils-ld-default-entry-of-0-for-shared.patch
# Purpose: Fix a seg-fault compiling the efivar libraries.
# Lifetime: Fixed in 2.38.
Patch23: binutils-empty-MIND-string.patch
# Purpose: Fix ccache test failure introduced with 2.37
# Lifetime: Fixed in 2.38.
Patch24: binutils-gas-Use-the-directory-name-in-.file-0.patch
# Purpose: Add ability to show unicode characters to display tools
# Lifetime: Fixed in 2.38.
Patch25: binutils.unicode.patch
# Purpose: Add ability to create read-only notes via linker scripts
# Lifetime: Fixed in 2.38.
Patch26: binutils-ld-read-only-script.patch
# Purpose: Add ability to warn about unicode characters in the assembler
# Lifetime: Fixed in 2.38.
Patch27: binutils-gas-multibyte-warnings.patch
# Purpose: Add support for the EFI format to the AArch64 target.
# Lifetime: Fixed in 2.38.
Patch28: binutils-AArch64-EFI.patch
# Purpose: Recognize FDO Packaging Metadata ELF note in readelf.
# Lifetime: Fixed in 2.38.
Patch29: binutils-readelf-recognize-FDO-Packaging-Metadata-ELF-note.patch
# Purpose: Fix a potential illegal memory access parsing a corrupt COFF file.
# Lifetime: Fixed in 2.38.
Patch30: binutils-CVE-2021-45078.patch
# Purpose: Allow the binutils to be configured with any (recent) version of
# autoconf.
# Lifetime: Fixed in 2.39 (maybe ?)
Patch18: binutils-autoconf-version.patch
# Purpose: Stop libtool from inserting useless runpaths into binaries.
# Lifetime: Who knows.
Patch31: gcc12-libtool-no-rpath.patch
Patch19: gcc12-libtool-no-rpath.patch
#----------------------------------------------------------------------------
@ -915,6 +863,7 @@ exit 0
%{_infodir}/gprof.info.*
%{_infodir}/ld.info.*
%{_infodir}/bfd.info.*
%{_infodir}/ctf-spec.info.*
%endif
%endif
@ -946,6 +895,9 @@ exit 0
#----------------------------------------------------------------------------
%changelog
* Wed Feb 09 2022 Nick Clifton <nickc@redhat.comn> - 2.38-1
- Rebase on GNU Binutils 2.38.
* Thu Jan 27 2022 Nick Clifton <nickc@redhat.comn> - 2.37-25
- Borrow a patch from the GCC package to stop libtool from inserting needless runpaths into binaries. (#2030667)

View File

@ -1,2 +1 @@
SHA512 (binutils-2.37.tar.xz) = 5c11aeef6935860a6819ed3a3c93371f052e52b4bdc5033da36037c1544d013b7f12cb8d561ec954fe7469a68f1b66f1a3cd53d5a3af7293635a90d69edd15e7
SHA512 (binutils-2.19.50.0.1-output-format.sed) = 2f8686b0c8af13c98cda056824c2820416f6e2d003f70b78ccf5314525b9ee3684d421dfa83e638a2d42d06ea4d4bdaf5226b64d6ec26f7ff59c44ffb2a23dd2
SHA512 (binutils-2.38.tar.xz) = 8bf0b0d193c9c010e0518ee2b2e5a830898af206510992483b427477ed178396cd210235e85fd7bd99a96fc6d5eedbeccbd48317a10f752b7336ada8b2bb826d