33 lines
963 B
Diff
33 lines
963 B
Diff
diff --git a/configure.in b/configure.in
|
|
index b79aab0..da67ad5 100644
|
|
--- a/configure.in
|
|
+++ b/configure.in
|
|
@@ -3774,6 +3774,10 @@ if test "$use_atomic" = "yes"; then
|
|
AC_MSG_RESULT($arch)
|
|
fi
|
|
|
|
+if test ! "$arch" = "x86_64" -a "$have_xaddq" = "yes"; then
|
|
+ AC_MSG_ERROR([XADDQ present but disabled by Fedora patch!])
|
|
+fi
|
|
+
|
|
if test "$have_atomic" = "yes"; then
|
|
AC_MSG_CHECKING([compiler support for inline assembly code])
|
|
|
|
diff --git a/lib/isc/include/isc/platform.h.in b/lib/isc/include/isc/platform.h.in
|
|
index 2c6e2a5..bf34499 100644
|
|
--- a/lib/isc/include/isc/platform.h.in
|
|
+++ b/lib/isc/include/isc/platform.h.in
|
|
@@ -285,7 +285,11 @@
|
|
* If the "xaddq" operation (64bit xadd) is available on this architecture,
|
|
* ISC_PLATFORM_HAVEXADDQ will be defined.
|
|
*/
|
|
-@ISC_PLATFORM_HAVEXADDQ@
|
|
+#ifdef __x86_64__
|
|
+#define ISC_PLATFORM_HAVEXADDQ 1
|
|
+#else
|
|
+#undef ISC_PLATFORM_HAVEXADDQ
|
|
+#endif
|
|
|
|
/*
|
|
* If the 32-bit "atomic swap" operation is available on this
|