- 9.6.0rc1 release
- patches merged - bind-9.2.0rc3-varrun.patch - bind-95-sdlz-include.patch - bind-96-libxml2.patch - fixed rare use-after-free problem in host utility (#452060) - enabled chase of DNSSEC signature chains in dig
This commit is contained in:
parent
98dc3420a0
commit
f8a48cba51
@ -1,5 +1,5 @@
|
||||
config-4.tar.bz2
|
||||
libbind-man.tar.gz
|
||||
bind-chroot.tar.bz2
|
||||
bind-9.6.0b1.tar.gz
|
||||
bind-9.6.0rc1.tar.gz
|
||||
libbind-9.5.1b2.tar.bz2
|
||||
|
@ -1,15 +0,0 @@
|
||||
diff -up bind-9.5.1b1/bin/named/include/named/globals.h.varrun bind-9.5.1b1/bin/named/include/named/globals.h
|
||||
--- bind-9.5.1b1/bin/named/include/named/globals.h.varrun 2007-09-26 05:22:43.000000000 +0200
|
||||
+++ bind-9.5.1b1/bin/named/include/named/globals.h 2008-07-21 12:13:33.000000000 +0200
|
||||
@@ -107,9 +107,9 @@ EXTERN isc_boolean_t ns_g_foreground I
|
||||
EXTERN isc_boolean_t ns_g_logstderr INIT(ISC_FALSE);
|
||||
|
||||
EXTERN const char * ns_g_defaultpidfile INIT(NS_LOCALSTATEDIR
|
||||
- "/run/named.pid");
|
||||
+ "/run/named/named.pid");
|
||||
EXTERN const char * lwresd_g_defaultpidfile INIT(NS_LOCALSTATEDIR
|
||||
- "/run/lwresd.pid");
|
||||
+ "/run/named/lwresd.pid");
|
||||
EXTERN const char * ns_g_username INIT(NULL);
|
||||
|
||||
EXTERN int ns_g_listen INIT(3);
|
@ -1,7 +1,7 @@
|
||||
--- bind-9.4.0/bin/named/named.8.redhat_doc 2007-01-30 01:23:44.000000000 +0100
|
||||
+++ bind-9.4.0/bin/named/named.8 2007-03-12 15:39:19.000000000 +0100
|
||||
@@ -205,6 +205,63 @@
|
||||
\fI/var/run/named.pid\fR
|
||||
\fI/var/run/named/named.pid\fR
|
||||
.RS 4
|
||||
The default process\-id file.
|
||||
+.PP
|
||||
|
40
bind-95-rh452060.patch
Normal file
40
bind-95-rh452060.patch
Normal file
@ -0,0 +1,40 @@
|
||||
diff -up bind-9.5.0-P2/bin/dig/dighost.c.rh452060 bind-9.5.0-P2/bin/dig/dighost.c
|
||||
--- bind-9.5.0-P2/bin/dig/dighost.c.rh452060 2008-12-01 22:30:01.000000000 +0100
|
||||
+++ bind-9.5.0-P2/bin/dig/dighost.c 2008-12-01 22:30:07.000000000 +0100
|
||||
@@ -1280,6 +1280,12 @@ clear_query(dig_query_t *query) {
|
||||
|
||||
debug("clear_query(%p)", query);
|
||||
|
||||
+ if (query->waiting_senddone) {
|
||||
+ debug("send_done not yet called");
|
||||
+ query->pending_free = ISC_TRUE;
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
lookup = query->lookup;
|
||||
|
||||
if (lookup->current_query == query)
|
||||
@@ -1301,10 +1307,7 @@ clear_query(dig_query_t *query) {
|
||||
isc_mempool_put(commctx, query->recvspace);
|
||||
isc_buffer_invalidate(&query->recvbuf);
|
||||
isc_buffer_invalidate(&query->lengthbuf);
|
||||
- if (query->waiting_senddone)
|
||||
- query->pending_free = ISC_TRUE;
|
||||
- else
|
||||
- isc_mem_free(mctx, query);
|
||||
+ isc_mem_free(mctx, query);
|
||||
}
|
||||
|
||||
/*%
|
||||
@@ -2175,9 +2178,9 @@ send_done(isc_task_t *_task, isc_event_t
|
||||
isc_event_free(&event);
|
||||
|
||||
if (query->pending_free)
|
||||
- isc_mem_free(mctx, query);
|
||||
+ clear_query(query);
|
||||
|
||||
- check_if_done();
|
||||
+ check_next_lookup(l);
|
||||
UNLOCK_LOOKUP;
|
||||
}
|
||||
|
@ -1,32 +0,0 @@
|
||||
diff -up bind-9.5.1b2/lib/dns/include/dns/Makefile.in.includes bind-9.5.1b2/lib/dns/include/dns/Makefile.in
|
||||
--- bind-9.5.1b2/lib/dns/include/dns/Makefile.in.includes 2007-09-12 03:09:08.000000000 +0200
|
||||
+++ bind-9.5.1b2/lib/dns/include/dns/Makefile.in 2008-10-30 13:00:33.000000000 +0100
|
||||
@@ -23,14 +23,14 @@ top_srcdir = @top_srcdir@
|
||||
|
||||
HEADERS = acl.h adb.h byaddr.h cache.h callbacks.h \
|
||||
cert.h compress.h \
|
||||
- db.h dbiterator.h dbtable.h diff.h dispatch.h \
|
||||
+ db.h dbiterator.h dbtable.h diff.h dispatch.h dlz.h \
|
||||
dnssec.h ds.h events.h fixedname.h iptable.h journal.h keyflags.h \
|
||||
keytable.h keyvalues.h lib.h log.h master.h masterdump.h \
|
||||
message.h name.h ncache.h \
|
||||
nsec.h peer.h portlist.h rbt.h rcode.h \
|
||||
rdata.h rdataclass.h rdatalist.h rdataset.h rdatasetiter.h \
|
||||
rdataslab.h rdatatype.h request.h resolver.h result.h \
|
||||
- rootns.h sdb.h secalg.h secproto.h soa.h ssu.h \
|
||||
+ rootns.h sdb.h secalg.h secproto.h sdlz.h soa.h ssu.h \
|
||||
tcpmsg.h time.h tkey.h \
|
||||
tsig.h ttl.h types.h validator.h version.h view.h xfrin.h \
|
||||
zone.h zonekey.h zt.h
|
||||
diff -up bind-9.5.1b2/lib/isc/include/isc/Makefile.in.includes bind-9.5.1b2/lib/isc/include/isc/Makefile.in
|
||||
--- bind-9.5.1b2/lib/isc/include/isc/Makefile.in.includes 2008-10-30 12:59:46.000000000 +0100
|
||||
+++ bind-9.5.1b2/lib/isc/include/isc/Makefile.in 2008-10-30 13:00:03.000000000 +0100
|
||||
@@ -35,7 +35,7 @@ HEADERS = app.h assertions.h base64.h bi
|
||||
lfsr.h lib.h list.h log.h \
|
||||
magic.h md5.h mem.h msgcat.h msgs.h \
|
||||
mutexblock.h netaddr.h ondestroy.h os.h parseint.h \
|
||||
- print.h quota.h random.h ratelimiter.h \
|
||||
+ print.h quota.h radix.h random.h ratelimiter.h \
|
||||
refcount.h region.h resource.h \
|
||||
result.h resultclass.h rwlock.h serial.h sha1.h sha2.h \
|
||||
sockaddr.h socket.h stdio.h stdlib.h string.h \
|
@ -1,12 +0,0 @@
|
||||
diff -up bind-9.6.0b1/configure.in.libxml2 bind-9.6.0b1/configure.in
|
||||
--- bind-9.6.0b1/configure.in.libxml2 2008-11-11 16:04:27.000000000 +0100
|
||||
+++ bind-9.6.0b1/configure.in 2008-11-11 16:04:46.000000000 +0100
|
||||
@@ -1002,7 +1002,7 @@ case "$use_libxml2" in
|
||||
;;
|
||||
auto|yes)
|
||||
case X`(xml2-config --version) 2>/dev/null` in
|
||||
- X2.6.*)
|
||||
+ X2.[[67]].*)
|
||||
libxml2_libs=`xml2-config --libs`
|
||||
libxml2_cflags=`xml2-config --cflags`
|
||||
;;
|
26
bind.spec
26
bind.spec
@ -2,7 +2,7 @@
|
||||
# Red Hat BIND package .spec file
|
||||
#
|
||||
|
||||
%define PREVER b1
|
||||
%define PREVER rc1
|
||||
%define VERSION %{version}%{PREVER}
|
||||
|
||||
%{?!SDB: %define SDB 1}
|
||||
@ -18,7 +18,7 @@ Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) serv
|
||||
Name: bind
|
||||
License: ISC
|
||||
Version: 9.6.0
|
||||
Release: 0.4.1.%{PREVER}%{?dist}
|
||||
Release: 0.5.%{PREVER}%{?dist}
|
||||
Epoch: 32
|
||||
Url: http://www.isc.org/products/BIND/
|
||||
Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -47,7 +47,6 @@ Source31: libbind-9.5.1b2.tar.bz2
|
||||
%endif
|
||||
|
||||
# Common patches
|
||||
Patch0: bind-9.2.0rc3-varrun.patch
|
||||
Patch1: bind-9.3.3rc2-rndckey.patch
|
||||
Patch5: bind-nonexec.patch
|
||||
Patch10: bind-9.5-PIE.patch
|
||||
@ -56,15 +55,14 @@ Patch16: bind-9.3.2-redhat_doc.patch
|
||||
Patch71: bind-9.5-overflow.patch
|
||||
Patch72: bind-9.5-dlz-64bit.patch
|
||||
Patch87: bind-9.5-parallel-build.patch
|
||||
Patch95: bind-95-sdlz-include.patch
|
||||
Patch96: bind-95-rh469440.patch
|
||||
%if %{LIBBIND}
|
||||
Patch97: bind-96-temporary-libbind.patch
|
||||
Patch100:bind-96-libtool2-libbind.patch
|
||||
%endif
|
||||
Patch98: bind-96-libxml2.patch
|
||||
Patch99: bind-96-libtool2.patch
|
||||
Patch101:bind-96-old-api.patch
|
||||
Patch102:bind-95-rh452060.patch
|
||||
|
||||
# SDB patches
|
||||
Patch11: bind-9.3.2b2-sdbsrc.patch
|
||||
@ -182,7 +180,6 @@ sed -i 's/SUBDIRS\(.*\)/SUBDIRS\1 lib\/bind/' Makefile.in
|
||||
%endif
|
||||
|
||||
# Common patches
|
||||
%patch0 -p1 -b .varrun
|
||||
%patch1 -p1 -b .key
|
||||
%patch5 -p1 -b .nonexec
|
||||
%patch10 -p1 -b .PIE
|
||||
@ -231,9 +228,7 @@ cp -fp contrib/sdb/sqlite/zone2sqlite.c bin/sdb_tools
|
||||
%patch85 -p1 -b .libidn3
|
||||
%patch87 -p1 -b .parallel
|
||||
%patch94 -p1 -b .rh461409
|
||||
%patch95 -p1 -b .includes
|
||||
%patch96 -p1 -b .rh469440
|
||||
%patch98 -p1 -b .libxml2
|
||||
|
||||
# XXX due new libtool. Not sure about proper upstream approach yet.
|
||||
mkdir m4
|
||||
@ -243,6 +238,8 @@ mkdir lib/bind/m4
|
||||
%patch100 -p1 -b .libtool2-libbind
|
||||
%endif
|
||||
|
||||
%patch102 -p1 -b .rh452060
|
||||
|
||||
# Sparc and s390 arches need to use -fPIE
|
||||
%ifarch sparcv9 sparc64 s390 s390x
|
||||
for i in bin/named{,-sdb}/{,unix}/Makefile.in; do
|
||||
@ -254,8 +251,8 @@ done
|
||||
|
||||
%build
|
||||
export CFLAGS="$CFLAGS $RPM_OPT_FLAGS"
|
||||
export CPPFLAGS="$CPPFLAGS"
|
||||
export STD_CFLAGS="$CPPFLAGS"
|
||||
export CPPFLAGS="$CPPFLAGS -DDIG_SIGCHASE"
|
||||
export STD_CDEFINES="$CPPFLAGS"
|
||||
|
||||
sed -i -e \
|
||||
's/RELEASEVER=\(.*\)/RELEASEVER=\1-RedHat-%{version}-%{release}/' \
|
||||
@ -600,6 +597,15 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%ghost %{chroot_prefix}/etc/localtime
|
||||
|
||||
%changelog
|
||||
* Wed Dec 03 2008 Adam Tkac <atkac redhat com> 32:9.6.0-0.5.rc1
|
||||
- 9.6.0rc1 release
|
||||
- patches merged
|
||||
- bind-9.2.0rc3-varrun.patch
|
||||
- bind-95-sdlz-include.patch
|
||||
- bind-96-libxml2.patch
|
||||
- fixed rare use-after-free problem in host utility (#452060)
|
||||
- enabled chase of DNSSEC signature chains in dig
|
||||
|
||||
* Mon Dec 01 2008 Adam Tkac <atkac redhat com> 32:9.6.0-0.4.1.b1
|
||||
- improved sample config file (#473586)
|
||||
|
||||
|
2
sources
2
sources
@ -1,5 +1,5 @@
|
||||
de68e10e91e05ab100be879b5bcaa6cb config-4.tar.bz2
|
||||
13fef79f99fcefebb51d84b08805de51 libbind-man.tar.gz
|
||||
4faa4395b955e5f8a3d50f308b9fabc8 bind-chroot.tar.bz2
|
||||
29d868ead2c985f522e2edf6c5152310 bind-9.6.0b1.tar.gz
|
||||
f4afbc1a4695fd1f6a6fb5fefc389f08 bind-9.6.0rc1.tar.gz
|
||||
3d1dad3630ec3510c8ab0ac2217a3317 libbind-9.5.1b2.tar.bz2
|
||||
|
Loading…
Reference in New Issue
Block a user