- update to 9.7.0a2
- merged patches - bind-96-db_unregister.patch - bind96-rh507469.patch
This commit is contained in:
parent
dd9171cb2c
commit
f12e46d9ad
@ -1,2 +1,2 @@
|
||||
bind-9.6.1-P1.tar.gz
|
||||
bind-9.7.0a2.tar.gz
|
||||
config-4.tar.bz2
|
||||
|
@ -241,12 +241,3 @@
|
||||
void
|
||||
addrdata(dns_name_t *name, dns_ttl_t ttl, dns_rdata_t *rdata) {
|
||||
unsigned char namearray[DNS_NAME_MAXTEXT + 1];
|
||||
@@ -165,7 +172,7 @@
|
||||
check_result(result, "isc_mem_create");
|
||||
|
||||
result = isc_entropy_create(mctx, &ectx);
|
||||
- result_check (result, "isc_entropy_create");
|
||||
+ check_result (result, "isc_entropy_create");
|
||||
|
||||
result = isc_hash_create(mctx, ectx, DNS_NAME_MAXWIRE);
|
||||
check_result (result, "isc_hash_create");
|
||||
|
@ -1,7 +1,67 @@
|
||||
diff -up bind-9.5.0b2/bin/named-sdb/main.c.sdb bind-9.5.0b2/bin/named/main-sdb.c
|
||||
--- bind-9.5.0b2/bin/named-sdb/main.c.sdb 2008-02-11 17:32:43.000000000 +0100
|
||||
+++ bind-9.5.0b2/bin/named-sdb/main.c 2008-02-11 17:32:43.000000000 +0100
|
||||
@@ -72,6 +72,9 @@
|
||||
diff -up bind-9.7.0a2/bin/Makefile.in.sdb bind-9.7.0a2/bin/Makefile.in
|
||||
--- bind-9.7.0a2/bin/Makefile.in.sdb 2009-06-10 02:27:21.000000000 +0200
|
||||
+++ bind-9.7.0a2/bin/Makefile.in 2009-09-15 14:43:48.966994484 +0200
|
||||
@@ -19,7 +19,8 @@ srcdir = @srcdir@
|
||||
VPATH = @srcdir@
|
||||
top_srcdir = @top_srcdir@
|
||||
|
||||
-SUBDIRS = named rndc dig dnssec tests tools nsupdate check confgen
|
||||
+SUBDIRS = named named-sdb rndc dig dnssec tests tools nsupdate check \
|
||||
+ confgen sdb_tools
|
||||
TARGETS =
|
||||
|
||||
@BIND9_MAKE_RULES@
|
||||
diff -up bind-9.7.0a2/bin/named/Makefile.in.sdb bind-9.7.0a2/bin/named/Makefile.in
|
||||
--- bind-9.7.0a2/bin/named/Makefile.in.sdb 2009-09-15 14:41:03.827015348 +0200
|
||||
+++ bind-9.7.0a2/bin/named/Makefile.in 2009-09-15 14:41:03.886994927 +0200
|
||||
@@ -45,7 +45,7 @@ CINCLUDES = -I${srcdir}/include -I${srcd
|
||||
${ISCCFG_INCLUDES} ${ISCCC_INCLUDES} ${ISC_INCLUDES} \
|
||||
${DLZDRIVER_INCLUDES} ${DBDRIVER_INCLUDES}
|
||||
|
||||
-CDEFINES = @USE_DLZ@
|
||||
+CDEFINES =
|
||||
|
||||
CWARNINGS =
|
||||
|
||||
@@ -68,7 +68,7 @@ DEPLIBS = ${LWRESDEPLIBS} ${DNSDEPLIBS}
|
||||
|
||||
LIBS = ${LWRESLIBS} ${DNSLIBS} ${BIND9LIBS} \
|
||||
${ISCCFGLIBS} ${ISCCCLIBS} ${ISCLIBS} \
|
||||
- ${DLZDRIVER_LIBS} ${DBDRIVER_LIBS} @LIBS@
|
||||
+ @LIBS@
|
||||
|
||||
SUBDIRS = unix
|
||||
|
||||
@@ -81,8 +81,7 @@ OBJS = builtin.@O@ client.@O@ config.@O
|
||||
tkeyconf.@O@ tsigconf.@O@ update.@O@ xfrout.@O@ \
|
||||
zoneconf.@O@ \
|
||||
lwaddr.@O@ lwresd.@O@ lwdclient.@O@ lwderror.@O@ lwdgabn.@O@ \
|
||||
- lwdgnba.@O@ lwdgrbn.@O@ lwdnoop.@O@ lwsearch.@O@ \
|
||||
- ${DLZDRIVER_OBJS} ${DBDRIVER_OBJS}
|
||||
+ lwdgnba.@O@ lwdgrbn.@O@ lwdnoop.@O@ lwsearch.@O@
|
||||
|
||||
UOBJS = unix/os.@O@
|
||||
|
||||
@@ -93,8 +92,7 @@ SRCS = builtin.c client.c config.c cont
|
||||
tkeyconf.c tsigconf.c update.c xfrout.c \
|
||||
zoneconf.c \
|
||||
lwaddr.c lwresd.c lwdclient.c lwderror.c lwdgabn.c \
|
||||
- lwdgnba.c lwdgrbn.c lwdnoop.c lwsearch.c \
|
||||
- ${DLZDRIVER_SRCS} ${DBDRIVER_SRCS}
|
||||
+ lwdgnba.c lwdgrbn.c lwdnoop.c lwsearch.c
|
||||
|
||||
MANPAGES = named.8 lwresd.8 named.conf.5
|
||||
|
||||
@@ -158,5 +156,3 @@ install:: named@EXEEXT@ lwresd@EXEEXT@ i
|
||||
${INSTALL_DATA} ${srcdir}/named.8 ${DESTDIR}${mandir}/man8
|
||||
${INSTALL_DATA} ${srcdir}/lwresd.8 ${DESTDIR}${mandir}/man8
|
||||
${INSTALL_DATA} ${srcdir}/named.conf.5 ${DESTDIR}${mandir}/man5
|
||||
-
|
||||
-@DLZ_DRIVER_RULES@
|
||||
diff -up bind-9.7.0a2/bin/named-sdb/main.c.sdb bind-9.7.0a2/bin/named-sdb/main.c
|
||||
--- bind-9.7.0a2/bin/named-sdb/main.c.sdb 2009-09-15 14:41:03.846995272 +0200
|
||||
+++ bind-9.7.0a2/bin/named-sdb/main.c 2009-09-15 14:41:03.886994927 +0200
|
||||
@@ -74,6 +74,9 @@
|
||||
* Include header files for database drivers here.
|
||||
*/
|
||||
/* #include "xxdb.h" */
|
||||
@ -11,7 +71,7 @@ diff -up bind-9.5.0b2/bin/named-sdb/main.c.sdb bind-9.5.0b2/bin/named/main-sdb.c
|
||||
|
||||
/*
|
||||
* Include DLZ drivers if appropriate.
|
||||
@@ -641,6 +644,10 @@ setup(void) {
|
||||
@@ -685,6 +688,10 @@ setup(void) {
|
||||
ns_main_earlyfatal("isc_app_start() failed: %s",
|
||||
isc_result_totext(result));
|
||||
|
||||
@ -22,7 +82,7 @@ diff -up bind-9.5.0b2/bin/named-sdb/main.c.sdb bind-9.5.0b2/bin/named/main-sdb.c
|
||||
isc_log_write(ns_g_lctx, NS_LOGCATEGORY_GENERAL, NS_LOGMODULE_MAIN,
|
||||
ISC_LOG_NOTICE, "starting BIND %s%s", ns_g_version,
|
||||
saved_command_line);
|
||||
@@ -702,6 +709,57 @@ setup(void) {
|
||||
@@ -766,6 +773,57 @@ setup(void) {
|
||||
isc_result_totext(result));
|
||||
#endif
|
||||
|
||||
@ -80,7 +140,7 @@ diff -up bind-9.5.0b2/bin/named-sdb/main.c.sdb bind-9.5.0b2/bin/named/main-sdb.c
|
||||
ns_server_create(ns_g_mctx, &ns_g_server);
|
||||
}
|
||||
|
||||
@@ -727,6 +785,10 @@ cleanup(void) {
|
||||
@@ -793,6 +851,10 @@ cleanup(void) {
|
||||
|
||||
dns_name_destroy();
|
||||
|
||||
@ -91,30 +151,10 @@ diff -up bind-9.5.0b2/bin/named-sdb/main.c.sdb bind-9.5.0b2/bin/named/main-sdb.c
|
||||
isc_log_write(ns_g_lctx, NS_LOGCATEGORY_GENERAL, NS_LOGMODULE_MAIN,
|
||||
ISC_LOG_NOTICE, "exiting");
|
||||
ns_log_shutdown();
|
||||
diff -up bind-9.5.0b2/configure.in.sdb bind-9.5.0b2/configure.in
|
||||
--- bind-9.5.0b2/configure.in.sdb 2008-02-14 14:14:55.000000000 +0100
|
||||
+++ bind-9.5.0b2/configure.in 2008-02-14 14:15:34.000000000 +0100
|
||||
@@ -2761,6 +2761,8 @@ AC_CONFIG_FILES([
|
||||
bin/check/Makefile
|
||||
bin/named/Makefile
|
||||
bin/named/unix/Makefile
|
||||
+ bin/named-sdb/Makefile
|
||||
+ bin/named-sdb/unix/Makefile
|
||||
bin/rndc/Makefile
|
||||
bin/rndc/unix/Makefile
|
||||
bin/dig/Makefile
|
||||
@@ -2782,6 +2784,7 @@ AC_CONFIG_FILES([
|
||||
bin/tests/system/tkey/Makefile
|
||||
bin/tests/headerdep_test.sh
|
||||
bin/dnssec/Makefile
|
||||
+ bin/sdb_tools/Makefile
|
||||
doc/Makefile
|
||||
doc/arm/Makefile
|
||||
doc/misc/Makefile
|
||||
diff -up bind-9.5.0b2/bin/named-sdb/Makefile.in.sdb bind-9.5.0b2/bin/named-sdb/Makefile.in
|
||||
--- bind-9.5.0b2/bin/named-sdb/Makefile.in.sdb 2008-02-14 14:16:10.000000000 +0100
|
||||
+++ bind-9.5.0b2/bin/named-sdb/Makefile.in 2008-02-14 14:18:45.000000000 +0100
|
||||
@@ -26,10 +26,10 @@ top_srcdir = @top_srcdir@
|
||||
diff -up bind-9.7.0a2/bin/named-sdb/Makefile.in.sdb bind-9.7.0a2/bin/named-sdb/Makefile.in
|
||||
--- bind-9.7.0a2/bin/named-sdb/Makefile.in.sdb 2009-09-15 14:41:03.846995272 +0200
|
||||
+++ bind-9.7.0a2/bin/named-sdb/Makefile.in 2009-09-15 14:43:19.486994430 +0200
|
||||
@@ -28,10 +28,10 @@ top_srcdir = @top_srcdir@
|
||||
#
|
||||
# Add database drivers here.
|
||||
#
|
||||
@ -128,7 +168,7 @@ diff -up bind-9.5.0b2/bin/named-sdb/Makefile.in.sdb bind-9.5.0b2/bin/named-sdb/M
|
||||
|
||||
DLZ_DRIVER_DIR = ${top_srcdir}/contrib/dlz/drivers
|
||||
|
||||
@@ -70,7 +70,7 @@ LIBS = ${LWRESLIBS} ${DNSLIBS} ${BIND9L
|
||||
@@ -72,7 +72,7 @@ LIBS = ${LWRESLIBS} ${DNSLIBS} ${BIND9L
|
||||
|
||||
SUBDIRS = unix
|
||||
|
||||
@ -137,8 +177,8 @@ diff -up bind-9.5.0b2/bin/named-sdb/Makefile.in.sdb bind-9.5.0b2/bin/named-sdb/M
|
||||
|
||||
OBJS = builtin.@O@ client.@O@ config.@O@ control.@O@ \
|
||||
controlconf.@O@ interfacemgr.@O@ \
|
||||
@@ -118,7 +118,7 @@ config.@O@: config.c
|
||||
-DNS_LOCALSTATEDIR=\"${localstatedir}\" \
|
||||
@@ -125,7 +125,7 @@ config.@O@: config.c bind.keys.h
|
||||
-DNS_SYSCONFDIR=\"${sysconfdir}\" \
|
||||
-c ${srcdir}/config.c
|
||||
|
||||
-named@EXEEXT@: ${OBJS} ${UOBJS} ${DEPLIBS}
|
||||
@ -146,7 +186,7 @@ diff -up bind-9.5.0b2/bin/named-sdb/Makefile.in.sdb bind-9.5.0b2/bin/named-sdb/M
|
||||
${LIBTOOL_MODE_LINK} ${PURIFY} ${CC} ${CFLAGS} ${LDFLAGS} -o $@ \
|
||||
${OBJS} ${UOBJS} ${LIBS}
|
||||
|
||||
@@ -142,14 +142,8 @@ server.o: bind9.xsl.h
|
||||
@@ -149,14 +149,8 @@ statschannel.@O@: bind9.xsl.h
|
||||
|
||||
installdirs:
|
||||
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${sbindir}
|
||||
@ -163,62 +203,23 @@ diff -up bind-9.5.0b2/bin/named-sdb/Makefile.in.sdb bind-9.5.0b2/bin/named-sdb/M
|
||||
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} named-sdb@EXEEXT@ ${DESTDIR}${sbindir}
|
||||
|
||||
@DLZ_DRIVER_RULES@
|
||||
diff -up bind-9.5.0b2/bin/Makefile.in.sdb bind-9.5.0b2/bin/Makefile.in
|
||||
--- bind-9.5.0b2/bin/Makefile.in.sdb 2008-02-14 14:15:42.000000000 +0100
|
||||
+++ bind-9.5.0b2/bin/Makefile.in 2008-02-14 14:15:55.000000000 +0100
|
||||
@@ -19,7 +19,7 @@ srcdir = @srcdir@
|
||||
VPATH = @srcdir@
|
||||
top_srcdir = @top_srcdir@
|
||||
|
||||
-SUBDIRS = named rndc dig dnssec tests nsupdate check
|
||||
+SUBDIRS = named named-sdb rndc dig dnssec tests nsupdate check sdb_tools
|
||||
TARGETS =
|
||||
|
||||
@BIND9_MAKE_RULES@
|
||||
diff -up bind-9.5.0b2/bin/named/Makefile.in.sdb bind-9.5.0b2/bin/named/Makefile.in
|
||||
--- bind-9.5.0b2/bin/named/Makefile.in.sdb 2008-02-14 14:19:39.000000000 +0100
|
||||
+++ bind-9.5.0b2/bin/named/Makefile.in 2008-02-14 14:20:18.000000000 +0100
|
||||
@@ -43,7 +43,7 @@ CINCLUDES = -I${srcdir}/include -I${srcd
|
||||
${ISCCFG_INCLUDES} ${ISCCC_INCLUDES} ${ISC_INCLUDES} \
|
||||
${DLZDRIVER_INCLUDES} ${DBDRIVER_INCLUDES}
|
||||
|
||||
-CDEFINES = @USE_DLZ@
|
||||
+CDEFINES =
|
||||
|
||||
CWARNINGS =
|
||||
|
||||
@@ -66,7 +66,7 @@ DEPLIBS = ${LWRESDEPLIBS} ${DNSDEPLIBS}
|
||||
|
||||
LIBS = ${LWRESLIBS} ${DNSLIBS} ${BIND9LIBS} \
|
||||
${ISCCFGLIBS} ${ISCCCLIBS} ${ISCLIBS} \
|
||||
- ${DLZDRIVER_LIBS} ${DBDRIVER_LIBS} @LIBS@
|
||||
+ @LIBS@
|
||||
|
||||
SUBDIRS = unix
|
||||
|
||||
@@ -79,8 +79,7 @@ OBJS = builtin.@O@ client.@O@ config.@O
|
||||
tkeyconf.@O@ tsigconf.@O@ update.@O@ xfrout.@O@ \
|
||||
zoneconf.@O@ \
|
||||
lwaddr.@O@ lwresd.@O@ lwdclient.@O@ lwderror.@O@ lwdgabn.@O@ \
|
||||
- lwdgnba.@O@ lwdgrbn.@O@ lwdnoop.@O@ lwsearch.@O@ \
|
||||
- ${DLZDRIVER_OBJS} ${DBDRIVER_OBJS}
|
||||
+ lwdgnba.@O@ lwdgrbn.@O@ lwdnoop.@O@ lwsearch.@O@
|
||||
|
||||
UOBJS = unix/os.@O@
|
||||
|
||||
@@ -91,8 +90,7 @@ SRCS = builtin.c client.c config.c cont
|
||||
tkeyconf.c tsigconf.c update.c xfrout.c \
|
||||
zoneconf.c \
|
||||
lwaddr.c lwresd.c lwdclient.c lwderror.c lwdgabn.c \
|
||||
- lwdgnba.c lwdgrbn.c lwdnoop.c lwsearch.c \
|
||||
- ${DLZDRIVER_SRCS} ${DBDRIVER_SRCS}
|
||||
+ lwdgnba.c lwdgrbn.c lwdnoop.c lwsearch.c
|
||||
|
||||
MANPAGES = named.8 lwresd.8 named.conf.5
|
||||
|
||||
@@ -151,5 +149,3 @@ install:: named@EXEEXT@ lwresd@EXEEXT@ i
|
||||
${INSTALL_DATA} ${srcdir}/named.8 ${DESTDIR}${mandir}/man8
|
||||
${INSTALL_DATA} ${srcdir}/lwresd.8 ${DESTDIR}${mandir}/man8
|
||||
${INSTALL_DATA} ${srcdir}/named.conf.5 ${DESTDIR}${mandir}/man5
|
||||
-
|
||||
-@DLZ_DRIVER_RULES@
|
||||
diff -up bind-9.7.0a2/configure.in.sdb bind-9.7.0a2/configure.in
|
||||
--- bind-9.7.0a2/configure.in.sdb 2009-07-15 00:38:37.000000000 +0200
|
||||
+++ bind-9.7.0a2/configure.in 2009-09-15 14:43:00.036994464 +0200
|
||||
@@ -2958,6 +2958,8 @@ AC_CONFIG_FILES([
|
||||
bin/confgen/unix/Makefile
|
||||
bin/named/Makefile
|
||||
bin/named/unix/Makefile
|
||||
+ bin/named-sdb/Makefile
|
||||
+ bin/named-sdb/unix/Makefile
|
||||
bin/rndc/Makefile
|
||||
bin/dig/Makefile
|
||||
bin/nsupdate/Makefile
|
||||
@@ -2979,6 +2981,7 @@ AC_CONFIG_FILES([
|
||||
bin/tests/headerdep_test.sh
|
||||
bin/tools/Makefile
|
||||
bin/dnssec/Makefile
|
||||
+ bin/sdb_tools/Makefile
|
||||
doc/Makefile
|
||||
doc/arm/Makefile
|
||||
doc/misc/Makefile
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff --git a/lib/dns/db.c b/lib/dns/db.c
|
||||
index a4c2864..62f461c 100644
|
||||
--- a/lib/dns/db.c
|
||||
+++ b/lib/dns/db.c
|
||||
@@ -860,6 +860,8 @@ dns_db_unregister(dns_dbimplementation_t **dbimp) {
|
||||
isc_mem_put(mctx, imp, sizeof(dns_dbimplementation_t));
|
||||
isc_mem_detach(&mctx);
|
||||
RWUNLOCK(&implock, isc_rwlocktype_write);
|
||||
+
|
||||
+ *dbimp = NULL;
|
||||
}
|
||||
|
||||
isc_result_t
|
@ -1,5 +1,6 @@
|
||||
--- a/bin/named/main.c
|
||||
+++ b/bin/named/main.c
|
||||
diff -up bind-9.7.0a2/bin/named/main.c.dyndb bind-9.7.0a2/bin/named/main.c
|
||||
--- bind-9.7.0a2/bin/named/main.c.dyndb 2009-05-07 11:33:52.000000000 +0200
|
||||
+++ bind-9.7.0a2/bin/named/main.c 2009-09-15 14:35:49.054494598 +0200
|
||||
@@ -44,6 +44,7 @@
|
||||
#include <isccc/result.h>
|
||||
|
||||
@ -8,7 +9,7 @@
|
||||
#include <dns/name.h>
|
||||
#include <dns/result.h>
|
||||
#include <dns/view.h>
|
||||
@@ -760,6 +761,8 @@ setup(void) {
|
||||
@@ -770,6 +771,8 @@ setup(void) {
|
||||
|
||||
static void
|
||||
cleanup(void) {
|
||||
@ -17,9 +18,10 @@
|
||||
destroy_managers();
|
||||
|
||||
ns_server_destroy(&ns_g_server);
|
||||
--- a/bin/named/server.c
|
||||
+++ b/bin/named/server.c
|
||||
@@ -57,6 +57,7 @@
|
||||
diff -up bind-9.7.0a2/bin/named/server.c.dyndb bind-9.7.0a2/bin/named/server.c
|
||||
--- bind-9.7.0a2/bin/named/server.c.dyndb 2009-08-05 19:35:33.000000000 +0200
|
||||
+++ bind-9.7.0a2/bin/named/server.c 2009-09-15 14:35:49.064494786 +0200
|
||||
@@ -58,6 +58,7 @@
|
||||
#ifdef DLZ
|
||||
#include <dns/dlz.h>
|
||||
#endif
|
||||
@ -27,7 +29,7 @@
|
||||
#include <dns/forward.h>
|
||||
#include <dns/journal.h>
|
||||
#include <dns/keytable.h>
|
||||
@@ -849,6 +850,72 @@ configure_peer(const cfg_obj_t *cpeer, i
|
||||
@@ -1036,6 +1037,72 @@ configure_peer(const cfg_obj_t *cpeer, i
|
||||
}
|
||||
|
||||
static isc_result_t
|
||||
@ -100,7 +102,7 @@
|
||||
disable_algorithms(const cfg_obj_t *disabled, dns_resolver_t *resolver) {
|
||||
isc_result_t result;
|
||||
const cfg_obj_t *algorithms;
|
||||
@@ -1016,6 +1083,7 @@ configure_view(dns_view_t *view, const c
|
||||
@@ -1245,6 +1312,7 @@ configure_view(dns_view_t *view, const c
|
||||
unsigned int dlzargc;
|
||||
char **dlzargv;
|
||||
#endif
|
||||
@ -108,7 +110,7 @@
|
||||
const cfg_obj_t *disabled;
|
||||
const cfg_obj_t *obj;
|
||||
const cfg_listelt_t *element;
|
||||
@@ -1189,6 +1257,37 @@ configure_view(dns_view_t *view, const c
|
||||
@@ -1429,6 +1497,37 @@ configure_view(dns_view_t *view, const c
|
||||
#endif
|
||||
|
||||
/*
|
||||
@ -146,7 +148,7 @@
|
||||
* Obtain configuration parameters that affect the decision of whether
|
||||
* we can reuse/share an existing cache.
|
||||
*/
|
||||
@@ -2942,6 +3041,7 @@ load_configuration(const char *filename,
|
||||
@@ -3581,6 +3680,7 @@ load_configuration(const char *filename,
|
||||
result = isc_task_beginexclusive(server->task);
|
||||
RUNTIME_CHECK(result == ISC_R_SUCCESS);
|
||||
|
||||
@ -154,7 +156,7 @@
|
||||
/*
|
||||
* Parse the global default pseudo-config file.
|
||||
*/
|
||||
@@ -4185,6 +4285,8 @@ loadconfig(ns_server_t *server) {
|
||||
@@ -4927,6 +5027,8 @@ loadconfig(ns_server_t *server) {
|
||||
static isc_result_t
|
||||
reload(ns_server_t *server) {
|
||||
isc_result_t result;
|
||||
@ -163,41 +165,9 @@
|
||||
CHECK(loadconfig(server));
|
||||
|
||||
result = load_zones(server, ISC_FALSE);
|
||||
--- a/lib/dns/Makefile.in
|
||||
+++ b/lib/dns/Makefile.in
|
||||
@@ -57,7 +57,8 @@ DSTOBJS = @DST_EXTRA_OBJS@ \
|
||||
DNSOBJS = acache.@O@ acl.@O@ adb.@O@ byaddr.@O@ \
|
||||
cache.@O@ callbacks.@O@ compress.@O@ \
|
||||
db.@O@ dbiterator.@O@ dbtable.@O@ diff.@O@ dispatch.@O@ \
|
||||
- dlz.@O@ dnssec.@O@ ds.@O@ forward.@O@ iptable.@O@ journal.@O@ \
|
||||
+ dlz.@O@ dnssec.@O@ ds.@O@ dynamic_db.@O@ forward.@O@ \
|
||||
+ iptable.@O@ journal.@O@ \
|
||||
keytable.@O@ lib.@O@ log.@O@ lookup.@O@ \
|
||||
master.@O@ masterdump.@O@ message.@O@ \
|
||||
name.@O@ ncache.@O@ nsec.@O@ nsec3.@O@ order.@O@ peer.@O@ portlist.@O@ \
|
||||
@@ -83,7 +84,7 @@ DSTSRCS = @DST_EXTRA_SRCS@ \
|
||||
DNSSRCS = acache.c acl.c adb.c byaddr.c \
|
||||
cache.c callbacks.c compress.c \
|
||||
db.c dbiterator.c dbtable.c diff.c dispatch.c \
|
||||
- dlz.c dnssec.c ds.c forward.c iptable.c journal.c \
|
||||
+ dlz.c dnssec.c ds.c dynamic_db.c forward.c iptable.c journal.c \
|
||||
keytable.c lib.c log.c lookup.c \
|
||||
master.c masterdump.c message.c \
|
||||
name.c ncache.c nsec.c nsec3.c order.c peer.c portlist.c \
|
||||
@@ -114,6 +115,11 @@ version.@O@: version.c
|
||||
-DLIBAGE=${LIBAGE} \
|
||||
-c ${srcdir}/version.c
|
||||
|
||||
+dynamic_db.@O@: dynamic_db.c
|
||||
+ ${LIBTOOL_MODE_COMPILE} ${CC} ${ALL_CFLAGS} \
|
||||
+ -DDYNDB_LIBDIR=\"@libdir@/bind/\" \
|
||||
+ -c ${srcdir}/dynamic_db.c
|
||||
+
|
||||
libdns.@SA@: ${OBJS}
|
||||
${AR} ${ARFLAGS} $@ ${OBJS}
|
||||
${RANLIB} $@
|
||||
--- /dev/null
|
||||
+++ b/lib/dns/dynamic_db.c
|
||||
diff -up /dev/null bind-9.7.0a2/lib/dns/dynamic_db.c
|
||||
--- /dev/null 2009-09-15 11:43:46.690717252 +0200
|
||||
+++ bind-9.7.0a2/lib/dns/dynamic_db.c 2009-09-15 14:35:49.064494786 +0200
|
||||
@@ -0,0 +1,364 @@
|
||||
+/*
|
||||
+ * Copyright (C) 2008-2009 Red Hat, Inc.
|
||||
@ -563,19 +533,9 @@
|
||||
+
|
||||
+ return args->timermgr;
|
||||
+}
|
||||
--- a/lib/dns/include/dns/Makefile.in
|
||||
+++ b/lib/dns/include/dns/Makefile.in
|
||||
@@ -23,7 +23,7 @@ top_srcdir = @top_srcdir@
|
||||
|
||||
HEADERS = acl.h adb.h byaddr.h cache.h callbacks.h \
|
||||
cert.h compress.h \
|
||||
- db.h dbiterator.h dbtable.h diff.h dispatch.h dlz.h \
|
||||
+ db.h dbiterator.h dbtable.h diff.h dispatch.h dlz.h dynamic_db.h \
|
||||
dnssec.h ds.h events.h fixedname.h iptable.h journal.h keyflags.h \
|
||||
keytable.h keyvalues.h lib.h log.h master.h masterdump.h \
|
||||
message.h name.h ncache.h \
|
||||
--- /dev/null
|
||||
+++ b/lib/dns/include/dns/dynamic_db.h
|
||||
diff -up /dev/null bind-9.7.0a2/lib/dns/include/dns/dynamic_db.h
|
||||
--- /dev/null 2009-09-15 11:43:46.690717252 +0200
|
||||
+++ bind-9.7.0a2/lib/dns/include/dns/dynamic_db.h 2009-09-15 14:35:49.064494786 +0200
|
||||
@@ -0,0 +1,50 @@
|
||||
+/*
|
||||
+ * Copyright (C) 2008-2009 Red Hat, Inc.
|
||||
@ -627,8 +587,9 @@
|
||||
+isc_timermgr_t *dns_dyndb_get_timermgr(dns_dyndb_arguments_t *args);
|
||||
+
|
||||
+#endif
|
||||
--- a/lib/dns/include/dns/log.h
|
||||
+++ b/lib/dns/include/dns/log.h
|
||||
diff -up bind-9.7.0a2/lib/dns/include/dns/log.h.dyndb bind-9.7.0a2/lib/dns/include/dns/log.h
|
||||
--- bind-9.7.0a2/lib/dns/include/dns/log.h.dyndb 2009-01-18 00:47:43.000000000 +0100
|
||||
+++ bind-9.7.0a2/lib/dns/include/dns/log.h 2009-09-15 14:35:49.064494786 +0200
|
||||
@@ -73,6 +73,7 @@ LIBDNS_EXTERNAL_DATA extern isc_logmodul
|
||||
#define DNS_LOGMODULE_HINTS (&dns_modules[24])
|
||||
#define DNS_LOGMODULE_ACACHE (&dns_modules[25])
|
||||
@ -637,8 +598,21 @@
|
||||
|
||||
ISC_LANG_BEGINDECLS
|
||||
|
||||
--- a/lib/dns/include/dns/types.h
|
||||
+++ b/lib/dns/include/dns/types.h
|
||||
diff -up bind-9.7.0a2/lib/dns/include/dns/Makefile.in.dyndb bind-9.7.0a2/lib/dns/include/dns/Makefile.in
|
||||
--- bind-9.7.0a2/lib/dns/include/dns/Makefile.in.dyndb 2008-11-15 00:47:33.000000000 +0100
|
||||
+++ bind-9.7.0a2/lib/dns/include/dns/Makefile.in 2009-09-15 14:35:49.064494786 +0200
|
||||
@@ -23,7 +23,7 @@ top_srcdir = @top_srcdir@
|
||||
|
||||
HEADERS = acl.h adb.h byaddr.h cache.h callbacks.h \
|
||||
cert.h compress.h \
|
||||
- db.h dbiterator.h dbtable.h diff.h dispatch.h dlz.h \
|
||||
+ db.h dbiterator.h dbtable.h diff.h dispatch.h dlz.h dynamic_db.h \
|
||||
dnssec.h ds.h events.h fixedname.h iptable.h journal.h keyflags.h \
|
||||
keytable.h keyvalues.h lib.h log.h master.h masterdump.h \
|
||||
message.h name.h ncache.h \
|
||||
diff -up bind-9.7.0a2/lib/dns/include/dns/types.h.dyndb bind-9.7.0a2/lib/dns/include/dns/types.h
|
||||
--- bind-9.7.0a2/lib/dns/include/dns/types.h.dyndb 2009-07-19 06:18:05.000000000 +0200
|
||||
+++ bind-9.7.0a2/lib/dns/include/dns/types.h 2009-09-15 14:35:49.064494786 +0200
|
||||
@@ -56,6 +56,7 @@ typedef struct dns_dbtable dns_dbtable
|
||||
typedef void dns_dbversion_t;
|
||||
typedef struct dns_dlzimplementation dns_dlzimplementation_t;
|
||||
@ -647,8 +621,9 @@
|
||||
typedef struct dns_sdlzimplementation dns_sdlzimplementation_t;
|
||||
typedef struct dns_decompress dns_decompress_t;
|
||||
typedef struct dns_dispatch dns_dispatch_t;
|
||||
--- a/lib/dns/log.c
|
||||
+++ b/lib/dns/log.c
|
||||
diff -up bind-9.7.0a2/lib/dns/log.c.dyndb bind-9.7.0a2/lib/dns/log.c
|
||||
--- bind-9.7.0a2/lib/dns/log.c.dyndb 2007-06-19 01:47:40.000000000 +0200
|
||||
+++ bind-9.7.0a2/lib/dns/log.c 2009-09-15 14:35:49.064494786 +0200
|
||||
@@ -79,6 +79,7 @@ LIBDNS_EXTERNAL_DATA isc_logmodule_t dns
|
||||
{ "dns/hints", 0 },
|
||||
{ "dns/acache", 0 },
|
||||
@ -657,9 +632,45 @@
|
||||
{ NULL, 0 }
|
||||
};
|
||||
|
||||
--- a/lib/isccfg/namedconf.c
|
||||
+++ b/lib/isccfg/namedconf.c
|
||||
@@ -78,6 +78,7 @@ static cfg_type_t cfg_type_controls;
|
||||
diff -up bind-9.7.0a2/lib/dns/Makefile.in.dyndb bind-9.7.0a2/lib/dns/Makefile.in
|
||||
--- bind-9.7.0a2/lib/dns/Makefile.in.dyndb 2009-09-15 14:35:49.044494756 +0200
|
||||
+++ bind-9.7.0a2/lib/dns/Makefile.in 2009-09-15 14:36:51.104494645 +0200
|
||||
@@ -57,8 +57,8 @@ DSTOBJS = @DST_EXTRA_OBJS@ \
|
||||
DNSOBJS = acache.@O@ acl.@O@ adb.@O@ byaddr.@O@ \
|
||||
cache.@O@ callbacks.@O@ compress.@O@ \
|
||||
db.@O@ dbiterator.@O@ dbtable.@O@ diff.@O@ dispatch.@O@ \
|
||||
- dlz.@O@ dnssec.@O@ ds.@O@ forward.@O@ iptable.@O@ journal.@O@ \
|
||||
- keydata.@O@ keytable.@O@ lib.@O@ log.@O@ lookup.@O@ \
|
||||
+ dlz.@O@ dnssec.@O@ ds.@O@ dynamic_db.@O@ forward.@O@ iptable.@O@ \
|
||||
+ journal.@O@ keydata.@O@ keytable.@O@ lib.@O@ log.@O@ lookup.@O@ \
|
||||
master.@O@ masterdump.@O@ message.@O@ \
|
||||
name.@O@ ncache.@O@ nsec.@O@ nsec3.@O@ order.@O@ peer.@O@ \
|
||||
portlist.@O@ \
|
||||
@@ -84,7 +84,7 @@ DSTSRCS = @DST_EXTRA_SRCS@ \
|
||||
DNSSRCS = acache.c acl.c adb.c byaddr.c \
|
||||
cache.c callbacks.c compress.c \
|
||||
db.c dbiterator.c dbtable.c diff.c dispatch.c \
|
||||
- dlz.c dnssec.c ds.c forward.c iptable.c journal.c \
|
||||
+ dlz.c dnssec.c ds.c dynamic_db.c forward.c iptable.c journal.c \
|
||||
keydata.c keytable.c lib.c log.c lookup.c \
|
||||
master.c masterdump.c message.c \
|
||||
name.c ncache.c nsec.c nsec3.c order.c peer.c portlist.c \
|
||||
@@ -115,6 +115,11 @@ version.@O@: version.c
|
||||
-DLIBAGE=${LIBAGE} \
|
||||
-c ${srcdir}/version.c
|
||||
|
||||
+dynamic_db.@O@: dynamic_db.c
|
||||
+ ${LIBTOOL_MODE_COMPILE} ${CC} ${ALL_CFLAGS} \
|
||||
+ -DDYNDB_LIBDIR=\"@libdir@/bind/\" \
|
||||
+ -c ${srcdir}/dynamic_db.c
|
||||
+
|
||||
libdns.@SA@: ${OBJS}
|
||||
${AR} ${ARFLAGS} $@ ${OBJS}
|
||||
${RANLIB} $@
|
||||
diff -up bind-9.7.0a2/lib/isccfg/namedconf.c.dyndb bind-9.7.0a2/lib/isccfg/namedconf.c
|
||||
--- bind-9.7.0a2/lib/isccfg/namedconf.c.dyndb 2009-07-29 19:52:00.000000000 +0200
|
||||
+++ bind-9.7.0a2/lib/isccfg/namedconf.c 2009-09-15 14:37:13.096994453 +0200
|
||||
@@ -87,6 +87,7 @@ static cfg_type_t cfg_type_controls;
|
||||
static cfg_type_t cfg_type_controls_sockaddr;
|
||||
static cfg_type_t cfg_type_destinationlist;
|
||||
static cfg_type_t cfg_type_dialuptype;
|
||||
@ -667,15 +678,15 @@
|
||||
static cfg_type_t cfg_type_ixfrdifftype;
|
||||
static cfg_type_t cfg_type_key;
|
||||
static cfg_type_t cfg_type_logfile;
|
||||
@@ -651,6 +652,7 @@ namedconf_or_view_clauses[] = {
|
||||
@@ -760,6 +761,7 @@ namedconf_or_view_clauses[] = {
|
||||
{ "zone", &cfg_type_zone, CFG_CLAUSEFLAG_MULTI },
|
||||
/* only 1 DLZ per view allowed */
|
||||
{ "dlz", &cfg_type_dynamically_loadable_zones, 0 },
|
||||
+ { "dynamic-db", &cfg_type_dynamic_db, CFG_CLAUSEFLAG_MULTI },
|
||||
{ "server", &cfg_type_server, CFG_CLAUSEFLAG_MULTI },
|
||||
{ "trusted-keys", &cfg_type_trustedkeys, CFG_CLAUSEFLAG_MULTI },
|
||||
{ NULL, NULL, 0 }
|
||||
@@ -1365,6 +1367,40 @@ static cfg_type_t cfg_type_dialuptype =
|
||||
{ "trusted-keys", &cfg_type_dnsseckeys, CFG_CLAUSEFLAG_MULTI },
|
||||
{ "managed-keys", &cfg_type_dnsseckeys, CFG_CLAUSEFLAG_MULTI },
|
||||
@@ -1531,6 +1533,40 @@ static cfg_type_t cfg_type_dialuptype =
|
||||
&cfg_rep_string, dialup_enums
|
||||
};
|
||||
|
||||
|
34
bind.spec
34
bind.spec
@ -2,11 +2,11 @@
|
||||
# Red Hat BIND package .spec file
|
||||
#
|
||||
|
||||
%define PATCHVER P1
|
||||
#%define PATCHVER P1
|
||||
#%define PREVER rc1
|
||||
#%define VERSION %{version}
|
||||
#%define VERSION %{version}-%{PATCHVER}
|
||||
%define VERSION %{version}-%{PATCHVER}
|
||||
%define PREVER a2
|
||||
%define VERSION %{version}%{PREVER}
|
||||
|
||||
%{?!SDB: %define SDB 1}
|
||||
%{?!test: %define test 0}
|
||||
@ -19,8 +19,8 @@
|
||||
Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) server
|
||||
Name: bind
|
||||
License: ISC
|
||||
Version: 9.6.1
|
||||
Release: 9.%{PATCHVER}%{?dist}
|
||||
Version: 9.7.0
|
||||
Release: 0.1.%{PREVER}%{?dist}
|
||||
Epoch: 32
|
||||
Url: http://www.isc.org/products/BIND/
|
||||
Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -50,7 +50,6 @@ Patch99: bind-96-libtool2.patch
|
||||
Patch101:bind-96-old-api.patch
|
||||
Patch102:bind-95-rh452060.patch
|
||||
Patch106:bind93-rh490837.patch
|
||||
Patch107:bind96-rh507469.patch
|
||||
|
||||
# SDB patches
|
||||
Patch11: bind-9.3.2b2-sdbsrc.patch
|
||||
@ -60,7 +59,6 @@ Patch62: bind-9.5-sdb-sqlite-bld.patch
|
||||
# needs inpection
|
||||
Patch17: bind-9.3.2b1-fix_sdb_ldap.patch
|
||||
Patch104: bind-96-dyndb.patch
|
||||
Patch105: bind-96-db_unregister.patch
|
||||
|
||||
# IDN paches
|
||||
Patch73: bind-9.5-libidn.patch
|
||||
@ -167,7 +165,6 @@ Based on the code from Jan "Yenya" Kasprzak <kas@fi.muni.cz>
|
||||
%patch10 -p1 -b .PIE
|
||||
%patch16 -p1 -b .redhat_doc
|
||||
%patch104 -p1 -b .dyndb
|
||||
%patch105 -p1 -b .db_unregister
|
||||
%if %{SDB}
|
||||
%patch101 -p1 -b .old-api
|
||||
mkdir bin/named-sdb
|
||||
@ -215,7 +212,6 @@ mkdir m4
|
||||
|
||||
%patch102 -p1 -b .rh452060
|
||||
%patch106 -p0 -b .rh490837
|
||||
%patch107 -p1 -b .rh507469
|
||||
|
||||
# Sparc and s390 arches need to use -fPIE
|
||||
%ifarch sparcv9 sparc64 s390 s390x
|
||||
@ -315,6 +311,10 @@ touch ${RPM_BUILD_ROOT}/%{chroot_prefix}/etc/named.conf
|
||||
#end chroot
|
||||
|
||||
make DESTDIR=${RPM_BUILD_ROOT} install
|
||||
|
||||
# Remove unwanted files
|
||||
rm -f ${RPM_BUILD_ROOT}/etc/bind.keys
|
||||
|
||||
install -m 755 contrib/named-bootconf/named-bootconf.sh ${RPM_BUILD_ROOT}%{_sbindir}/named-bootconf
|
||||
install -m 755 %SOURCE2 ${RPM_BUILD_ROOT}/etc/rc.d/init.d/named
|
||||
install -m 644 %SOURCE3 ${RPM_BUILD_ROOT}/etc/logrotate.d/named
|
||||
@ -493,6 +493,11 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_libdir}/bind
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/named
|
||||
%{_sysconfdir}/rc.d/init.d/named
|
||||
%{_sbindir}/arpaname
|
||||
%{_sbindir}/ddns-confgen
|
||||
%{_sbindir}/genrandom
|
||||
%{_sbindir}/journalprint
|
||||
%{_sbindir}/nsec3hash
|
||||
%{_sbindir}/dnssec*
|
||||
%{_sbindir}/named-check*
|
||||
%{_sbindir}/lwresd
|
||||
@ -500,6 +505,7 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_sbindir}/named-bootconf
|
||||
%{_sbindir}/rndc*
|
||||
%{_sbindir}/named-compilezone
|
||||
%{_mandir}/man1/arpaname.1*
|
||||
%{_mandir}/man5/named.conf.5*
|
||||
%{_mandir}/man5/rndc.conf.5*
|
||||
%{_mandir}/man8/rndc.8*
|
||||
@ -510,6 +516,10 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_mandir}/man8/named-checkzone.8*
|
||||
%{_mandir}/man8/named-compilezone.8*
|
||||
%{_mandir}/man8/rndc-confgen.8*
|
||||
%{_mandir}/man8/ddns-confgen.8*
|
||||
%{_mandir}/man8/genrandom.8*
|
||||
%{_mandir}/man8/journalprint.8*
|
||||
%{_mandir}/man8/nsec3hash.8*
|
||||
%doc CHANGES COPYRIGHT README named.conf.default
|
||||
%doc doc/arm doc/misc doc/draft doc/rfc
|
||||
%doc sample/
|
||||
@ -582,6 +592,12 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%ghost %{chroot_prefix}/etc/localtime
|
||||
|
||||
%changelog
|
||||
* Tue Sep 15 2009 Adam Tkac <atkac redhat com> 32:9.7.0-0.1.a2
|
||||
- update to 9.7.0a2
|
||||
- merged patches
|
||||
- bind-96-db_unregister.patch
|
||||
- bind96-rh507469.patch
|
||||
|
||||
* Tue Sep 01 2009 Adam Tkac <atkac redhat com> 32:9.6.1-9.P1
|
||||
- next attempt to fix the postun trigger (#520385)
|
||||
- remove obsolete bind-9.3.1rc1-fix_libbind_includedir.patch
|
||||
|
@ -1,14 +0,0 @@
|
||||
diff -up bind-9.6.1/bin/dig/dighost.c.rh507469 bind-9.6.1/bin/dig/dighost.c
|
||||
--- bind-9.6.1/bin/dig/dighost.c.rh507469 2009-06-23 15:52:08.974779538 +0200
|
||||
+++ bind-9.6.1/bin/dig/dighost.c 2009-06-23 15:54:19.934977907 +0200
|
||||
@@ -1064,7 +1064,9 @@ setup_system(void) {
|
||||
debug("ndots is %d.", ndots);
|
||||
}
|
||||
|
||||
- copy_server_list(lwconf, &server_list);
|
||||
+ /* If user doesn't specify server use nameservers from resolv.conf */
|
||||
+ if (ISC_LIST_EMPTY(server_list))
|
||||
+ copy_server_list(lwconf, &server_list);
|
||||
|
||||
/* If we don't find a nameserver fall back to localhost */
|
||||
if (ISC_LIST_EMPTY(server_list)) {
|
Loading…
Reference in New Issue
Block a user