Minor bugfixes
- document dig exit codes in manpage - ignore empty "search" options in resolv.conf Signed-off-by: Adam Tkac <atkac@redhat.com>
This commit is contained in:
parent
15281fbc42
commit
cd3db89ffb
19
bind.spec
19
bind.spec
@ -26,7 +26,7 @@ Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) serv
|
|||||||
Name: bind
|
Name: bind
|
||||||
License: ISC
|
License: ISC
|
||||||
Version: 9.9.2
|
Version: 9.9.2
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Epoch: 32
|
Epoch: 32
|
||||||
Url: http://www.isc.org/products/BIND/
|
Url: http://www.isc.org/products/BIND/
|
||||||
Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -77,6 +77,8 @@ Patch127:bind99-forward.patch
|
|||||||
Patch130:bind-9.9.1-P2-dlz-libdb4.patch
|
Patch130:bind-9.9.1-P2-dlz-libdb4.patch
|
||||||
Patch131:bind-9.9.1-P2-multlib-conflict.patch
|
Patch131:bind-9.9.1-P2-multlib-conflict.patch
|
||||||
Patch132:bind99-stat.patch
|
Patch132:bind99-stat.patch
|
||||||
|
Patch133:bind99-rh640538.patch
|
||||||
|
Patch134:bind97-rh669163.patch
|
||||||
|
|
||||||
# SDB patches
|
# SDB patches
|
||||||
Patch11: bind-9.3.2b2-sdbsrc.patch
|
Patch11: bind-9.3.2b2-sdbsrc.patch
|
||||||
@ -120,7 +122,8 @@ BuildRequires: net-tools
|
|||||||
%if %{GSSTSIG}
|
%if %{GSSTSIG}
|
||||||
BuildRequires: krb5-devel
|
BuildRequires: krb5-devel
|
||||||
%endif
|
%endif
|
||||||
|
# Needed to regenerate dig.1 manpage
|
||||||
|
BuildRequires: docbook-style-xsl, libxslt
|
||||||
|
|
||||||
%description
|
%description
|
||||||
BIND (Berkeley Internet Name Domain) is an implementation of the DNS
|
BIND (Berkeley Internet Name Domain) is an implementation of the DNS
|
||||||
@ -308,6 +311,8 @@ cp -fp contrib/sdb/sqlite/zone2sqlite.c bin/sdb_tools
|
|||||||
%patch62 -p1 -b .sdb-sqlite-bld
|
%patch62 -p1 -b .sdb-sqlite-bld
|
||||||
%endif
|
%endif
|
||||||
%patch132 -p1 -b .stat
|
%patch132 -p1 -b .stat
|
||||||
|
%patch133 -p1 -b .rh640538
|
||||||
|
%patch134 -p1 -b .rh669163
|
||||||
|
|
||||||
# Sparc and s390 arches need to use -fPIE
|
# Sparc and s390 arches need to use -fPIE
|
||||||
%ifarch sparcv9 sparc64 s390 s390x
|
%ifarch sparcv9 sparc64 s390 s390x
|
||||||
@ -356,9 +361,15 @@ libtoolize -c -f; aclocal -I m4 --force; autoconf -f
|
|||||||
--disable-isc-spnego \
|
--disable-isc-spnego \
|
||||||
%endif
|
%endif
|
||||||
--enable-fixed-rrset \
|
--enable-fixed-rrset \
|
||||||
|
--with-docbook-xsl=%{_datadir}/sgml/docbook/xsl-stylesheets \
|
||||||
;
|
;
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
# Regenerate dig.1 manpage
|
||||||
|
pushd bin/dig
|
||||||
|
make man
|
||||||
|
popd
|
||||||
|
|
||||||
%if %{test}
|
%if %{test}
|
||||||
%check
|
%check
|
||||||
if [ "`whoami`" = 'root' ]; then
|
if [ "`whoami`" = 'root' ]; then
|
||||||
@ -758,6 +769,10 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 12 2012 Adam Tkac <atkac redhat com> 32:9.9.2-4
|
||||||
|
- document dig exit codes in manpage
|
||||||
|
- ignore empty "search" options in resolv.conf
|
||||||
|
|
||||||
* Mon Nov 12 2012 Adam Tkac <atkac redhat com> 32:9.9.2-3
|
* Mon Nov 12 2012 Adam Tkac <atkac redhat com> 32:9.9.2-3
|
||||||
- drop PKCS11 support on rhel
|
- drop PKCS11 support on rhel
|
||||||
|
|
||||||
|
14
bind97-rh669163.patch
Normal file
14
bind97-rh669163.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -up bind-9.7.2-P3/lib/lwres/lwconfig.c.rh669163 bind-9.7.2-P3/lib/lwres/lwconfig.c
|
||||||
|
--- bind-9.7.2-P3/lib/lwres/lwconfig.c.rh669163 2011-01-28 14:48:38.934472578 +0100
|
||||||
|
+++ bind-9.7.2-P3/lib/lwres/lwconfig.c 2011-01-28 14:49:50.421326035 +0100
|
||||||
|
@@ -612,6 +612,10 @@ lwres_conf_parse(lwres_context_t *ctx, c
|
||||||
|
break;
|
||||||
|
}
|
||||||
|
|
||||||
|
+ /* Ignore options with no parameters */
|
||||||
|
+ if (stopchar == '\n')
|
||||||
|
+ continue;
|
||||||
|
+
|
||||||
|
if (strlen(word) == 0U)
|
||||||
|
rval = LWRES_R_SUCCESS;
|
||||||
|
else if (strcmp(word, "nameserver") == 0)
|
44
bind99-rh640538.patch
Normal file
44
bind99-rh640538.patch
Normal file
@ -0,0 +1,44 @@
|
|||||||
|
diff -up bind-9.9.2/bin/dig/dig.docbook.rh640538 bind-9.9.2/bin/dig/dig.docbook
|
||||||
|
--- bind-9.9.2/bin/dig/dig.docbook.rh640538 2012-09-27 02:35:19.000000000 +0200
|
||||||
|
+++ bind-9.9.2/bin/dig/dig.docbook 2012-11-12 14:47:17.385334972 +0100
|
||||||
|
@@ -961,6 +961,40 @@ dig +qr www.isc.org any -x 127.0.0.1 isc
|
||||||
|
</refsect1>
|
||||||
|
|
||||||
|
<refsect1>
|
||||||
|
+ <title>RETURN CODES</title>
|
||||||
|
+ <para>
|
||||||
|
+ <command>Dig</command> return codes are:
|
||||||
|
+ <variablelist>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>0: Everything went well, including things like NXDOMAIN</para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>1: Usage error</para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>8: Couldn't open batch file</para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>9: No reply from server</para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>10: Internal error</para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ </variablelist>
|
||||||
|
+ </para>
|
||||||
|
+ </refsect1>
|
||||||
|
+
|
||||||
|
+ <refsect1>
|
||||||
|
<title>FILES</title>
|
||||||
|
<para><filename>/etc/resolv.conf</filename>
|
||||||
|
</para>
|
Loading…
Reference in New Issue
Block a user