Update to 9.9.6
- drop merged patches and rebase some of existing patches Signed-off-by: Tomas Hozza <thozza@redhat.com>
This commit is contained in:
parent
c095b972f6
commit
b746061914
1
.gitignore
vendored
1
.gitignore
vendored
@ -44,3 +44,4 @@ bind-9.7.2b1.tar.gz
|
||||
/bind-9.9.5rc2.tar.gz
|
||||
/bind-9.9.5.tar.gz
|
||||
/bind-9.9.5-P1.tar.gz
|
||||
/bind-9.9.6.tar.gz
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up bind-9.9.0/contrib/dlz/config.dlz.in.64bit bind-9.9.0/contrib/dlz/config.dlz.in
|
||||
--- bind-9.9.0/contrib/dlz/config.dlz.in.64bit 2011-11-05 06:14:28.000000000 +0100
|
||||
+++ bind-9.9.0/contrib/dlz/config.dlz.in 2012-04-24 14:52:08.398511143 +0200
|
||||
diff -up bind-9.10.1b1/contrib/dlz/config.dlz.in.64bit bind-9.10.1b1/contrib/dlz/config.dlz.in
|
||||
--- bind-9.10.1b1/contrib/dlz/config.dlz.in.64bit 2014-06-23 06:47:35.000000000 +0200
|
||||
+++ bind-9.10.1b1/contrib/dlz/config.dlz.in 2014-07-29 15:29:06.956527598 +0200
|
||||
@@ -17,6 +17,13 @@
|
||||
#
|
||||
dlzdir='${DLZ_DRIVER_DIR}'
|
||||
@ -15,7 +15,7 @@ diff -up bind-9.9.0/contrib/dlz/config.dlz.in.64bit bind-9.9.0/contrib/dlz/confi
|
||||
#
|
||||
# Private autoconf macro to simplify configuring drivers:
|
||||
#
|
||||
@@ -135,9 +142,9 @@ then
|
||||
@@ -140,9 +147,9 @@ then
|
||||
then
|
||||
use_dlz_mysql=$d
|
||||
mysql_include=$d/include/mysql
|
||||
@ -27,21 +27,19 @@ diff -up bind-9.9.0/contrib/dlz/config.dlz.in.64bit bind-9.9.0/contrib/dlz/confi
|
||||
else
|
||||
mysql_lib=$d/lib
|
||||
fi
|
||||
@@ -274,11 +281,11 @@ case "$use_dlz_bdb" in
|
||||
bdb_libnames="db48 db-4.8 db47 db-4.7 db46 db-4.6 db45 db-4.5 db44 db-4.4 db43 db-4.3 db42 db-4.2 db41 db-4.1 db"
|
||||
for d in $bdb_libnames
|
||||
do
|
||||
- if test -f "$dd/lib/lib${d}.so"
|
||||
+ if test -f "$dd/${target_lib}/lib${d}.so"
|
||||
then
|
||||
if test "$dd" != "/usr"
|
||||
@@ -288,9 +295,9 @@ case "$use_dlz_bdb" in
|
||||
then
|
||||
- dlz_bdb_libs="-L${dd}/lib "
|
||||
+ dlz_bdb_libs="-L${dd}/${target_lib} "
|
||||
else
|
||||
dlz_bdb_libs=""
|
||||
break
|
||||
fi
|
||||
@@ -383,7 +390,7 @@ case "$use_dlz_ldap" in
|
||||
- elif test -f "$dd/lib/lib${d}.so"
|
||||
+ elif test -f "$dd/${target_lib}/lib${d}.so"
|
||||
then
|
||||
- dlz_bdb_libs="-L${dd}/lib -l${d}"
|
||||
+ dlz_bdb_libs="-L${dd}/${target_lib} -l${d}"
|
||||
break
|
||||
fi
|
||||
done
|
||||
@@ -390,7 +397,7 @@ case "$use_dlz_ldap" in
|
||||
*)
|
||||
DLZ_ADD_DRIVER(LDAP, dlz_ldap_driver,
|
||||
[-I$use_dlz_ldap/include],
|
||||
@ -50,21 +48,17 @@ diff -up bind-9.9.0/contrib/dlz/config.dlz.in.64bit bind-9.9.0/contrib/dlz/confi
|
||||
|
||||
AC_MSG_RESULT(
|
||||
[using LDAP from $use_dlz_ldap/lib and $use_dlz_ldap/include])
|
||||
@@ -407,7 +414,7 @@ then
|
||||
odbcdirs="/usr /usr/local /usr/pkg"
|
||||
for d in $odbcdirs
|
||||
do
|
||||
- if test -f $d/include/sql.h -a -f $d/lib/libodbc.a
|
||||
+ if test -f $d/include/sql.h -a -f $d/${target_lib}/libodbc.a
|
||||
then
|
||||
use_dlz_odbc=$d
|
||||
break
|
||||
@@ -427,7 +434,7 @@ case "$use_dlz_odbc" in
|
||||
*)
|
||||
DLZ_ADD_DRIVER(ODBC, dlz_odbc_driver,
|
||||
[-I$use_dlz_odbc/include],
|
||||
- [-L$use_dlz_odbc/lib -lodbc])
|
||||
+ [-L$use_dlz_odbc/${target_lib} -lodbc])
|
||||
|
||||
AC_MSG_RESULT([using ODBC from $use_dlz_odbc])
|
||||
;;
|
||||
@@ -425,11 +432,11 @@ then
|
||||
odbcdirs="/usr /usr/local /usr/pkg"
|
||||
for d in $odbcdirs
|
||||
do
|
||||
- if test -f $d/include/sql.h -a -f $d/lib/libodbc.a
|
||||
+ if test -f $d/include/sql.h -a -f $d/${target_lib}/libodbc.a
|
||||
then
|
||||
use_dlz_odbc=$d
|
||||
dlz_odbc_include="-I$use_dlz_odbc/include"
|
||||
- dlz_odbc_libs="-L$use_dlz_odbc/lib -lodbc"
|
||||
+ dlz_odbc_libs="-L$use_dlz_odbc/${target_lib} -lodbc"
|
||||
break
|
||||
fi
|
||||
done
|
||||
|
@ -1,26 +1,30 @@
|
||||
diff -up bind-9.9.4/contrib/dlz/config.dlz.in.libdb bind-9.9.4/contrib/dlz/config.dlz.in
|
||||
--- bind-9.9.4/contrib/dlz/config.dlz.in.libdb 2014-01-06 13:24:24.669256364 +0100
|
||||
+++ bind-9.9.4/contrib/dlz/config.dlz.in 2014-01-06 13:26:29.861420493 +0100
|
||||
@@ -257,7 +257,7 @@ case "$use_dlz_bdb" in
|
||||
diff -up bind-9.10.1b1/contrib/dlz/config.dlz.in.libdb bind-9.10.1b1/contrib/dlz/config.dlz.in
|
||||
--- bind-9.10.1b1/contrib/dlz/config.dlz.in.libdb 2014-08-04 12:33:09.320735111 +0200
|
||||
+++ bind-9.10.1b1/contrib/dlz/config.dlz.in 2014-08-04 12:41:46.888241910 +0200
|
||||
@@ -263,7 +263,7 @@ case "$use_dlz_bdb" in
|
||||
# Check other locations for includes.
|
||||
# Order is important (sigh).
|
||||
|
||||
- bdb_incdirs="/ /db48/ /db47/ /db46/ /db45/ /db44/ /db43/ /db42/ /db41/ /db4/ /db/"
|
||||
+ bdb_incdirs="/ /db48/ /db47/ /db46/ /db45/ /db44/ /db43/ /db42/ /db41/ /db4/ /libdb/ /db/"
|
||||
for d in $bdb_incdirs
|
||||
- bdb_incdirs="/db53 /db51 /db48 /db47 /db46 /db45 /db44 /db43 /db42 /db41 /db4 /db"
|
||||
+ bdb_incdirs="/db53 /db51 /db48 /db47 /db46 /db45 /db44 /db43 /db42 /db41 /db4 /libdb /db"
|
||||
# include a blank element first
|
||||
for d in "" $bdb_incdirs
|
||||
do
|
||||
if test -f "$dd/include${d}db.h"
|
||||
@@ -283,13 +283,7 @@ case "$use_dlz_bdb" in
|
||||
@@ -288,16 +288,9 @@ case "$use_dlz_bdb" in
|
||||
bdb_libnames="db53 db-5.3 db51 db-5.1 db48 db-4.8 db47 db-4.7 db46 db-4.6 db45 db-4.5 db44 db-4.4 db43 db-4.3 db42 db-4.2 db41 db-4.1 db"
|
||||
for d in $bdb_libnames
|
||||
do
|
||||
if test -f "$dd/${target_lib}/lib${d}.so"
|
||||
- if test "$dd" = "/usr"
|
||||
+ if test -f "$dd/${target_lib}/lib${d}.so"
|
||||
then
|
||||
- if test "$dd" != "/usr"
|
||||
- AC_CHECK_LIB($d, db_create, dlz_bdb_libs="-l${d}")
|
||||
- if test $dlz_bdb_libs != "yes"
|
||||
- then
|
||||
- dlz_bdb_libs="-L${dd}/${target_lib} "
|
||||
- else
|
||||
- dlz_bdb_libs=""
|
||||
- break
|
||||
- fi
|
||||
- dlz_bdb_libs="${dlz_bdb_libs}-l${d}"
|
||||
- elif test -f "$dd/${target_lib}/lib${d}.so"
|
||||
- then
|
||||
- dlz_bdb_libs="-L${dd}/${target_lib} -l${d}"
|
||||
+ dlz_bdb_libs="-L${dd}/${target_lib}/libdb -l${d}"
|
||||
break
|
||||
fi
|
||||
|
@ -1,7 +1,8 @@
|
||||
diff -up bind-9.9.3rc2/config.h.in.multlib-conflict bind-9.9.3rc2/config.h.in
|
||||
--- bind-9.9.3rc2/config.h.in.multlib-conflict 2013-04-30 08:38:46.000000000 +0200
|
||||
+++ bind-9.9.3rc2/config.h.in 2013-05-13 12:10:22.514870894 +0200
|
||||
@@ -416,7 +416,7 @@ int sigwait(const unsigned int *set, int
|
||||
diff --git a/config.h.in b/config.h.in
|
||||
index 71048b6..7382171 100644
|
||||
--- a/config.h.in
|
||||
+++ b/config.h.in
|
||||
@@ -440,7 +440,7 @@ int sigwait(const unsigned int *set, int *sig);
|
||||
#undef PORT_NONBLOCK
|
||||
|
||||
/* The size of `void *', as computed by sizeof. */
|
||||
@ -10,24 +11,26 @@ diff -up bind-9.9.3rc2/config.h.in.multlib-conflict bind-9.9.3rc2/config.h.in
|
||||
|
||||
/* Define to 1 if you have the ANSI C header files. */
|
||||
#undef STDC_HEADERS
|
||||
diff -up bind-9.9.3rc2/configure.in.multlib-conflict bind-9.9.3rc2/configure.in
|
||||
--- bind-9.9.3rc2/configure.in.multlib-conflict 2013-05-13 12:10:22.481870901 +0200
|
||||
+++ bind-9.9.3rc2/configure.in 2013-05-13 12:10:22.515870894 +0200
|
||||
@@ -2251,7 +2251,9 @@ int getnameinfo(const struct sockaddr *,
|
||||
size_t, char *, size_t, int);],
|
||||
diff --git a/configure.in b/configure.in
|
||||
index 1a34bb6..1c29465 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -2370,7 +2370,9 @@ int getnameinfo(const struct sockaddr *, socklen_t, char *,
|
||||
size_t, char *, size_t, int);],
|
||||
[ return (0);],
|
||||
[AC_MSG_RESULT(size_t for buflen; int for flags)
|
||||
- AC_DEFINE(IRS_GETNAMEINFO_BUFLEN_T, size_t)
|
||||
+ # Changed to solve multilib conflict on Fedora
|
||||
+ #AC_DEFINE(IRS_GETNAMEINFO_BUFLEN_T, size_t)
|
||||
+ # Changed to solve multilib conflict on Fedora
|
||||
+ # AC_DEFINE(IRS_GETNAMEINFO_BUFLEN_T, size_t)
|
||||
+ AC_DEFINE(IRS_GETNAMEINFO_BUFLEN_T, socklen_t)
|
||||
AC_DEFINE(IRS_GETNAMEINFO_FLAGS_T, int)],
|
||||
[AC_MSG_RESULT(not match any subspecies; assume standard definition)
|
||||
AC_DEFINE(IRS_GETNAMEINFO_BUFLEN_T, socklen_t)
|
||||
diff -up bind-9.9.3rc2/isc-config.sh.in.multlib-conflict bind-9.9.3rc2/isc-config.sh.in
|
||||
--- bind-9.9.3rc2/isc-config.sh.in.multlib-conflict 2013-04-30 08:38:46.000000000 +0200
|
||||
+++ bind-9.9.3rc2/isc-config.sh.in 2013-05-13 12:26:40.258698745 +0200
|
||||
@@ -21,7 +21,18 @@ prefix=@prefix@
|
||||
diff --git a/isc-config.sh.in b/isc-config.sh.in
|
||||
index 10df275..9b30482 100644
|
||||
--- a/isc-config.sh.in
|
||||
+++ b/isc-config.sh.in
|
||||
@@ -21,7 +21,19 @@ prefix=@prefix@
|
||||
exec_prefix=@exec_prefix@
|
||||
exec_prefix_set=
|
||||
includedir=@includedir@
|
||||
@ -44,10 +47,11 @@ diff -up bind-9.9.3rc2/isc-config.sh.in.multlib-conflict bind-9.9.3rc2/isc-confi
|
||||
+ sec_libdir=/usr/lib64
|
||||
+ ;;
|
||||
+esac
|
||||
+
|
||||
|
||||
usage()
|
||||
{
|
||||
@@ -133,6 +144,16 @@ if test x"$echo_libs" = x"true"; then
|
||||
@@ -133,6 +145,16 @@ if test x"$echo_libs" = x"true"; then
|
||||
if test x"${exec_prefix_set}" = x"true"; then
|
||||
includes="-L${exec_prefix}/lib"
|
||||
else
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up bind-9.9.5rc2/lib/dns/include/dns/Makefile.in.update bind-9.9.5rc2/lib/dns/include/dns/Makefile.in
|
||||
--- bind-9.9.5rc2/lib/dns/include/dns/Makefile.in.update 2014-01-24 12:50:47.811725841 +0100
|
||||
+++ bind-9.9.5rc2/lib/dns/include/dns/Makefile.in 2014-01-24 12:51:33.866701688 +0100
|
||||
@@ -31,7 +31,7 @@ HEADERS = acl.h adb.h byaddr.h cache.h c
|
||||
rdata.h rdataclass.h rdatalist.h rdataset.h rdatasetiter.h \
|
||||
rdataslab.h rdatatype.h request.h resolver.h result.h \
|
||||
rootns.h rpz.h rrl.h sdb.h sdlz.h secalg.h secproto.h soa.h ssu.h \
|
||||
- tcpmsg.h time.h tkey.h tsec.h tsig.h ttl.h types.h \
|
||||
+ tcpmsg.h time.h tkey.h tsec.h tsig.h ttl.h types.h update.h \
|
||||
validator.h version.h view.h xfrin.h zone.h zonekey.h zt.h
|
||||
|
||||
GENHEADERS = enumclass.h enumtype.h rdatastruct.h
|
@ -1,39 +0,0 @@
|
||||
diff --git a/lib/dns/resolver.c b/lib/dns/resolver.c
|
||||
index 7023a82..d7f817c 100644
|
||||
--- a/lib/dns/resolver.c
|
||||
+++ b/lib/dns/resolver.c
|
||||
@@ -351,6 +351,7 @@ typedef struct {
|
||||
|
||||
struct dns_fetch {
|
||||
unsigned int magic;
|
||||
+ isc_mem_t * mctx;
|
||||
fetchctx_t * private;
|
||||
};
|
||||
|
||||
@@ -8416,6 +8417,8 @@ dns_resolver_createfetch2(dns_resolver_t *res, dns_name_t *name,
|
||||
fetch = isc_mem_get(res->mctx, sizeof(*fetch));
|
||||
if (fetch == NULL)
|
||||
return (ISC_R_NOMEMORY);
|
||||
+ fetch->mctx = NULL;
|
||||
+ isc_mem_attach(res->mctx, &fetch->mctx);
|
||||
|
||||
bucketnum = dns_name_fullhash(name, ISC_FALSE) % res->nbuckets;
|
||||
|
||||
@@ -8506,7 +8509,7 @@ dns_resolver_createfetch2(dns_resolver_t *res, dns_name_t *name,
|
||||
FTRACE("created");
|
||||
*fetchp = fetch;
|
||||
} else
|
||||
- isc_mem_put(res->mctx, fetch, sizeof(*fetch));
|
||||
+ isc_mem_putanddetach(&fetch->mctx, fetch, sizeof(*fetch));
|
||||
|
||||
return (result);
|
||||
}
|
||||
@@ -8597,7 +8600,7 @@ dns_resolver_destroyfetch(dns_fetch_t **fetchp) {
|
||||
|
||||
UNLOCK(&res->buckets[bucketnum].lock);
|
||||
|
||||
- isc_mem_put(res->mctx, fetch, sizeof(*fetch));
|
||||
+ isc_mem_putanddetach(&fetch->mctx, fetch, sizeof(*fetch));
|
||||
*fetchp = NULL;
|
||||
|
||||
if (bucket_empty)
|
@ -1,38 +0,0 @@
|
||||
From 576f2f19067c0c974d1d39f92c51e5f3a08fc17f Mon Sep 17 00:00:00 2001
|
||||
From: Tomas Hozza <thozza@redhat.com>
|
||||
Date: Tue, 4 Mar 2014 16:34:21 +0100
|
||||
Subject: [PATCH] Return ISC_R_FAILURE if the API version check fails
|
||||
|
||||
Signed-off-by: Tomas Hozza <thozza@redhat.com>
|
||||
---
|
||||
bin/named/unix/dlz_dlopen_driver.c | 1 +
|
||||
bin/named/win32/dlz_dlopen_driver.c | 1 +
|
||||
2 files changed, 2 insertions(+)
|
||||
|
||||
diff --git a/bin/named/unix/dlz_dlopen_driver.c b/bin/named/unix/dlz_dlopen_driver.c
|
||||
index 2ba8a02..62b6614 100644
|
||||
--- a/bin/named/unix/dlz_dlopen_driver.c
|
||||
+++ b/bin/named/unix/dlz_dlopen_driver.c
|
||||
@@ -330,6 +330,7 @@ dlopen_dlz_create(const char *dlzname, unsigned int argc, char *argv[],
|
||||
"dlz_dlopen: incorrect version %d "
|
||||
"should be %d in '%s'",
|
||||
cd->version, DLZ_DLOPEN_VERSION, cd->dl_path);
|
||||
+ result = ISC_R_FAILURE;
|
||||
goto failed;
|
||||
}
|
||||
|
||||
diff --git a/bin/named/win32/dlz_dlopen_driver.c b/bin/named/win32/dlz_dlopen_driver.c
|
||||
index 0c192b4..62008c0 100644
|
||||
--- a/bin/named/win32/dlz_dlopen_driver.c
|
||||
+++ b/bin/named/win32/dlz_dlopen_driver.c
|
||||
@@ -314,6 +314,7 @@ dlopen_dlz_create(const char *dlzname, unsigned int argc, char *argv[],
|
||||
"dlz_dlopen: incorrect version %d "
|
||||
"should be %d in '%s'",
|
||||
cd->version, DLZ_DLOPEN_VERSION, cd->dl_path);
|
||||
+ result = ISC_R_FAILURE;
|
||||
goto failed;
|
||||
}
|
||||
|
||||
--
|
||||
1.8.5.3
|
||||
|
@ -605,13 +605,13 @@ diff -up bind-9.9.5rc2/lib/dns/include/dns/Makefile.in.dyndb bind-9.9.5rc2/lib/d
|
||||
+++ bind-9.9.5rc2/lib/dns/include/dns/Makefile.in 2014-01-24 12:43:29.234908816 +0100
|
||||
@@ -23,7 +23,7 @@ top_srcdir = @top_srcdir@
|
||||
|
||||
HEADERS = acl.h adb.h byaddr.h cache.h callbacks.h cert.h compress.h \
|
||||
HEADERS = acache.h acl.h adb.h bit.h byaddr.h cache.h callbacks.h cert.h \
|
||||
client.h clientinfo.h compress.h \
|
||||
- db.h dbiterator.h dbtable.h diff.h dispatch.h \
|
||||
+ db.h dbiterator.h dbtable.h diff.h dispatch.h dynamic_db.h \
|
||||
dlz.h dnssec.h ds.h events.h fixedname.h iptable.h journal.h \
|
||||
keyflags.h keytable.h keyvalues.h lib.h log.h \
|
||||
master.h masterdump.h message.h name.h ncache.h nsec.h \
|
||||
dlz.h dlz_dlopen.h dns64.h dnssec.h ds.h \
|
||||
ecdb.h events.h fixedname.h forward.h iptable.h \
|
||||
journal.h keydata.h keyflags.h keytable.h keyvalues.h \
|
||||
diff -up bind-9.9.5rc2/lib/dns/include/dns/types.h.dyndb bind-9.9.5rc2/lib/dns/include/dns/types.h
|
||||
--- bind-9.9.5rc2/lib/dns/include/dns/types.h.dyndb 2014-01-17 04:27:12.000000000 +0100
|
||||
+++ bind-9.9.5rc2/lib/dns/include/dns/types.h 2014-01-24 10:45:59.050572062 +0100
|
||||
@ -681,7 +681,7 @@ diff -up bind-9.9.5rc2/lib/isccfg/namedconf.c.dyndb bind-9.9.5rc2/lib/isccfg/nam
|
||||
@@ -897,6 +898,7 @@ namedconf_or_view_clauses[] = {
|
||||
{ "zone", &cfg_type_zone, CFG_CLAUSEFLAG_MULTI },
|
||||
/* only 1 DLZ per view allowed */
|
||||
{ "dlz", &cfg_type_dynamically_loadable_zones, 0 },
|
||||
{ "dlz", &cfg_type_dlz, 0 },
|
||||
+ { "dynamic-db", &cfg_type_dynamic_db, CFG_CLAUSEFLAG_MULTI },
|
||||
{ "server", &cfg_type_server, CFG_CLAUSEFLAG_MULTI },
|
||||
{ "trusted-keys", &cfg_type_dnsseckeys, CFG_CLAUSEFLAG_MULTI },
|
||||
|
@ -1,72 +0,0 @@
|
||||
diff -up bind-9.7.0rc2/lib/bind9/Makefile.in.nonexec bind-9.7.0rc2/lib/bind9/Makefile.in
|
||||
--- bind-9.7.0rc2/lib/bind9/Makefile.in.nonexec 2009-12-06 00:31:40.000000000 +0100
|
||||
+++ bind-9.7.0rc2/lib/bind9/Makefile.in 2010-01-28 12:13:33.406696161 +0100
|
||||
@@ -78,7 +78,7 @@ installdirs:
|
||||
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${libdir}
|
||||
|
||||
install:: timestamp installdirs
|
||||
- ${LIBTOOL_MODE_INSTALL} ${INSTALL_DATA} libbind9.@A@ ${DESTDIR}${libdir}
|
||||
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} libbind9.@A@ ${DESTDIR}${libdir}
|
||||
|
||||
clean distclean::
|
||||
rm -f libbind9.@A@ timestamp
|
||||
diff -up bind-9.7.0rc2/lib/dns/Makefile.in.nonexec bind-9.7.0rc2/lib/dns/Makefile.in
|
||||
--- bind-9.7.0rc2/lib/dns/Makefile.in.nonexec 2009-12-06 00:31:40.000000000 +0100
|
||||
+++ bind-9.7.0rc2/lib/dns/Makefile.in 2010-01-28 12:13:33.406696161 +0100
|
||||
@@ -131,7 +131,7 @@ installdirs:
|
||||
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${libdir}
|
||||
|
||||
install:: timestamp installdirs
|
||||
- ${LIBTOOL_MODE_INSTALL} ${INSTALL_DATA} libdns.@A@ ${DESTDIR}${libdir}
|
||||
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} libdns.@A@ ${DESTDIR}${libdir}
|
||||
|
||||
clean distclean::
|
||||
rm -f libdns.@A@ timestamp
|
||||
diff -up bind-9.7.0rc2/lib/isccc/Makefile.in.nonexec bind-9.7.0rc2/lib/isccc/Makefile.in
|
||||
--- bind-9.7.0rc2/lib/isccc/Makefile.in.nonexec 2009-12-06 00:31:41.000000000 +0100
|
||||
+++ bind-9.7.0rc2/lib/isccc/Makefile.in 2010-01-28 12:13:33.406696161 +0100
|
||||
@@ -80,7 +80,7 @@ installdirs:
|
||||
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${libdir}
|
||||
|
||||
install:: timestamp installdirs
|
||||
- ${LIBTOOL_MODE_INSTALL} ${INSTALL_DATA} libisccc.@A@ ${DESTDIR}${libdir}
|
||||
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} libisccc.@A@ ${DESTDIR}${libdir}
|
||||
|
||||
clean distclean::
|
||||
rm -f libisccc.@A@ timestamp
|
||||
diff -up bind-9.7.0rc2/lib/isccfg/Makefile.in.nonexec bind-9.7.0rc2/lib/isccfg/Makefile.in
|
||||
--- bind-9.7.0rc2/lib/isccfg/Makefile.in.nonexec 2009-12-06 00:31:41.000000000 +0100
|
||||
+++ bind-9.7.0rc2/lib/isccfg/Makefile.in 2010-01-28 12:13:33.406696161 +0100
|
||||
@@ -77,7 +77,7 @@ installdirs:
|
||||
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${libdir}
|
||||
|
||||
install:: timestamp installdirs
|
||||
- ${LIBTOOL_MODE_INSTALL} ${INSTALL_DATA} libisccfg.@A@ ${DESTDIR}${libdir}
|
||||
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} libisccfg.@A@ ${DESTDIR}${libdir}
|
||||
|
||||
clean distclean::
|
||||
rm -f libisccfg.@A@ timestamp
|
||||
diff -up bind-9.7.0rc2/lib/isc/Makefile.in.nonexec bind-9.7.0rc2/lib/isc/Makefile.in
|
||||
--- bind-9.7.0rc2/lib/isc/Makefile.in.nonexec 2009-12-18 05:09:55.000000000 +0100
|
||||
+++ bind-9.7.0rc2/lib/isc/Makefile.in 2010-01-28 12:13:53.566696766 +0100
|
||||
@@ -121,7 +121,7 @@ installdirs:
|
||||
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${libdir}
|
||||
|
||||
install:: timestamp installdirs
|
||||
- ${LIBTOOL_MODE_INSTALL} ${INSTALL_DATA} libisc.@A@ ${DESTDIR}${libdir}
|
||||
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} libisc.@A@ ${DESTDIR}${libdir}
|
||||
|
||||
clean distclean::
|
||||
rm -f libisc.@A@ libisc-nosymtbl.@A@ libisc.la \
|
||||
diff -up bind-9.7.0rc2/lib/lwres/Makefile.in.nonexec bind-9.7.0rc2/lib/lwres/Makefile.in
|
||||
--- bind-9.7.0rc2/lib/lwres/Makefile.in.nonexec 2007-06-20 01:47:22.000000000 +0200
|
||||
+++ bind-9.7.0rc2/lib/lwres/Makefile.in 2010-01-28 12:13:33.406696161 +0100
|
||||
@@ -78,7 +78,7 @@ installdirs:
|
||||
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${libdir}
|
||||
|
||||
install:: timestamp installdirs
|
||||
- ${LIBTOOL_MODE_INSTALL} ${INSTALL_DATA} liblwres.@A@ ${DESTDIR}${libdir}
|
||||
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} liblwres.@A@ ${DESTDIR}${libdir}
|
||||
|
||||
clean distclean::
|
||||
rm -f liblwres.@A@ liblwres.la timestamp
|
31
bind.spec
31
bind.spec
@ -2,7 +2,7 @@
|
||||
# Red Hat BIND package .spec file
|
||||
#
|
||||
|
||||
%global PATCHVER P1
|
||||
#%%global PATCHVER P1
|
||||
#%%global PREVER rc2
|
||||
%global VERSION %{version}%{?PREVER}%{?PATCHVER:-%{PATCHVER}}
|
||||
|
||||
@ -27,8 +27,8 @@
|
||||
Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) server
|
||||
Name: bind
|
||||
License: ISC
|
||||
Version: 9.9.5
|
||||
Release: 9%{?PATCHVER:.%{PATCHVER}}%{?PREVER:.%{PREVER}}%{?dist}
|
||||
Version: 9.9.6
|
||||
Release: 1%{?PATCHVER:.%{PATCHVER}}%{?PREVER:.%{PREVER}}%{?dist}
|
||||
Epoch: 32
|
||||
Url: http://www.isc.org/products/BIND/
|
||||
Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -62,7 +62,6 @@ Source45: named-sdb-chroot-setup.service
|
||||
Source46: named-setup-rndc.service
|
||||
|
||||
# Common patches
|
||||
Patch5: bind-nonexec.patch
|
||||
Patch10: bind-9.5-PIE.patch
|
||||
Patch16: bind-9.3.2-redhat_doc.patch
|
||||
Patch72: bind-9.5-dlz-64bit.patch
|
||||
@ -79,18 +78,10 @@ Patch119:bind97-rh693982.patch
|
||||
Patch123:bind98-rh735103.patch
|
||||
Patch124:nslookup-norec.patch
|
||||
Patch125:bind99-buildfix.patch
|
||||
Patch127:bind99-forward.patch
|
||||
Patch130:bind-9.9.1-P2-dlz-libdb.patch
|
||||
Patch131:bind-9.9.1-P2-multlib-conflict.patch
|
||||
Patch133:bind99-rh640538.patch
|
||||
Patch134:bind97-rh669163.patch
|
||||
Patch137:bind99-rrl.patch
|
||||
# Install dns/update.h header for bind-dyndb-ldap plugin
|
||||
Patch138:bind-9.9.3-include-update-h.patch
|
||||
# [ISC-Bugs #35495]
|
||||
Patch139:bind-99-ISC-Bugs-35495.patch
|
||||
# [ISC-Bugs #35385]
|
||||
Patch140:bind-99-ISC-Bugs-35385.patch
|
||||
|
||||
# SDB patches
|
||||
Patch11: bind-9.3.2b2-sdbsrc.patch
|
||||
@ -270,7 +261,6 @@ Based on the code from Jan "Yenya" Kasprzak <kas@fi.muni.cz>
|
||||
%setup -q -n %{name}-%{VERSION}
|
||||
|
||||
# Common patches
|
||||
%patch5 -p1 -b .nonexec
|
||||
%patch10 -p1 -b .PIE
|
||||
%patch16 -p1 -b .redhat_doc
|
||||
%patch104 -p1 -b .dyndb
|
||||
@ -293,13 +283,8 @@ pushd bin/dig
|
||||
%patch124 -p0 -b .nslookup-norec
|
||||
popd
|
||||
%patch125 -p1 -b .buildfix
|
||||
%patch127 -p1 -b .forward
|
||||
%patch130 -p1 -b .libdb
|
||||
%patch131 -p1 -b .multlib-conflict
|
||||
%patch137 -p1 -b .rrl
|
||||
%patch138 -p1 -b .update
|
||||
%patch139 -p1 -b .dlz_segfault
|
||||
%patch140 -p1 -b .fetch_race_cond
|
||||
|
||||
%if %{SDB}
|
||||
%patch101 -p1 -b .old-api
|
||||
@ -783,15 +768,15 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%files libs
|
||||
%defattr(-,root,root,-)
|
||||
%{_libdir}/libbind9.so.90*
|
||||
%{_libdir}/libdns.so.100*
|
||||
%{_libdir}/libdns.so.104*
|
||||
%{_libdir}/libisc.so.95*
|
||||
%{_libdir}/libisccc.so.90*
|
||||
%{_libdir}/libisccfg.so.90*
|
||||
%{_libdir}/liblwres.so.90*
|
||||
%{_libdir}/liblwres.so.91*
|
||||
|
||||
%files libs-lite
|
||||
%defattr(-,root,root,-)
|
||||
%{_libdir}/libdns-export.so.100*
|
||||
%{_libdir}/libdns-export.so.104*
|
||||
%{_libdir}/libirs-export.so.91*
|
||||
%{_libdir}/libisc-export.so.95*
|
||||
%{_libdir}/libisccfg-export.so.90*
|
||||
@ -929,6 +914,10 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Oct 02 2014 Tomas Hozza <thozza@redhat.com> - 32:9.9.6-1
|
||||
- Update to 9.9.6
|
||||
- drop merged patches and rebase some of existing patches
|
||||
|
||||
* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 32:9.9.5-9.P1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
|
@ -5,8 +5,8 @@ diff -up bind-9.9.4b1/bin/tests/system/Makefile.in.buildfix bind-9.9.4b1/bin/tes
|
||||
|
||||
@BIND9_MAKE_INCLUDES@
|
||||
|
||||
-SUBDIRS = dlzexternal filter-aaaa lwresd rpz rrl \
|
||||
+SUBDIRS = filter-aaaa lwresd rpz rrl \
|
||||
-SUBDIRS = builtin dlzexternal filter-aaaa lwresd rpz rrl \
|
||||
+SUBDIRS = builtin filter-aaaa lwresd rpz rrl \
|
||||
rsabigexponent tkey tsiggss
|
||||
TARGETS =
|
||||
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up bind-9.9.5rc2/lib/dns/include/dns/Makefile.in.forward bind-9.9.5rc2/lib/dns/include/dns/Makefile.in
|
||||
--- bind-9.9.5rc2/lib/dns/include/dns/Makefile.in.forward 2014-01-24 12:46:04.875847331 +0100
|
||||
+++ bind-9.9.5rc2/lib/dns/include/dns/Makefile.in 2014-01-24 12:47:51.707805950 +0100
|
||||
@@ -24,7 +24,7 @@ top_srcdir = @top_srcdir@
|
||||
HEADERS = acl.h adb.h byaddr.h cache.h callbacks.h cert.h compress.h \
|
||||
client.h clientinfo.h compress.h \
|
||||
db.h dbiterator.h dbtable.h diff.h dispatch.h dynamic_db.h \
|
||||
- dlz.h dnssec.h ds.h events.h fixedname.h iptable.h journal.h \
|
||||
+ dlz.h dnssec.h ds.h events.h fixedname.h forward.h iptable.h journal.h \
|
||||
keyflags.h keytable.h keyvalues.h lib.h log.h \
|
||||
master.h masterdump.h message.h name.h ncache.h nsec.h \
|
||||
peer.h portlist.h private.h rbt.h rcode.h \
|
@ -1,12 +0,0 @@
|
||||
diff -up bind-9.9.5rc2/lib/dns/include/dns/Makefile.in.rrl bind-9.9.5rc2/lib/dns/include/dns/Makefile.in
|
||||
--- bind-9.9.5rc2/lib/dns/include/dns/Makefile.in.rrl 2014-01-24 12:48:16.869796283 +0100
|
||||
+++ bind-9.9.5rc2/lib/dns/include/dns/Makefile.in 2014-01-24 12:49:15.704773787 +0100
|
||||
@@ -30,7 +30,7 @@ HEADERS = acl.h adb.h byaddr.h cache.h c
|
||||
peer.h portlist.h private.h rbt.h rcode.h \
|
||||
rdata.h rdataclass.h rdatalist.h rdataset.h rdatasetiter.h \
|
||||
rdataslab.h rdatatype.h request.h resolver.h result.h \
|
||||
- rootns.h rpz.h sdb.h sdlz.h secalg.h secproto.h soa.h ssu.h \
|
||||
+ rootns.h rpz.h rrl.h sdb.h sdlz.h secalg.h secproto.h soa.h ssu.h \
|
||||
tcpmsg.h time.h tkey.h tsec.h tsig.h ttl.h types.h \
|
||||
validator.h version.h view.h xfrin.h zone.h zonekey.h zt.h
|
||||
|
Loading…
Reference in New Issue
Block a user