First version compiling up to tests

Unfortunately, test fails.
This commit is contained in:
Petr Menšík 2019-07-23 16:18:58 +02:00
parent df81e828c7
commit aaee84a4fb
5 changed files with 123 additions and 21 deletions

View File

@ -247,7 +247,7 @@ index 856463f..dc826dd 100644
@DLZ_DRIVER_RULES@
diff --git a/bin/pkcs11/Makefile.in b/bin/pkcs11/Makefile.in
index 454d145..0e542f3 100644
index 96aec05..0e542f3 100644
--- a/bin/pkcs11/Makefile.in
+++ b/bin/pkcs11/Makefile.in
@@ -13,13 +13,13 @@ top_srcdir = @top_srcdir@
@ -259,7 +259,8 @@ index 454d145..0e542f3 100644
CDEFINES =
ISCLIBS = ../../lib/isc-pkcs11/libisc-pkcs11.@A@ @OPENSSL_LIBS@
-ISCLIBS = ../../lib/isc/libisc.@A@ @OPENSSL_LIBS@
+ISCLIBS = ../../lib/isc-pkcs11/libisc-pkcs11.@A@ @OPENSSL_LIBS@
-ISCDEPLIBS = ../../lib/isc/libisc.@A@
+ISCDEPLIBS = ../../lib/isc-pkcs11/libisc-pkcs11.@A@

View File

@ -1,4 +1,4 @@
From f37b26cb7c8f7351d22dfea79df33edb74d42e23 Mon Sep 17 00:00:00 2001
From 0b1c2b11ccec87da88bcdceeda814c489163461b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20Men=C5=A1=C3=ADk?= <pemensik@redhat.com>
Date: Thu, 2 Aug 2018 23:46:45 +0200
Subject: [PATCH] FIPS tests changes
@ -77,7 +77,7 @@ Date: Wed Mar 7 10:44:23 2018 +0100
bin/tests/system/checkconf/bad-tsig.conf | 2 +-
bin/tests/system/checkconf/good.conf | 2 +-
bin/tests/system/dlv/ns3/sign.sh | 1 +
bin/tests/system/feature-test.c | 13 ++++
bin/tests/system/feature-test.c | 14 ++++
bin/tests/system/notify/ns5/named.conf.in | 6 +-
bin/tests/system/notify/tests.sh | 6 +-
bin/tests/system/nsupdate/ns1/named.conf.in | 2 +-
@ -91,7 +91,7 @@ Date: Wed Mar 7 10:44:23 2018 +0100
bin/tests/system/tsig/tests.sh | 67 ++++++++++++-------
bin/tests/system/upforwd/ns1/named.conf.in | 2 +-
bin/tests/system/upforwd/tests.sh | 2 +-
33 files changed, 151 insertions(+), 107 deletions(-)
33 files changed, 152 insertions(+), 107 deletions(-)
diff --git a/bin/tests/system/acl/ns2/named1.conf.in b/bin/tests/system/acl/ns2/named1.conf.in
index 0ea6502..026db3f 100644
@ -574,7 +574,7 @@ index fa51ae1..bc46942 100755
zone=child1.utld.
infile=child.db.in
diff --git a/bin/tests/system/feature-test.c b/bin/tests/system/feature-test.c
index 8b9deb6..ceb4fe8 100644
index 8b9deb6..e5d8997 100644
--- a/bin/tests/system/feature-test.c
+++ b/bin/tests/system/feature-test.c
@@ -19,6 +19,7 @@
@ -585,16 +585,17 @@ index 8b9deb6..ceb4fe8 100644
#include <dns/edns.h>
#ifdef WIN32
@@ -159,6 +160,18 @@ main(int argc, char **argv) {
@@ -159,6 +160,19 @@ main(int argc, char **argv) {
#endif
}
+ if (strcmp(argv[1], "--md5") == 0) {
+ unsigned char digest[ISC_MAX_MD_SIZE];
+ const char test[] = test;
+ const unsigned char test[] = "test";
+ unsigned int size = sizeof(digest);
+
+ if (isc_md(ISC_MD_MD5, test, sizeof(test),
+ digest, sizeof(digest)) == ISC_R_SUCCESS) {
+ digest, &size) == ISC_R_SUCCESS) {
+ return (0);
+ } else {
+ return (1);

View File

@ -1,4 +1,4 @@
From 9b9087cce00acd8f1fc2ce8e5c89d1dab1158683 Mon Sep 17 00:00:00 2001
From c2e22d5b55fdc17cd51bf77980892e147c2b2ea1 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20Men=C5=A1=C3=ADk?= <pemensik@redhat.com>
Date: Tue, 2 Jan 2018 18:13:07 +0100
Subject: [PATCH] Fix pkcs11 variants atf tests
@ -15,10 +15,10 @@ Add pkcs11 Kyuafile, fix dh_test to pass in pkcs11 mode
5 files changed, 14 insertions(+), 10 deletions(-)
diff --git a/configure.ac b/configure.ac
index b7dd8e5..e9dbbba 100644
index 0f7c850..0532e5f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3023,6 +3023,7 @@ AC_CONFIG_FILES([
@@ -3032,6 +3032,7 @@ AC_CONFIG_FILES([
lib/dns-pkcs11/include/Makefile
lib/dns-pkcs11/include/dns/Makefile
lib/dns-pkcs11/include/dst/Makefile
@ -81,19 +81,20 @@ index d83d9f5..d5bda29 100644
dst_key_free(&key);
}
diff --git a/lib/isc-pkcs11/tests/Makefile.in b/lib/isc-pkcs11/tests/Makefile.in
index 5735829..97b26c1 100644
index 7e62737..e91cd67 100644
--- a/lib/isc-pkcs11/tests/Makefile.in
+++ b/lib/isc-pkcs11/tests/Makefile.in
@@ -16,10 +16,10 @@ VERSION=@BIND9_VERSION@
@@ -15,11 +15,11 @@ VERSION=@BIND9_VERSION@
@BIND9_MAKE_INCLUDES@
CINCLUDES = -I. -Iinclude ${ISC_INCLUDES} @OPENSSL_INCLUDES@ @CMOCKA_CFLAGS@
-CINCLUDES = -I. -Iinclude ${ISC_INCLUDES} @OPENSSL_INCLUDES@ @CMOCKA_CFLAGS@
-CDEFINES = -DTESTS="\"${top_builddir}/lib/isc/tests/\""
+CINCLUDES = -I. -Iinclude ${ISC_PKCS11_INCLUDES} @OPENSSL_INCLUDES@ @CMOCKA_CFLAGS@
+CDEFINES = -DTESTS="\"${top_builddir}/lib/isc-pkcs11/tests/\""
-ISCLIBS = ../libisc.@A@ @OPENSSL_LIBS@
ISCLIBS = ../libisc-pkcs11.@A@ @OPENSSL_LIBS@
-ISCDEPLIBS = ../libisc.@A@
+ISCLIBS = ../libisc-pkcs11.@A@ @ISC_OPENSSL_LIBS@
+ISCDEPLIBS = ../libisc-pkcs11.@A@
LIBS = @LIBS@ @CMOCKA_LIBS@

95
bind-9.14-json-c.patch Normal file
View File

@ -0,0 +1,95 @@
From 0698eb93f6e618d2882ae2c8758c5fa87524bea6 Mon Sep 17 00:00:00 2001
From: Petr Mensik <pemensik@redhat.com>
Date: Tue, 23 Jul 2019 12:10:39 +0200
Subject: [PATCH] Allow explicitly using json-c but not libjson
Separate detection of json support. Allows explicit use of json-c when
jsoncpp package is found. Have to use --without-libjson --with-json-c.
---
configure.ac | 52 +++++++++++++++++++++++++++++++++++++++++-----------
1 file changed, 41 insertions(+), 11 deletions(-)
diff --git a/configure.ac b/configure.ac
index f7978e4..40b4f9f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1331,7 +1331,6 @@ AC_ARG_WITH(libjson,
use_libjson="$withval", use_libjson="auto")
have_libjson=""
-have_libjson_c=""
case "$use_libjson" in
no)
libjson_libs=""
@@ -1347,7 +1346,43 @@ case "$use_libjson" in
LIBS="$LIBS -L${d}/lib"
fi
have_libjson="yes"
- elif test -f "${d}/include/json-c/json.h"
+ fi
+ done
+ ;;
+ *)
+ if test -f "${use_libjson}/include/json/json.h"
+ then
+ libjson_cflags="-I${use_libjson}/include"
+ LIBS="$LIBS -L${use_libjson}/lib"
+ have_libjson="yes"
+ else
+ AC_MSG_ERROR([$use_libjson/include/json/json.h not found.])
+ fi
+ ;;
+esac
+
+#
+# was --with-json-c specified?
+#
+AC_ARG_WITH(json-c,
+ AS_HELP_STRING([--with-json-c[=PATH]],
+ [build with json-c library [yes|no|path]]),
+ use_json_c="$withval", use_json_c="$use_libjson")
+
+if test "X${have_libjson}" != "X"
+then
+ # Do not use if libjson were found
+ use_json_c=no
+fi
+
+have_libjson_c=""
+case "$use_json_c" in
+ no)
+ ;;
+ auto|yes)
+ for d in /usr /usr/local /opt/local
+ do
+ if test -f "${d}/include/json-c/json.h"
then
if test ${d} != /usr
then
@@ -1360,19 +1395,14 @@ case "$use_libjson" in
done
;;
*)
- if test -f "${use_libjson}/include/json/json.h"
- then
- libjson_cflags="-I${use_libjson}/include"
- LIBS="$LIBS -L${use_libjson}/lib"
- have_libjson="yes"
- elif test -f "${use_libjson}/include/json-c/json.h"
+ if test -f "${use_json_c}/include/json-c/json.h"
then
- libjson_cflags="-I${use_libjson}/include"
- LIBS="$LIBS -L${use_libjson}/lib"
+ libjson_cflags="-I${use_json_c}/include"
+ LIBS="$LIBS -L${use_json_c}/lib"
have_libjson="yes"
have_libjson_c="yes"
else
- AC_MSG_ERROR([$use_libjson/include/json{,-c}/json.h not found.])
+ AC_MSG_ERROR([$use_json_c/include/json-c/json.h not found.])
fi
;;
esac
--
2.20.1

View File

@ -21,8 +21,11 @@
%bcond_without LMDB
%bcond_without JSON
%bcond_without DNSTAP
%bcond_without DLZ
# TODO: mysql is not well suported without SDB.
%bcond_with BDB
# skip DLZ for now
%bcond_with DLZ
# Support for builds without threads removed. DHCP no longer needs it anyway.
%bcond_with EXPORT_LIBS
# Legacy GeoIP support
%bcond_with GEOIP
@ -163,6 +166,7 @@ Patch173:bind-9.11-rh1732883.patch
# Make sure jsonccp-devel does not interfere
Patch174:bind-9.11-json-c.patch
Patch175:bind-9.11-fips-disable.patch
Patch176: bind-9.11-unit-dnstap-pkcs11.patch
Patch177: bind-9.11-serve-stale.patch
Patch178: bind-9.11-serve-stale-dbfix.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=1736762
@ -567,6 +571,7 @@ are used for building ISC DHCP.
#%patch174 -p1 -b .unit-timer
%patch174 -p1 -b .json-c
%patch175 -p1 -b .rh1709553
%patch176 -p1 -b .unit-dnstap
%patch177 -p1 -b .serve-stale
%patch178 -p1 -b .rh1770492
%patch183 -p1 -b .rh1736762-5
@ -706,7 +711,7 @@ export LIBDIR_SUFFIX
--with-lmdb=no \
%endif
%if %{with JSON}
--with-libjson \
--without-libjson --with-json-c \
%endif
%if %{with DNSTAP}
--enable-dnstap \
@ -1401,14 +1406,13 @@ fi;
%files devel
%{_libdir}/libbind9.so
%{_libdir}/libisccc.so
%{_libdir}/liblwres.so
%{_libdir}/libns.so
%{_includedir}/bind9/config.h
%{_includedir}/bind9/bind9
%{_includedir}/bind9/isccc
%{_includedir}/bind9/ns
%{_mandir}/man1/isc-config.sh.1*
%{_mandir}/man1/bind9-config.1*
%{_mandir}/man3/lwres*
%{_bindir}/isc-config.sh
%{_bindir}/bind9-config
%endif