- 9.5.1b2 release
- patches merged - bind95-rh454783.patch - bind-9.5-edns.patch - bind95-rh450995.patch - bind95-rh457175.patch
This commit is contained in:
parent
77020b9c5b
commit
a99cd96ce0
@ -1,4 +1,4 @@
|
||||
bind-chroot.tar.bz2
|
||||
config-4.tar.bz2
|
||||
libbind-man.tar.gz
|
||||
bind-9.5.1b1.tar.gz
|
||||
bind-chroot.tar.bz2
|
||||
bind-9.5.1b2.tar.gz
|
||||
|
@ -1,21 +0,0 @@
|
||||
diff -up bind-9.5.0b3/lib/dns/resolver.c.edns bind-9.5.0b3/lib/dns/resolver.c
|
||||
--- bind-9.5.0b3/lib/dns/resolver.c.edns 2008-05-13 08:55:43.000000000 +0200
|
||||
+++ bind-9.5.0b3/lib/dns/resolver.c 2008-05-13 08:58:12.000000000 +0200
|
||||
@@ -1552,13 +1552,16 @@ resquery_send(resquery_t *query) {
|
||||
dns_peer_getsupportedns(peer, &useedns) == ISC_R_SUCCESS &&
|
||||
!useedns)
|
||||
{
|
||||
- query->options |= DNS_FETCHOPT_NOEDNS0;
|
||||
dns_adb_changeflags(fctx->adb,
|
||||
query->addrinfo,
|
||||
DNS_FETCHOPT_NOEDNS0,
|
||||
DNS_FETCHOPT_NOEDNS0);
|
||||
}
|
||||
|
||||
+ /* Sync query->options and query->addrinfo->flags now */
|
||||
+ if ((query->addrinfo->flags & DNS_FETCHOPT_NOEDNS0) != 0)
|
||||
+ query->options |= DNS_FETCHOPT_NOEDNS0;
|
||||
+
|
||||
/*
|
||||
* Use EDNS0, unless the caller doesn't want it, or we know that
|
||||
* the remote server doesn't like it.
|
22
bind.spec
22
bind.spec
@ -2,7 +2,7 @@
|
||||
# Red Hat BIND package .spec file
|
||||
#
|
||||
|
||||
%define PREVER b1
|
||||
%define PREVER b2
|
||||
%define VERSION %{version}%{PREVER}
|
||||
|
||||
%{?!SDB: %define SDB 1}
|
||||
@ -19,7 +19,7 @@ Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) serv
|
||||
Name: bind
|
||||
License: ISC
|
||||
Version: 9.5.1
|
||||
Release: 0.6.%{PREVER}%{?dist}
|
||||
Release: 0.7.%{PREVER}%{?dist}
|
||||
Epoch: 32
|
||||
Url: http://www.isc.org/products/BIND/
|
||||
Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -57,10 +57,6 @@ Patch63: bind-9.4.0-dnssec-directory.patch
|
||||
Patch71: bind-9.5-overflow.patch
|
||||
Patch72: bind-9.5-dlz-64bit.patch
|
||||
Patch87: bind-9.5-parallel-build.patch
|
||||
Patch90: bind-9.5-edns.patch
|
||||
Patch91: bind95-rh450995.patch
|
||||
Patch92: bind95-rh457175.patch
|
||||
Patch93: bind95-rh454783.patch
|
||||
|
||||
# SDB patches
|
||||
Patch11: bind-9.3.2b2-sdbsrc.patch
|
||||
@ -186,7 +182,6 @@ Based on the code from Jan "Yenya" Kasprzak <kas@fi.muni.cz>
|
||||
%patch5 -p1 -b .nonexec
|
||||
%patch10 -p1 -b .PIE
|
||||
%patch16 -p1 -b .redhat_doc
|
||||
%patch93 -p1 -b .rh454783
|
||||
%if %{SDB}
|
||||
mkdir bin/named-sdb
|
||||
cp -r bin/named/* bin/named-sdb
|
||||
@ -243,9 +238,6 @@ cp -fp contrib/dbus/{dbus_mgr.h,dbus_service.h} bin/named/include/named
|
||||
%patch83 -p1 -b .libidn2
|
||||
%patch85 -p1 -b .libidn3
|
||||
%patch87 -p1 -b .parallel
|
||||
%patch90 -p1 -b .edns
|
||||
%patch91 -p1 -b .rh450995
|
||||
%patch92 -p1 -b .rh457175
|
||||
%patch94 -p1 -b .rh461409
|
||||
|
||||
# Sparc and s390 arches need to use -fPIE
|
||||
@ -590,7 +582,7 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_bindir}/nslookup
|
||||
%{_bindir}/nsupdate
|
||||
%{_mandir}/man1/host.1*
|
||||
%{_mandir}/man8/nsupdate.8*
|
||||
%{_mandir}/man1/nsupdate.1*
|
||||
%{_mandir}/man1/dig.1*
|
||||
%{_mandir}/man1/nslookup.1*
|
||||
|
||||
@ -644,6 +636,14 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_sbindir}/bind-chroot-admin
|
||||
|
||||
%changelog
|
||||
* Wed Sep 24 2008 Adam Tkac <atkac redhat com> 32:9.5.1-0.7.b2
|
||||
- 9.5.1b2 release
|
||||
- patches merged
|
||||
- bind95-rh454783.patch
|
||||
- bind-9.5-edns.patch
|
||||
- bind95-rh450995.patch
|
||||
- bind95-rh457175.patch
|
||||
|
||||
* Wed Sep 17 2008 Adam Tkac <atkac redhat com> 32:9.5.1-0.6.b1
|
||||
- IDN output strings didn't honour locale settings (#461409)
|
||||
|
||||
|
@ -1,11 +0,0 @@
|
||||
diff -up bind-9.5.0/lib/isccfg/aclconf.c.450995 bind-9.5.0/lib/isccfg/aclconf.c
|
||||
--- bind-9.5.0/lib/isccfg/aclconf.c.450995 2008-06-18 12:29:05.000000000 +0200
|
||||
+++ bind-9.5.0/lib/isccfg/aclconf.c 2008-06-18 12:30:01.000000000 +0200
|
||||
@@ -287,6 +287,7 @@ nested_acl:
|
||||
} else {
|
||||
dns_acl_merge(dacl, inneracl,
|
||||
ISC_TF(!neg));
|
||||
+ de += inneracl->length; /* elements added */
|
||||
dns_acl_detach(&inneracl);
|
||||
continue;
|
||||
}
|
@ -1,50 +0,0 @@
|
||||
diff -up bind-9.5.0-P1/bin/named/xfrout.c.rh454783 bind-9.5.0-P1/bin/named-sdb/xfrout.c
|
||||
--- bind-9.5.0-P1/bin/named/xfrout.c.rh454783 2008-08-05 12:50:44.000000000 +0200
|
||||
+++ bind-9.5.0-P1/bin/named/xfrout.c 2008-08-05 12:57:54.000000000 +0200
|
||||
@@ -829,7 +829,9 @@ typedef struct {
|
||||
dns_name_t *qname; /* Question name of request */
|
||||
dns_rdatatype_t qtype; /* dns_rdatatype_{a,i}xfr */
|
||||
dns_rdataclass_t qclass;
|
||||
+#ifndef DLZ
|
||||
dns_zone_t *zone; /* (necessary for stats) */
|
||||
+#endif
|
||||
dns_db_t *db;
|
||||
dns_dbversion_t *ver;
|
||||
isc_quota_t *quota;
|
||||
@@ -1330,10 +1332,14 @@ xfrout_ctx_create(isc_mem_t *mctx, ns_cl
|
||||
xfr->qname = qname;
|
||||
xfr->qtype = qtype;
|
||||
xfr->qclass = qclass;
|
||||
+#ifndef DLZ
|
||||
xfr->zone = NULL;
|
||||
+#endif
|
||||
xfr->db = NULL;
|
||||
xfr->ver = NULL;
|
||||
+#ifndef DLZ
|
||||
dns_zone_attach(zone, &xfr->zone);
|
||||
+#endif
|
||||
dns_db_attach(db, &xfr->db);
|
||||
dns_db_attachversion(db, ver, &xfr->ver);
|
||||
xfr->end_of_stream = ISC_FALSE;
|
||||
@@ -1709,8 +1715,10 @@ xfrout_ctx_destroy(xfrout_ctx_t **xfrp)
|
||||
isc_quota_detach(&xfr->quota);
|
||||
if (xfr->ver != NULL)
|
||||
dns_db_closeversion(xfr->db, &xfr->ver, ISC_FALSE);
|
||||
+#ifndef DLZ
|
||||
if (xfr->zone != NULL)
|
||||
dns_zone_detach(&xfr->zone);
|
||||
+#endif
|
||||
if (xfr->db != NULL)
|
||||
dns_db_detach(&xfr->db);
|
||||
|
||||
@@ -1744,7 +1752,10 @@ xfrout_senddone(isc_task_t *task, isc_ev
|
||||
sendstream(xfr);
|
||||
} else {
|
||||
/* End of zone transfer stream. */
|
||||
+#ifndef DLZ
|
||||
+ /* XXX DLZ zones doesn't support stats */
|
||||
inc_stats(xfr->zone, dns_nsstatscounter_xfrdone);
|
||||
+#endif
|
||||
xfrout_log(xfr, ISC_LOG_INFO, "%s ended", xfr->mnemonic);
|
||||
ns_client_next(xfr->client, ISC_R_SUCCESS);
|
||||
xfrout_ctx_destroy(&xfr);
|
@ -1,25 +0,0 @@
|
||||
diff -up bind-9.5.0-P1/lib/dns/iptable.c.rh457175 bind-9.5.0-P1/lib/dns/iptable.c
|
||||
--- bind-9.5.0-P1/lib/dns/iptable.c.rh457175 2008-01-21 22:02:24.000000000 +0100
|
||||
+++ bind-9.5.0-P1/lib/dns/iptable.c 2008-07-31 16:10:46.000000000 +0200
|
||||
@@ -117,16 +117,17 @@ dns_iptable_merge(dns_iptable_t *tab, dn
|
||||
if (node->data[0] &&
|
||||
*(isc_boolean_t *) node->data[0] == ISC_TRUE)
|
||||
new_node->data[0] = &dns_iptable_neg;
|
||||
- else
|
||||
- new_node->data[0] = node->data[0];
|
||||
|
||||
if (node->data[1] &&
|
||||
*(isc_boolean_t *) node->data[1] == ISC_TRUE)
|
||||
new_node->data[1] = &dns_iptable_neg;
|
||||
- else
|
||||
- new_node->data[1] = node->data[0];
|
||||
}
|
||||
|
||||
+ if (new_node->data[0] == NULL)
|
||||
+ new_node->data[0] = node->data[0];
|
||||
+ if (new_node->data[1] == NULL)
|
||||
+ new_node->data[1] = node->data[1];
|
||||
+
|
||||
if (node->node_num[0] > max_node)
|
||||
max_node = node->node_num[0];
|
||||
if (node->node_num[1] > max_node)
|
4
sources
4
sources
@ -1,4 +1,4 @@
|
||||
4faa4395b955e5f8a3d50f308b9fabc8 bind-chroot.tar.bz2
|
||||
de68e10e91e05ab100be879b5bcaa6cb config-4.tar.bz2
|
||||
13fef79f99fcefebb51d84b08805de51 libbind-man.tar.gz
|
||||
bbd52aadb39f76b50e8413fa165f805e bind-9.5.1b1.tar.gz
|
||||
4faa4395b955e5f8a3d50f308b9fabc8 bind-chroot.tar.bz2
|
||||
7c2ca5b5c49b6259498a3822142afd34 bind-9.5.1b2.tar.gz
|
||||
|
Loading…
Reference in New Issue
Block a user