Fixed bind-devel multilib conflict (#478718)

This commit is contained in:
Tomas Hozza 2012-08-01 15:23:45 +02:00
parent f992a0bef3
commit a013398319
2 changed files with 73 additions and 1 deletions

View File

@ -0,0 +1,67 @@
diff -up bind-9.9.1-P2/config.h.in.multlib-conflict bind-9.9.1-P2/config.h.in
--- bind-9.9.1-P2/config.h.in.multlib-conflict 2012-08-01 14:07:40.300605215 +0200
+++ bind-9.9.1-P2/config.h.in 2012-08-01 14:08:06.449526607 +0200
@@ -400,7 +400,7 @@ int sigwait(const unsigned int *set, int
#undef PORT_NONBLOCK
/* The size of `void *', as computed by sizeof. */
-#undef SIZEOF_VOID_P
+/* #undef SIZEOF_VOID_P */
/* Define to 1 if you have the ANSI C header files. */
#undef STDC_HEADERS
diff -up bind-9.9.1-P2/configure.in.multlib-conflict bind-9.9.1-P2/configure.in
--- bind-9.9.1-P2/configure.in.multlib-conflict 2012-08-01 13:25:04.871278041 +0200
+++ bind-9.9.1-P2/configure.in 2012-08-01 13:25:08.705266546 +0200
@@ -2102,7 +2102,9 @@ int getnameinfo(const struct sockaddr *,
size_t, char *, size_t, int);],
[ return (0);],
[AC_MSG_RESULT(size_t for buflen; int for flags)
- AC_DEFINE(IRS_GETNAMEINFO_BUFLEN_T, size_t)
+ # Changed to solve multilib conflict on Fedora
+ #AC_DEFINE(IRS_GETNAMEINFO_BUFLEN_T, size_t)
+ AC_DEFINE(IRS_GETNAMEINFO_BUFLEN_T, socklen_t)
AC_DEFINE(IRS_GETNAMEINFO_FLAGS_T, int)],
[AC_MSG_RESULT(not match any subspecies; assume standard definition)
AC_DEFINE(IRS_GETNAMEINFO_BUFLEN_T, socklen_t)
diff -up bind-9.9.1-P2/isc-config.sh.in.multlib-conflict bind-9.9.1-P2/isc-config.sh.in
--- bind-9.9.1-P2/isc-config.sh.in.multlib-conflict 2012-08-01 10:30:18.414494493 +0200
+++ bind-9.9.1-P2/isc-config.sh.in 2012-08-01 14:12:11.696789273 +0200
@@ -20,8 +20,19 @@
prefix=@prefix@
exec_prefix=@exec_prefix@
exec_prefix_set=
-libdir=@libdir@
includedir=@includedir@
+arch=$(uname -m)
+
+case $arch in
+ x86_64 | amd64 | sparc64 | s390x | ppc64)
+ libdir=/usr/lib64
+ sec_libdir=/usr/lib
+ ;;
+ * )
+ libdir=/usr/lib
+ sec_libdir=/usr/lib64
+ ;;
+esac
usage()
{
@@ -124,6 +135,16 @@ if test x"$echo_cflags" = x"true"; then
echo $includes
fi
if test x"$echo_libs" = x"true"; then
+ if [ ! -x $libdir/libisc.so ] ; then
+ if [ ! -x $sec_libdir/libisc.so ] ; then
+ echo "Error: ISC libs not found in $libdir"
+ if [ -d $sec_libdir ] ; then
+ echo "Error: ISC libs not found in $sec_libdir"
+ fi
+ exit 1
+ fi
+ libdir=$sec_libdir
+ fi
libs="-L${libdir}"
if test x"$liblwres" = x"true" ; then
libs="$libs -llwres"

View File

@ -22,7 +22,7 @@ Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) serv
Name: bind
License: ISC
Version: 9.9.1
Release: 6.%{PATCHVER}%{?dist}
Release: 7.%{PATCHVER}%{?dist}
Epoch: 32
Url: http://www.isc.org/products/BIND/
Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -73,6 +73,7 @@ Patch125:bind99-buildfix.patch
Patch127:bind99-forward.patch
Patch129:bind98-rh816164.patch
Patch130:bind-9.9.1-P2-dlz-libdb4.patch
Patch131:bind-9.9.1-P2-multlib-conflict.patch
# SDB patches
Patch11: bind-9.3.2b2-sdbsrc.patch
@ -270,6 +271,7 @@ popd
%patch127 -p1 -b .forward
%patch129 -p1 -b .rh816164
%patch130 -p1 -b .libdb4
%patch131 -p1 -b .multlib-conflict
%if %{SDB}
%patch101 -p1 -b .old-api
@ -773,6 +775,9 @@ rm -rf ${RPM_BUILD_ROOT}
%endif
%changelog
* Wed Aug 01 2012 Tomas Hozza <thozza@redhat.com> 32:9.9.1-7.P2
- Fixed bind-devel multilib conflict (#478718)
* Mon Jul 30 2012 Tomas Hozza <thozza@redhat.com> 32:9.9.1-6.P2
- Fixed bad path to systemctl in /etc/NetworkManager/dispatcher.d/13-named (#844047)
- Fixed path to libdb.so in config.dlz.in