Forward export libs path to isc-config
This commit is contained in:
parent
6787c0592a
commit
9a235f827e
39
bind-9.11-export-suffix.patch
Normal file
39
bind-9.11-export-suffix.patch
Normal file
@ -0,0 +1,39 @@
|
||||
diff --git a/configure.in b/configure.in
|
||||
index e6cd6a4..988b0a7 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -5116,6 +5116,8 @@ AC_SUBST(BUILD_CPPFLAGS)
|
||||
AC_SUBST(BUILD_LDFLAGS)
|
||||
AC_SUBST(BUILD_LIBS)
|
||||
|
||||
+AC_SUBST(LIBDIR_SUFFIX)
|
||||
+
|
||||
#
|
||||
# Commands to run at the end of config.status.
|
||||
# Don't just put these into configure, it won't work right if somebody
|
||||
diff --git a/isc-config.sh.in b/isc-config.sh.in
|
||||
index 110191a..5a64004 100644
|
||||
--- a/isc-config.sh.in
|
||||
+++ b/isc-config.sh.in
|
||||
@@ -12,16 +12,17 @@ prefix=@prefix@
|
||||
exec_prefix=@exec_prefix@
|
||||
exec_prefix_set=
|
||||
includedir=@includedir@
|
||||
+libdir_suffix=@LIBDIR_SUFFIX@
|
||||
arch=$(uname -m)
|
||||
|
||||
case $arch in
|
||||
x86_64 | amd64 | sparc64 | s390x | ppc64)
|
||||
- libdir=/usr/lib64
|
||||
- sec_libdir=/usr/lib
|
||||
+ libdir=/usr/lib64${libdir_suffix}
|
||||
+ sec_libdir=/usr/lib${libdir_suffix}
|
||||
;;
|
||||
* )
|
||||
- libdir=/usr/lib
|
||||
- sec_libdir=/usr/lib64
|
||||
+ libdir=/usr/lib${libdir_suffix}
|
||||
+ sec_libdir=/usr/lib64${libdir_suffix}
|
||||
;;
|
||||
esac
|
||||
|
@ -109,6 +109,7 @@ Patch150:bind-9.11-kyua-portfix.patch
|
||||
# [ISC-Bugs #46333] commit 66258ca349b7398062e684337b19c5ce76701037 ISC 4776
|
||||
Patch151:bind-9.11-kyua-ht_test.patch
|
||||
Patch152:bind-9.11-kyua-unit-oot.patch
|
||||
Patch153:bind-9.11-export-suffix.patch
|
||||
|
||||
# SDB patches
|
||||
Patch11: bind-9.3.2b2-sdbsrc.patch
|
||||
@ -456,6 +457,7 @@ are used for building ISC DHCP.
|
||||
%patch150 -p1 -b .kyua-portfix
|
||||
%patch151 -p1 -b .kyua-ht_test
|
||||
%patch152 -p1 -b .kyua-unit-oot
|
||||
%patch153 -p1 -b .export_suffix
|
||||
|
||||
%if %{PKCS11}
|
||||
cp -r bin/named{,-pkcs11}
|
||||
@ -535,6 +537,8 @@ libtoolize -c -f; aclocal -I libtool.m4 --force; autoconf -f
|
||||
|
||||
mkdir build
|
||||
pushd build
|
||||
LIBDIR_SUFFIX=
|
||||
export LIBDIR_SUFFIX
|
||||
%configure \
|
||||
--with-python=%{__python3} \
|
||||
--with-libtool \
|
||||
@ -614,6 +618,8 @@ popd # build
|
||||
## Create export libs ##
|
||||
mkdir -p export-libs
|
||||
pushd export-libs
|
||||
LIBDIR_SUFFIX=%{_export_dir}
|
||||
export LIBDIR_SUFFIX
|
||||
## minimal subset of options to make clients aka dhcp working
|
||||
%{configure} \
|
||||
--with-libtool \
|
||||
@ -621,7 +627,7 @@ pushd export-libs
|
||||
--disable-epoll \
|
||||
--disable-kqueue \
|
||||
--libdir=%{_libdir}%{_export_dir} \
|
||||
--includedir=%{_includedir}/%{_export_dir}/ \
|
||||
--includedir=%{_includedir}%{_export_dir}/ \
|
||||
--disable-threads \
|
||||
--with-gssapi=yes \
|
||||
--disable-isc-spnego \
|
||||
@ -1400,6 +1406,7 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%changelog
|
||||
* Wed Feb 07 2018 Petr Menšík <pemensik@redhat.com> - 32:9.11.2-11.P1
|
||||
- Fix starting of unit tests
|
||||
- Forward export libs path to isc-config
|
||||
|
||||
* Wed Feb 07 2018 Pavel Zhukov <pzhukov@redhat.com> - 32:9.11.2-10.P1
|
||||
- Add obsoletes/provides tags for smooth update
|
||||
|
Loading…
Reference in New Issue
Block a user