Update the dyndb patch.

Signed-off-by: Adam Tkac <atkac@redhat.com>
This commit is contained in:
Adam Tkac 2011-06-02 12:26:12 +02:00
parent 36ea44a658
commit 95c9b3fdb6
2 changed files with 45 additions and 40 deletions

View File

@ -1,6 +1,6 @@
diff -up bind-9.8.0rc1/bin/named/main.c.dyndb bind-9.8.0rc1/bin/named/main.c diff -up bind-9.8.0-P2/bin/named/main.c.dyndb bind-9.8.0-P2/bin/named/main.c
--- bind-9.8.0rc1/bin/named/main.c.dyndb 2010-12-22 04:59:02.000000000 +0100 --- bind-9.8.0-P2/bin/named/main.c.dyndb 2010-12-22 04:59:02.000000000 +0100
+++ bind-9.8.0rc1/bin/named/main.c 2011-02-21 16:27:08.408863231 +0100 +++ bind-9.8.0-P2/bin/named/main.c 2011-06-02 12:13:15.957660734 +0200
@@ -45,6 +45,7 @@ @@ -45,6 +45,7 @@
#include <isccc/result.h> #include <isccc/result.h>
@ -18,9 +18,9 @@ diff -up bind-9.8.0rc1/bin/named/main.c.dyndb bind-9.8.0rc1/bin/named/main.c
destroy_managers(); destroy_managers();
ns_server_destroy(&ns_g_server); ns_server_destroy(&ns_g_server);
diff -up bind-9.8.0rc1/bin/named/server.c.dyndb bind-9.8.0rc1/bin/named/server.c diff -up bind-9.8.0-P2/bin/named/server.c.dyndb bind-9.8.0-P2/bin/named/server.c
--- bind-9.8.0rc1/bin/named/server.c.dyndb 2011-02-03 13:17:49.000000000 +0100 --- bind-9.8.0-P2/bin/named/server.c.dyndb 2011-02-16 20:46:12.000000000 +0100
+++ bind-9.8.0rc1/bin/named/server.c 2011-02-21 16:27:44.208789205 +0100 +++ bind-9.8.0-P2/bin/named/server.c 2011-06-02 12:13:15.960660734 +0200
@@ -63,6 +63,7 @@ @@ -63,6 +63,7 @@
#ifdef DLZ #ifdef DLZ
#include <dns/dlz.h> #include <dns/dlz.h>
@ -148,7 +148,7 @@ diff -up bind-9.8.0rc1/bin/named/server.c.dyndb bind-9.8.0rc1/bin/named/server.c
* Obtain configuration parameters that affect the decision of whether * Obtain configuration parameters that affect the decision of whether
* we can reuse/share an existing cache. * we can reuse/share an existing cache.
*/ */
@@ -4186,6 +4285,7 @@ load_configuration(const char *filename, @@ -4187,6 +4286,7 @@ load_configuration(const char *filename,
result = isc_task_beginexclusive(server->task); result = isc_task_beginexclusive(server->task);
RUNTIME_CHECK(result == ISC_R_SUCCESS); RUNTIME_CHECK(result == ISC_R_SUCCESS);
@ -156,7 +156,7 @@ diff -up bind-9.8.0rc1/bin/named/server.c.dyndb bind-9.8.0rc1/bin/named/server.c
/* /*
* Parse the global default pseudo-config file. * Parse the global default pseudo-config file.
*/ */
@@ -5541,6 +5641,8 @@ loadconfig(ns_server_t *server) { @@ -5542,6 +5642,8 @@ loadconfig(ns_server_t *server) {
static isc_result_t static isc_result_t
reload(ns_server_t *server) { reload(ns_server_t *server) {
isc_result_t result; isc_result_t result;
@ -165,12 +165,12 @@ diff -up bind-9.8.0rc1/bin/named/server.c.dyndb bind-9.8.0rc1/bin/named/server.c
CHECK(loadconfig(server)); CHECK(loadconfig(server));
result = load_zones(server, ISC_FALSE); result = load_zones(server, ISC_FALSE);
diff -up bind-9.8.0rc1/lib/dns/dynamic_db.c.dyndb bind-9.8.0rc1/lib/dns/dynamic_db.c diff -up bind-9.8.0-P2/lib/dns/dynamic_db.c.dyndb bind-9.8.0-P2/lib/dns/dynamic_db.c
--- bind-9.8.0rc1/lib/dns/dynamic_db.c.dyndb 2011-02-21 16:27:08.408863231 +0100 --- bind-9.8.0-P2/lib/dns/dynamic_db.c.dyndb 2011-06-02 12:13:15.984660736 +0200
+++ bind-9.8.0rc1/lib/dns/dynamic_db.c 2011-02-21 16:27:08.408863231 +0100 +++ bind-9.8.0-P2/lib/dns/dynamic_db.c 2011-06-02 12:13:15.984660736 +0200
@@ -0,0 +1,364 @@ @@ -0,0 +1,366 @@
+/* +/*
+ * Copyright (C) 2008-2009 Red Hat, Inc. + * Copyright (C) 2008-2011 Red Hat, Inc.
+ * + *
+ * Permission to use, copy, modify, and/or distribute this software for any + * Permission to use, copy, modify, and/or distribute this software for any
+ * purpose with or without fee is hereby granted, provided that the above + * purpose with or without fee is hereby granted, provided that the above
@ -221,7 +221,8 @@ diff -up bind-9.8.0rc1/lib/dns/dynamic_db.c.dyndb bind-9.8.0rc1/lib/dns/dynamic_
+ +
+ +
+typedef isc_result_t (*register_func_t)(isc_mem_t *mctx, const char *name, +typedef isc_result_t (*register_func_t)(isc_mem_t *mctx, const char *name,
+ const char * const *argv, dns_dyndb_arguments_t *dyndb_args); + const char * const *argv,
+ const dns_dyndb_arguments_t *dyndb_args);
+typedef void (*destroy_func_t)(void); +typedef void (*destroy_func_t)(void);
+ +
+typedef struct dyndb_implementation dyndb_implementation_t; +typedef struct dyndb_implementation dyndb_implementation_t;
@ -289,7 +290,7 @@ diff -up bind-9.8.0rc1/lib/dns/dynamic_db.c.dyndb bind-9.8.0rc1/lib/dns/dynamic_
+ size_t module_size; + size_t module_size;
+ isc_buffer_t *module_buf = NULL; + isc_buffer_t *module_buf = NULL;
+ isc_region_t module_region; + isc_region_t module_region;
+ void *handle; + void *handle = NULL;
+ dyndb_implementation_t *imp; + dyndb_implementation_t *imp;
+ register_func_t register_function = NULL; + register_func_t register_function = NULL;
+ destroy_func_t destroy_function = NULL; + destroy_func_t destroy_function = NULL;
@ -390,7 +391,8 @@ diff -up bind-9.8.0rc1/lib/dns/dynamic_db.c.dyndb bind-9.8.0rc1/lib/dns/dynamic_
+ +
+isc_result_t +isc_result_t
+dns_dynamic_db_load(const char *libname, const char *name, isc_mem_t *mctx, +dns_dynamic_db_load(const char *libname, const char *name, isc_mem_t *mctx,
+ const char * const *argv, dns_dyndb_arguments_t *dyndb_args) + const char * const *argv,
+ const dns_dyndb_arguments_t *dyndb_args)
+{ +{
+ isc_result_t result; + isc_result_t result;
+ dyndb_implementation_t *implementation = NULL; + dyndb_implementation_t *implementation = NULL;
@ -533,12 +535,12 @@ diff -up bind-9.8.0rc1/lib/dns/dynamic_db.c.dyndb bind-9.8.0rc1/lib/dns/dynamic_
+ +
+ return args->timermgr; + return args->timermgr;
+} +}
diff -up bind-9.8.0rc1/lib/dns/include/dns/dynamic_db.h.dyndb bind-9.8.0rc1/lib/dns/include/dns/dynamic_db.h diff -up bind-9.8.0-P2/lib/dns/include/dns/dynamic_db.h.dyndb bind-9.8.0-P2/lib/dns/include/dns/dynamic_db.h
--- bind-9.8.0rc1/lib/dns/include/dns/dynamic_db.h.dyndb 2011-02-21 16:27:08.408863231 +0100 --- bind-9.8.0-P2/lib/dns/include/dns/dynamic_db.h.dyndb 2011-06-02 12:13:15.962660734 +0200
+++ bind-9.8.0rc1/lib/dns/include/dns/dynamic_db.h 2011-02-21 16:27:08.408863231 +0100 +++ bind-9.8.0-P2/lib/dns/include/dns/dynamic_db.h 2011-06-02 12:13:15.962660734 +0200
@@ -0,0 +1,50 @@ @@ -0,0 +1,50 @@
+/* +/*
+ * Copyright (C) 2008-2009 Red Hat, Inc. + * Copyright (C) 2008-2011 Red Hat, Inc.
+ * + *
+ * Permission to use, copy, modify, and/or distribute this software for any + * Permission to use, copy, modify, and/or distribute this software for any
+ * purpose with or without fee is hereby granted, provided that the above + * purpose with or without fee is hereby granted, provided that the above
@ -569,7 +571,7 @@ diff -up bind-9.8.0rc1/lib/dns/include/dns/dynamic_db.h.dyndb bind-9.8.0rc1/lib/
+ +
+isc_result_t dns_dynamic_db_load(const char *libname, const char *name, +isc_result_t dns_dynamic_db_load(const char *libname, const char *name,
+ isc_mem_t *mctx, const char * const *argv, + isc_mem_t *mctx, const char * const *argv,
+ dns_dyndb_arguments_t *dyndb_args); + const dns_dyndb_arguments_t *dyndb_args);
+ +
+void dns_dynamic_db_cleanup(isc_boolean_t exiting); +void dns_dynamic_db_cleanup(isc_boolean_t exiting);
+ +
@ -587,9 +589,9 @@ diff -up bind-9.8.0rc1/lib/dns/include/dns/dynamic_db.h.dyndb bind-9.8.0rc1/lib/
+isc_timermgr_t *dns_dyndb_get_timermgr(dns_dyndb_arguments_t *args); +isc_timermgr_t *dns_dyndb_get_timermgr(dns_dyndb_arguments_t *args);
+ +
+#endif +#endif
diff -up bind-9.8.0rc1/lib/dns/include/dns/log.h.dyndb bind-9.8.0rc1/lib/dns/include/dns/log.h diff -up bind-9.8.0-P2/lib/dns/include/dns/log.h.dyndb bind-9.8.0-P2/lib/dns/include/dns/log.h
--- bind-9.8.0rc1/lib/dns/include/dns/log.h.dyndb 2009-12-18 23:16:49.000000000 +0100 --- bind-9.8.0-P2/lib/dns/include/dns/log.h.dyndb 2009-12-18 23:16:49.000000000 +0100
+++ bind-9.8.0rc1/lib/dns/include/dns/log.h 2011-02-21 16:27:08.408863231 +0100 +++ bind-9.8.0-P2/lib/dns/include/dns/log.h 2011-06-02 12:13:15.962660734 +0200
@@ -74,6 +74,7 @@ LIBDNS_EXTERNAL_DATA extern isc_logmodul @@ -74,6 +74,7 @@ LIBDNS_EXTERNAL_DATA extern isc_logmodul
#define DNS_LOGMODULE_ACACHE (&dns_modules[25]) #define DNS_LOGMODULE_ACACHE (&dns_modules[25])
#define DNS_LOGMODULE_DLZ (&dns_modules[26]) #define DNS_LOGMODULE_DLZ (&dns_modules[26])
@ -598,9 +600,9 @@ diff -up bind-9.8.0rc1/lib/dns/include/dns/log.h.dyndb bind-9.8.0rc1/lib/dns/inc
ISC_LANG_BEGINDECLS ISC_LANG_BEGINDECLS
diff -up bind-9.8.0rc1/lib/dns/include/dns/Makefile.in.dyndb bind-9.8.0rc1/lib/dns/include/dns/Makefile.in diff -up bind-9.8.0-P2/lib/dns/include/dns/Makefile.in.dyndb bind-9.8.0-P2/lib/dns/include/dns/Makefile.in
--- bind-9.8.0rc1/lib/dns/include/dns/Makefile.in.dyndb 2009-10-09 01:48:10.000000000 +0200 --- bind-9.8.0-P2/lib/dns/include/dns/Makefile.in.dyndb 2009-10-09 01:48:10.000000000 +0200
+++ bind-9.8.0rc1/lib/dns/include/dns/Makefile.in 2011-02-21 16:27:08.408863231 +0100 +++ bind-9.8.0-P2/lib/dns/include/dns/Makefile.in 2011-06-02 12:13:15.963660734 +0200
@@ -22,7 +22,7 @@ top_srcdir = @top_srcdir@ @@ -22,7 +22,7 @@ top_srcdir = @top_srcdir@
@BIND9_VERSION@ @BIND9_VERSION@
@ -610,9 +612,9 @@ diff -up bind-9.8.0rc1/lib/dns/include/dns/Makefile.in.dyndb bind-9.8.0rc1/lib/d
dnssec.h ds.h events.h fixedname.h iptable.h journal.h \ dnssec.h ds.h events.h fixedname.h iptable.h journal.h \
keyflags.h keytable.h keyvalues.h lib.h log.h \ keyflags.h keytable.h keyvalues.h lib.h log.h \
master.h masterdump.h message.h name.h ncache.h nsec.h \ master.h masterdump.h message.h name.h ncache.h nsec.h \
diff -up bind-9.8.0rc1/lib/dns/include/dns/types.h.dyndb bind-9.8.0rc1/lib/dns/include/dns/types.h diff -up bind-9.8.0-P2/lib/dns/include/dns/types.h.dyndb bind-9.8.0-P2/lib/dns/include/dns/types.h
--- bind-9.8.0rc1/lib/dns/include/dns/types.h.dyndb 2010-12-08 03:46:16.000000000 +0100 --- bind-9.8.0-P2/lib/dns/include/dns/types.h.dyndb 2010-12-08 03:46:16.000000000 +0100
+++ bind-9.8.0rc1/lib/dns/include/dns/types.h 2011-02-21 16:27:08.408863231 +0100 +++ bind-9.8.0-P2/lib/dns/include/dns/types.h 2011-06-02 12:13:15.974660734 +0200
@@ -60,6 +60,7 @@ typedef struct dns_dbtable dns_dbtable @@ -60,6 +60,7 @@ typedef struct dns_dbtable dns_dbtable
typedef void dns_dbversion_t; typedef void dns_dbversion_t;
typedef struct dns_dlzimplementation dns_dlzimplementation_t; typedef struct dns_dlzimplementation dns_dlzimplementation_t;
@ -621,9 +623,9 @@ diff -up bind-9.8.0rc1/lib/dns/include/dns/types.h.dyndb bind-9.8.0rc1/lib/dns/i
typedef struct dns_sdlzimplementation dns_sdlzimplementation_t; typedef struct dns_sdlzimplementation dns_sdlzimplementation_t;
typedef struct dns_decompress dns_decompress_t; typedef struct dns_decompress dns_decompress_t;
typedef struct dns_dispatch dns_dispatch_t; typedef struct dns_dispatch dns_dispatch_t;
diff -up bind-9.8.0rc1/lib/dns/log.c.dyndb bind-9.8.0rc1/lib/dns/log.c diff -up bind-9.8.0-P2/lib/dns/log.c.dyndb bind-9.8.0-P2/lib/dns/log.c
--- bind-9.8.0rc1/lib/dns/log.c.dyndb 2009-12-19 00:49:03.000000000 +0100 --- bind-9.8.0-P2/lib/dns/log.c.dyndb 2009-12-19 00:49:03.000000000 +0100
+++ bind-9.8.0rc1/lib/dns/log.c 2011-02-21 16:27:08.408863231 +0100 +++ bind-9.8.0-P2/lib/dns/log.c 2011-06-02 12:13:15.981660733 +0200
@@ -80,6 +80,7 @@ LIBDNS_EXTERNAL_DATA isc_logmodule_t dns @@ -80,6 +80,7 @@ LIBDNS_EXTERNAL_DATA isc_logmodule_t dns
{ "dns/acache", 0 }, { "dns/acache", 0 },
{ "dns/dlz", 0 }, { "dns/dlz", 0 },
@ -632,9 +634,9 @@ diff -up bind-9.8.0rc1/lib/dns/log.c.dyndb bind-9.8.0rc1/lib/dns/log.c
{ NULL, 0 } { NULL, 0 }
}; };
diff -up bind-9.8.0rc1/lib/dns/Makefile.in.dyndb bind-9.8.0rc1/lib/dns/Makefile.in diff -up bind-9.8.0-P2/lib/dns/Makefile.in.dyndb bind-9.8.0-P2/lib/dns/Makefile.in
--- bind-9.8.0rc1/lib/dns/Makefile.in.dyndb 2011-02-21 16:27:08.398863252 +0100 --- bind-9.8.0-P2/lib/dns/Makefile.in.dyndb 2011-06-02 12:13:15.943660734 +0200
+++ bind-9.8.0rc1/lib/dns/Makefile.in 2011-02-21 16:28:31.708690237 +0100 +++ bind-9.8.0-P2/lib/dns/Makefile.in 2011-06-02 12:13:15.981660733 +0200
@@ -58,7 +58,7 @@ DNSOBJS = acache.@O@ acl.@O@ adb.@O@ bya @@ -58,7 +58,7 @@ DNSOBJS = acache.@O@ acl.@O@ adb.@O@ bya
cache.@O@ callbacks.@O@ compress.@O@ \ cache.@O@ callbacks.@O@ compress.@O@ \
db.@O@ dbiterator.@O@ dbtable.@O@ diff.@O@ dispatch.@O@ \ db.@O@ dbiterator.@O@ dbtable.@O@ diff.@O@ dispatch.@O@ \
@ -665,9 +667,9 @@ diff -up bind-9.8.0rc1/lib/dns/Makefile.in.dyndb bind-9.8.0rc1/lib/dns/Makefile.
libdns.@SA@: ${OBJS} libdns.@SA@: ${OBJS}
${AR} ${ARFLAGS} $@ ${OBJS} ${AR} ${ARFLAGS} $@ ${OBJS}
${RANLIB} $@ ${RANLIB} $@
diff -up bind-9.8.0rc1/lib/isccfg/namedconf.c.dyndb bind-9.8.0rc1/lib/isccfg/namedconf.c diff -up bind-9.8.0-P2/lib/isccfg/namedconf.c.dyndb bind-9.8.0-P2/lib/isccfg/namedconf.c
--- bind-9.8.0rc1/lib/isccfg/namedconf.c.dyndb 2011-02-03 06:50:08.000000000 +0100 --- bind-9.8.0-P2/lib/isccfg/namedconf.c.dyndb 2011-02-03 06:50:08.000000000 +0100
+++ bind-9.8.0rc1/lib/isccfg/namedconf.c 2011-02-21 16:27:08.418863210 +0100 +++ bind-9.8.0-P2/lib/isccfg/namedconf.c 2011-06-02 12:13:15.983660735 +0200
@@ -89,6 +89,7 @@ static cfg_type_t cfg_type_controls; @@ -89,6 +89,7 @@ static cfg_type_t cfg_type_controls;
static cfg_type_t cfg_type_controls_sockaddr; static cfg_type_t cfg_type_controls_sockaddr;
static cfg_type_t cfg_type_destinationlist; static cfg_type_t cfg_type_destinationlist;

View File

@ -22,7 +22,7 @@ Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) serv
Name: bind Name: bind
License: ISC License: ISC
Version: 9.8.0 Version: 9.8.0
Release: 5.%{PATCHVER}%{?dist} Release: 6.%{PATCHVER}%{?dist}
Epoch: 32 Epoch: 32
Url: http://www.isc.org/products/BIND/ Url: http://www.isc.org/products/BIND/
Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -772,6 +772,9 @@ rm -rf ${RPM_BUILD_ROOT}
%endif %endif
%changelog %changelog
* Thu Jun 02 2011 Adam Tkac <atkac redhat com> 32:9.8.0-6.P2
- update the dyndb patch
* Fri May 27 2011 Adam Tkac <atkac redhat com> 32:9.8.0-5.P2 * Fri May 27 2011 Adam Tkac <atkac redhat com> 32:9.8.0-5.P2
- fix compilation of libdns-export.so - fix compilation of libdns-export.so