- 9.6.0rc2 release
- bind-96-rh475120.patch merged
This commit is contained in:
parent
b1c08c198e
commit
8ff18349e6
@ -1,5 +1,5 @@
|
|||||||
config-4.tar.bz2
|
config-4.tar.bz2
|
||||||
libbind-man.tar.gz
|
libbind-man.tar.gz
|
||||||
bind-chroot.tar.bz2
|
bind-chroot.tar.bz2
|
||||||
bind-9.6.0rc1.tar.gz
|
bind-9.6.0rc2.tar.gz
|
||||||
libbind-9.5.1b2.tar.bz2
|
libbind-9.5.1b2.tar.bz2
|
||||||
|
@ -1,19 +0,0 @@
|
|||||||
diff -up bind-9.6.0rc1/lib/dns/dispatch.c.rh475120 bind-9.6.0rc1/lib/dns/dispatch.c
|
|
||||||
--- bind-9.6.0rc1/lib/dns/dispatch.c.rh475120 2008-11-13 00:10:57.000000000 +0100
|
|
||||||
+++ bind-9.6.0rc1/lib/dns/dispatch.c 2008-12-09 15:06:18.000000000 +0100
|
|
||||||
@@ -2702,6 +2702,15 @@ get_udpsocket(dns_dispatchmgr_t *mgr, dn
|
|
||||||
* If this fails 1024 times, we then ask the kernel for
|
|
||||||
* choosing one.
|
|
||||||
*/
|
|
||||||
+ } else {
|
|
||||||
+ /* Allow to reuse address for non-random ports */
|
|
||||||
+ result = open_socket(sockmgr, localaddr,
|
|
||||||
+ ISC_SOCKET_REUSEADDRESS, &sock);
|
|
||||||
+
|
|
||||||
+ if (result == ISC_R_SUCCESS)
|
|
||||||
+ *sockp = sock;
|
|
||||||
+
|
|
||||||
+ return (result);
|
|
||||||
}
|
|
||||||
|
|
||||||
memset(held, 0, sizeof(held));
|
|
10
bind.spec
10
bind.spec
@ -2,7 +2,7 @@
|
|||||||
# Red Hat BIND package .spec file
|
# Red Hat BIND package .spec file
|
||||||
#
|
#
|
||||||
|
|
||||||
%define PREVER rc1
|
%define PREVER rc2
|
||||||
%define VERSION %{version}%{PREVER}
|
%define VERSION %{version}%{PREVER}
|
||||||
|
|
||||||
%{?!SDB: %define SDB 1}
|
%{?!SDB: %define SDB 1}
|
||||||
@ -18,7 +18,7 @@ Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) serv
|
|||||||
Name: bind
|
Name: bind
|
||||||
License: ISC
|
License: ISC
|
||||||
Version: 9.6.0
|
Version: 9.6.0
|
||||||
Release: 0.6.%{PREVER}%{?dist}
|
Release: 0.7.%{PREVER}%{?dist}
|
||||||
Epoch: 32
|
Epoch: 32
|
||||||
Url: http://www.isc.org/products/BIND/
|
Url: http://www.isc.org/products/BIND/
|
||||||
Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -63,7 +63,6 @@ Patch100:bind-96-libtool2-libbind.patch
|
|||||||
Patch99: bind-96-libtool2.patch
|
Patch99: bind-96-libtool2.patch
|
||||||
Patch101:bind-96-old-api.patch
|
Patch101:bind-96-old-api.patch
|
||||||
Patch102:bind-95-rh452060.patch
|
Patch102:bind-95-rh452060.patch
|
||||||
Patch103:bind-96-rh475120.patch
|
|
||||||
|
|
||||||
# SDB patches
|
# SDB patches
|
||||||
Patch11: bind-9.3.2b2-sdbsrc.patch
|
Patch11: bind-9.3.2b2-sdbsrc.patch
|
||||||
@ -242,7 +241,6 @@ mkdir lib/bind/m4
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%patch102 -p1 -b .rh452060
|
%patch102 -p1 -b .rh452060
|
||||||
%patch103 -p1 -b .rh475120
|
|
||||||
|
|
||||||
# Sparc and s390 arches need to use -fPIE
|
# Sparc and s390 arches need to use -fPIE
|
||||||
%ifarch sparcv9 sparc64 s390 s390x
|
%ifarch sparcv9 sparc64 s390 s390x
|
||||||
@ -601,6 +599,10 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%ghost %{chroot_prefix}/etc/localtime
|
%ghost %{chroot_prefix}/etc/localtime
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Dec 18 2008 Adam Tkac <atkac redhat com> 32:9.6.0-0.7.rc2
|
||||||
|
- 9.6.0rc2 release
|
||||||
|
- bind-96-rh475120.patch merged
|
||||||
|
|
||||||
* Tue Dec 16 2008 Martin Nagy <mnagy redhat com> 32:9.6.0-0.6.rc1
|
* Tue Dec 16 2008 Martin Nagy <mnagy redhat com> 32:9.6.0-0.6.rc1
|
||||||
- add patch for dynamic loading of database backends
|
- add patch for dynamic loading of database backends
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,5 +1,5 @@
|
|||||||
de68e10e91e05ab100be879b5bcaa6cb config-4.tar.bz2
|
de68e10e91e05ab100be879b5bcaa6cb config-4.tar.bz2
|
||||||
13fef79f99fcefebb51d84b08805de51 libbind-man.tar.gz
|
13fef79f99fcefebb51d84b08805de51 libbind-man.tar.gz
|
||||||
4faa4395b955e5f8a3d50f308b9fabc8 bind-chroot.tar.bz2
|
4faa4395b955e5f8a3d50f308b9fabc8 bind-chroot.tar.bz2
|
||||||
f4afbc1a4695fd1f6a6fb5fefc389f08 bind-9.6.0rc1.tar.gz
|
6a2cf98100ac5df8b7f70931456d73f5 bind-9.6.0rc2.tar.gz
|
||||||
3d1dad3630ec3510c8ab0ac2217a3317 libbind-9.5.1b2.tar.bz2
|
3d1dad3630ec3510c8ab0ac2217a3317 libbind-9.5.1b2.tar.bz2
|
||||||
|
Loading…
Reference in New Issue
Block a user