Update to 9.9.0b2 (CVE-2011-4313)
Patches merged - bind97-rh700097.patch - bind99-cinfo.patch Signed-off-by: Adam Tkac <atkac@redhat.com>
This commit is contained in:
parent
6161cf7d2c
commit
8e38086c4b
1
.gitignore
vendored
1
.gitignore
vendored
@ -17,3 +17,4 @@ bind-9.7.2b1.tar.gz
|
|||||||
/bind-9.8.1rc1.tar.gz
|
/bind-9.8.1rc1.tar.gz
|
||||||
/bind-9.8.1.tar.gz
|
/bind-9.8.1.tar.gz
|
||||||
/bind-9.9.0b1.tar.gz
|
/bind-9.9.0b1.tar.gz
|
||||||
|
/bind-9.9.0b2.tar.gz
|
||||||
|
@ -27,20 +27,6 @@ diff -up bind-9.5.1b1/contrib/dlz/config.dlz.in.64bit bind-9.5.1b1/contrib/dlz/c
|
|||||||
else
|
else
|
||||||
mysql_lib=$d/lib
|
mysql_lib=$d/lib
|
||||||
fi
|
fi
|
||||||
@@ -274,11 +281,11 @@ case "$use_dlz_bdb" in
|
|
||||||
bdb_libnames="db42 db-4.2 db41 db-4.1 db"
|
|
||||||
for d in $bdb_libnames
|
|
||||||
do
|
|
||||||
- if test -f "$dd/lib/lib${d}.so"
|
|
||||||
+ if test -f "$dd/${target_lib}/lib${d}.so"
|
|
||||||
then
|
|
||||||
if test "$dd" != "/usr"
|
|
||||||
then
|
|
||||||
- dlz_bdb_libs="-L${dd}/lib "
|
|
||||||
+ dlz_bdb_libs="-L${dd}/${target_lib} "
|
|
||||||
else
|
|
||||||
dlz_bdb_libs=""
|
|
||||||
fi
|
|
||||||
@@ -383,7 +390,7 @@ case "$use_dlz_ldap" in
|
@@ -383,7 +390,7 @@ case "$use_dlz_ldap" in
|
||||||
*)
|
*)
|
||||||
DLZ_ADD_DRIVER(LDAP, dlz_ldap_driver,
|
DLZ_ADD_DRIVER(LDAP, dlz_ldap_driver,
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -up bind-9.9.0b1/bin/named/main.c.dyndb bind-9.9.0b1/bin/named/main.c
|
diff -up bind-9.9.0b2/bin/named/main.c.dyndb bind-9.9.0b2/bin/named/main.c
|
||||||
--- bind-9.9.0b1/bin/named/main.c.dyndb 2011-03-11 07:11:21.000000000 +0100
|
--- bind-9.9.0b2/bin/named/main.c.dyndb 2011-11-09 19:44:03.000000000 +0100
|
||||||
+++ bind-9.9.0b1/bin/named/main.c 2011-11-10 12:47:24.182292777 +0100
|
+++ bind-9.9.0b2/bin/named/main.c 2011-11-22 12:56:27.907485613 +0100
|
||||||
@@ -45,6 +45,7 @@
|
@@ -45,6 +45,7 @@
|
||||||
#include <isccc/result.h>
|
#include <isccc/result.h>
|
||||||
|
|
||||||
@ -9,7 +9,7 @@ diff -up bind-9.9.0b1/bin/named/main.c.dyndb bind-9.9.0b1/bin/named/main.c
|
|||||||
#include <dns/name.h>
|
#include <dns/name.h>
|
||||||
#include <dns/result.h>
|
#include <dns/result.h>
|
||||||
#include <dns/view.h>
|
#include <dns/view.h>
|
||||||
@@ -884,6 +885,8 @@ setup(void) {
|
@@ -914,6 +915,8 @@ setup(void) {
|
||||||
|
|
||||||
static void
|
static void
|
||||||
cleanup(void) {
|
cleanup(void) {
|
||||||
@ -18,9 +18,9 @@ diff -up bind-9.9.0b1/bin/named/main.c.dyndb bind-9.9.0b1/bin/named/main.c
|
|||||||
destroy_managers();
|
destroy_managers();
|
||||||
|
|
||||||
ns_server_destroy(&ns_g_server);
|
ns_server_destroy(&ns_g_server);
|
||||||
diff -up bind-9.9.0b1/bin/named/server.c.dyndb bind-9.9.0b1/bin/named/server.c
|
diff -up bind-9.9.0b2/bin/named/server.c.dyndb bind-9.9.0b2/bin/named/server.c
|
||||||
--- bind-9.9.0b1/bin/named/server.c.dyndb 2011-10-28 14:08:04.000000000 +0200
|
--- bind-9.9.0b2/bin/named/server.c.dyndb 2011-11-09 19:44:03.000000000 +0100
|
||||||
+++ bind-9.9.0b1/bin/named/server.c 2011-11-10 12:47:24.185292777 +0100
|
+++ bind-9.9.0b2/bin/named/server.c 2011-11-22 12:56:27.911485608 +0100
|
||||||
@@ -63,6 +63,7 @@
|
@@ -63,6 +63,7 @@
|
||||||
#include <dns/db.h>
|
#include <dns/db.h>
|
||||||
#include <dns/dispatch.h>
|
#include <dns/dispatch.h>
|
||||||
@ -150,7 +150,7 @@ diff -up bind-9.9.0b1/bin/named/server.c.dyndb bind-9.9.0b1/bin/named/server.c
|
|||||||
/*
|
/*
|
||||||
* Obtain configuration parameters that affect the decision of whether
|
* Obtain configuration parameters that affect the decision of whether
|
||||||
* we can reuse/share an existing cache.
|
* we can reuse/share an existing cache.
|
||||||
@@ -4354,6 +4455,7 @@ load_configuration(const char *filename,
|
@@ -4360,6 +4461,7 @@ load_configuration(const char *filename,
|
||||||
cfg_aclconfctx_detach(&ns_g_aclconfctx);
|
cfg_aclconfctx_detach(&ns_g_aclconfctx);
|
||||||
CHECK(cfg_aclconfctx_create(ns_g_mctx, &ns_g_aclconfctx));
|
CHECK(cfg_aclconfctx_create(ns_g_mctx, &ns_g_aclconfctx));
|
||||||
|
|
||||||
@ -158,9 +158,9 @@ diff -up bind-9.9.0b1/bin/named/server.c.dyndb bind-9.9.0b1/bin/named/server.c
|
|||||||
/*
|
/*
|
||||||
* Parse the global default pseudo-config file.
|
* Parse the global default pseudo-config file.
|
||||||
*/
|
*/
|
||||||
diff -up bind-9.9.0b1/lib/dns/dynamic_db.c.dyndb bind-9.9.0b1/lib/dns/dynamic_db.c
|
diff -up bind-9.9.0b2/lib/dns/dynamic_db.c.dyndb bind-9.9.0b2/lib/dns/dynamic_db.c
|
||||||
--- bind-9.9.0b1/lib/dns/dynamic_db.c.dyndb 2011-11-10 12:47:24.186292776 +0100
|
--- bind-9.9.0b2/lib/dns/dynamic_db.c.dyndb 2011-11-22 12:56:27.912485606 +0100
|
||||||
+++ bind-9.9.0b1/lib/dns/dynamic_db.c 2011-11-10 12:47:24.186292776 +0100
|
+++ bind-9.9.0b2/lib/dns/dynamic_db.c 2011-11-22 12:56:27.912485606 +0100
|
||||||
@@ -0,0 +1,366 @@
|
@@ -0,0 +1,366 @@
|
||||||
+/*
|
+/*
|
||||||
+ * Copyright (C) 2008-2011 Red Hat, Inc.
|
+ * Copyright (C) 2008-2011 Red Hat, Inc.
|
||||||
@ -528,9 +528,9 @@ diff -up bind-9.9.0b1/lib/dns/dynamic_db.c.dyndb bind-9.9.0b1/lib/dns/dynamic_db
|
|||||||
+
|
+
|
||||||
+ return args->timermgr;
|
+ return args->timermgr;
|
||||||
+}
|
+}
|
||||||
diff -up bind-9.9.0b1/lib/dns/include/dns/dynamic_db.h.dyndb bind-9.9.0b1/lib/dns/include/dns/dynamic_db.h
|
diff -up bind-9.9.0b2/lib/dns/include/dns/dynamic_db.h.dyndb bind-9.9.0b2/lib/dns/include/dns/dynamic_db.h
|
||||||
--- bind-9.9.0b1/lib/dns/include/dns/dynamic_db.h.dyndb 2011-11-10 12:47:24.186292776 +0100
|
--- bind-9.9.0b2/lib/dns/include/dns/dynamic_db.h.dyndb 2011-11-22 12:56:27.912485606 +0100
|
||||||
+++ bind-9.9.0b1/lib/dns/include/dns/dynamic_db.h 2011-11-10 12:47:24.186292776 +0100
|
+++ bind-9.9.0b2/lib/dns/include/dns/dynamic_db.h 2011-11-22 12:56:27.913485604 +0100
|
||||||
@@ -0,0 +1,50 @@
|
@@ -0,0 +1,50 @@
|
||||||
+/*
|
+/*
|
||||||
+ * Copyright (C) 2008-2011 Red Hat, Inc.
|
+ * Copyright (C) 2008-2011 Red Hat, Inc.
|
||||||
@ -582,9 +582,9 @@ diff -up bind-9.9.0b1/lib/dns/include/dns/dynamic_db.h.dyndb bind-9.9.0b1/lib/dn
|
|||||||
+isc_timermgr_t *dns_dyndb_get_timermgr(dns_dyndb_arguments_t *args);
|
+isc_timermgr_t *dns_dyndb_get_timermgr(dns_dyndb_arguments_t *args);
|
||||||
+
|
+
|
||||||
+#endif
|
+#endif
|
||||||
diff -up bind-9.9.0b1/lib/dns/include/dns/log.h.dyndb bind-9.9.0b1/lib/dns/include/dns/log.h
|
diff -up bind-9.9.0b2/lib/dns/include/dns/log.h.dyndb bind-9.9.0b2/lib/dns/include/dns/log.h
|
||||||
--- bind-9.9.0b1/lib/dns/include/dns/log.h.dyndb 2011-10-14 00:48:24.000000000 +0200
|
--- bind-9.9.0b2/lib/dns/include/dns/log.h.dyndb 2011-10-14 00:48:24.000000000 +0200
|
||||||
+++ bind-9.9.0b1/lib/dns/include/dns/log.h 2011-11-10 12:47:24.187292776 +0100
|
+++ bind-9.9.0b2/lib/dns/include/dns/log.h 2011-11-22 12:56:27.913485604 +0100
|
||||||
@@ -75,6 +75,7 @@ LIBDNS_EXTERNAL_DATA extern isc_logmodul
|
@@ -75,6 +75,7 @@ LIBDNS_EXTERNAL_DATA extern isc_logmodul
|
||||||
#define DNS_LOGMODULE_ACACHE (&dns_modules[25])
|
#define DNS_LOGMODULE_ACACHE (&dns_modules[25])
|
||||||
#define DNS_LOGMODULE_DLZ (&dns_modules[26])
|
#define DNS_LOGMODULE_DLZ (&dns_modules[26])
|
||||||
@ -593,21 +593,21 @@ diff -up bind-9.9.0b1/lib/dns/include/dns/log.h.dyndb bind-9.9.0b1/lib/dns/inclu
|
|||||||
|
|
||||||
ISC_LANG_BEGINDECLS
|
ISC_LANG_BEGINDECLS
|
||||||
|
|
||||||
diff -up bind-9.9.0b1/lib/dns/include/dns/Makefile.in.dyndb bind-9.9.0b1/lib/dns/include/dns/Makefile.in
|
diff -up bind-9.9.0b2/lib/dns/include/dns/Makefile.in.dyndb bind-9.9.0b2/lib/dns/include/dns/Makefile.in
|
||||||
--- bind-9.9.0b1/lib/dns/include/dns/Makefile.in.dyndb 2011-03-02 00:48:07.000000000 +0100
|
--- bind-9.9.0b2/lib/dns/include/dns/Makefile.in.dyndb 2011-11-14 19:32:34.000000000 +0100
|
||||||
+++ bind-9.9.0b1/lib/dns/include/dns/Makefile.in 2011-11-10 12:47:24.187292776 +0100
|
+++ bind-9.9.0b2/lib/dns/include/dns/Makefile.in 2011-11-22 12:56:56.309437358 +0100
|
||||||
@@ -22,7 +22,7 @@ top_srcdir = @top_srcdir@
|
@@ -22,7 +22,7 @@ top_srcdir = @top_srcdir@
|
||||||
@BIND9_VERSION@
|
@BIND9_VERSION@
|
||||||
|
|
||||||
HEADERS = acl.h adb.h byaddr.h cache.h callbacks.h cert.h compress.h \
|
HEADERS = acl.h adb.h byaddr.h cache.h callbacks.h cert.h compress.h \
|
||||||
- db.h dbiterator.h dbtable.h diff.h dispatch.h dlz.h \
|
- clientinfo.h db.h dbiterator.h dbtable.h diff.h dispatch.h \
|
||||||
+ db.h dbiterator.h dbtable.h diff.h dispatch.h dlz.h dynamic_db.h \
|
+ clientinfo.h db.h dbiterator.h dbtable.h diff.h dispatch.h dynamic_db.h \
|
||||||
dnssec.h ds.h events.h fixedname.h iptable.h journal.h \
|
dlz.h dnssec.h ds.h events.h fixedname.h iptable.h journal.h \
|
||||||
keyflags.h keytable.h keyvalues.h lib.h log.h \
|
keyflags.h keytable.h keyvalues.h lib.h log.h \
|
||||||
master.h masterdump.h message.h name.h ncache.h nsec.h \
|
master.h masterdump.h message.h name.h ncache.h nsec.h \
|
||||||
diff -up bind-9.9.0b1/lib/dns/include/dns/types.h.dyndb bind-9.9.0b1/lib/dns/include/dns/types.h
|
diff -up bind-9.9.0b2/lib/dns/include/dns/types.h.dyndb bind-9.9.0b2/lib/dns/include/dns/types.h
|
||||||
--- bind-9.9.0b1/lib/dns/include/dns/types.h.dyndb 2011-07-02 01:47:44.000000000 +0200
|
--- bind-9.9.0b2/lib/dns/include/dns/types.h.dyndb 2011-07-02 01:47:44.000000000 +0200
|
||||||
+++ bind-9.9.0b1/lib/dns/include/dns/types.h 2011-11-10 12:47:24.187292776 +0100
|
+++ bind-9.9.0b2/lib/dns/include/dns/types.h 2011-11-22 12:56:27.914485602 +0100
|
||||||
@@ -60,6 +60,7 @@ typedef struct dns_dbtable dns_dbtable
|
@@ -60,6 +60,7 @@ typedef struct dns_dbtable dns_dbtable
|
||||||
typedef void dns_dbversion_t;
|
typedef void dns_dbversion_t;
|
||||||
typedef struct dns_dlzimplementation dns_dlzimplementation_t;
|
typedef struct dns_dlzimplementation dns_dlzimplementation_t;
|
||||||
@ -616,9 +616,9 @@ diff -up bind-9.9.0b1/lib/dns/include/dns/types.h.dyndb bind-9.9.0b1/lib/dns/inc
|
|||||||
typedef struct dns_sdlzimplementation dns_sdlzimplementation_t;
|
typedef struct dns_sdlzimplementation dns_sdlzimplementation_t;
|
||||||
typedef struct dns_decompress dns_decompress_t;
|
typedef struct dns_decompress dns_decompress_t;
|
||||||
typedef struct dns_dispatch dns_dispatch_t;
|
typedef struct dns_dispatch dns_dispatch_t;
|
||||||
diff -up bind-9.9.0b1/lib/dns/log.c.dyndb bind-9.9.0b1/lib/dns/log.c
|
diff -up bind-9.9.0b2/lib/dns/log.c.dyndb bind-9.9.0b2/lib/dns/log.c
|
||||||
--- bind-9.9.0b1/lib/dns/log.c.dyndb 2011-10-14 00:48:24.000000000 +0200
|
--- bind-9.9.0b2/lib/dns/log.c.dyndb 2011-10-14 00:48:24.000000000 +0200
|
||||||
+++ bind-9.9.0b1/lib/dns/log.c 2011-11-10 12:47:24.188292776 +0100
|
+++ bind-9.9.0b2/lib/dns/log.c 2011-11-22 12:56:27.915485600 +0100
|
||||||
@@ -81,6 +81,7 @@ LIBDNS_EXTERNAL_DATA isc_logmodule_t dns
|
@@ -81,6 +81,7 @@ LIBDNS_EXTERNAL_DATA isc_logmodule_t dns
|
||||||
{ "dns/acache", 0 },
|
{ "dns/acache", 0 },
|
||||||
{ "dns/dlz", 0 },
|
{ "dns/dlz", 0 },
|
||||||
@ -627,9 +627,9 @@ diff -up bind-9.9.0b1/lib/dns/log.c.dyndb bind-9.9.0b1/lib/dns/log.c
|
|||||||
{ NULL, 0 }
|
{ NULL, 0 }
|
||||||
};
|
};
|
||||||
|
|
||||||
diff -up bind-9.9.0b1/lib/dns/Makefile.in.dyndb bind-9.9.0b1/lib/dns/Makefile.in
|
diff -up bind-9.9.0b2/lib/dns/Makefile.in.dyndb bind-9.9.0b2/lib/dns/Makefile.in
|
||||||
--- bind-9.9.0b1/lib/dns/Makefile.in.dyndb 2011-11-10 12:47:24.167292778 +0100
|
--- bind-9.9.0b2/lib/dns/Makefile.in.dyndb 2011-11-22 12:56:27.894485636 +0100
|
||||||
+++ bind-9.9.0b1/lib/dns/Makefile.in 2011-11-10 12:48:03.124290065 +0100
|
+++ bind-9.9.0b2/lib/dns/Makefile.in 2011-11-22 12:56:27.915485600 +0100
|
||||||
@@ -58,7 +58,7 @@ DNSOBJS = acache.@O@ acl.@O@ adb.@O@ bya
|
@@ -58,7 +58,7 @@ DNSOBJS = acache.@O@ acl.@O@ adb.@O@ bya
|
||||||
cache.@O@ callbacks.@O@ clientinfo.@O@ compress.@O@ \
|
cache.@O@ callbacks.@O@ clientinfo.@O@ compress.@O@ \
|
||||||
db.@O@ dbiterator.@O@ dbtable.@O@ diff.@O@ dispatch.@O@ \
|
db.@O@ dbiterator.@O@ dbtable.@O@ diff.@O@ dispatch.@O@ \
|
||||||
@ -660,9 +660,9 @@ diff -up bind-9.9.0b1/lib/dns/Makefile.in.dyndb bind-9.9.0b1/lib/dns/Makefile.in
|
|||||||
libdns.@SA@: ${OBJS}
|
libdns.@SA@: ${OBJS}
|
||||||
${AR} ${ARFLAGS} $@ ${OBJS}
|
${AR} ${ARFLAGS} $@ ${OBJS}
|
||||||
${RANLIB} $@
|
${RANLIB} $@
|
||||||
diff -up bind-9.9.0b1/lib/isccfg/namedconf.c.dyndb bind-9.9.0b1/lib/isccfg/namedconf.c
|
diff -up bind-9.9.0b2/lib/isccfg/namedconf.c.dyndb bind-9.9.0b2/lib/isccfg/namedconf.c
|
||||||
--- bind-9.9.0b1/lib/isccfg/namedconf.c.dyndb 2011-10-13 03:32:34.000000000 +0200
|
--- bind-9.9.0b2/lib/isccfg/namedconf.c.dyndb 2011-11-07 01:14:11.000000000 +0100
|
||||||
+++ bind-9.9.0b1/lib/isccfg/namedconf.c 2011-11-10 12:47:24.190292776 +0100
|
+++ bind-9.9.0b2/lib/isccfg/namedconf.c 2011-11-22 12:56:27.917485596 +0100
|
||||||
@@ -89,6 +89,7 @@ static cfg_type_t cfg_type_controls;
|
@@ -89,6 +89,7 @@ static cfg_type_t cfg_type_controls;
|
||||||
static cfg_type_t cfg_type_controls_sockaddr;
|
static cfg_type_t cfg_type_controls_sockaddr;
|
||||||
static cfg_type_t cfg_type_destinationlist;
|
static cfg_type_t cfg_type_destinationlist;
|
||||||
|
14
bind.spec
14
bind.spec
@ -3,7 +3,7 @@
|
|||||||
#
|
#
|
||||||
|
|
||||||
#%define PATCHVER P4
|
#%define PATCHVER P4
|
||||||
%define PREVER b1
|
%define PREVER b2
|
||||||
#%define VERSION %{version}
|
#%define VERSION %{version}
|
||||||
#%define VERSION %{version}-%{PATCHVER}
|
#%define VERSION %{version}-%{PATCHVER}
|
||||||
%define VERSION %{version}%{PREVER}
|
%define VERSION %{version}%{PREVER}
|
||||||
@ -22,7 +22,7 @@ Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) serv
|
|||||||
Name: bind
|
Name: bind
|
||||||
License: ISC
|
License: ISC
|
||||||
Version: 9.9.0
|
Version: 9.9.0
|
||||||
Release: 0.2.%{PREVER}%{?dist}
|
Release: 0.3.%{PREVER}%{?dist}
|
||||||
Epoch: 32
|
Epoch: 32
|
||||||
Url: http://www.isc.org/products/BIND/
|
Url: http://www.isc.org/products/BIND/
|
||||||
Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -65,13 +65,11 @@ Patch112:bind97-rh645544.patch
|
|||||||
Patch117:bind98-rh725741.patch
|
Patch117:bind98-rh725741.patch
|
||||||
Patch118:bind97-rh699951.patch
|
Patch118:bind97-rh699951.patch
|
||||||
Patch119:bind97-rh693982.patch
|
Patch119:bind97-rh693982.patch
|
||||||
Patch120:bind97-rh700097.patch
|
|
||||||
Patch121:bind97-rh714049.patch
|
Patch121:bind97-rh714049.patch
|
||||||
Patch123:bind98-rh735103.patch
|
Patch123:bind98-rh735103.patch
|
||||||
Patch124:nslookup-norec.patch
|
Patch124:nslookup-norec.patch
|
||||||
Patch125:bind99-buildfix.patch
|
Patch125:bind99-buildfix.patch
|
||||||
Patch126:bind99-v6only.patch
|
Patch126:bind99-v6only.patch
|
||||||
Patch127:bind99-cinfo.patch
|
|
||||||
|
|
||||||
# SDB patches
|
# SDB patches
|
||||||
Patch11: bind-9.3.2b2-sdbsrc.patch
|
Patch11: bind-9.3.2b2-sdbsrc.patch
|
||||||
@ -290,7 +288,6 @@ mkdir m4
|
|||||||
%patch112 -p1 -b .rh645544
|
%patch112 -p1 -b .rh645544
|
||||||
%patch118 -p1 -b .rh699951
|
%patch118 -p1 -b .rh699951
|
||||||
%patch119 -p1 -b .rh693982
|
%patch119 -p1 -b .rh693982
|
||||||
%patch120 -p1 -b .rh700097
|
|
||||||
%patch121 -p1 -b .rh714049
|
%patch121 -p1 -b .rh714049
|
||||||
%patch123 -p1 -b .rh735103
|
%patch123 -p1 -b .rh735103
|
||||||
pushd bin/dig
|
pushd bin/dig
|
||||||
@ -298,7 +295,6 @@ pushd bin/dig
|
|||||||
popd
|
popd
|
||||||
%patch125 -p1 -b .buildfix
|
%patch125 -p1 -b .buildfix
|
||||||
%patch126 -p1 -b .v6only
|
%patch126 -p1 -b .v6only
|
||||||
%patch127 -p1 -b .cinfo
|
|
||||||
|
|
||||||
# Sparc and s390 arches need to use -fPIE
|
# Sparc and s390 arches need to use -fPIE
|
||||||
%ifarch sparcv9 sparc64 s390 s390x
|
%ifarch sparcv9 sparc64 s390 s390x
|
||||||
@ -769,6 +765,12 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 22 2011 Adam Tkac <atkac redhat com> 32:9.9.0-0.3.b2
|
||||||
|
- update to 9.9.0b2 (CVE-2011-4313)
|
||||||
|
- patches merged
|
||||||
|
- bind97-rh700097.patch
|
||||||
|
- bind99-cinfo.patch
|
||||||
|
|
||||||
* Mon Nov 14 2011 Adam Tkac <atkac redhat com> 32:9.9.0-0.2.b1
|
* Mon Nov 14 2011 Adam Tkac <atkac redhat com> 32:9.9.0-0.2.b1
|
||||||
- ship dns/clientinfo.h in bind-devel
|
- ship dns/clientinfo.h in bind-devel
|
||||||
|
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
diff -up bind-9.7.3-P3/bin/nsupdate/nsupdate.c.rh700097 bind-9.7.3-P3/bin/nsupdate/nsupdate.c
|
|
||||||
--- bind-9.7.3-P3/bin/nsupdate/nsupdate.c.rh700097 2011-08-12 16:24:18.730205763 +0200
|
|
||||||
+++ bind-9.7.3-P3/bin/nsupdate/nsupdate.c 2011-08-12 16:24:27.833205103 +0200
|
|
||||||
@@ -2298,6 +2298,7 @@ recvsoa(isc_task_t *task, isc_event_t *e
|
|
||||||
dns_message_destroy(&soaquery);
|
|
||||||
ddebug("Out of recvsoa");
|
|
||||||
done_update();
|
|
||||||
+ seenerror = ISC_TRUE;
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
|
|
@ -1,18 +0,0 @@
|
|||||||
diff -up bind-9.9.0b1/lib/dns/include/dns/Makefile.in.cinfo bind-9.9.0b1/lib/dns/include/dns/Makefile.in
|
|
||||||
--- bind-9.9.0b1/lib/dns/include/dns/Makefile.in.cinfo 2011-11-14 14:16:00.887716693 +0100
|
|
||||||
+++ bind-9.9.0b1/lib/dns/include/dns/Makefile.in 2011-11-14 14:16:31.141714598 +0100
|
|
||||||
@@ -21,10 +21,10 @@ top_srcdir = @top_srcdir@
|
|
||||||
|
|
||||||
@BIND9_VERSION@
|
|
||||||
|
|
||||||
-HEADERS = acl.h adb.h byaddr.h cache.h callbacks.h cert.h compress.h \
|
|
||||||
- db.h dbiterator.h dbtable.h diff.h dispatch.h dlz.h dynamic_db.h \
|
|
||||||
- dnssec.h ds.h events.h fixedname.h iptable.h journal.h \
|
|
||||||
- keyflags.h keytable.h keyvalues.h lib.h log.h \
|
|
||||||
+HEADERS = acl.h adb.h byaddr.h cache.h callbacks.h cert.h clientinfo.h \
|
|
||||||
+ compress.h db.h dbiterator.h dbtable.h diff.h dispatch.h dlz.h \
|
|
||||||
+ dynamic_db.h dnssec.h ds.h events.h fixedname.h iptable.h \
|
|
||||||
+ journal.h keyflags.h keytable.h keyvalues.h lib.h log.h \
|
|
||||||
master.h masterdump.h message.h name.h ncache.h nsec.h \
|
|
||||||
peer.h portlist.h private.h rbt.h rcode.h \
|
|
||||||
rdata.h rdataclass.h rdatalist.h rdataset.h rdatasetiter.h \
|
|
@ -6,7 +6,7 @@
|
|||||||
fputs(l->cmdline, stdout);
|
fputs(l->cmdline, stdout);
|
||||||
- printf(";; connection timed out; no servers could be "
|
- printf(";; connection timed out; no servers could be "
|
||||||
- "reached\n");
|
- "reached\n");
|
||||||
+ if (!next_origin(NULL, query)) {
|
+ if (!next_origin(query)) {
|
||||||
+ printf(";; connection timed out; no servers could be "
|
+ printf(";; connection timed out; no servers could be "
|
||||||
+ "reached\n");
|
+ "reached\n");
|
||||||
+ } else {
|
+ } else {
|
||||||
|
Loading…
Reference in New Issue
Block a user