Remove GEOIP and EXPORT_LIBS
Most recent release is no longer able to statisfy export libs and geoip legacy. Remove its support from GeoIP.
This commit is contained in:
parent
a6f9fe005e
commit
80d0367669
@ -1,39 +0,0 @@
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index c1bfd62..7c5ad51 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -5333,6 +5333,8 @@ AC_SUBST(BUILD_CPPFLAGS)
|
||||
AC_SUBST(BUILD_LDFLAGS)
|
||||
AC_SUBST(BUILD_LIBS)
|
||||
|
||||
+AC_SUBST(LIBDIR_SUFFIX)
|
||||
+
|
||||
#
|
||||
# Commands to run at the end of config.status.
|
||||
# Don't just put these into configure, it won't work right if somebody
|
||||
diff --git a/isc-config.sh.in b/isc-config.sh.in
|
||||
index b5e94ed..d2857e0 100644
|
||||
--- a/isc-config.sh.in
|
||||
+++ b/isc-config.sh.in
|
||||
@@ -13,16 +13,17 @@ prefix=@prefix@
|
||||
exec_prefix=@exec_prefix@
|
||||
exec_prefix_set=
|
||||
includedir=@includedir@
|
||||
+libdir_suffix=@LIBDIR_SUFFIX@
|
||||
arch=$(uname -m)
|
||||
|
||||
case $arch in
|
||||
x86_64 | amd64 | sparc64 | s390x | ppc64)
|
||||
- libdir=/usr/lib64
|
||||
- sec_libdir=/usr/lib
|
||||
+ libdir=/usr/lib64${libdir_suffix}
|
||||
+ sec_libdir=/usr/lib${libdir_suffix}
|
||||
;;
|
||||
* )
|
||||
- libdir=/usr/lib
|
||||
- sec_libdir=/usr/lib64
|
||||
+ libdir=/usr/lib${libdir_suffix}
|
||||
+ sec_libdir=/usr/lib64${libdir_suffix}
|
||||
;;
|
||||
esac
|
||||
|
175
bind.spec
175
bind.spec
@ -29,8 +29,6 @@
|
||||
%bcond_with GEOIP
|
||||
# New MaxMind GeoLite support
|
||||
%bcond_without GEOIP2
|
||||
# Support for builds without threads removed. DHCP no longer needs it anyway.
|
||||
%bcond_with EXPORT_LIBS
|
||||
# Legacy GeoIP support
|
||||
%bcond_with GEOIP
|
||||
# New MaxMind GeoLite support
|
||||
@ -141,7 +139,6 @@ Patch137:bind-9.10-use-of-strlcat.patch
|
||||
Patch140:bind-9.11-rh1410433.patch
|
||||
# Avoid conflicts with OpenSSL PKCS11 engine
|
||||
Patch150:bind-9.11-engine-pkcs11.patch
|
||||
Patch153:bind-9.11-export-suffix.patch
|
||||
Patch154:bind-9.11-oot-manual.patch
|
||||
Patch157:bind-9.11-fips-tests.patch
|
||||
Patch164:bind-9.11-rh1666814.patch
|
||||
@ -485,39 +482,6 @@ BuildArch: noarch
|
||||
%description -n python3-bind
|
||||
This package provides a module which allows commands to be sent to rndc directly from Python programs.
|
||||
|
||||
%if %{with EXPORT_LIBS}
|
||||
%package export-libs
|
||||
Summary: ISC libs for DHCP application
|
||||
%if 0%{?fedora} >= 1
|
||||
Obsoletes: bind99-libs < 9.9.11-4
|
||||
Provides: bind99-libs = 9.9.11-4
|
||||
# This subpackage will not use shared license, but distribute its own
|
||||
%endif
|
||||
|
||||
%description export-libs
|
||||
BIND (Berkeley Internet Name Domain) is an implementation of the DNS
|
||||
(Domain Name System) protocols. This package set contains only export
|
||||
version of BIND libraries, that are used for building ISC DHCP.
|
||||
|
||||
%package export-devel
|
||||
Summary: Header files and libraries needed for BIND export libraries
|
||||
Requires: %{name}-export-libs%{?_isa} = %{epoch}:%{version}-%{release}
|
||||
Requires: openssl-devel
|
||||
Requires: libcap-devel
|
||||
|
||||
%if 0%{?fedora} >= 1
|
||||
Obsoletes: bind99-devel < 9.9.11-4
|
||||
# To prevent linking against wrong set of libraries,
|
||||
# do not coexist with bind99-devel
|
||||
Conflicts: bind99-devel
|
||||
%endif
|
||||
|
||||
%description export-devel
|
||||
This package contains export version of the header files and libraries
|
||||
required for development with ISC BIND. These headers and libraries
|
||||
are used for building ISC DHCP.
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%{gpgverify} --keyring='%{SOURCE4}' --signature='%{SOURCE2}' --data='%{SOURCE0}'
|
||||
%setup -q -n %{name}-%{BINDVERSION}
|
||||
@ -530,9 +494,6 @@ are used for building ISC DHCP.
|
||||
%patch112 -p1 -b .rh645544
|
||||
%patch130 -p1 -b .libdb
|
||||
%patch140 -p1 -b .rh1410433
|
||||
%if %{with EXPORT_LIBS}
|
||||
%patch153 -p1 -b .export_suffix
|
||||
%endif
|
||||
%patch154 -p1 -b .oot-man
|
||||
%patch157 -p1 -b .fips-tests
|
||||
%patch164 -p1 -b .rh1666814
|
||||
@ -645,7 +606,7 @@ export LIBDIR_SUFFIX
|
||||
--with-geoip \
|
||||
%endif
|
||||
%if %{with GEOIP2}
|
||||
--with-geoip2 \
|
||||
--with-maxminddb \
|
||||
%endif
|
||||
%if %{with PKCS11}
|
||||
--enable-native-pkcs11 \
|
||||
@ -731,78 +692,6 @@ popd # build
|
||||
%unit_prepare_build build
|
||||
%systemtest_prepare_build build
|
||||
|
||||
%if %{with EXPORT_LIBS}
|
||||
|
||||
## Create export libs ##
|
||||
mkdir -p export-libs
|
||||
pushd export-libs
|
||||
LIBDIR_SUFFIX=%{_export_dir}
|
||||
export LIBDIR_SUFFIX
|
||||
## minimal subset of options to make clients aka dhcp working
|
||||
%{configure} \
|
||||
--with-libtool \
|
||||
--disable-static \
|
||||
--disable-epoll \
|
||||
--disable-kqueue \
|
||||
--libdir=%{_libdir}%{_export_dir} \
|
||||
--includedir=%{_includedir}%{_export_dir}/ \
|
||||
--disable-threads \
|
||||
%if %{with GSSTSIG}
|
||||
--with-gssapi=yes \
|
||||
--disable-isc-spnego \
|
||||
%endif
|
||||
%if %{with UNITTEST}
|
||||
--with-cmocka \
|
||||
%endif
|
||||
--enable-fixed-rrset \
|
||||
--disable-rpz-nsip \
|
||||
--disable-rpz-nsdname \
|
||||
--without-lmdb \
|
||||
--without-libxml2 \
|
||||
--without-libjson \
|
||||
--without-zlib \
|
||||
--without-dlopen \
|
||||
--enable-full-report
|
||||
|
||||
## We don't want to build other libs than -export twice
|
||||
## FIXME this should be in patch instead of SED'ing
|
||||
## but do we really like/want to patch generated files?
|
||||
|
||||
|
||||
sed -i \
|
||||
-e '/^SUBDIRS =/s/.*/SUBDIRS = make lib/i' \
|
||||
Makefile
|
||||
|
||||
sed -i -e \
|
||||
"/^SUBDIRS =/s/.*/SUBDIRS = %{bind_export_libs}/i" \
|
||||
lib/Makefile
|
||||
|
||||
for lib in %{bind_export_libs}
|
||||
do
|
||||
find . -name Makefile -exec sed "s/lib${lib}\./lib${lib}-export\./g" -i {} \;
|
||||
sed -e "s/-l${lib}\([^[:alpha:]]\)/-l${lib}-export\1/g" \
|
||||
-e "s/lib${lib}\./lib${lib}-export\./g" \
|
||||
-i isc-export-config.sh
|
||||
done;
|
||||
|
||||
make %{?_smp_mflags}
|
||||
popd
|
||||
|
||||
# export library unit tests
|
||||
%unit_prepare_build export-libs
|
||||
# Test just compiled libraries
|
||||
for lib in %{bind_export_libs}
|
||||
do
|
||||
sed -e "s,^\s*include(.*${lib}/.*,-- use &," \
|
||||
-i export-libs/lib/Kyuafile
|
||||
done
|
||||
|
||||
sed -e "/^\s*include(/ d" -e 's/^-- use //' \
|
||||
-i export-libs/lib/Kyuafile
|
||||
|
||||
## End of export libs
|
||||
%endif
|
||||
|
||||
%check
|
||||
%if %{with PKCS11}
|
||||
# Tests require initialization of pkcs11 token
|
||||
@ -822,17 +711,6 @@ export TSAN_OPTIONS="log_exe_name=true log_path=ThreadSanitizer exitcode=0"
|
||||
exit $e;
|
||||
fi;
|
||||
popd
|
||||
|
||||
%if %{with EXPORT_LIBS}
|
||||
pushd export-libs
|
||||
make unit
|
||||
e=$?
|
||||
if [ "$e" -ne 0 ]; then
|
||||
echo "ERROR: this build of BIND export-libs failed 'make unit'. Aborting."
|
||||
exit $e;
|
||||
fi;
|
||||
popd
|
||||
%endif
|
||||
## End of UNITTEST
|
||||
%endif
|
||||
|
||||
@ -911,17 +789,6 @@ pushd build
|
||||
make DESTDIR=${RPM_BUILD_ROOT} install
|
||||
popd
|
||||
|
||||
%if %{with EXPORT_LIBS}
|
||||
pushd export-libs
|
||||
make DESTDIR=${RPM_BUILD_ROOT} install
|
||||
mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/ld.so.conf.d
|
||||
echo "%{_libdir}/%{_export_dir}" > %{buildroot}%{_sysconfdir}/ld.so.conf.d/%{name}-export-%{_arch}.conf
|
||||
cp -fp config.h ${RPM_BUILD_ROOT}/%{_includedir}%{_export_dir}
|
||||
rm -rf ${RPM_BUILD_ROOT}/%{_includedir}%{_export_dir}/pkcs11/
|
||||
rm -f ${RPM_BUILD_ROOT}/%{_includedir}%{_export_dir}/pk11/{constants,internal,pk11,result}.h
|
||||
popd
|
||||
%endif
|
||||
|
||||
# Remove unwanted files
|
||||
rm -f ${RPM_BUILD_ROOT}/etc/bind.keys
|
||||
|
||||
@ -1163,14 +1030,6 @@ fi
|
||||
%ldconfig_scriptlets pkcs11-libs
|
||||
%endif
|
||||
|
||||
%if %{with EXPORT_LIBS}
|
||||
%post export-libs -p /sbin/ldconfig
|
||||
%end
|
||||
|
||||
%postun export-libs -p /sbin/ldconfig
|
||||
%end
|
||||
%endif
|
||||
|
||||
# Fix permissions on existing device files on upgrade
|
||||
%define chroot_fix_devices() \
|
||||
if [ $1 -gt 1 ]; then \
|
||||
@ -1488,38 +1347,6 @@ fi;
|
||||
%{_libdir}/libisc-pkcs11.so
|
||||
%endif
|
||||
|
||||
%if %{with EXPORT_LIBS}
|
||||
%files export-libs
|
||||
%dir %{_libdir}/%{_export_dir}
|
||||
%{_libdir}/%{_export_dir}/libdns-export.so.%{sover_dns}*
|
||||
%{_libdir}/%{_export_dir}/libirs-export.so.%{sover_irs}*
|
||||
%{_libdir}/%{_export_dir}/libisc-export.so.%{sover_isc}*
|
||||
%{_libdir}/%{_export_dir}/libisccfg-export.so.%{sover_isccfg}*
|
||||
%config(noreplace) %{_sysconfdir}/ld.so.conf.d/%{name}-export-%{_arch}.conf
|
||||
# This subpackage has to distribute its own license. Do not conflict with
|
||||
# other subpackages of different version
|
||||
%license COPYRIGHT
|
||||
|
||||
%files export-devel
|
||||
%{_libdir}/%{_export_dir}/libdns-export.so
|
||||
%{_libdir}/%{_export_dir}/libirs-export.so
|
||||
%{_libdir}/%{_export_dir}/libisc-export.so
|
||||
%{_libdir}/%{_export_dir}/libisccfg-export.so
|
||||
%dir %{_includedir}/%{_export_dir}
|
||||
%{_includedir}/%{_export_dir}/dns
|
||||
%{_includedir}/%{_export_dir}/dst
|
||||
%{_includedir}/%{_export_dir}/irs
|
||||
%{_includedir}/%{_export_dir}/isc
|
||||
%dir %{_includedir}/%{_export_dir}/pk11
|
||||
%{_includedir}/%{_export_dir}/pk11/site.h
|
||||
%{_includedir}/%{_export_dir}/isccfg
|
||||
%{_includedir}/%{_export_dir}/config.h
|
||||
%{_mandir}/man1/isc-export-config.sh.1*
|
||||
%{_mandir}/man1/bind9-export-config.1*
|
||||
%attr(0755,root,root) %{_bindir}/isc-export-config.sh
|
||||
%{_bindir}/bind9-export-config
|
||||
%endif
|
||||
|
||||
%if %{with DLZ} && %{with BDB}
|
||||
%files dlz-bdb
|
||||
%if %{with SDB}
|
||||
|
Loading…
Reference in New Issue
Block a user