- update to 9.7.0rc2

This commit is contained in:
Adam Tkac 2010-01-28 11:31:36 +00:00
parent 13e55cd35c
commit 7f138a6ba9
5 changed files with 75 additions and 70 deletions

View File

@ -1,2 +1,2 @@
bind-9.7.0rc1.tar.gz
config-5.tar.bz2
bind-9.7.0rc2.tar.gz

View File

@ -1,6 +1,6 @@
diff -up bind-9.7.0b1/bin/named/main.c.dyndb bind-9.7.0b1/bin/named/main.c
--- bind-9.7.0b1/bin/named/main.c.dyndb 2009-10-05 19:30:49.000000000 +0200
+++ bind-9.7.0b1/bin/named/main.c 2009-10-20 10:39:55.439045751 +0200
diff -up bind-9.7.0rc2/bin/named/main.c.dyndb bind-9.7.0rc2/bin/named/main.c
--- bind-9.7.0rc2/bin/named/main.c.dyndb 2009-10-05 19:30:49.000000000 +0200
+++ bind-9.7.0rc2/bin/named/main.c 2010-01-28 12:14:14.579196829 +0100
@@ -45,6 +45,7 @@
#include <isccc/result.h>
@ -18,9 +18,9 @@ diff -up bind-9.7.0b1/bin/named/main.c.dyndb bind-9.7.0b1/bin/named/main.c
destroy_managers();
ns_server_destroy(&ns_g_server);
diff -up bind-9.7.0b1/bin/named/server.c.dyndb bind-9.7.0b1/bin/named/server.c
--- bind-9.7.0b1/bin/named/server.c.dyndb 2009-10-12 22:48:11.000000000 +0200
+++ bind-9.7.0b1/bin/named/server.c 2009-10-20 10:39:55.439045751 +0200
diff -up bind-9.7.0rc2/bin/named/server.c.dyndb bind-9.7.0rc2/bin/named/server.c
--- bind-9.7.0rc2/bin/named/server.c.dyndb 2010-01-14 00:48:19.000000000 +0100
+++ bind-9.7.0rc2/bin/named/server.c 2010-01-28 12:14:14.579196829 +0100
@@ -58,6 +58,7 @@
#ifdef DLZ
#include <dns/dlz.h>
@ -29,7 +29,7 @@ diff -up bind-9.7.0b1/bin/named/server.c.dyndb bind-9.7.0b1/bin/named/server.c
#include <dns/forward.h>
#include <dns/journal.h>
#include <dns/keytable.h>
@@ -1054,6 +1055,72 @@ configure_peer(const cfg_obj_t *cpeer, i
@@ -1071,6 +1072,72 @@ configure_peer(const cfg_obj_t *cpeer, i
}
static isc_result_t
@ -102,7 +102,7 @@ diff -up bind-9.7.0b1/bin/named/server.c.dyndb bind-9.7.0b1/bin/named/server.c
disable_algorithms(const cfg_obj_t *disabled, dns_resolver_t *resolver) {
isc_result_t result;
const cfg_obj_t *algorithms;
@@ -1263,6 +1330,7 @@ configure_view(dns_view_t *view, const c
@@ -1280,6 +1347,7 @@ configure_view(dns_view_t *view, const c
unsigned int dlzargc;
char **dlzargv;
#endif
@ -110,7 +110,7 @@ diff -up bind-9.7.0b1/bin/named/server.c.dyndb bind-9.7.0b1/bin/named/server.c
const cfg_obj_t *disabled;
const cfg_obj_t *obj;
const cfg_listelt_t *element;
@@ -1447,6 +1515,37 @@ configure_view(dns_view_t *view, const c
@@ -1464,6 +1532,37 @@ configure_view(dns_view_t *view, const c
#endif
/*
@ -148,7 +148,7 @@ diff -up bind-9.7.0b1/bin/named/server.c.dyndb bind-9.7.0b1/bin/named/server.c
* Obtain configuration parameters that affect the decision of whether
* we can reuse/share an existing cache.
*/
@@ -3598,6 +3697,7 @@ load_configuration(const char *filename,
@@ -3633,6 +3732,7 @@ load_configuration(const char *filename,
result = isc_task_beginexclusive(server->task);
RUNTIME_CHECK(result == ISC_R_SUCCESS);
@ -156,7 +156,7 @@ diff -up bind-9.7.0b1/bin/named/server.c.dyndb bind-9.7.0b1/bin/named/server.c
/*
* Parse the global default pseudo-config file.
*/
@@ -4945,6 +5045,8 @@ loadconfig(ns_server_t *server) {
@@ -4979,6 +5079,8 @@ loadconfig(ns_server_t *server) {
static isc_result_t
reload(ns_server_t *server) {
isc_result_t result;
@ -165,9 +165,9 @@ diff -up bind-9.7.0b1/bin/named/server.c.dyndb bind-9.7.0b1/bin/named/server.c
CHECK(loadconfig(server));
result = load_zones(server, ISC_FALSE);
diff -up /dev/null bind-9.7.0b1/lib/dns/dynamic_db.c
--- /dev/null 2009-10-20 12:29:23.540001947 +0200
+++ bind-9.7.0b1/lib/dns/dynamic_db.c 2009-10-20 10:39:55.439045751 +0200
diff -up bind-9.7.0rc2/lib/dns/dynamic_db.c.dyndb bind-9.7.0rc2/lib/dns/dynamic_db.c
--- bind-9.7.0rc2/lib/dns/dynamic_db.c.dyndb 2010-01-28 12:14:14.579196829 +0100
+++ bind-9.7.0rc2/lib/dns/dynamic_db.c 2010-01-28 12:14:14.579196829 +0100
@@ -0,0 +1,364 @@
+/*
+ * Copyright (C) 2008-2009 Red Hat, Inc.
@ -533,9 +533,9 @@ diff -up /dev/null bind-9.7.0b1/lib/dns/dynamic_db.c
+
+ return args->timermgr;
+}
diff -up /dev/null bind-9.7.0b1/lib/dns/include/dns/dynamic_db.h
--- /dev/null 2009-10-20 12:29:23.540001947 +0200
+++ bind-9.7.0b1/lib/dns/include/dns/dynamic_db.h 2009-10-20 10:39:55.439045751 +0200
diff -up bind-9.7.0rc2/lib/dns/include/dns/dynamic_db.h.dyndb bind-9.7.0rc2/lib/dns/include/dns/dynamic_db.h
--- bind-9.7.0rc2/lib/dns/include/dns/dynamic_db.h.dyndb 2010-01-28 12:14:14.579196829 +0100
+++ bind-9.7.0rc2/lib/dns/include/dns/dynamic_db.h 2010-01-28 12:14:14.579196829 +0100
@@ -0,0 +1,50 @@
+/*
+ * Copyright (C) 2008-2009 Red Hat, Inc.
@ -587,20 +587,20 @@ diff -up /dev/null bind-9.7.0b1/lib/dns/include/dns/dynamic_db.h
+isc_timermgr_t *dns_dyndb_get_timermgr(dns_dyndb_arguments_t *args);
+
+#endif
diff -up bind-9.7.0b1/lib/dns/include/dns/log.h.dyndb bind-9.7.0b1/lib/dns/include/dns/log.h
--- bind-9.7.0b1/lib/dns/include/dns/log.h.dyndb 2009-01-18 00:47:43.000000000 +0100
+++ bind-9.7.0b1/lib/dns/include/dns/log.h 2009-10-20 10:39:55.439045751 +0200
@@ -73,6 +73,7 @@ LIBDNS_EXTERNAL_DATA extern isc_logmodul
#define DNS_LOGMODULE_HINTS (&dns_modules[24])
diff -up bind-9.7.0rc2/lib/dns/include/dns/log.h.dyndb bind-9.7.0rc2/lib/dns/include/dns/log.h
--- bind-9.7.0rc2/lib/dns/include/dns/log.h.dyndb 2009-12-18 23:13:54.000000000 +0100
+++ bind-9.7.0rc2/lib/dns/include/dns/log.h 2010-01-28 12:14:51.009197177 +0100
@@ -74,6 +74,7 @@ LIBDNS_EXTERNAL_DATA extern isc_logmodul
#define DNS_LOGMODULE_ACACHE (&dns_modules[25])
#define DNS_LOGMODULE_DLZ (&dns_modules[26])
+#define DNS_LOGMODULE_DYNDB (&dns_modules[27])
#define DNS_LOGMODULE_DNSSEC (&dns_modules[27])
+#define DNS_LOGMODULE_DYNDB (&dns_modules[28])
ISC_LANG_BEGINDECLS
diff -up bind-9.7.0b1/lib/dns/include/dns/Makefile.in.dyndb bind-9.7.0b1/lib/dns/include/dns/Makefile.in
--- bind-9.7.0b1/lib/dns/include/dns/Makefile.in.dyndb 2009-10-09 01:48:10.000000000 +0200
+++ bind-9.7.0b1/lib/dns/include/dns/Makefile.in 2009-10-20 10:42:34.949043781 +0200
diff -up bind-9.7.0rc2/lib/dns/include/dns/Makefile.in.dyndb bind-9.7.0rc2/lib/dns/include/dns/Makefile.in
--- bind-9.7.0rc2/lib/dns/include/dns/Makefile.in.dyndb 2009-10-09 01:48:10.000000000 +0200
+++ bind-9.7.0rc2/lib/dns/include/dns/Makefile.in 2010-01-28 12:14:14.579196829 +0100
@@ -22,7 +22,7 @@ top_srcdir = @top_srcdir@
@BIND9_VERSION@
@ -610,9 +610,9 @@ diff -up bind-9.7.0b1/lib/dns/include/dns/Makefile.in.dyndb bind-9.7.0b1/lib/dns
dnssec.h ds.h events.h fixedname.h iptable.h journal.h \
keyflags.h keytable.h keyvalues.h lib.h log.h \
master.h masterdump.h message.h name.h ncache.h nsec.h \
diff -up bind-9.7.0b1/lib/dns/include/dns/types.h.dyndb bind-9.7.0b1/lib/dns/include/dns/types.h
--- bind-9.7.0b1/lib/dns/include/dns/types.h.dyndb 2009-09-01 02:22:27.000000000 +0200
+++ bind-9.7.0b1/lib/dns/include/dns/types.h 2009-10-20 10:39:55.439045751 +0200
diff -up bind-9.7.0rc2/lib/dns/include/dns/types.h.dyndb bind-9.7.0rc2/lib/dns/include/dns/types.h
--- bind-9.7.0rc2/lib/dns/include/dns/types.h.dyndb 2009-12-30 09:33:41.000000000 +0100
+++ bind-9.7.0rc2/lib/dns/include/dns/types.h 2010-01-28 12:14:14.579196829 +0100
@@ -60,6 +60,7 @@ typedef struct dns_dbtable dns_dbtable
typedef void dns_dbversion_t;
typedef struct dns_dlzimplementation dns_dlzimplementation_t;
@ -621,21 +621,21 @@ diff -up bind-9.7.0b1/lib/dns/include/dns/types.h.dyndb bind-9.7.0b1/lib/dns/inc
typedef struct dns_sdlzimplementation dns_sdlzimplementation_t;
typedef struct dns_decompress dns_decompress_t;
typedef struct dns_dispatch dns_dispatch_t;
diff -up bind-9.7.0b1/lib/dns/log.c.dyndb bind-9.7.0b1/lib/dns/log.c
--- bind-9.7.0b1/lib/dns/log.c.dyndb 2007-06-19 01:47:40.000000000 +0200
+++ bind-9.7.0b1/lib/dns/log.c 2009-10-20 10:39:55.439045751 +0200
@@ -79,6 +79,7 @@ LIBDNS_EXTERNAL_DATA isc_logmodule_t dns
{ "dns/hints", 0 },
diff -up bind-9.7.0rc2/lib/dns/log.c.dyndb bind-9.7.0rc2/lib/dns/log.c
--- bind-9.7.0rc2/lib/dns/log.c.dyndb 2009-12-19 00:48:18.000000000 +0100
+++ bind-9.7.0rc2/lib/dns/log.c 2010-01-28 12:15:13.106698708 +0100
@@ -80,6 +80,7 @@ LIBDNS_EXTERNAL_DATA isc_logmodule_t dns
{ "dns/acache", 0 },
{ "dns/dlz", 0 },
{ "dns/dnssec", 0 },
+ { "dns/dynamic_db", 0 },
{ NULL, 0 }
};
diff -up bind-9.7.0b1/lib/dns/Makefile.in.dyndb bind-9.7.0b1/lib/dns/Makefile.in
--- bind-9.7.0b1/lib/dns/Makefile.in.dyndb 2009-10-20 10:39:55.429046304 +0200
+++ bind-9.7.0b1/lib/dns/Makefile.in 2009-10-20 10:43:14.571543754 +0200
@@ -57,8 +57,8 @@ DSTOBJS = @DST_EXTRA_OBJS@ \
diff -up bind-9.7.0rc2/lib/dns/Makefile.in.dyndb bind-9.7.0rc2/lib/dns/Makefile.in
--- bind-9.7.0rc2/lib/dns/Makefile.in.dyndb 2010-01-28 12:14:14.559198055 +0100
+++ bind-9.7.0rc2/lib/dns/Makefile.in 2010-01-28 12:14:14.579196829 +0100
@@ -56,8 +56,8 @@ DSTOBJS = @DST_EXTRA_OBJS@ \
DNSOBJS = acache.@O@ acl.@O@ adb.@O@ byaddr.@O@ \
cache.@O@ callbacks.@O@ compress.@O@ \
db.@O@ dbiterator.@O@ dbtable.@O@ diff.@O@ dispatch.@O@ \
@ -646,7 +646,7 @@ diff -up bind-9.7.0b1/lib/dns/Makefile.in.dyndb bind-9.7.0b1/lib/dns/Makefile.in
master.@O@ masterdump.@O@ message.@O@ \
name.@O@ ncache.@O@ nsec.@O@ nsec3.@O@ order.@O@ peer.@O@ \
portlist.@O@ private.@O@ \
@@ -84,7 +84,7 @@ DSTSRCS = @DST_EXTRA_SRCS@ \
@@ -83,7 +83,7 @@ DSTSRCS = @DST_EXTRA_SRCS@ \
DNSSRCS = acache.c acl.c adb.c byaddr.c \
cache.c callbacks.c compress.c \
db.c dbiterator.c dbtable.c diff.c dispatch.c \
@ -655,7 +655,7 @@ diff -up bind-9.7.0b1/lib/dns/Makefile.in.dyndb bind-9.7.0b1/lib/dns/Makefile.in
keydata.c keytable.c lib.c log.c lookup.c \
master.c masterdump.c message.c \
name.c ncache.c nsec.c nsec3.c order.c peer.c portlist.c \
@@ -115,6 +115,11 @@ version.@O@: version.c
@@ -114,6 +114,11 @@ version.@O@: version.c
-DLIBAGE=${LIBAGE} \
-c ${srcdir}/version.c
@ -667,9 +667,9 @@ diff -up bind-9.7.0b1/lib/dns/Makefile.in.dyndb bind-9.7.0b1/lib/dns/Makefile.in
libdns.@SA@: ${OBJS}
${AR} ${ARFLAGS} $@ ${OBJS}
${RANLIB} $@
diff -up bind-9.7.0b1/lib/isccfg/namedconf.c.dyndb bind-9.7.0b1/lib/isccfg/namedconf.c
--- bind-9.7.0b1/lib/isccfg/namedconf.c.dyndb 2009-10-13 01:48:02.000000000 +0200
+++ bind-9.7.0b1/lib/isccfg/namedconf.c 2009-10-20 10:39:55.439045751 +0200
diff -up bind-9.7.0rc2/lib/isccfg/namedconf.c.dyndb bind-9.7.0rc2/lib/isccfg/namedconf.c
--- bind-9.7.0rc2/lib/isccfg/namedconf.c.dyndb 2009-12-04 22:09:34.000000000 +0100
+++ bind-9.7.0rc2/lib/isccfg/namedconf.c 2010-01-28 12:14:14.579196829 +0100
@@ -87,6 +87,7 @@ static cfg_type_t cfg_type_controls;
static cfg_type_t cfg_type_controls_sockaddr;
static cfg_type_t cfg_type_destinationlist;
@ -678,7 +678,7 @@ diff -up bind-9.7.0b1/lib/isccfg/namedconf.c.dyndb bind-9.7.0b1/lib/isccfg/named
static cfg_type_t cfg_type_ixfrdifftype;
static cfg_type_t cfg_type_key;
static cfg_type_t cfg_type_logfile;
@@ -798,6 +799,7 @@ namedconf_or_view_clauses[] = {
@@ -802,6 +803,7 @@ namedconf_or_view_clauses[] = {
{ "zone", &cfg_type_zone, CFG_CLAUSEFLAG_MULTI },
/* only 1 DLZ per view allowed */
{ "dlz", &cfg_type_dynamically_loadable_zones, 0 },
@ -686,7 +686,7 @@ diff -up bind-9.7.0b1/lib/isccfg/namedconf.c.dyndb bind-9.7.0b1/lib/isccfg/named
{ "server", &cfg_type_server, CFG_CLAUSEFLAG_MULTI },
{ "trusted-keys", &cfg_type_dnsseckeys, CFG_CLAUSEFLAG_MULTI },
{ "managed-keys", &cfg_type_managedkeys, CFG_CLAUSEFLAG_MULTI },
@@ -1571,6 +1573,40 @@ static cfg_type_t cfg_type_dialuptype =
@@ -1579,6 +1581,40 @@ static cfg_type_t cfg_type_dialuptype =
&cfg_rep_string, dialup_enums
};

View File

@ -1,6 +1,6 @@
diff -up bind-9.7.0a3/lib/bind9/Makefile.in.nonexec bind-9.7.0a3/lib/bind9/Makefile.in
--- bind-9.7.0a3/lib/bind9/Makefile.in.nonexec 2009-09-03 01:48:01.000000000 +0200
+++ bind-9.7.0a3/lib/bind9/Makefile.in 2009-09-16 10:46:27.554643093 +0200
diff -up bind-9.7.0rc2/lib/bind9/Makefile.in.nonexec bind-9.7.0rc2/lib/bind9/Makefile.in
--- bind-9.7.0rc2/lib/bind9/Makefile.in.nonexec 2009-12-06 00:31:40.000000000 +0100
+++ bind-9.7.0rc2/lib/bind9/Makefile.in 2010-01-28 12:13:33.406696161 +0100
@@ -78,7 +78,7 @@ installdirs:
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${libdir}
@ -10,10 +10,10 @@ diff -up bind-9.7.0a3/lib/bind9/Makefile.in.nonexec bind-9.7.0a3/lib/bind9/Makef
clean distclean::
rm -f libbind9.@A@ timestamp
diff -up bind-9.7.0a3/lib/dns/Makefile.in.nonexec bind-9.7.0a3/lib/dns/Makefile.in
--- bind-9.7.0a3/lib/dns/Makefile.in.nonexec 2009-09-01 02:22:26.000000000 +0200
+++ bind-9.7.0a3/lib/dns/Makefile.in 2009-09-16 10:46:27.554643093 +0200
@@ -132,7 +132,7 @@ installdirs:
diff -up bind-9.7.0rc2/lib/dns/Makefile.in.nonexec bind-9.7.0rc2/lib/dns/Makefile.in
--- bind-9.7.0rc2/lib/dns/Makefile.in.nonexec 2009-12-06 00:31:40.000000000 +0100
+++ bind-9.7.0rc2/lib/dns/Makefile.in 2010-01-28 12:13:33.406696161 +0100
@@ -131,7 +131,7 @@ installdirs:
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${libdir}
install:: timestamp installdirs
@ -22,9 +22,9 @@ diff -up bind-9.7.0a3/lib/dns/Makefile.in.nonexec bind-9.7.0a3/lib/dns/Makefile.
clean distclean::
rm -f libdns.@A@ timestamp
diff -up bind-9.7.0a3/lib/isccc/Makefile.in.nonexec bind-9.7.0a3/lib/isccc/Makefile.in
--- bind-9.7.0a3/lib/isccc/Makefile.in.nonexec 2009-09-03 01:48:03.000000000 +0200
+++ bind-9.7.0a3/lib/isccc/Makefile.in 2009-09-16 10:46:27.554643093 +0200
diff -up bind-9.7.0rc2/lib/isccc/Makefile.in.nonexec bind-9.7.0rc2/lib/isccc/Makefile.in
--- bind-9.7.0rc2/lib/isccc/Makefile.in.nonexec 2009-12-06 00:31:41.000000000 +0100
+++ bind-9.7.0rc2/lib/isccc/Makefile.in 2010-01-28 12:13:33.406696161 +0100
@@ -80,7 +80,7 @@ installdirs:
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${libdir}
@ -34,9 +34,9 @@ diff -up bind-9.7.0a3/lib/isccc/Makefile.in.nonexec bind-9.7.0a3/lib/isccc/Makef
clean distclean::
rm -f libisccc.@A@ timestamp
diff -up bind-9.7.0a3/lib/isccfg/Makefile.in.nonexec bind-9.7.0a3/lib/isccfg/Makefile.in
--- bind-9.7.0a3/lib/isccfg/Makefile.in.nonexec 2009-09-03 01:48:03.000000000 +0200
+++ bind-9.7.0a3/lib/isccfg/Makefile.in 2009-09-16 10:46:27.554643093 +0200
diff -up bind-9.7.0rc2/lib/isccfg/Makefile.in.nonexec bind-9.7.0rc2/lib/isccfg/Makefile.in
--- bind-9.7.0rc2/lib/isccfg/Makefile.in.nonexec 2009-12-06 00:31:41.000000000 +0100
+++ bind-9.7.0rc2/lib/isccfg/Makefile.in 2010-01-28 12:13:33.406696161 +0100
@@ -77,7 +77,7 @@ installdirs:
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${libdir}
@ -46,9 +46,9 @@ diff -up bind-9.7.0a3/lib/isccfg/Makefile.in.nonexec bind-9.7.0a3/lib/isccfg/Mak
clean distclean::
rm -f libisccfg.@A@ timestamp
diff -up bind-9.7.0a3/lib/isc/Makefile.in.nonexec bind-9.7.0a3/lib/isc/Makefile.in
--- bind-9.7.0a3/lib/isc/Makefile.in.nonexec 2009-09-04 20:13:44.000000000 +0200
+++ bind-9.7.0a3/lib/isc/Makefile.in 2009-09-16 10:47:07.074642868 +0200
diff -up bind-9.7.0rc2/lib/isc/Makefile.in.nonexec bind-9.7.0rc2/lib/isc/Makefile.in
--- bind-9.7.0rc2/lib/isc/Makefile.in.nonexec 2009-12-18 05:09:55.000000000 +0100
+++ bind-9.7.0rc2/lib/isc/Makefile.in 2010-01-28 12:13:53.566696766 +0100
@@ -121,7 +121,7 @@ installdirs:
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${libdir}
@ -56,11 +56,11 @@ diff -up bind-9.7.0a3/lib/isc/Makefile.in.nonexec bind-9.7.0a3/lib/isc/Makefile.
- ${LIBTOOL_MODE_INSTALL} ${INSTALL_DATA} libisc.@A@ ${DESTDIR}${libdir}
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} libisc.@A@ ${DESTDIR}${libdir}
install:: @ISC_ARCH_DIR@/include/isc/atomic.h
${INSTALL_DATA} @ISC_ARCH_DIR@/include/isc/atomic.h ${DESTDIR}${includedir}/isc
diff -up bind-9.7.0a3/lib/lwres/Makefile.in.nonexec bind-9.7.0a3/lib/lwres/Makefile.in
--- bind-9.7.0a3/lib/lwres/Makefile.in.nonexec 2007-06-20 01:47:22.000000000 +0200
+++ bind-9.7.0a3/lib/lwres/Makefile.in 2009-09-16 10:46:27.554643093 +0200
clean distclean::
rm -f libisc.@A@ libisc-nosymtbl.@A@ libisc.la \
diff -up bind-9.7.0rc2/lib/lwres/Makefile.in.nonexec bind-9.7.0rc2/lib/lwres/Makefile.in
--- bind-9.7.0rc2/lib/lwres/Makefile.in.nonexec 2007-06-20 01:47:22.000000000 +0200
+++ bind-9.7.0rc2/lib/lwres/Makefile.in 2010-01-28 12:13:33.406696161 +0100
@@ -78,7 +78,7 @@ installdirs:
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${libdir}

View File

@ -4,7 +4,7 @@
#%define PATCHVER P1
#%define VERSION %{version}-%{PATCHVER}
%define PREVER rc1
%define PREVER rc2
%define VERSION %{version}%{PREVER}
%{?!SDB: %define SDB 1}
@ -20,7 +20,7 @@ Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) serv
Name: bind
License: ISC
Version: 9.7.0
Release: 0.12.%{PREVER}%{?dist}
Release: 0.13.%{PREVER}%{?dist}
Epoch: 32
Url: http://www.isc.org/products/BIND/
Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -496,6 +496,7 @@ rm -rf ${RPM_BUILD_ROOT}
%{_sbindir}/named
%{_sbindir}/rndc*
%{_sbindir}/named-compilezone
%{_sbindir}/isc-hmac-fixup
%{_mandir}/man1/arpaname.1*
%{_mandir}/man5/named.conf.5*
%{_mandir}/man5/rndc.conf.5*
@ -511,6 +512,7 @@ rm -rf ${RPM_BUILD_ROOT}
%{_mandir}/man8/genrandom.8*
%{_mandir}/man8/named-journalprint.8*
%{_mandir}/man8/nsec3hash.8*
%{_mandir}/man8/isc-hmac-fixup.8*
%doc CHANGES COPYRIGHT README named.conf.default
%doc doc/arm doc/misc doc/draft doc/rfc
%doc sample/
@ -621,6 +623,9 @@ rm -rf ${RPM_BUILD_ROOT}
%endif
%changelog
* Thu Jan 28 2010 Adam Tkac <atkac redhat com> 32:9.7.0-0.13.rc2
- update to 9.7.0rc2
* Wed Jan 27 2010 Adam Tkac <atkac redhat com> 32:9.7.0-0.12.rc1
- initscript LSB related fixes (#523435)

View File

@ -1,2 +1,2 @@
4f7e99f8aef6b3d19ef86647c183f502 bind-9.7.0rc1.tar.gz
4c35a2aac8d8054ea2154906bf57fb52 config-5.tar.bz2
9b8a31ac279868264e5bcbacd7991149 bind-9.7.0rc2.tar.gz