Update to correct Docbook stylesheets
Docbook5 stylesheets with namespaces are required. BIND uses Docbook5 format. While it tries to keep compatibility with older stylesheets, it fails silently and format of manual pages is broken. Details in upstream issue: https://gitlab.isc.org/isc-projects/bind9/-/issues/2310 Docbook5 generates manual pages with [FIXME: manual] instead of BIND9. Fix metadata to be recognized and provide this value.
This commit is contained in:
parent
118269cb8c
commit
7c7ec8981c
11
bind.spec
11
bind.spec
@ -232,7 +232,9 @@ BuildRequires: libmaxminddb-devel
|
||||
BuildRequires: fstrm-devel protobuf-c-devel
|
||||
%endif
|
||||
# Needed to regenerate dig.1 manpage
|
||||
BuildRequires: docbook-style-xsl, libxslt
|
||||
# Docbook5 with namespace is required.
|
||||
# Visit for details: https://gitlab.isc.org/isc-projects/bind9/-/issues/2310
|
||||
BuildRequires: docbook5-style-xsl, libxslt
|
||||
%if %{with TSAN}
|
||||
BuildRequires: libtsan
|
||||
%endif
|
||||
@ -583,6 +585,11 @@ are used for building ISC DHCP.
|
||||
mkdir lib/dns/tests/testdata/dstrandom
|
||||
cp -a %{SOURCE50} lib/dns/tests/testdata/dstrandom/random.data
|
||||
|
||||
# Avoid having [FIXME: manual] on top of generated manual pages
|
||||
# https://gitlab.isc.org/isc-projects/bind9/-/merge_requests/4524
|
||||
find bin lib/lwres/man -name '*.docbook' -exec \
|
||||
sed -e 's|<refmiscinfo>BIND9|<refmiscinfo class="manual">BIND9|' -i '{}' ';'
|
||||
|
||||
%if %{with PKCS11}
|
||||
cp -r bin/named{,-pkcs11}
|
||||
cp -r bin/dnssec{,-pkcs11}
|
||||
@ -727,7 +734,7 @@ export LIBDIR_SUFFIX
|
||||
--with-cmocka \
|
||||
%endif
|
||||
--enable-fixed-rrset \
|
||||
--with-docbook-xsl=%{_datadir}/sgml/docbook/xsl-stylesheets \
|
||||
--with-docbook-xsl=%{_datadir}/sgml/docbook/xsl-ns-stylesheets \
|
||||
--enable-full-report \
|
||||
;
|
||||
%if %{with DNSTAP}
|
||||
|
@ -1,38 +1,56 @@
|
||||
From a76716d5d039947d6fe2cd49a151b16a29e12d42 Mon Sep 17 00:00:00 2001
|
||||
From: Petr Mensik <pemensik@redhat.com>
|
||||
Date: Mon, 4 Jan 2021 12:55:49 +0100
|
||||
Subject: [PATCH] .rh640538
|
||||
---
|
||||
bin/dig/dig.docbook | 43 +++++++++++++++++++++++++++++++++++++++++++
|
||||
1 file changed, 43 insertions(+)
|
||||
|
||||
diff --git a/bin/dig/dig.docbook b/bin/dig/dig.docbook
|
||||
index 1079421..f11abd1 100644
|
||||
index 8ccf207..6d16d37 100644
|
||||
--- a/bin/dig/dig.docbook
|
||||
+++ b/bin/dig/dig.docbook
|
||||
@@ -1177,6 +1177,39 @@ dig +qr www.isc.org any -x 127.0.0.1 isc.org ns +noqr
|
||||
@@ -1336,6 +1336,49 @@ dig +qr www.isc.org any -x 127.0.0.1 isc.org ns +noqr
|
||||
</para>
|
||||
</refsection>
|
||||
|
||||
+ <refsection><info><title>RETURN CODES</title></info>
|
||||
+
|
||||
+ <para>
|
||||
+ <command>Dig</command> return codes are:
|
||||
+
|
||||
+ <variablelist>
|
||||
+ <varlistentry>
|
||||
+ <term>0</term>
|
||||
+ <listitem>
|
||||
+ <para>0: Everything went well, including things like NXDOMAIN</para>
|
||||
+ <para>Everything went well, including things like NXDOMAIN.</para>
|
||||
+ </listitem>
|
||||
+ </varlistentry>
|
||||
+ <varlistentry>
|
||||
+ <term>1</term>
|
||||
+ <listitem>
|
||||
+ <para>1: Usage error</para>
|
||||
+ <para>Usage error.</para>
|
||||
+ </listitem>
|
||||
+ </varlistentry>
|
||||
+
|
||||
+ <varlistentry>
|
||||
+ <term>8</term>
|
||||
+ <listitem>
|
||||
+ <para>Could not open batch file.</para>
|
||||
+ </listitem>
|
||||
+ </varlistentry>
|
||||
+ <varlistentry>
|
||||
+ <term>9</term>
|
||||
+ <listitem>
|
||||
+ <para>8: Couldn't open batch file</para>
|
||||
+ <para>No reply from server.
|
||||
+ </para>
|
||||
+ </listitem>
|
||||
+ </varlistentry>
|
||||
+ <varlistentry>
|
||||
+ <term>10</term>
|
||||
+ <listitem>
|
||||
+ <para>9: No reply from server</para>
|
||||
+ </listitem>
|
||||
+ </varlistentry>
|
||||
+ <varlistentry>
|
||||
+ <listitem>
|
||||
+ <para>10: Internal error</para>
|
||||
+ <para>Internal error.
|
||||
+ </para>
|
||||
+ </listitem>
|
||||
+ </varlistentry>
|
||||
+ </variablelist>
|
||||
@ -42,3 +60,6 @@ index 1079421..f11abd1 100644
|
||||
<refsection><info><title>FILES</title></info>
|
||||
|
||||
<para><filename>/etc/resolv.conf</filename>
|
||||
--
|
||||
2.26.2
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user