Update to 9.8.0-P4

- bind98-libdns-export.patch merged

Signed-off-by: Adam Tkac <atkac@redhat.com>
This commit is contained in:
Adam Tkac 2011-07-05 21:00:37 +02:00
parent 95c9b3fdb6
commit 796ae3f199
4 changed files with 8 additions and 62 deletions

1
.gitignore vendored
View File

@ -13,3 +13,4 @@ bind-9.7.2b1.tar.gz
/bind-9.8.0.tar.gz
/bind-9.8.0-P1.tar.gz
/bind-9.8.0-P2.tar.gz
/bind-9.8.0-P4.tar.gz

View File

@ -2,7 +2,7 @@
# Red Hat BIND package .spec file
#
%define PATCHVER P2
%define PATCHVER P4
#%define PREVER rc1
#%define VERSION %{version}
#%define VERSION %{version}%{PREVER}
@ -22,7 +22,7 @@ Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) serv
Name: bind
License: ISC
Version: 9.8.0
Release: 6.%{PATCHVER}%{?dist}
Release: 7.%{PATCHVER}%{?dist}
Epoch: 32
Url: http://www.isc.org/products/BIND/
Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -64,7 +64,6 @@ Patch112:bind97-rh645544.patch
Patch113:bind97-rh674334.patch
Patch115:bind97-cleanup.patch
Patch116:bind98-includes.patch
Patch117:bind98-libdns-export.patch
# SDB patches
Patch11: bind-9.3.2b2-sdbsrc.patch
@ -303,7 +302,6 @@ mkdir m4
%patch113 -p1 -b .rh674334
%patch115 -p1 -b .cleanup
%patch116 -p1 -b .includes
%patch117 -p1 -b .libdns-export
# Sparc and s390 arches need to use -fPIE
%ifarch sparcv9 sparc64 s390 s390x
@ -772,6 +770,10 @@ rm -rf ${RPM_BUILD_ROOT}
%endif
%changelog
* Tue Jul 05 2011 Adam Tkac <atkac redhat com> 32:9.8.0-7.P4
- update to 9.8.0-P4
- bind98-libdns-export.patch merged
* Thu Jun 02 2011 Adam Tkac <atkac redhat com> 32:9.8.0-6.P2
- update the dyndb patch

View File

@ -1,57 +0,0 @@
diff -up bind-9.8.0-P2/lib/dns/masterdump.c.libdns-export bind-9.8.0-P2/lib/dns/masterdump.c
--- bind-9.8.0-P2/lib/dns/masterdump.c.libdns-export 2011-05-27 10:48:10.216765461 +0200
+++ bind-9.8.0-P2/lib/dns/masterdump.c 2011-05-27 10:48:50.428765471 +0200
@@ -700,6 +700,26 @@ dns_master_questiontotext(dns_name_t *ow
ISC_FALSE, target));
}
+static const char *trustnames[] = {
+ "none",
+ "pending-additional",
+ "pending-answer",
+ "additional",
+ "glue",
+ "answer",
+ "authauthority",
+ "authanswer",
+ "secure",
+ "local" /* aka ultimate */
+};
+
+const char *
+dns_trust_totext(dns_trust_t trust) {
+ if (trust >= sizeof(trustnames)/sizeof(*trustnames))
+ return ("bad");
+ return (trustnames[trust]);
+}
+
#ifdef BIND9
/*
* Print an rdataset. 'buffer' is a scratch buffer, which must have been
@@ -835,26 +855,6 @@ dump_order_compare(const void *a, const
#define MAXSORT 64
-static const char *trustnames[] = {
- "none",
- "pending-additional",
- "pending-answer",
- "additional",
- "glue",
- "answer",
- "authauthority",
- "authanswer",
- "secure",
- "local" /* aka ultimate */
-};
-
-const char *
-dns_trust_totext(dns_trust_t trust) {
- if (trust >= sizeof(trustnames)/sizeof(*trustnames))
- return ("bad");
- return (trustnames[trust]);
-}
-
static isc_result_t
dump_rdatasets_text(isc_mem_t *mctx, dns_name_t *name,
dns_rdatasetiter_t *rdsiter, dns_totext_ctx_t *ctx,

View File

@ -1,2 +1,2 @@
5f90dcf1730631feacdad3257c465c54 bind-9.8.0-P2.tar.gz
76857526420dc8e153ad688aeb5a2c4b config-8.tar.bz2
13e36e3f28dc1ce7675b45a4192e8389 bind-9.8.0-P4.tar.gz