Update to 9.8.1 and fix some bugs
- ship /etc/trusted-key.key (needed by dig) - use select instead of epoll in export libs (#735103) Signed-off-by: Adam Tkac <atkac@redhat.com>
This commit is contained in:
parent
4cd36470f8
commit
771823363d
1
.gitignore
vendored
1
.gitignore
vendored
@ -15,3 +15,4 @@ bind-9.7.2b1.tar.gz
|
|||||||
/bind-9.8.0-P2.tar.gz
|
/bind-9.8.0-P2.tar.gz
|
||||||
/bind-9.8.0-P4.tar.gz
|
/bind-9.8.0-P4.tar.gz
|
||||||
/bind-9.8.1rc1.tar.gz
|
/bind-9.8.1rc1.tar.gz
|
||||||
|
/bind-9.8.1.tar.gz
|
||||||
|
18
bind.spec
18
bind.spec
@ -3,10 +3,10 @@
|
|||||||
#
|
#
|
||||||
|
|
||||||
#%define PATCHVER P4
|
#%define PATCHVER P4
|
||||||
%define PREVER rc1
|
#%define PREVER rc1
|
||||||
#%define VERSION %{version}
|
#%define VERSION %{version}%{PREVER}
|
||||||
#%define VERSION %{version}-%{PATCHVER}
|
#%define VERSION %{version}-%{PATCHVER}
|
||||||
%define VERSION %{version}%{PREVER}
|
%define VERSION %{version}
|
||||||
|
|
||||||
%{?!SDB: %define SDB 1}
|
%{?!SDB: %define SDB 1}
|
||||||
%{?!test: %define test 0}
|
%{?!test: %define test 0}
|
||||||
@ -22,7 +22,7 @@ Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) serv
|
|||||||
Name: bind
|
Name: bind
|
||||||
License: ISC
|
License: ISC
|
||||||
Version: 9.8.1
|
Version: 9.8.1
|
||||||
Release: 0.3.%{PREVER}%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 32
|
Epoch: 32
|
||||||
Url: http://www.isc.org/products/BIND/
|
Url: http://www.isc.org/products/BIND/
|
||||||
Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -44,6 +44,7 @@ Source32: named-sdb.8
|
|||||||
Source33: zonetodb.1
|
Source33: zonetodb.1
|
||||||
Source34: zone2sqlite.1
|
Source34: zone2sqlite.1
|
||||||
Source35: bind.tmpfiles.d
|
Source35: bind.tmpfiles.d
|
||||||
|
Source36: trusted-key.key
|
||||||
|
|
||||||
# Common patches
|
# Common patches
|
||||||
Patch5: bind-nonexec.patch
|
Patch5: bind-nonexec.patch
|
||||||
@ -67,6 +68,7 @@ Patch119:bind97-rh693982.patch
|
|||||||
Patch120:bind97-rh700097.patch
|
Patch120:bind97-rh700097.patch
|
||||||
Patch121:bind97-rh714049.patch
|
Patch121:bind97-rh714049.patch
|
||||||
Patch122:bind98-dlz_buildfix.patch
|
Patch122:bind98-dlz_buildfix.patch
|
||||||
|
Patch123:bind98-rh735103.patch
|
||||||
|
|
||||||
# SDB patches
|
# SDB patches
|
||||||
Patch11: bind-9.3.2b2-sdbsrc.patch
|
Patch11: bind-9.3.2b2-sdbsrc.patch
|
||||||
@ -309,6 +311,7 @@ mkdir m4
|
|||||||
%patch120 -p1 -b .rh700097
|
%patch120 -p1 -b .rh700097
|
||||||
%patch121 -p1 -b .rh714049
|
%patch121 -p1 -b .rh714049
|
||||||
%patch122 -p1 -b .dlz_buildfix
|
%patch122 -p1 -b .dlz_buildfix
|
||||||
|
%patch123 -p1 -b .rh735103
|
||||||
|
|
||||||
# Sparc and s390 arches need to use -fPIE
|
# Sparc and s390 arches need to use -fPIE
|
||||||
%ifarch sparcv9 sparc64 s390 s390x
|
%ifarch sparcv9 sparc64 s390 s390x
|
||||||
@ -459,6 +462,7 @@ touch ${RPM_BUILD_ROOT}/etc/rndc.key
|
|||||||
touch ${RPM_BUILD_ROOT}/etc/rndc.conf
|
touch ${RPM_BUILD_ROOT}/etc/rndc.conf
|
||||||
mkdir ${RPM_BUILD_ROOT}/etc/named
|
mkdir ${RPM_BUILD_ROOT}/etc/named
|
||||||
install -m 644 bind.keys ${RPM_BUILD_ROOT}/etc/named.iscdlv.key
|
install -m 644 bind.keys ${RPM_BUILD_ROOT}/etc/named.iscdlv.key
|
||||||
|
install -m 644 %{SOURCE36} ${RPM_BUILD_ROOT}/etc/trusted-key.key
|
||||||
|
|
||||||
# sample bind configuration files for %%doc:
|
# sample bind configuration files for %%doc:
|
||||||
mkdir -p sample/etc sample/var/named/{data,slaves}
|
mkdir -p sample/etc sample/var/named/{data,slaves}
|
||||||
@ -723,6 +727,7 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%{_mandir}/man1/nsupdate.1*
|
%{_mandir}/man1/nsupdate.1*
|
||||||
%{_mandir}/man1/dig.1*
|
%{_mandir}/man1/dig.1*
|
||||||
%{_mandir}/man1/nslookup.1*
|
%{_mandir}/man1/nslookup.1*
|
||||||
|
%{_sysconfdir}/trusted-key.key
|
||||||
|
|
||||||
%if %{DEVEL}
|
%if %{DEVEL}
|
||||||
%files devel
|
%files devel
|
||||||
@ -777,6 +782,11 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Sep 07 2011 Adam Tkac <atkac redhat com> 32:9.8.1-1
|
||||||
|
- update to 9.8.1
|
||||||
|
- ship /etc/trusted-key.key (needed by dig)
|
||||||
|
- use select instead of epoll in export libs (#735103)
|
||||||
|
|
||||||
* Wed Aug 31 2011 Adam Tkac <atkac redhat com> 32:9.8.1-0.3.rc1
|
* Wed Aug 31 2011 Adam Tkac <atkac redhat com> 32:9.8.1-0.3.rc1
|
||||||
- fix DLZ related compilation issues
|
- fix DLZ related compilation issues
|
||||||
- make /etc/named.{root,iscdlv}.key world-readable
|
- make /etc/named.{root,iscdlv}.key world-readable
|
||||||
|
40
bind98-rh735103.patch
Normal file
40
bind98-rh735103.patch
Normal file
@ -0,0 +1,40 @@
|
|||||||
|
diff -up bind-9.8.1rc1/lib/isc/unix/socket.c.rh735103 bind-9.8.1rc1/lib/isc/unix/socket.c
|
||||||
|
--- bind-9.8.1rc1/lib/isc/unix/socket.c.rh735103 2011-07-29 04:19:20.000000000 +0200
|
||||||
|
+++ bind-9.8.1rc1/lib/isc/unix/socket.c 2011-09-07 18:49:54.100215897 +0200
|
||||||
|
@@ -57,6 +57,20 @@
|
||||||
|
#include <isc/util.h>
|
||||||
|
#include <isc/xml.h>
|
||||||
|
|
||||||
|
+/* See task.c about the following definition: */
|
||||||
|
+#ifdef BIND9
|
||||||
|
+#ifdef ISC_PLATFORM_USETHREADS
|
||||||
|
+#define USE_WATCHER_THREAD
|
||||||
|
+#else
|
||||||
|
+#define USE_SHARED_MANAGER
|
||||||
|
+#endif /* ISC_PLATFORM_USETHREADS */
|
||||||
|
+#else /* BIND9 */
|
||||||
|
+#undef ISC_PLATFORM_HAVESYSUNH
|
||||||
|
+#undef ISC_PLATFORM_HAVEKQUEUE
|
||||||
|
+#undef ISC_PLATFORM_HAVEEPOLL
|
||||||
|
+#undef ISC_PLATFORM_HAVEDEVPOLL
|
||||||
|
+#endif /* BIND9 */
|
||||||
|
+
|
||||||
|
#ifdef ISC_PLATFORM_HAVESYSUNH
|
||||||
|
#include <sys/un.h>
|
||||||
|
#endif
|
||||||
|
@@ -76,15 +90,6 @@
|
||||||
|
|
||||||
|
#include "errno2result.h"
|
||||||
|
|
||||||
|
-/* See task.c about the following definition: */
|
||||||
|
-#ifdef BIND9
|
||||||
|
-#ifdef ISC_PLATFORM_USETHREADS
|
||||||
|
-#define USE_WATCHER_THREAD
|
||||||
|
-#else
|
||||||
|
-#define USE_SHARED_MANAGER
|
||||||
|
-#endif /* ISC_PLATFORM_USETHREADS */
|
||||||
|
-#endif /* BIND9 */
|
||||||
|
-
|
||||||
|
#ifndef USE_WATCHER_THREAD
|
||||||
|
#include "socket_p.h"
|
||||||
|
#include "../task_p.h"
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
76857526420dc8e153ad688aeb5a2c4b config-8.tar.bz2
|
76857526420dc8e153ad688aeb5a2c4b config-8.tar.bz2
|
||||||
64f3cfe9fb2c3e03e1dc7e29b6f33125 bind-9.8.1rc1.tar.gz
|
cf31117c5d35af34d4c0702970ad9fb7 bind-9.8.1.tar.gz
|
||||||
|
1
trusted-key.key
Normal file
1
trusted-key.key
Normal file
@ -0,0 +1 @@
|
|||||||
|
. 3600 IN DNSKEY 257 3 8 AwEAAagAIKlVZrpC6Ia7gEzahOR+9W29euxhJhVVLOyQbSEW0O8gcCjFFVQUTf6v58fLjwBd0YI0EzrAcQqBGCzh/RStIoO8g0NfnfL2MTJRkxoXbfDaUeVPQuYEhg37NZWAJQ9VnMVDxP/VHL496M/QZxkjf5/Efucp2gaDX6RS6CXpoY68LsvPVjR0ZSwzz1apAzvN9dlzEheX7ICJBBtuA6G3LQpzW5hOA2hzCTMjJPJ8LbqF6dsV6DoBQzgul0sGIcGOYl7OyQdXfZ57relSQageu+ipAdTTJ25AsRTAoub8ONGcLmqrAmRLKBP1dfwhYB4N7knNnulqQxA+Uk1ihz0=
|
Loading…
Reference in New Issue
Block a user