- update to 9.7.2b1
- patches merged - bind97-rh507429.patch
This commit is contained in:
parent
fcc67a64f4
commit
62ad4d6446
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
bind-9.7.1-P2.tar.gz
|
||||
config-8.tar.bz2
|
||||
bind-9.7.2b1.tar.gz
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up bind-9.7.0rc1/bin/Makefile.in.sdb bind-9.7.0rc1/bin/Makefile.in
|
||||
--- bind-9.7.0rc1/bin/Makefile.in.sdb 2009-10-05 14:07:08.000000000 +0200
|
||||
+++ bind-9.7.0rc1/bin/Makefile.in 2009-12-15 12:58:11.913941164 +0100
|
||||
diff -up bind-9.7.2b1/bin/Makefile.in.sdb bind-9.7.2b1/bin/Makefile.in
|
||||
--- bind-9.7.2b1/bin/Makefile.in.sdb 2009-10-05 14:07:08.000000000 +0200
|
||||
+++ bind-9.7.2b1/bin/Makefile.in 2010-08-03 14:19:16.513711718 +0200
|
||||
@@ -19,8 +19,8 @@ srcdir = @srcdir@
|
||||
VPATH = @srcdir@
|
||||
top_srcdir = @top_srcdir@
|
||||
@ -12,9 +12,9 @@ diff -up bind-9.7.0rc1/bin/Makefile.in.sdb bind-9.7.0rc1/bin/Makefile.in
|
||||
TARGETS =
|
||||
|
||||
@BIND9_MAKE_RULES@
|
||||
diff -up bind-9.7.0rc1/bin/named/Makefile.in.sdb bind-9.7.0rc1/bin/named/Makefile.in
|
||||
--- bind-9.7.0rc1/bin/named/Makefile.in.sdb 2009-12-15 12:58:11.863950805 +0100
|
||||
+++ bind-9.7.0rc1/bin/named/Makefile.in 2009-12-15 12:58:57.163938385 +0100
|
||||
diff -up bind-9.7.2b1/bin/named/Makefile.in.sdb bind-9.7.2b1/bin/named/Makefile.in
|
||||
--- bind-9.7.2b1/bin/named/Makefile.in.sdb 2010-08-03 14:19:16.363679615 +0200
|
||||
+++ bind-9.7.2b1/bin/named/Makefile.in 2010-08-03 14:19:16.523713862 +0200
|
||||
@@ -45,7 +45,7 @@ CINCLUDES = -I${srcdir}/include -I${srcd
|
||||
${ISCCFG_INCLUDES} ${ISCCC_INCLUDES} ${ISC_INCLUDES} \
|
||||
${DLZDRIVER_INCLUDES} ${DBDRIVER_INCLUDES}
|
||||
@ -64,9 +64,9 @@ diff -up bind-9.7.0rc1/bin/named/Makefile.in.sdb bind-9.7.0rc1/bin/named/Makefil
|
||||
${INSTALL_DATA} ${srcdir}/named.conf.5 ${DESTDIR}${mandir}/man5
|
||||
-
|
||||
-@DLZ_DRIVER_RULES@
|
||||
diff -up bind-9.7.0rc1/bin/named-sdb/main.c.sdb bind-9.7.0rc1/bin/named-sdb/main.c
|
||||
--- bind-9.7.0rc1/bin/named-sdb/main.c.sdb 2009-12-15 12:58:11.893960333 +0100
|
||||
+++ bind-9.7.0rc1/bin/named-sdb/main.c 2009-12-15 12:58:11.913941164 +0100
|
||||
diff -up bind-9.7.2b1/bin/named-sdb/main.c.sdb bind-9.7.2b1/bin/named-sdb/main.c
|
||||
--- bind-9.7.2b1/bin/named-sdb/main.c.sdb 2010-08-03 14:19:16.423692459 +0200
|
||||
+++ bind-9.7.2b1/bin/named-sdb/main.c 2010-08-03 14:19:16.523713862 +0200
|
||||
@@ -75,6 +75,9 @@
|
||||
* Include header files for database drivers here.
|
||||
*/
|
||||
@ -77,7 +77,7 @@ diff -up bind-9.7.0rc1/bin/named-sdb/main.c.sdb bind-9.7.0rc1/bin/named-sdb/main
|
||||
|
||||
/*
|
||||
* Include DLZ drivers if appropriate.
|
||||
@@ -766,6 +769,10 @@ setup(void) {
|
||||
@@ -768,6 +771,10 @@ setup(void) {
|
||||
ns_main_earlyfatal("isc_app_start() failed: %s",
|
||||
isc_result_totext(result));
|
||||
|
||||
@ -88,7 +88,7 @@ diff -up bind-9.7.0rc1/bin/named-sdb/main.c.sdb bind-9.7.0rc1/bin/named-sdb/main
|
||||
isc_log_write(ns_g_lctx, NS_LOGCATEGORY_GENERAL, NS_LOGMODULE_MAIN,
|
||||
ISC_LOG_NOTICE, "starting BIND %s%s", ns_g_version,
|
||||
saved_command_line);
|
||||
@@ -849,6 +856,57 @@ setup(void) {
|
||||
@@ -851,6 +858,57 @@ setup(void) {
|
||||
isc_result_totext(result));
|
||||
#endif
|
||||
|
||||
@ -146,7 +146,7 @@ diff -up bind-9.7.0rc1/bin/named-sdb/main.c.sdb bind-9.7.0rc1/bin/named-sdb/main
|
||||
ns_server_create(ns_g_mctx, &ns_g_server);
|
||||
}
|
||||
|
||||
@@ -876,6 +934,10 @@ cleanup(void) {
|
||||
@@ -878,6 +936,10 @@ cleanup(void) {
|
||||
|
||||
dns_name_destroy();
|
||||
|
||||
@ -157,9 +157,9 @@ diff -up bind-9.7.0rc1/bin/named-sdb/main.c.sdb bind-9.7.0rc1/bin/named-sdb/main
|
||||
isc_log_write(ns_g_lctx, NS_LOGCATEGORY_GENERAL, NS_LOGMODULE_MAIN,
|
||||
ISC_LOG_NOTICE, "exiting");
|
||||
ns_log_shutdown();
|
||||
diff -up bind-9.7.0rc1/bin/named-sdb/Makefile.in.sdb bind-9.7.0rc1/bin/named-sdb/Makefile.in
|
||||
--- bind-9.7.0rc1/bin/named-sdb/Makefile.in.sdb 2009-12-15 12:58:11.873941824 +0100
|
||||
+++ bind-9.7.0rc1/bin/named-sdb/Makefile.in 2009-12-15 12:58:11.913941164 +0100
|
||||
diff -up bind-9.7.2b1/bin/named-sdb/Makefile.in.sdb bind-9.7.2b1/bin/named-sdb/Makefile.in
|
||||
--- bind-9.7.2b1/bin/named-sdb/Makefile.in.sdb 2010-08-03 14:19:16.413690320 +0200
|
||||
+++ bind-9.7.2b1/bin/named-sdb/Makefile.in 2010-08-03 14:19:16.523713862 +0200
|
||||
@@ -28,10 +28,10 @@ top_srcdir = @top_srcdir@
|
||||
#
|
||||
# Add database drivers here.
|
||||
@ -209,10 +209,10 @@ diff -up bind-9.7.0rc1/bin/named-sdb/Makefile.in.sdb bind-9.7.0rc1/bin/named-sdb
|
||||
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} named-sdb@EXEEXT@ ${DESTDIR}${sbindir}
|
||||
|
||||
@DLZ_DRIVER_RULES@
|
||||
diff -up bind-9.7.0rc1/configure.in.sdb bind-9.7.0rc1/configure.in
|
||||
--- bind-9.7.0rc1/configure.in.sdb 2009-11-11 09:46:47.000000000 +0100
|
||||
+++ bind-9.7.0rc1/configure.in 2009-12-15 12:58:11.913941164 +0100
|
||||
@@ -3241,6 +3241,8 @@ AC_CONFIG_FILES([
|
||||
diff -up bind-9.7.2b1/configure.in.sdb bind-9.7.2b1/configure.in
|
||||
--- bind-9.7.2b1/configure.in.sdb 2010-06-22 06:02:39.000000000 +0200
|
||||
+++ bind-9.7.2b1/configure.in 2010-08-03 14:20:20.707451485 +0200
|
||||
@@ -3266,6 +3266,8 @@ AC_CONFIG_FILES([
|
||||
bin/confgen/unix/Makefile
|
||||
bin/named/Makefile
|
||||
bin/named/unix/Makefile
|
||||
@ -221,8 +221,8 @@ diff -up bind-9.7.0rc1/configure.in.sdb bind-9.7.0rc1/configure.in
|
||||
bin/rndc/Makefile
|
||||
bin/dig/Makefile
|
||||
bin/nsupdate/Makefile
|
||||
@@ -3262,6 +3264,7 @@ AC_CONFIG_FILES([
|
||||
bin/tests/headerdep_test.sh
|
||||
@@ -3290,6 +3292,7 @@ AC_CONFIG_FILES([
|
||||
bin/tests/virtual-time/conf.sh
|
||||
bin/tools/Makefile
|
||||
bin/dnssec/Makefile
|
||||
+ bin/sdb_tools/Makefile
|
||||
|
19
bind.spec
19
bind.spec
@ -2,11 +2,11 @@
|
||||
# Red Hat BIND package .spec file
|
||||
#
|
||||
|
||||
%define PATCHVER P2
|
||||
#%define PREVER rc1
|
||||
#%define VERSION %{version}%{PREVER}
|
||||
#%define PATCHVER P2
|
||||
%define PREVER b1
|
||||
#%define VERSION %{version}
|
||||
%define VERSION %{version}-%{PATCHVER}
|
||||
#%define VERSION %{version}-%{PATCHVER}
|
||||
%define VERSION %{version}%{PREVER}
|
||||
|
||||
%{?!SDB: %define SDB 1}
|
||||
%{?!test: %define test 0}
|
||||
@ -20,8 +20,8 @@
|
||||
Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) server
|
||||
Name: bind
|
||||
License: ISC
|
||||
Version: 9.7.1
|
||||
Release: 5.%{PATCHVER}%{?dist}
|
||||
Version: 9.7.2
|
||||
Release: 0.1.%{PREVER}%{?dist}
|
||||
Epoch: 32
|
||||
Url: http://www.isc.org/products/BIND/
|
||||
Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -56,7 +56,6 @@ Patch102:bind-95-rh452060.patch
|
||||
Patch106:bind93-rh490837.patch
|
||||
Patch107:bind97-dist-pkcs11.patch
|
||||
Patch109:bind97-rh478718.patch
|
||||
Patch110:bind97-rh507429.patch
|
||||
|
||||
# SDB patches
|
||||
Patch11: bind-9.3.2b2-sdbsrc.patch
|
||||
@ -238,7 +237,6 @@ mkdir m4
|
||||
%patch106 -p0 -b .rh490837
|
||||
%patch107 -p1 -b .dist-pkcs11
|
||||
%patch109 -p1 -b .rh478718
|
||||
%patch110 -p1 -b .rh507429
|
||||
|
||||
# Sparc and s390 arches need to use -fPIE
|
||||
%ifarch sparcv9 sparc64 s390 s390x
|
||||
@ -674,6 +672,11 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Aug 03 2010 Adam Tkac <atkac redhat com> 32:9.7.2-0.1.b1
|
||||
- update to 9.7.2b1
|
||||
- patches merged
|
||||
- bind97-rh507429.patch
|
||||
|
||||
* Mon Jul 19 2010 Adam Tkac <atkac redhat com> 32:9.7.1-5.P2
|
||||
- supply root zone DNSKEY in default configuration
|
||||
|
||||
|
@ -1,33 +0,0 @@
|
||||
diff -up bind-9.7.0-P1/lib/dns/resolver.c.rh507429 bind-9.7.0-P1/lib/dns/resolver.c
|
||||
--- bind-9.7.0-P1/lib/dns/resolver.c.rh507429 2010-03-26 14:53:12.776469537 +0100
|
||||
+++ bind-9.7.0-P1/lib/dns/resolver.c 2010-03-26 15:07:18.363969402 +0100
|
||||
@@ -6160,6 +6160,7 @@ resume_dslookup(isc_task_t *task, isc_ev
|
||||
if (fevent->result == ISC_R_CANCELED) {
|
||||
dns_resolver_destroyfetch(&fctx->nsfetch);
|
||||
fctx_done(fctx, ISC_R_CANCELED, __LINE__);
|
||||
+ goto cleanup;
|
||||
} else if (fevent->result == ISC_R_SUCCESS) {
|
||||
|
||||
FCTXTRACE("resuming DS lookup");
|
||||
@@ -6219,15 +6220,16 @@ resume_dslookup(isc_task_t *task, isc_ev
|
||||
resume_dslookup, fctx,
|
||||
&fctx->nsrrset, NULL,
|
||||
&fctx->nsfetch);
|
||||
- if (result != ISC_R_SUCCESS)
|
||||
+ if (result != ISC_R_SUCCESS) {
|
||||
fctx_done(fctx, result, __LINE__);
|
||||
- else {
|
||||
- LOCK(&res->buckets[bucketnum].lock);
|
||||
- locked = ISC_TRUE;
|
||||
- fctx->references++;
|
||||
+ goto cleanup;
|
||||
}
|
||||
}
|
||||
|
||||
+ LOCK(&res->buckets[bucketnum].lock);
|
||||
+ locked = ISC_TRUE;
|
||||
+ fctx->references++;
|
||||
+
|
||||
cleanup:
|
||||
if (dns_rdataset_isassociated(&nameservers))
|
||||
dns_rdataset_disassociate(&nameservers);
|
Loading…
Reference in New Issue
Block a user