Remove unused patches
This commit is contained in:
parent
c223e3e275
commit
5c15ad824e
@ -1,53 +0,0 @@
|
|||||||
diff --git a/bin/named-sdb/Makefile.in b/bin/named-sdb/Makefile.in
|
|
||||||
index 1894830..445182a 100644
|
|
||||||
--- a/bin/named-sdb/Makefile.in
|
|
||||||
+++ b/bin/named-sdb/Makefile.in
|
|
||||||
@@ -34,10 +34,10 @@ top_srcdir = @top_srcdir@
|
|
||||||
#
|
|
||||||
# Add database drivers here.
|
|
||||||
#
|
|
||||||
-DBDRIVER_OBJS = ldapdb.@O@ pgsqldb.@O@ dirdb.@O@
|
|
||||||
-DBDRIVER_SRCS = ldapdb.c pgsqldb.c dirdb.c
|
|
||||||
+DBDRIVER_OBJS = ldapdb.@O@ pgsqldb.@O@ sqlitedb.@O@ dirdb.@O@
|
|
||||||
+DBDRIVER_SRCS = ldapdb.c pgsqldb.c sqlitedb.c dirdb.c
|
|
||||||
DBDRIVER_INCLUDES =
|
|
||||||
-DBDRIVER_LIBS = -lldap -llber -lpq
|
|
||||||
+DBDRIVER_LIBS = -lldap -llber -lsqlite3 -lpq
|
|
||||||
|
|
||||||
DLZ_DRIVER_DIR = ${top_srcdir}/contrib/dlz/drivers
|
|
||||||
|
|
||||||
diff --git a/bin/sdb_tools/Makefile.in b/bin/sdb_tools/Makefile.in
|
|
||||||
index 7f3c5e2..b1bca66 100644
|
|
||||||
--- a/bin/sdb_tools/Makefile.in
|
|
||||||
+++ b/bin/sdb_tools/Makefile.in
|
|
||||||
@@ -32,11 +32,11 @@ DEPLIBS = ${LWRESDEPLIBS} ${DNSDEPLIBS} ${BIND9DEPLIBS} \
|
|
||||||
LIBS = ${LWRESLIBS} ${DNSLIBS} ${BIND9LIBS} \
|
|
||||||
${ISCCFGLIBS} ${ISCCCLIBS} ${ISCLIBS} ${DBDRIVER_LIBS} @LIBS@
|
|
||||||
|
|
||||||
-TARGETS = zone2ldap@EXEEXT@ zonetodb@EXEEXT@
|
|
||||||
+TARGETS = zone2ldap@EXEEXT@ zonetodb@EXEEXT@ zone2sqlite@EXEEXT@
|
|
||||||
|
|
||||||
-OBJS = zone2ldap.@O@ zonetodb.@O@
|
|
||||||
+OBJS = zone2ldap.@O@ zonetodb.@O@ zone2sqlite.@O@
|
|
||||||
|
|
||||||
-SRCS = zone2ldap.c zonetodb.c
|
|
||||||
+SRCS = zone2ldap.c zonetodb.c zone2sqlite.c
|
|
||||||
|
|
||||||
MANPAGES = zone2ldap.1
|
|
||||||
|
|
||||||
@@ -50,6 +50,9 @@ zone2ldap@EXEEXT@: zone2ldap.@O@ ${DEPLIBS}
|
|
||||||
zonetodb@EXEEXT@: zonetodb.@O@ ${DEPLIBS}
|
|
||||||
${LIBTOOL_MODE_LINK} ${PURIFY} ${CC} ${CFLAGS} ${LDFLAGS} -o $@ zonetodb.@O@ -lpq ${LIBS}
|
|
||||||
|
|
||||||
+zone2sqlite@EXEEXT@: zone2sqlite.@O@ ${DEPLIBS}
|
|
||||||
+ ${LIBTOOL_MODE_LINK} ${PURIFY} ${CC} ${ALL_CFLAGS} ${LDFLAGS} -o $@ zone2sqlite.@O@ -lsqlite3 -lssl ${LIBS}
|
|
||||||
+
|
|
||||||
clean distclean manclean maintainer-clean::
|
|
||||||
rm -f ${TARGETS} ${OBJS}
|
|
||||||
|
|
||||||
@@ -60,4 +63,5 @@ installdirs:
|
|
||||||
install:: ${TARGETS} installdirs
|
|
||||||
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} zone2ldap@EXEEXT@ ${DESTDIR}${sbindir}
|
|
||||||
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} zonetodb@EXEEXT@ ${DESTDIR}${sbindir}
|
|
||||||
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} zone2sqlite@EXEEXT@ ${DESTDIR}${sbindir}
|
|
||||||
${INSTALL_DATA} ${srcdir}/zone2ldap.1 ${DESTDIR}${mandir}/man1/zone2ldap.1
|
|
@ -1,86 +0,0 @@
|
|||||||
From fdfc8ad6a1069eea6b012972c972798003d58312 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Petr=20Men=C5=A1=C3=ADk?= <pemensik@redhat.com>
|
|
||||||
Date: Tue, 29 Jan 2019 18:07:44 +0100
|
|
||||||
Subject: [PATCH] Fallback to ASCII on output IDN conversion error
|
|
||||||
|
|
||||||
It is possible dig used ACE encoded name in locale, which does not
|
|
||||||
support converting it to unicode. Instead of fatal error, fallback to
|
|
||||||
ACE name on output.
|
|
||||||
|
|
||||||
(cherry picked from commit 7f4cb8f9584597fea16de6557124ac8b1bd47440)
|
|
||||||
|
|
||||||
Modify idna test to fallback to ACE
|
|
||||||
|
|
||||||
Test valid A-label on input would be displayed as A-label on output if
|
|
||||||
locale does not allow U-label.
|
|
||||||
|
|
||||||
(cherry picked from commit 4ce232f8605bdbe0594ebe5a71383c9d4e6f263b)
|
|
||||||
|
|
||||||
Emit warning on IDN output failure
|
|
||||||
|
|
||||||
Warning is emitted before any dig headers.
|
|
||||||
|
|
||||||
(cherry picked from commit 4b410038c531fbb902cd5fb83174eed1f06cb7d7)
|
|
||||||
---
|
|
||||||
bin/dig/dighost.c | 15 +++++++++++++--
|
|
||||||
bin/tests/system/idna/tests.sh | 17 +++++++++++++++++
|
|
||||||
2 files changed, 30 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/bin/dig/dighost.c b/bin/dig/dighost.c
|
|
||||||
index 73aaab8..375f99f 100644
|
|
||||||
--- a/bin/dig/dighost.c
|
|
||||||
+++ b/bin/dig/dighost.c
|
|
||||||
@@ -4877,9 +4877,20 @@ idn_ace_to_locale(const char *from, char *to, size_t tolen) {
|
|
||||||
*/
|
|
||||||
res = idn2_to_unicode_8zlz(utf8_src, &tmp_str, 0);
|
|
||||||
if (res != IDN2_OK) {
|
|
||||||
- fatal("Cannot represent '%s' in the current locale (%s), "
|
|
||||||
- "use +noidnout or a different locale",
|
|
||||||
+ static bool warned = false;
|
|
||||||
+
|
|
||||||
+ res = idn2_to_ascii_8z(utf8_src, &tmp_str, 0);
|
|
||||||
+ if (res != IDN2_OK) {
|
|
||||||
+ fatal("Cannot represent '%s' "
|
|
||||||
+ "in the current locale nor ascii (%s), "
|
|
||||||
+ "use +noidnout or a different locale",
|
|
||||||
from, idn2_strerror(res));
|
|
||||||
+ } else if (!warned) {
|
|
||||||
+ fprintf(stderr, ";; Warning: cannot represent '%s' "
|
|
||||||
+ "in the current locale",
|
|
||||||
+ tmp_str);
|
|
||||||
+ warned = true;
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
|
|
||||||
/*
|
|
||||||
diff --git a/bin/tests/system/idna/tests.sh b/bin/tests/system/idna/tests.sh
|
|
||||||
index 7acb0fa..0269bcd 100644
|
|
||||||
--- a/bin/tests/system/idna/tests.sh
|
|
||||||
+++ b/bin/tests/system/idna/tests.sh
|
|
||||||
@@ -244,6 +244,23 @@ idna_enabled_test() {
|
|
||||||
idna_test "$text" "+idnin +noidnout" "xn--nxasmq6b.com" "xn--nxasmq6b.com."
|
|
||||||
idna_test "$text" "+idnin +idnout" "xn--nxasmq6b.com" "βόλοσ.com."
|
|
||||||
|
|
||||||
+ # Test of valid A-label in locale that cannot display it
|
|
||||||
+ #
|
|
||||||
+ # +noidnout: The string is sent as-is to the server and the returned qname
|
|
||||||
+ # is displayed in the same form.
|
|
||||||
+ # +idnout: The string is sent as-is to the server and the returned qname
|
|
||||||
+ # is displayed as the corresponding A-label.
|
|
||||||
+ #
|
|
||||||
+ # The "+[no]idnout" flag has no effect in these cases.
|
|
||||||
+ text="Checking valid A-label in C locale"
|
|
||||||
+ label="xn--nxasmq6b.com"
|
|
||||||
+ LC_ALL=C idna_test "$text" "" "$label" "$label."
|
|
||||||
+ LC_ALL=C idna_test "$text" "+noidnin +noidnout" "$label" "$label."
|
|
||||||
+ LC_ALL=C idna_test "$text" "+noidnin +idnout" "$label" "$label."
|
|
||||||
+ LC_ALL=C idna_test "$text" "+idnin +noidnout" "$label" "$label."
|
|
||||||
+ LC_ALL=C idna_test "$text" "+idnin +idnout" "$label" "$label."
|
|
||||||
+ LC_ALL=C idna_test "$text" "+noidnin +idnout" "$label" "$label."
|
|
||||||
+
|
|
||||||
|
|
||||||
|
|
||||||
# Tests of invalid A-labels
|
|
||||||
--
|
|
||||||
2.20.1
|
|
||||||
|
|
@ -1,28 +0,0 @@
|
|||||||
From 3466dfd7d44940821f195a36fceb0f1100f77c4e Mon Sep 17 00:00:00 2001
|
|
||||||
From: Mark Andrews <marka@isc.org>
|
|
||||||
Date: Tue, 5 Nov 2019 12:56:18 +1100
|
|
||||||
Subject: [PATCH] The default geoip-directory should be
|
|
||||||
<MAXMINDDB_PREFIX>/share/GeoIP
|
|
||||||
|
|
||||||
(cherry picked from commit fcd765a59db9b9a2b187448a90f3dbe6aa72fb84)
|
|
||||||
(cherry picked from commit 7e79ebeebada6bcca81e8368eef72efbaae3c8c7)
|
|
||||||
---
|
|
||||||
bin/named/config.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/bin/named/config.c b/bin/named/config.c
|
|
||||||
index 833c1dc9d3..63da4b03f6 100644
|
|
||||||
--- a/bin/named/config.c
|
|
||||||
+++ b/bin/named/config.c
|
|
||||||
@@ -72,7 +72,7 @@ options {\n\
|
|
||||||
" files unlimited;\n"
|
|
||||||
#endif
|
|
||||||
#if defined(HAVE_GEOIP2) && !defined(WIN32)
|
|
||||||
-" geoip-directory \"" MAXMINDDB_PREFIX "/share/GeoIP2\";\n"
|
|
||||||
+" geoip-directory \"" MAXMINDDB_PREFIX "/share/GeoIP\";\n"
|
|
||||||
#elif defined(HAVE_GEOIP2)
|
|
||||||
" geoip-directory \".\";\n"
|
|
||||||
#endif
|
|
||||||
--
|
|
||||||
2.20.1
|
|
||||||
|
|
@ -169,9 +169,8 @@ Patch183: bind-9.11-rh1736762-5.patch
|
|||||||
# SDB patches
|
# SDB patches
|
||||||
Patch11: bind-9.3.2b2-sdbsrc.patch
|
Patch11: bind-9.3.2b2-sdbsrc.patch
|
||||||
Patch12: bind-9.10-sdb.patch
|
Patch12: bind-9.10-sdb.patch
|
||||||
|
|
||||||
# needs inpection
|
# needs inpection
|
||||||
Patch17: bind-9.3.2b1-fix_sdb_ldap.patch
|
Patch13: bind-9.3.2b1-fix_sdb_ldap.patch
|
||||||
|
|
||||||
Requires(post): systemd
|
Requires(post): systemd
|
||||||
Requires(preun): systemd
|
Requires(preun): systemd
|
||||||
@ -603,7 +602,7 @@ cp -fp contrib/sdb/ldap/{zone2ldap.1,zone2ldap.c} bin/sdb_tools
|
|||||||
cp -fp contrib/sdb/pgsql/zonetodb.c bin/sdb_tools
|
cp -fp contrib/sdb/pgsql/zonetodb.c bin/sdb_tools
|
||||||
cp -fp contrib/sdb/sqlite/zone2sqlite.c bin/sdb_tools
|
cp -fp contrib/sdb/sqlite/zone2sqlite.c bin/sdb_tools
|
||||||
%patch12 -p1 -b .sdb
|
%patch12 -p1 -b .sdb
|
||||||
%patch17 -p1 -b .fix_sdb_ldap
|
%patch13 -p1 -b .fix_sdb_ldap
|
||||||
%patch137 -p1 -b .strlcat_fix
|
%patch137 -p1 -b .strlcat_fix
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user