Update to 9.16.18
Fixup release after bugs released in 9.16.17. https://downloads.isc.org/isc/bind9/9.16.18/doc/arm/html/notes.html#notes-for-bind-9-16-18
This commit is contained in:
parent
2c4a614d01
commit
48d8c90e0d
2
.gitignore
vendored
2
.gitignore
vendored
@ -150,3 +150,5 @@ bind-9.7.2b1.tar.gz
|
|||||||
/bind-9.16.16.tar.xz.asc
|
/bind-9.16.16.tar.xz.asc
|
||||||
/bind-9.16.17.tar.xz
|
/bind-9.16.17.tar.xz
|
||||||
/bind-9.16.17.tar.xz.asc
|
/bind-9.16.17.tar.xz.asc
|
||||||
|
/bind-9.16.18.tar.xz
|
||||||
|
/bind-9.16.18.tar.xz.asc
|
||||||
|
@ -1,37 +0,0 @@
|
|||||||
From 52cc9ff372ba637289d1e8f35d1f3f35d46ea25f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Mark Andrews <marka@isc.org>
|
|
||||||
Date: Fri, 18 Jun 2021 11:29:45 +1000
|
|
||||||
Subject: [PATCH] Add w and W to maptoupper and maptolower tables
|
|
||||||
|
|
||||||
(cherry picked from commit 08eeebb6a7ef45ac796a0df47a92350473a4e0b8)
|
|
||||||
---
|
|
||||||
lib/dns/rbtdb.c | 6 ++++--
|
|
||||||
1 file changed, 4 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/lib/dns/rbtdb.c b/lib/dns/rbtdb.c
|
|
||||||
index 223194a6d6..9dfd219dce 100644
|
|
||||||
--- a/lib/dns/rbtdb.c
|
|
||||||
+++ b/lib/dns/rbtdb.c
|
|
||||||
@@ -9890,7 +9890,8 @@ static const unsigned char maptolower[256] = {
|
|
||||||
['F'] = 'f', ['G'] = 'g', ['H'] = 'h', ['I'] = 'i', ['J'] = 'j',
|
|
||||||
['K'] = 'k', ['L'] = 'l', ['M'] = 'm', ['N'] = 'n', ['O'] = 'o',
|
|
||||||
['P'] = 'p', ['Q'] = 'q', ['R'] = 'r', ['S'] = 's', ['T'] = 't',
|
|
||||||
- ['U'] = 'u', ['V'] = 'v', ['X'] = 'x', ['Y'] = 'y', ['Z'] = 'z',
|
|
||||||
+ ['U'] = 'u', ['V'] = 'v', ['W'] = 'w', ['X'] = 'x', ['Y'] = 'y',
|
|
||||||
+ ['Z'] = 'z',
|
|
||||||
};
|
|
||||||
|
|
||||||
static const unsigned char maptoupper[256] = {
|
|
||||||
@@ -9898,7 +9899,8 @@ static const unsigned char maptoupper[256] = {
|
|
||||||
['f'] = 'F', ['g'] = 'G', ['h'] = 'H', ['i'] = 'I', ['j'] = 'J',
|
|
||||||
['k'] = 'K', ['l'] = 'L', ['m'] = 'M', ['n'] = 'N', ['o'] = 'O',
|
|
||||||
['p'] = 'P', ['q'] = 'Q', ['r'] = 'R', ['s'] = 'S', ['t'] = 'T',
|
|
||||||
- ['u'] = 'U', ['v'] = 'V', ['x'] = 'X', ['y'] = 'Y', ['z'] = 'Z',
|
|
||||||
+ ['u'] = 'U', ['v'] = 'V', ['w'] = 'W', ['x'] = 'X', ['y'] = 'Y',
|
|
||||||
+ ['z'] = 'Z',
|
|
||||||
};
|
|
||||||
|
|
||||||
static void
|
|
||||||
--
|
|
||||||
2.31.1
|
|
||||||
|
|
@ -1,58 +0,0 @@
|
|||||||
From ab597b8b91de5f9c6d6b0da410e8a0350876f484 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Mark Andrews <marka@isc.org>
|
|
||||||
Date: Fri, 18 Jun 2021 13:02:46 +1000
|
|
||||||
Subject: [PATCH] Check wild card expansions by code point
|
|
||||||
|
|
||||||
(cherry picked from commit c65dc2f7dc211358d5e28ff368cd60ddf5d5dcd4)
|
|
||||||
---
|
|
||||||
bin/tests/system/wildcard/tests.sh | 35 ++++++++++++++++++++++++++++++
|
|
||||||
1 file changed, 35 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/bin/tests/system/wildcard/tests.sh b/bin/tests/system/wildcard/tests.sh
|
|
||||||
index 439f8f1eff..0cf2189223 100644
|
|
||||||
--- a/bin/tests/system/wildcard/tests.sh
|
|
||||||
+++ b/bin/tests/system/wildcard/tests.sh
|
|
||||||
@@ -231,5 +231,40 @@ grep "ANSWER: 0," dig.out.ns1.test$n > /dev/null || ret=1
|
|
||||||
if [ $ret != 0 ]; then echo_i "failed"; fi
|
|
||||||
status=`expr $status + $ret`
|
|
||||||
|
|
||||||
+n=`expr $n + 1`
|
|
||||||
+echo_i "check wild card expansions by code point ($n)"
|
|
||||||
+ret=0
|
|
||||||
+i=0
|
|
||||||
+while test $i -lt 256
|
|
||||||
+do
|
|
||||||
+ x=`expr 00$i : '.*\(...\)$'`
|
|
||||||
+ $DIG $DIGOPTS @10.53.0.1 "\\$x.example" TXT > dig.out.ns1.$x.test$n
|
|
||||||
+ if test $i -le 32 -o $i -ge 127
|
|
||||||
+ then
|
|
||||||
+ grep '^\\'"$x"'\.example\..*TXT.*\"this is a wildcard\"$' dig.out.ns1.$x.test$n > /dev/null || { echo_i "code point $x failed" ; ret=1; }
|
|
||||||
+ # "=34 $=36 (=40 )=41 .=46 ;=59 \=92 @=64
|
|
||||||
+ elif test $i -eq 34 -o $i -eq 36 -o $i -eq 40 -o $i -eq 41 -o \
|
|
||||||
+ $i -eq 46 -o $i -eq 59 -o $i -eq 64 -o $i -eq 92
|
|
||||||
+ then
|
|
||||||
+ case $i in
|
|
||||||
+ 34) a='"';;
|
|
||||||
+ 36) a='$';;
|
|
||||||
+ 40) a='(';;
|
|
||||||
+ 41) a=')';;
|
|
||||||
+ 46) a='\.';;
|
|
||||||
+ 59) a=';';;
|
|
||||||
+ 64) a='@';;
|
|
||||||
+ 92) a='\\';;
|
|
||||||
+ *) a=''; echo_i "code point $x failed" ; ret=1 ;;
|
|
||||||
+ esac
|
|
||||||
+ grep '^\\'"$a"'\.example.*.*TXT.*"this is a wildcard"$' dig.out.ns1.$x.test$n > /dev/null || { echo_i "code point $x failed" ; ret=1; }
|
|
||||||
+ else
|
|
||||||
+ grep '^\\' dig.out.ns1.$x.test$n && { echo_i "code point $x failed" ; ret=1; }
|
|
||||||
+ fi
|
|
||||||
+ i=`expr $i + 1`
|
|
||||||
+done
|
|
||||||
+if [ $ret != 0 ]; then echo_i "failed"; fi
|
|
||||||
+status=`expr $status + $ret`
|
|
||||||
+
|
|
||||||
echo_i "exit status: $status"
|
|
||||||
[ $status -eq 0 ] || exit 1
|
|
||||||
--
|
|
||||||
2.31.1
|
|
||||||
|
|
12
bind.spec
12
bind.spec
@ -61,8 +61,8 @@
|
|||||||
Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) server
|
Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) server
|
||||||
Name: bind
|
Name: bind
|
||||||
License: MPLv2.0
|
License: MPLv2.0
|
||||||
Version: 9.16.17
|
Version: 9.16.18
|
||||||
Release: 2%{?PATCHVER:.%{PATCHVER}}%{?PREVER:.%{PREVER}}%{?dist}
|
Release: 1%{?PATCHVER:.%{PATCHVER}}%{?PREVER:.%{PREVER}}%{?dist}
|
||||||
Epoch: 32
|
Epoch: 32
|
||||||
Url: https://www.isc.org/downloads/bind/
|
Url: https://www.isc.org/downloads/bind/
|
||||||
#
|
#
|
||||||
@ -113,9 +113,6 @@ Patch157:bind-9.11-fips-tests.patch
|
|||||||
Patch164:bind-9.11-rh1666814.patch
|
Patch164:bind-9.11-rh1666814.patch
|
||||||
Patch170:bind-9.11-feature-test-named.patch
|
Patch170:bind-9.11-feature-test-named.patch
|
||||||
Patch171:bind-9.11-tests-variants.patch
|
Patch171:bind-9.11-tests-variants.patch
|
||||||
# https://gitlab.isc.org/isc-projects/bind9/-/issues/2779
|
|
||||||
Patch172:bind-9.16-maptolower-w.patch
|
|
||||||
Patch173:bind-9.16-test-wildcard-expansion
|
|
||||||
|
|
||||||
Requires(post): systemd
|
Requires(post): systemd
|
||||||
Requires(preun): systemd
|
Requires(preun): systemd
|
||||||
@ -419,8 +416,6 @@ in HTML and PDF format.
|
|||||||
%patch164 -p1 -b .rh1666814
|
%patch164 -p1 -b .rh1666814
|
||||||
%patch170 -p1 -b .featuretest-named
|
%patch170 -p1 -b .featuretest-named
|
||||||
%patch171 -p1 -b .test-variant
|
%patch171 -p1 -b .test-variant
|
||||||
%patch172 -p1 -b .rh1973587
|
|
||||||
%patch173 -p1 -b .rh1973587
|
|
||||||
|
|
||||||
%if %{with PKCS11}
|
%if %{with PKCS11}
|
||||||
%patch135 -p1 -b .config-pkcs11
|
%patch135 -p1 -b .config-pkcs11
|
||||||
@ -1141,6 +1136,9 @@ fi;
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 18 2021 Petr Menšík <pemensik@redhat.com> - 32:9.16.18-1
|
||||||
|
- Update to 9.16.18
|
||||||
|
|
||||||
* Fri Jun 18 2021 Petr Menšík <pemensik@redhat.com> - 32:9.16.17-2
|
* Fri Jun 18 2021 Petr Menšík <pemensik@redhat.com> - 32:9.16.17-2
|
||||||
- Fix wildcard expansion not working with 'w' (#1973587)
|
- Fix wildcard expansion not working with 'w' (#1973587)
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (bind-9.16.17.tar.xz) = 983d7d0ecd17ae926db2811c4af0354bafcfbaa96c82625f419be3dc81132ed23d599d1273351a3924ee9df79b358d67d88f42a91ad48c2dc596ff01904c83c3
|
SHA512 (bind-9.16.18.tar.xz) = 6ba2f14324ebdc66d2a6d60e929fb47e170dd7662cf4b18ef3ad9da30a61b43c7d5539e931c483ab36e63ae0398aeed255fd672489fb332dccf182df9aa102f9
|
||||||
SHA512 (bind-9.16.17.tar.xz.asc) = 0c7c7fa4a1176020888805b5f47547b5e040d216a3f8dfe24a9c4e9ed39d66bac327bf94300043ad92ace623c0470eac91006021432b66c4343aa560cdae7699
|
SHA512 (bind-9.16.18.tar.xz.asc) = 384887fec89de30436b3c570843f2ae532b9bb54065991a8778c63262a3608c724a7007c55989c4f9132d7718f5a08b447b0c73ff9025f5fa6d47ee41200dabe
|
||||||
|
Loading…
Reference in New Issue
Block a user