- 9.5.0a7
- dropped patches (upstream) - bind-9.5-update.patch - bind-9.5-pool_badfree.patch - bind-9.5-_res_errno.patch
This commit is contained in:
parent
15c5cd7a8d
commit
31f7ce1b8b
@ -1,4 +1,4 @@
|
||||
bind-9.5.0a6.tar.gz
|
||||
bind-9.5.0a7.tar.gz
|
||||
bind-chroot.tar.bz2
|
||||
config-2.tar
|
||||
libbind-man.tar.gz
|
||||
|
@ -1,33 +0,0 @@
|
||||
Written-by: Mark Andrews <Mark_Andrews isc org> (upstream)
|
||||
Reviewed-by: Adam Tkac <atkac redhat com>
|
||||
|
||||
diff -up bind-9.5.0a6/lib/bind/resolv/res_data.c._res_errno bind-9.5.0a6/lib/bind/resolv/res_data.c
|
||||
--- bind-9.5.0a6/lib/bind/resolv/res_data.c._res_errno 2007-09-06 09:26:29.000000000 +0200
|
||||
+++ bind-9.5.0a6/lib/bind/resolv/res_data.c 2007-09-06 09:28:14.000000000 +0200
|
||||
@@ -40,7 +40,6 @@ static const char rcsid[] = "$Id: res_da
|
||||
#include <unistd.h>
|
||||
|
||||
#include "port_after.h"
|
||||
-#undef _res
|
||||
|
||||
const char *_res_opcodes[] = {
|
||||
"QUERY",
|
||||
@@ -70,6 +69,7 @@ const char *_res_sectioncodes[] = {
|
||||
};
|
||||
#endif
|
||||
|
||||
+#undef _res
|
||||
#ifndef __BIND_NOSTATIC
|
||||
struct __res_state _res
|
||||
# if defined(__BIND_RES_TEXT)
|
||||
@@ -77,6 +77,10 @@ struct __res_state _res
|
||||
# endif
|
||||
;
|
||||
|
||||
+#if defined(DO_PTHREADS) || defined(__linux)
|
||||
+#define _res (*__res_state())
|
||||
+#endif
|
||||
+
|
||||
/* Proto. */
|
||||
|
||||
int res_ourserver_p(const res_state, const struct sockaddr_in *);
|
@ -1,6 +1,6 @@
|
||||
diff -up bind-9.5.0a6/lib/dns/view.c.edns bind-9.5.0a6/lib/dns/view.c
|
||||
--- bind-9.5.0a6/lib/dns/view.c.edns 2007-06-19 01:47:42.000000000 +0200
|
||||
+++ bind-9.5.0a6/lib/dns/view.c 2007-09-19 17:46:10.000000000 +0200
|
||||
diff -up bind-9.5.0a7/lib/dns/view.c.edns bind-9.5.0a7/lib/dns/view.c
|
||||
--- bind-9.5.0a7/lib/dns/view.c.edns 2007-06-19 01:47:42.000000000 +0200
|
||||
+++ bind-9.5.0a7/lib/dns/view.c 2007-11-15 12:32:12.000000000 +0100
|
||||
@@ -179,6 +179,7 @@ dns_view_create(isc_mem_t *mctx, dns_rda
|
||||
view->flush = ISC_FALSE;
|
||||
view->dlv = NULL;
|
||||
@ -9,29 +9,29 @@ diff -up bind-9.5.0a6/lib/dns/view.c.edns bind-9.5.0a6/lib/dns/view.c
|
||||
dns_fixedname_init(&view->dlv_fixed);
|
||||
|
||||
result = dns_order_create(view->mctx, &view->order);
|
||||
diff -up bind-9.5.0a6/lib/dns/resolver.c.edns bind-9.5.0a6/lib/dns/resolver.c
|
||||
--- bind-9.5.0a6/lib/dns/resolver.c.edns 2007-09-19 17:46:10.000000000 +0200
|
||||
+++ bind-9.5.0a6/lib/dns/resolver.c 2007-09-19 17:47:19.000000000 +0200
|
||||
@@ -1484,10 +1484,12 @@ resquery_send(resquery_t *query) {
|
||||
* The ADB does not know about servers with "edns no". Check this,
|
||||
* and then inform the ADB for future use.
|
||||
*/
|
||||
- if ((query->addrinfo->flags & DNS_FETCHOPT_NOEDNS0) == 0 &&
|
||||
- peer != NULL &&
|
||||
- dns_peer_getsupportedns(peer, &useedns) == ISC_R_SUCCESS &&
|
||||
- !useedns)
|
||||
+ if (((query->addrinfo->flags & DNS_FETCHOPT_NOEDNS0) == 0 ||
|
||||
+ (query->options & DNS_FETCHOPT_NOEDNS0) == 0) &&
|
||||
+ (!(res->view->edns) ||
|
||||
+ (peer != NULL &&
|
||||
+ dns_peer_getsupportedns(peer, &useedns) == ISC_R_SUCCESS &&
|
||||
+ !useedns)))
|
||||
{
|
||||
query->options |= DNS_FETCHOPT_NOEDNS0;
|
||||
dns_adb_changeflags(fctx->adb,
|
||||
diff -up bind-9.5.0a6/lib/dns/include/dns/view.h.edns bind-9.5.0a6/lib/dns/include/dns/view.h
|
||||
--- bind-9.5.0a6/lib/dns/include/dns/view.h.edns 2007-06-19 01:47:42.000000000 +0200
|
||||
+++ bind-9.5.0a6/lib/dns/include/dns/view.h 2007-09-19 17:46:10.000000000 +0200
|
||||
diff -up bind-9.5.0a7/lib/dns/resolver.c.edns bind-9.5.0a7/lib/dns/resolver.c
|
||||
--- bind-9.5.0a7/lib/dns/resolver.c.edns 2007-10-19 19:15:53.000000000 +0200
|
||||
+++ bind-9.5.0a7/lib/dns/resolver.c 2007-11-15 12:32:44.000000000 +0100
|
||||
@@ -1509,10 +1509,12 @@ resquery_send(resquery_t *query) {
|
||||
* The ADB does not know about servers with "edns no". Check this,
|
||||
* and then inform the ADB for future use.
|
||||
*/
|
||||
- if ((query->addrinfo->flags & DNS_FETCHOPT_NOEDNS0) == 0 &&
|
||||
- peer != NULL &&
|
||||
- dns_peer_getsupportedns(peer, &useedns) == ISC_R_SUCCESS &&
|
||||
- !useedns)
|
||||
+ if (((query->addrinfo->flags & DNS_FETCHOPT_NOEDNS0) == 0 ||
|
||||
+ (query->options & DNS_FETCHOPT_NOEDNS0) == 0) &&
|
||||
+ (!(res->view->edns) ||
|
||||
+ (peer != NULL &&
|
||||
+ dns_peer_getsupportedns(peer, &useedns) == ISC_R_SUCCESS &&
|
||||
+ !useedns)))
|
||||
{
|
||||
query->options |= DNS_FETCHOPT_NOEDNS0;
|
||||
dns_adb_changeflags(fctx->adb,
|
||||
diff -up bind-9.5.0a7/lib/dns/include/dns/view.h.edns bind-9.5.0a7/lib/dns/include/dns/view.h
|
||||
--- bind-9.5.0a7/lib/dns/include/dns/view.h.edns 2007-06-19 01:47:42.000000000 +0200
|
||||
+++ bind-9.5.0a7/lib/dns/include/dns/view.h 2007-11-15 12:32:12.000000000 +0100
|
||||
@@ -137,6 +137,7 @@ struct dns_view {
|
||||
dns_name_t * dlv;
|
||||
dns_fixedname_t dlv_fixed;
|
||||
@ -40,9 +40,9 @@ diff -up bind-9.5.0a6/lib/dns/include/dns/view.h.edns bind-9.5.0a6/lib/dns/inclu
|
||||
|
||||
/*
|
||||
* Configurable data for server use only,
|
||||
diff -up bind-9.5.0a6/lib/isccfg/namedconf.c.edns bind-9.5.0a6/lib/isccfg/namedconf.c
|
||||
--- bind-9.5.0a6/lib/isccfg/namedconf.c.edns 2007-06-19 01:47:50.000000000 +0200
|
||||
+++ bind-9.5.0a6/lib/isccfg/namedconf.c 2007-09-19 17:46:10.000000000 +0200
|
||||
diff -up bind-9.5.0a7/lib/isccfg/namedconf.c.edns bind-9.5.0a7/lib/isccfg/namedconf.c
|
||||
--- bind-9.5.0a7/lib/isccfg/namedconf.c.edns 2007-09-26 05:22:45.000000000 +0200
|
||||
+++ bind-9.5.0a7/lib/isccfg/namedconf.c 2007-11-15 12:32:12.000000000 +0100
|
||||
@@ -618,6 +618,7 @@ options_clauses[] = {
|
||||
{ "deallocate-on-exit", &cfg_type_boolean, CFG_CLAUSEFLAG_OBSOLETE },
|
||||
{ "directory", &cfg_type_qstring, CFG_CLAUSEFLAG_CALLBACK },
|
||||
@ -51,32 +51,32 @@ diff -up bind-9.5.0a6/lib/isccfg/namedconf.c.edns bind-9.5.0a6/lib/isccfg/namedc
|
||||
{ "fake-iquery", &cfg_type_boolean, CFG_CLAUSEFLAG_OBSOLETE },
|
||||
{ "files", &cfg_type_size, 0 },
|
||||
{ "has-old-clients", &cfg_type_boolean, CFG_CLAUSEFLAG_OBSOLETE },
|
||||
diff -up bind-9.5.0a6/doc/misc/options.edns bind-9.5.0a6/doc/misc/options
|
||||
--- bind-9.5.0a6/doc/misc/options.edns 2007-03-29 17:19:20.000000000 +0200
|
||||
+++ bind-9.5.0a6/doc/misc/options 2007-09-19 17:46:10.000000000 +0200
|
||||
@@ -11,6 +11,7 @@ options {
|
||||
deallocate-on-exit <boolean>; // obsolete
|
||||
directory <quoted_string>;
|
||||
diff -up bind-9.5.0a7/doc/misc/options.edns bind-9.5.0a7/doc/misc/options
|
||||
--- bind-9.5.0a7/doc/misc/options.edns 2007-10-22 00:15:34.000000000 +0200
|
||||
+++ bind-9.5.0a7/doc/misc/options 2007-11-15 12:34:04.000000000 +0100
|
||||
@@ -97,6 +97,7 @@ options {
|
||||
<integer>] | <ipv4_address> [port <integer>] | <ipv6_address>
|
||||
[port <integer>] ); ... };
|
||||
dump-file <quoted_string>;
|
||||
+ edns <boolean>;
|
||||
fake-iquery <boolean>; // obsolete
|
||||
files <size>;
|
||||
has-old-clients <boolean>; // obsolete
|
||||
diff -up bind-9.5.0a6/bin/named/config.c.edns bind-9.5.0a6/bin/named/config.c
|
||||
--- bind-9.5.0a6/bin/named/config.c.edns 2007-06-19 01:47:18.000000000 +0200
|
||||
+++ bind-9.5.0a6/bin/named/config.c 2007-09-19 17:46:10.000000000 +0200
|
||||
edns-udp-size <integer>;
|
||||
empty-contact <string>;
|
||||
empty-server <string>;
|
||||
diff -up bind-9.5.0a7/bin/named/config.c.edns bind-9.5.0a7/bin/named/config.c
|
||||
--- bind-9.5.0a7/bin/named/config.c.edns 2007-10-19 19:15:53.000000000 +0200
|
||||
+++ bind-9.5.0a7/bin/named/config.c 2007-11-15 12:34:33.000000000 +0100
|
||||
@@ -137,6 +137,7 @@ options {\n\
|
||||
acache-enable no;\n\
|
||||
acache-cleaning-interval 60;\n\
|
||||
max-acache-size 0;\n\
|
||||
max-acache-size 16M;\n\
|
||||
+ edns yes;\n\
|
||||
dnssec-enable yes;\n\
|
||||
dnssec-validation no; /* Make yes for 9.5. */ \n\
|
||||
dnssec-accept-expired no;\n\
|
||||
diff -up bind-9.5.0a6/bin/named/server.c.edns bind-9.5.0a6/bin/named/server.c
|
||||
--- bind-9.5.0a6/bin/named/server.c.edns 2007-09-19 17:46:10.000000000 +0200
|
||||
+++ bind-9.5.0a6/bin/named/server.c 2007-09-19 17:46:10.000000000 +0200
|
||||
@@ -1624,7 +1624,12 @@ configure_view(dns_view_t *view, const c
|
||||
diff -up bind-9.5.0a7/bin/named/server.c.edns bind-9.5.0a7/bin/named/server.c
|
||||
--- bind-9.5.0a7/bin/named/server.c.edns 2007-10-18 03:37:49.000000000 +0200
|
||||
+++ bind-9.5.0a7/bin/named/server.c 2007-11-15 12:32:12.000000000 +0100
|
||||
@@ -1669,7 +1669,12 @@ configure_view(dns_view_t *view, const c
|
||||
dns_resolver_setclientsperquery(view->resolver,
|
||||
cfg_obj_asuint32(obj),
|
||||
max_clients_per_query);
|
||||
@ -90,9 +90,9 @@ diff -up bind-9.5.0a6/bin/named/server.c.edns bind-9.5.0a6/bin/named/server.c
|
||||
obj = NULL;
|
||||
result = ns_config_get(maps, "dnssec-enable", &obj);
|
||||
INSIST(result == ISC_R_SUCCESS);
|
||||
diff -up bind-9.5.0a6/bin/named/named.conf.5.edns bind-9.5.0a6/bin/named/named.conf.5
|
||||
--- bind-9.5.0a6/bin/named/named.conf.5.edns 2007-06-20 04:27:32.000000000 +0200
|
||||
+++ bind-9.5.0a6/bin/named/named.conf.5 2007-09-19 17:46:10.000000000 +0200
|
||||
diff -up bind-9.5.0a7/bin/named/named.conf.5.edns bind-9.5.0a7/bin/named/named.conf.5
|
||||
--- bind-9.5.0a7/bin/named/named.conf.5.edns 2007-10-22 00:15:32.000000000 +0200
|
||||
+++ bind-9.5.0a7/bin/named/named.conf.5 2007-11-15 12:32:12.000000000 +0100
|
||||
@@ -160,6 +160,7 @@ options {
|
||||
datasize \fIsize\fR;
|
||||
directory \fIquoted_string\fR;
|
||||
|
@ -1,30 +0,0 @@
|
||||
Written-by: Tomas Mraz <tmraz@redhat.com>
|
||||
Reviewed-by: Adam Tkac <atkac@redhat.com>
|
||||
|
||||
diff -up bind-9.5.0a6/lib/dns/resolver.c.badfree bind-9.5.0a6/lib/dns/resolver.c
|
||||
--- bind-9.5.0a6/lib/dns/resolver.c.badfree 2007-06-19 01:47:41.000000000 +0200
|
||||
+++ bind-9.5.0a6/lib/dns/resolver.c 2007-09-05 16:20:21.000000000 +0200
|
||||
@@ -7455,17 +7455,17 @@ dns_resolver_createdispatchpool(dns_reso
|
||||
return (result);
|
||||
|
||||
cleanup:
|
||||
- for (i = 0; i < ndisps; i++) {
|
||||
- if (res->dispatchv4pool[i] != NULL)
|
||||
- dns_dispatch_detach(&res->dispatchv4pool[i]);
|
||||
- if (res->dispatchv6pool[i] != NULL)
|
||||
- dns_dispatch_detach(&res->dispatchv6pool[i]);
|
||||
- }
|
||||
if (res->dispatchv4pool != NULL) {
|
||||
+ for (i = 0; i < ndisps; i++)
|
||||
+ if (res->dispatchv4pool[i] != NULL)
|
||||
+ dns_dispatch_detach(&res->dispatchv4pool[i]);
|
||||
isc_mem_put(res->mctx, res->dispatchv4pool,
|
||||
sizeof(dns_dispatch_t *) * ndisps);
|
||||
}
|
||||
if (res->dispatchv6pool != NULL) {
|
||||
+ for (i = 0; i < ndisps; i++)
|
||||
+ if (res->dispatchv6pool[i] != NULL)
|
||||
+ dns_dispatch_detach(&res->dispatchv6pool[i]);
|
||||
isc_mem_put(res->mctx, res->dispatchv6pool,
|
||||
sizeof(dns_dispatch_t *) * ndisps);
|
||||
}
|
@ -1,15 +0,0 @@
|
||||
diff -up bind-9.4.1-P1/lib/dns/message.c.update bind-9.4.1-P1/lib/dns/message.c
|
||||
--- bind-9.4.1-P1/lib/dns/message.c.update 2007-08-14 10:53:25.000000000 +0200
|
||||
+++ bind-9.4.1-P1/lib/dns/message.c 2007-08-14 10:54:52.000000000 +0200
|
||||
@@ -1308,6 +1308,11 @@ getsection(isc_buffer_t *source, dns_mes
|
||||
rdata->type = rdtype;
|
||||
rdata->flags = DNS_RDATA_UPDATE;
|
||||
result = ISC_R_SUCCESS;
|
||||
+ } else if (rdclass == dns_rdataclass_none &&
|
||||
+ msg->opcode == dns_opcode_update &&
|
||||
+ sectionid == DNS_SECTION_UPDATE) {
|
||||
+ result = getrdata(source, msg, dctx, msg->rdclass,
|
||||
+ rdtype, rdatalen, rdata);
|
||||
} else
|
||||
result = getrdata(source, msg, dctx, rdclass,
|
||||
rdtype, rdatalen, rdata);
|
19
bind.spec
19
bind.spec
@ -2,7 +2,7 @@
|
||||
# Red Hat BIND package .spec file
|
||||
#
|
||||
|
||||
%define RELEASEVER a6
|
||||
%define RELEASEVER a7
|
||||
|
||||
%{?!SDB: %define SDB 1}
|
||||
%{?!LIBBIND: %define LIBBIND 1}
|
||||
@ -21,7 +21,7 @@ Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) serv
|
||||
Name: bind
|
||||
License: ISC
|
||||
Version: 9.5.0
|
||||
Release: 16.5.%{RELEASEVER}%{?dist}
|
||||
Release: 17.%{RELEASEVER}%{?dist}
|
||||
Epoch: 32
|
||||
Url: http://www.isc.org/products/BIND/
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -62,9 +62,6 @@ Patch63: bind-9.4.0-dnssec-directory.patch
|
||||
Patch69: bind-9.5.0-generate-xml.patch
|
||||
Patch71: bind-9.5-overflow.patch
|
||||
Patch72: bind-9.5-dlz-64bit.patch
|
||||
Patch75: bind-9.5-update.patch
|
||||
Patch78: bind-9.5-pool_badfree.patch
|
||||
Patch79: bind-9.5-_res_errno.patch
|
||||
Patch80: bind-9.5-edns.patch
|
||||
|
||||
# SDB patches
|
||||
@ -258,9 +255,6 @@ cp -fp contrib/dbus/{dbus_mgr.h,dbus_service.h} bin/named/include/named
|
||||
%patch72 -p1 -b .64bit
|
||||
%endif
|
||||
%patch73 -p1 -b .libidn
|
||||
%patch75 -p1 -b .update
|
||||
%patch78 -p1 -b .badfree
|
||||
%patch79 -p1 -b .errno
|
||||
%patch80 -p1 -b .edns
|
||||
:;
|
||||
|
||||
@ -671,7 +665,14 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_sbindir}/bind-chroot-admin
|
||||
|
||||
%changelog
|
||||
* Wed Nov 15 2007 Adam Tkac <atkac redhat com> 32:9.5.0-16.5.a6
|
||||
* Thu Nov 15 2007 Adam Tkac <atkac redhat com> 32:9.5.0-17.a7
|
||||
- 9.5.0a7
|
||||
- dropped patches (upstream)
|
||||
- bind-9.5-update.patch
|
||||
- bind-9.5-pool_badfree.patch
|
||||
- bind-9.5-_res_errno.patch
|
||||
|
||||
* Thu Nov 15 2007 Adam Tkac <atkac redhat com> 32:9.5.0-16.5.a6
|
||||
- added bind-sdb again, contains SDB modules and DLZ modules
|
||||
- bind-9.3.1rc1-sdb.patch replaced by bind-9.5-sdb.patch
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user