- removed conditional build with libefence (use -fmudflapth instead)
- fixed building of DLZ stuff (#432497) - do not build Berkeley DB DLZ backend - temporary build with --disable-linux-caps and without threads (#433102) - update named.ca file to affect IPv6 changes in root zone
This commit is contained in:
parent
b2b15fb648
commit
300cfcff2d
@ -1,4 +1,4 @@
|
|||||||
bind-9.5.0b2.tar.gz
|
bind-9.5.0b2.tar.gz
|
||||||
bind-chroot.tar.bz2
|
bind-chroot.tar.bz2
|
||||||
config-2.tar
|
config-3.tar.bz2
|
||||||
libbind-man.tar.gz
|
libbind-man.tar.gz
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
--- bind-9.3.4/bin/named/Makefile.in.ldap-api 2007-05-18 16:21:21.000000000 +0200
|
--- bind-9.3.4/bin/named-sdb/Makefile.in.ldap-api 2007-05-18 16:21:21.000000000 +0200
|
||||||
+++ bind-9.3.4/bin/named/Makefile.in 2007-05-18 16:22:16.000000000 +0200
|
+++ bind-9.3.4/bin/named-sdb/Makefile.in 2007-05-18 16:22:16.000000000 +0200
|
||||||
@@ -96,7 +96,7 @@ HTMLPAGES = named.html lwresd.html named
|
@@ -96,7 +96,7 @@ HTMLPAGES = named.html lwresd.html named
|
||||||
|
|
||||||
MANOBJS = ${MANPAGES} ${HTMLPAGES}
|
MANOBJS = ${MANPAGES} ${HTMLPAGES}
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -up bind-9.5.0b2/bin/named/Makefile.in.sdb-sqlite-bld bind-9.5.0b2/bin/named/Makefile.in
|
diff -up bind-9.5.0b2/bin/named-sdb/Makefile.in.sdb-sqlite-bld bind-9.5.0b2/bin/named/Makefile.in
|
||||||
--- bind-9.5.0b2/bin/named/Makefile.in.sdb-sqlite-bld 2008-02-11 17:44:32.000000000 +0100
|
--- bind-9.5.0b2/bin/named-sdb/Makefile.in.sdb-sqlite-bld 2008-02-11 17:44:32.000000000 +0100
|
||||||
+++ bind-9.5.0b2/bin/named/Makefile.in 2008-02-11 17:46:00.000000000 +0100
|
+++ bind-9.5.0b2/bin/named-sdb/Makefile.in 2008-02-11 17:46:00.000000000 +0100
|
||||||
@@ -26,10 +26,10 @@ top_srcdir = @top_srcdir@
|
@@ -26,10 +26,10 @@ top_srcdir = @top_srcdir@
|
||||||
#
|
#
|
||||||
# Add database drivers here.
|
# Add database drivers here.
|
||||||
@ -15,9 +15,9 @@ diff -up bind-9.5.0b2/bin/named/Makefile.in.sdb-sqlite-bld bind-9.5.0b2/bin/name
|
|||||||
|
|
||||||
DLZ_DRIVER_DIR = ${top_srcdir}/contrib/dlz/drivers
|
DLZ_DRIVER_DIR = ${top_srcdir}/contrib/dlz/drivers
|
||||||
|
|
||||||
diff -up bind-9.5.0b2/bin/named/main-sdb.c.sdb-sqlite-bld bind-9.5.0b2/bin/named/main-sdb.c
|
diff -up bind-9.5.0b2/bin/named-sdb/main.c.sdb-sqlite-bld bind-9.5.0b2/bin/named/main-sdb.c
|
||||||
--- bind-9.5.0b2/bin/named/main-sdb.c.sdb-sqlite-bld 2008-02-11 17:44:32.000000000 +0100
|
--- bind-9.5.0b2/bin/named-sdb/main.c.sdb-sqlite-bld 2008-02-11 17:44:32.000000000 +0100
|
||||||
+++ bind-9.5.0b2/bin/named/main-sdb.c 2008-02-11 17:44:33.000000000 +0100
|
+++ bind-9.5.0b2/bin/named-sdb/main.c 2008-02-11 17:44:33.000000000 +0100
|
||||||
@@ -74,6 +74,7 @@
|
@@ -74,6 +74,7 @@
|
||||||
/* #include "xxdb.h" */
|
/* #include "xxdb.h" */
|
||||||
#include "ldapdb.h"
|
#include "ldapdb.h"
|
||||||
|
@ -1,127 +1,6 @@
|
|||||||
diff -up bind-9.5.0b2/configure.in.sdb bind-9.5.0b2/configure.in
|
diff -up bind-9.5.0b2/bin/named-sdb/main.c.sdb bind-9.5.0b2/bin/named/main-sdb.c
|
||||||
--- bind-9.5.0b2/configure.in.sdb 2008-01-24 03:29:56.000000000 +0100
|
--- bind-9.5.0b2/bin/named-sdb/main.c.sdb 2008-02-11 17:32:43.000000000 +0100
|
||||||
+++ bind-9.5.0b2/configure.in 2008-02-11 17:32:43.000000000 +0100
|
+++ bind-9.5.0b2/bin/named-sdb/main.c 2008-02-11 17:32:43.000000000 +0100
|
||||||
@@ -2782,6 +2782,7 @@ AC_CONFIG_FILES([
|
|
||||||
bin/tests/system/tkey/Makefile
|
|
||||||
bin/tests/headerdep_test.sh
|
|
||||||
bin/dnssec/Makefile
|
|
||||||
+ bin/sdb_tools/Makefile
|
|
||||||
doc/Makefile
|
|
||||||
doc/arm/Makefile
|
|
||||||
doc/misc/Makefile
|
|
||||||
diff -up bind-9.5.0b2/bin/Makefile.in.sdb bind-9.5.0b2/bin/Makefile.in
|
|
||||||
--- bind-9.5.0b2/bin/Makefile.in.sdb 2007-06-20 01:46:59.000000000 +0200
|
|
||||||
+++ bind-9.5.0b2/bin/Makefile.in 2008-02-11 17:32:43.000000000 +0100
|
|
||||||
@@ -19,7 +19,7 @@ srcdir = @srcdir@
|
|
||||||
VPATH = @srcdir@
|
|
||||||
top_srcdir = @top_srcdir@
|
|
||||||
|
|
||||||
-SUBDIRS = named rndc dig dnssec tests nsupdate check
|
|
||||||
+SUBDIRS = named rndc dig dnssec tests nsupdate check sdb_tools
|
|
||||||
TARGETS =
|
|
||||||
|
|
||||||
@BIND9_MAKE_RULES@
|
|
||||||
diff -up bind-9.5.0b2/bin/named/Makefile.in.sdb bind-9.5.0b2/bin/named/Makefile.in
|
|
||||||
--- bind-9.5.0b2/bin/named/Makefile.in.sdb 2008-02-11 17:32:43.000000000 +0100
|
|
||||||
+++ bind-9.5.0b2/bin/named/Makefile.in 2008-02-11 17:43:50.000000000 +0100
|
|
||||||
@@ -26,10 +26,10 @@ top_srcdir = @top_srcdir@
|
|
||||||
#
|
|
||||||
# Add database drivers here.
|
|
||||||
#
|
|
||||||
-DBDRIVER_OBJS =
|
|
||||||
-DBDRIVER_SRCS =
|
|
||||||
+DBDRIVER_OBJS = ldapdb.@O@ pgsqldb.@O@ dirdb.@O@
|
|
||||||
+DBDRIVER_SRCS = ldapdb.c pgsqldb.c dirdb.c
|
|
||||||
DBDRIVER_INCLUDES =
|
|
||||||
-DBDRIVER_LIBS =
|
|
||||||
+DBDRIVER_LIBS = -lldap -llber -lpq
|
|
||||||
|
|
||||||
DLZ_DRIVER_DIR = ${top_srcdir}/contrib/dlz/drivers
|
|
||||||
|
|
||||||
@@ -43,7 +43,7 @@ CINCLUDES = -I${srcdir}/include -I${srcd
|
|
||||||
${ISCCFG_INCLUDES} ${ISCCC_INCLUDES} ${ISC_INCLUDES} \
|
|
||||||
${DLZDRIVER_INCLUDES} ${DBDRIVER_INCLUDES}
|
|
||||||
|
|
||||||
-CDEFINES = @USE_DLZ@
|
|
||||||
+CDEFINES =
|
|
||||||
|
|
||||||
CWARNINGS =
|
|
||||||
|
|
||||||
@@ -66,27 +66,26 @@ DEPLIBS = ${LWRESDEPLIBS} ${DNSDEPLIBS}
|
|
||||||
|
|
||||||
LIBS = ${LWRESLIBS} ${DNSLIBS} ${BIND9LIBS} \
|
|
||||||
${ISCCFGLIBS} ${ISCCCLIBS} ${ISCLIBS} \
|
|
||||||
- ${DLZDRIVER_LIBS} ${DBDRIVER_LIBS} @LIBS@
|
|
||||||
+ @LIBS@
|
|
||||||
|
|
||||||
SUBDIRS = unix
|
|
||||||
|
|
||||||
-TARGETS = named@EXEEXT@ lwresd@EXEEXT@
|
|
||||||
+TARGETS = named@EXEEXT@ named-sdb@EXEEXT@ lwresd@EXEEXT@
|
|
||||||
|
|
||||||
OBJS = builtin.@O@ client.@O@ config.@O@ control.@O@ \
|
|
||||||
controlconf.@O@ interfacemgr.@O@ \
|
|
||||||
- listenlist.@O@ log.@O@ logconf.@O@ main.@O@ notify.@O@ \
|
|
||||||
+ listenlist.@O@ log.@O@ logconf.@O@ notify.@O@ \
|
|
||||||
query.@O@ server.@O@ sortlist.@O@ statschannel.@O@ \
|
|
||||||
tkeyconf.@O@ tsigconf.@O@ update.@O@ xfrout.@O@ \
|
|
||||||
zoneconf.@O@ \
|
|
||||||
lwaddr.@O@ lwresd.@O@ lwdclient.@O@ lwderror.@O@ lwdgabn.@O@ \
|
|
||||||
lwdgnba.@O@ lwdgrbn.@O@ lwdnoop.@O@ lwsearch.@O@ \
|
|
||||||
- ${DLZDRIVER_OBJS} ${DBDRIVER_OBJS}
|
|
||||||
|
|
||||||
UOBJS = unix/os.@O@
|
|
||||||
|
|
||||||
SRCS = builtin.c client.c config.c control.c \
|
|
||||||
controlconf.c interfacemgr.c \
|
|
||||||
- listenlist.c log.c logconf.c main.c notify.c \
|
|
||||||
+ listenlist.c log.c logconf.c main.c main-sdb.c notify.c \
|
|
||||||
query.c server.c sortlist.c statschannel.c \
|
|
||||||
tkeyconf.c tsigconf.c update.c xfrout.c \
|
|
||||||
zoneconf.c \
|
|
||||||
@@ -112,15 +111,26 @@ main.@O@: main.c
|
|
||||||
-DNS_LOCALSTATEDIR=\"${localstatedir}\" \
|
|
||||||
-DNS_SYSCONFDIR=\"${sysconfdir}\" -c ${srcdir}/main.c
|
|
||||||
|
|
||||||
+main-sdb.@O@: main-sdb.c
|
|
||||||
+ ${LIBTOOL_MODE_COMPILE} ${CC} ${ALL_CFLAGS} @USE_DLZ@ \
|
|
||||||
+ -DVERSION=\"${VERSION}\" \
|
|
||||||
+ -DNS_LOCALSTATEDIR=\"${localstatedir}\" \
|
|
||||||
+ -DNS_SYSCONFDIR=\"${sysconfdir}\" -c ${srcdir}/main-sdb.c
|
|
||||||
+
|
|
||||||
config.@O@: config.c
|
|
||||||
${LIBTOOL_MODE_COMPILE} ${CC} ${ALL_CFLAGS} \
|
|
||||||
-DVERSION=\"${VERSION}\" \
|
|
||||||
-DNS_LOCALSTATEDIR=\"${localstatedir}\" \
|
|
||||||
-c ${srcdir}/config.c
|
|
||||||
|
|
||||||
-named@EXEEXT@: ${OBJS} ${UOBJS} ${DEPLIBS}
|
|
||||||
+named@EXEEXT@: ${OBJS} ${UOBJS} ${DEPLIBS} main.@O@
|
|
||||||
+ ${LIBTOOL_MODE_LINK} ${PURIFY} ${CC} ${CFLAGS} ${LDFLAGS} -o $@ \
|
|
||||||
+ ${OBJS} main.@O@ ${UOBJS} ${LIBS}
|
|
||||||
+
|
|
||||||
+named-sdb@EXEEXT@: ${OBJS} ${UOBJS} ${DEPLIBS} main-sdb.@O@ ${DLZDRIVER_OBJS} ${DBDRIVER_OBJS}
|
|
||||||
${LIBTOOL_MODE_LINK} ${PURIFY} ${CC} ${CFLAGS} ${LDFLAGS} -o $@ \
|
|
||||||
- ${OBJS} ${UOBJS} ${LIBS}
|
|
||||||
+ ${OBJS} main-sdb.o ${DLZDRIVER_OBJS} ${DBDRIVER_OBJS} ${UOBJS} ${LIBS} \
|
|
||||||
+ ${DLZDRIVER_LIBS} ${DBDRIVER_LIBS}
|
|
||||||
|
|
||||||
lwresd@EXEEXT@: named@EXEEXT@
|
|
||||||
rm -f lwresd@EXEEXT@
|
|
||||||
@@ -145,8 +155,9 @@ installdirs:
|
|
||||||
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man5
|
|
||||||
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man8
|
|
||||||
|
|
||||||
-install:: named@EXEEXT@ lwresd@EXEEXT@ installdirs
|
|
||||||
+install:: named@EXEEXT@ named-sdb@EXEEXT@ lwresd@EXEEXT@ installdirs
|
|
||||||
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} named@EXEEXT@ ${DESTDIR}${sbindir}
|
|
||||||
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} named-sdb@EXEEXT@ ${DESTDIR}${sbindir}
|
|
||||||
(cd ${DESTDIR}${sbindir}; rm -f lwresd@EXEEXT@; @LN@ named@EXEEXT@ lwresd@EXEEXT@)
|
|
||||||
${INSTALL_DATA} ${srcdir}/named.8 ${DESTDIR}${mandir}/man8
|
|
||||||
${INSTALL_DATA} ${srcdir}/lwresd.8 ${DESTDIR}${mandir}/man8
|
|
||||||
diff -up bind-9.5.0b2/bin/named/main-sdb.c.sdb bind-9.5.0b2/bin/named/main-sdb.c
|
|
||||||
--- bind-9.5.0b2/bin/named/main-sdb.c.sdb 2008-02-11 17:32:43.000000000 +0100
|
|
||||||
+++ bind-9.5.0b2/bin/named/main-sdb.c 2008-02-11 17:32:43.000000000 +0100
|
|
||||||
@@ -72,6 +72,9 @@
|
@@ -72,6 +72,9 @@
|
||||||
* Include header files for database drivers here.
|
* Include header files for database drivers here.
|
||||||
*/
|
*/
|
||||||
@ -212,3 +91,134 @@ diff -up bind-9.5.0b2/bin/named/main-sdb.c.sdb bind-9.5.0b2/bin/named/main-sdb.c
|
|||||||
isc_log_write(ns_g_lctx, NS_LOGCATEGORY_GENERAL, NS_LOGMODULE_MAIN,
|
isc_log_write(ns_g_lctx, NS_LOGCATEGORY_GENERAL, NS_LOGMODULE_MAIN,
|
||||||
ISC_LOG_NOTICE, "exiting");
|
ISC_LOG_NOTICE, "exiting");
|
||||||
ns_log_shutdown();
|
ns_log_shutdown();
|
||||||
|
diff -up bind-9.5.0b2/configure.in.sdb bind-9.5.0b2/configure.in
|
||||||
|
--- bind-9.5.0b2/configure.in.sdb 2008-02-14 14:14:55.000000000 +0100
|
||||||
|
+++ bind-9.5.0b2/configure.in 2008-02-14 14:15:34.000000000 +0100
|
||||||
|
@@ -2761,6 +2761,8 @@ AC_CONFIG_FILES([
|
||||||
|
bin/check/Makefile
|
||||||
|
bin/named/Makefile
|
||||||
|
bin/named/unix/Makefile
|
||||||
|
+ bin/named-sdb/Makefile
|
||||||
|
+ bin/named-sdb/unix/Makefile
|
||||||
|
bin/rndc/Makefile
|
||||||
|
bin/rndc/unix/Makefile
|
||||||
|
bin/dig/Makefile
|
||||||
|
@@ -2782,6 +2784,7 @@ AC_CONFIG_FILES([
|
||||||
|
bin/tests/system/tkey/Makefile
|
||||||
|
bin/tests/headerdep_test.sh
|
||||||
|
bin/dnssec/Makefile
|
||||||
|
+ bin/sdb_tools/Makefile
|
||||||
|
doc/Makefile
|
||||||
|
doc/arm/Makefile
|
||||||
|
doc/misc/Makefile
|
||||||
|
diff -up bind-9.5.0b2/bin/named-sdb/Makefile.in.sdb bind-9.5.0b2/bin/named-sdb/Makefile.in
|
||||||
|
--- bind-9.5.0b2/bin/named-sdb/Makefile.in.sdb 2008-02-14 14:16:10.000000000 +0100
|
||||||
|
+++ bind-9.5.0b2/bin/named-sdb/Makefile.in 2008-02-14 14:18:45.000000000 +0100
|
||||||
|
@@ -26,10 +26,10 @@ top_srcdir = @top_srcdir@
|
||||||
|
#
|
||||||
|
# Add database drivers here.
|
||||||
|
#
|
||||||
|
-DBDRIVER_OBJS =
|
||||||
|
-DBDRIVER_SRCS =
|
||||||
|
+DBDRIVER_OBJS = ldapdb.@O@ pgsqldb.@O@ dirdb.@O@
|
||||||
|
+DBDRIVER_SRCS = ldapdb.c pgsqldb.c dirdb.c
|
||||||
|
DBDRIVER_INCLUDES =
|
||||||
|
-DBDRIVER_LIBS =
|
||||||
|
+DBDRIVER_LIBS = -lldap -llber -lpq
|
||||||
|
|
||||||
|
DLZ_DRIVER_DIR = ${top_srcdir}/contrib/dlz/drivers
|
||||||
|
|
||||||
|
@@ -70,7 +70,7 @@ LIBS = ${LWRESLIBS} ${DNSLIBS} ${BIND9L
|
||||||
|
|
||||||
|
SUBDIRS = unix
|
||||||
|
|
||||||
|
-TARGETS = named@EXEEXT@ lwresd@EXEEXT@
|
||||||
|
+TARGETS = named-sdb@EXEEXT@
|
||||||
|
|
||||||
|
OBJS = builtin.@O@ client.@O@ config.@O@ control.@O@ \
|
||||||
|
controlconf.@O@ interfacemgr.@O@ \
|
||||||
|
@@ -118,7 +118,7 @@ config.@O@: config.c
|
||||||
|
-DNS_LOCALSTATEDIR=\"${localstatedir}\" \
|
||||||
|
-c ${srcdir}/config.c
|
||||||
|
|
||||||
|
-named@EXEEXT@: ${OBJS} ${UOBJS} ${DEPLIBS}
|
||||||
|
+named-sdb@EXEEXT@: ${OBJS} ${UOBJS} ${DEPLIBS}
|
||||||
|
${LIBTOOL_MODE_LINK} ${PURIFY} ${CC} ${CFLAGS} ${LDFLAGS} -o $@ \
|
||||||
|
${OBJS} ${UOBJS} ${LIBS}
|
||||||
|
|
||||||
|
@@ -142,14 +142,8 @@ server.o: bind9.xsl.h
|
||||||
|
|
||||||
|
installdirs:
|
||||||
|
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${sbindir}
|
||||||
|
- $(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man5
|
||||||
|
- $(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man8
|
||||||
|
|
||||||
|
-install:: named@EXEEXT@ lwresd@EXEEXT@ installdirs
|
||||||
|
- ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} named@EXEEXT@ ${DESTDIR}${sbindir}
|
||||||
|
- (cd ${DESTDIR}${sbindir}; rm -f lwresd@EXEEXT@; @LN@ named@EXEEXT@ lwresd@EXEEXT@)
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/named.8 ${DESTDIR}${mandir}/man8
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/lwresd.8 ${DESTDIR}${mandir}/man8
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/named.conf.5 ${DESTDIR}${mandir}/man5
|
||||||
|
+install:: named-sdb@EXEEXT@ installdirs
|
||||||
|
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} named-sdb@EXEEXT@ ${DESTDIR}${sbindir}
|
||||||
|
|
||||||
|
@DLZ_DRIVER_RULES@
|
||||||
|
diff -up bind-9.5.0b2/bin/Makefile.in.sdb bind-9.5.0b2/bin/Makefile.in
|
||||||
|
--- bind-9.5.0b2/bin/Makefile.in.sdb 2008-02-14 14:15:42.000000000 +0100
|
||||||
|
+++ bind-9.5.0b2/bin/Makefile.in 2008-02-14 14:15:55.000000000 +0100
|
||||||
|
@@ -19,7 +19,7 @@ srcdir = @srcdir@
|
||||||
|
VPATH = @srcdir@
|
||||||
|
top_srcdir = @top_srcdir@
|
||||||
|
|
||||||
|
-SUBDIRS = named rndc dig dnssec tests nsupdate check
|
||||||
|
+SUBDIRS = named named-sdb rndc dig dnssec tests nsupdate check sdb_tools
|
||||||
|
TARGETS =
|
||||||
|
|
||||||
|
@BIND9_MAKE_RULES@
|
||||||
|
diff -up bind-9.5.0b2/bin/named/Makefile.in.sdb bind-9.5.0b2/bin/named/Makefile.in
|
||||||
|
--- bind-9.5.0b2/bin/named/Makefile.in.sdb 2008-02-14 14:19:39.000000000 +0100
|
||||||
|
+++ bind-9.5.0b2/bin/named/Makefile.in 2008-02-14 14:20:18.000000000 +0100
|
||||||
|
@@ -43,7 +43,7 @@ CINCLUDES = -I${srcdir}/include -I${srcd
|
||||||
|
${ISCCFG_INCLUDES} ${ISCCC_INCLUDES} ${ISC_INCLUDES} \
|
||||||
|
${DLZDRIVER_INCLUDES} ${DBDRIVER_INCLUDES}
|
||||||
|
|
||||||
|
-CDEFINES = @USE_DLZ@
|
||||||
|
+CDEFINES =
|
||||||
|
|
||||||
|
CWARNINGS =
|
||||||
|
|
||||||
|
@@ -66,7 +66,7 @@ DEPLIBS = ${LWRESDEPLIBS} ${DNSDEPLIBS}
|
||||||
|
|
||||||
|
LIBS = ${LWRESLIBS} ${DNSLIBS} ${BIND9LIBS} \
|
||||||
|
${ISCCFGLIBS} ${ISCCCLIBS} ${ISCLIBS} \
|
||||||
|
- ${DLZDRIVER_LIBS} ${DBDRIVER_LIBS} @LIBS@
|
||||||
|
+ @LIBS@
|
||||||
|
|
||||||
|
SUBDIRS = unix
|
||||||
|
|
||||||
|
@@ -79,8 +79,7 @@ OBJS = builtin.@O@ client.@O@ config.@O
|
||||||
|
tkeyconf.@O@ tsigconf.@O@ update.@O@ xfrout.@O@ \
|
||||||
|
zoneconf.@O@ \
|
||||||
|
lwaddr.@O@ lwresd.@O@ lwdclient.@O@ lwderror.@O@ lwdgabn.@O@ \
|
||||||
|
- lwdgnba.@O@ lwdgrbn.@O@ lwdnoop.@O@ lwsearch.@O@ \
|
||||||
|
- ${DLZDRIVER_OBJS} ${DBDRIVER_OBJS}
|
||||||
|
+ lwdgnba.@O@ lwdgrbn.@O@ lwdnoop.@O@ lwsearch.@O@
|
||||||
|
|
||||||
|
UOBJS = unix/os.@O@
|
||||||
|
|
||||||
|
@@ -91,8 +90,7 @@ SRCS = builtin.c client.c config.c cont
|
||||||
|
tkeyconf.c tsigconf.c update.c xfrout.c \
|
||||||
|
zoneconf.c \
|
||||||
|
lwaddr.c lwresd.c lwdclient.c lwderror.c lwdgabn.c \
|
||||||
|
- lwdgnba.c lwdgrbn.c lwdnoop.c lwsearch.c \
|
||||||
|
- ${DLZDRIVER_SRCS} ${DBDRIVER_SRCS}
|
||||||
|
+ lwdgnba.c lwdgrbn.c lwdnoop.c lwsearch.c
|
||||||
|
|
||||||
|
MANPAGES = named.8 lwresd.8 named.conf.5
|
||||||
|
|
||||||
|
@@ -151,5 +149,3 @@ install:: named@EXEEXT@ lwresd@EXEEXT@ i
|
||||||
|
${INSTALL_DATA} ${srcdir}/named.8 ${DESTDIR}${mandir}/man8
|
||||||
|
${INSTALL_DATA} ${srcdir}/lwresd.8 ${DESTDIR}${mandir}/man8
|
||||||
|
${INSTALL_DATA} ${srcdir}/named.conf.5 ${DESTDIR}${mandir}/man5
|
||||||
|
-
|
||||||
|
-@DLZ_DRIVER_RULES@
|
||||||
|
55
bind.spec
55
bind.spec
@ -6,13 +6,12 @@
|
|||||||
|
|
||||||
%{?!SDB: %define SDB 1}
|
%{?!SDB: %define SDB 1}
|
||||||
%{?!LIBBIND: %define LIBBIND 1}
|
%{?!LIBBIND: %define LIBBIND 1}
|
||||||
%{?!efence: %define efence 0}
|
|
||||||
%{?!test: %define test 0}
|
%{?!test: %define test 0}
|
||||||
%{?!WITH_DBUS: %define WITH_DBUS 0} # + dynamic forwarder table management with D-BUS
|
%{?!WITH_DBUS: %define WITH_DBUS 0} # + dynamic forwarder table management with D-BUS
|
||||||
%{?!bind_uid: %define bind_uid 25}
|
%{?!bind_uid: %define bind_uid 25}
|
||||||
%{?!bind_gid: %define bind_gid 25}
|
%{?!bind_gid: %define bind_gid 25}
|
||||||
%{?!DLZ: %define DLZ 1}
|
|
||||||
%{?!GSSTSIG: %define GSSTSIG 1}
|
%{?!GSSTSIG: %define GSSTSIG 1}
|
||||||
|
%{?!DEBUG: %define DEBUG 1}
|
||||||
%define bind_dir /var/named
|
%define bind_dir /var/named
|
||||||
%define chroot_prefix %{bind_dir}/chroot
|
%define chroot_prefix %{bind_dir}/chroot
|
||||||
#
|
#
|
||||||
@ -20,7 +19,7 @@ Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) serv
|
|||||||
Name: bind
|
Name: bind
|
||||||
License: ISC
|
License: ISC
|
||||||
Version: 9.5.0
|
Version: 9.5.0
|
||||||
Release: 26.%{RELEASEVER}%{?dist}
|
Release: 27.%{RELEASEVER}%{?dist}
|
||||||
Epoch: 32
|
Epoch: 32
|
||||||
Url: http://www.isc.org/products/BIND/
|
Url: http://www.isc.org/products/BIND/
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -45,7 +44,7 @@ Source21: Copyright.caching-nameserver
|
|||||||
Source22: bind-chroot-admin.in
|
Source22: bind-chroot-admin.in
|
||||||
Source24: libbind.pc
|
Source24: libbind.pc
|
||||||
Source25: named.conf.sample
|
Source25: named.conf.sample
|
||||||
Source28: config-2.tar
|
Source28: config-3.tar.bz2
|
||||||
Source30: ldap2zone.c
|
Source30: ldap2zone.c
|
||||||
|
|
||||||
# Common patches
|
# Common patches
|
||||||
@ -61,6 +60,7 @@ Patch71: bind-9.5-overflow.patch
|
|||||||
Patch72: bind-9.5-dlz-64bit.patch
|
Patch72: bind-9.5-dlz-64bit.patch
|
||||||
Patch87: bind-9.5-parallel-build.patch
|
Patch87: bind-9.5-parallel-build.patch
|
||||||
Patch88: bind-9.5-transfer-segv.patch
|
Patch88: bind-9.5-transfer-segv.patch
|
||||||
|
Patch89: bind-9.5-mudflap.patch
|
||||||
|
|
||||||
# SDB patches
|
# SDB patches
|
||||||
Patch11: bind-9.3.2b2-sdbsrc.patch
|
Patch11: bind-9.3.2b2-sdbsrc.patch
|
||||||
@ -91,10 +91,7 @@ Obsoletes: bind-config, caching-nameserver
|
|||||||
Provides: bind-config, caching-nameserver
|
Provides: bind-config, caching-nameserver
|
||||||
BuildRequires: gcc, glibc-devel >= 2.2.5-26, glibc-kernheaders >= 2.4-7.10, openssl-devel, libtool, autoconf, pkgconfig
|
BuildRequires: gcc, glibc-devel >= 2.2.5-26, glibc-kernheaders >= 2.4-7.10, openssl-devel, libtool, autoconf, pkgconfig
|
||||||
%if %{SDB}
|
%if %{SDB}
|
||||||
BuildRequires: openldap-devel, postgresql-devel, sqlite-devel
|
BuildRequires: openldap-devel, postgresql-devel, sqlite-devel, mysql-devel, unixODBC-devel
|
||||||
%endif
|
|
||||||
%if %{DLZ}
|
|
||||||
BuildRequires: openldap-devel, postgresql-devel, mysql-devel, db4-devel, unixODBC-devel
|
|
||||||
%endif
|
%endif
|
||||||
%if %{WITH_DBUS}
|
%if %{WITH_DBUS}
|
||||||
BuildRequires: dbus-devel
|
BuildRequires: dbus-devel
|
||||||
@ -106,6 +103,9 @@ BuildRequires: net-tools, perl
|
|||||||
BuildRequires: krb5-devel
|
BuildRequires: krb5-devel
|
||||||
Requires: krb5-libs
|
Requires: krb5-libs
|
||||||
%endif
|
%endif
|
||||||
|
%if %{DEBUG}
|
||||||
|
BuildRequires: libmudflap-devel
|
||||||
|
%endif
|
||||||
BuildRequires: libidn-devel
|
BuildRequires: libidn-devel
|
||||||
Requires: libidn
|
Requires: libidn
|
||||||
|
|
||||||
@ -191,19 +191,21 @@ Based on the code from Jan "Yenya" Kasprzak <kas@fi.muni.cz>
|
|||||||
%patch5 -p1 -b .nonexec
|
%patch5 -p1 -b .nonexec
|
||||||
%patch10 -p1 -b .PIE
|
%patch10 -p1 -b .PIE
|
||||||
%patch69 -p1 -b .generate-xml
|
%patch69 -p1 -b .generate-xml
|
||||||
|
%patch16 -p1 -b .redhat_doc
|
||||||
%if %{SDB}
|
%if %{SDB}
|
||||||
|
mkdir bin/named-sdb
|
||||||
|
cp -r bin/named/* bin/named-sdb
|
||||||
%patch11 -p1 -b .sdbsrc
|
%patch11 -p1 -b .sdbsrc
|
||||||
cp -f bin/named/main.c bin/named/main-sdb.c
|
|
||||||
# SDB ldap
|
# SDB ldap
|
||||||
cp -fp contrib/sdb/ldap/ldapdb.[ch] bin/named
|
cp -fp contrib/sdb/ldap/ldapdb.[ch] bin/named-sdb
|
||||||
# SDB postgreSQL
|
# SDB postgreSQL
|
||||||
cp -fp contrib/sdb/pgsql/pgsqldb.[ch] bin/named
|
cp -fp contrib/sdb/pgsql/pgsqldb.[ch] bin/named-sdb
|
||||||
# SDB sqlite
|
# SDB sqlite
|
||||||
cp -fp contrib/sdb/sqlite/sqlitedb.[ch] bin/named
|
cp -fp contrib/sdb/sqlite/sqlitedb.[ch] bin/named-sdb
|
||||||
# SDB Berkeley DB - needs to be ported to DB4!
|
# SDB Berkeley DB - needs to be ported to DB4!
|
||||||
#cp -fp contrib/sdb/bdb/bdb.[ch] bin/named_sdb
|
#cp -fp contrib/sdb/bdb/bdb.[ch] bin/named_sdb
|
||||||
# SDB dir
|
# SDB dir
|
||||||
cp -fp contrib/sdb/dir/dirdb.[ch] bin/named
|
cp -fp contrib/sdb/dir/dirdb.[ch] bin/named-sdb
|
||||||
# SDB tools
|
# SDB tools
|
||||||
mkdir -p bin/sdb_tools
|
mkdir -p bin/sdb_tools
|
||||||
cp -fp %{SOURCE30} bin/sdb_tools/ldap2zone.c
|
cp -fp %{SOURCE30} bin/sdb_tools/ldap2zone.c
|
||||||
@ -218,7 +220,6 @@ cp -fp contrib/sdb/sqlite/zone2sqlite.c bin/sdb_tools
|
|||||||
%if %{LIBBIND}
|
%if %{LIBBIND}
|
||||||
%patch13 -p1 -b .fix_libbind_includedir
|
%patch13 -p1 -b .fix_libbind_includedir
|
||||||
%endif
|
%endif
|
||||||
%patch16 -p1 -b .redhat_doc
|
|
||||||
%if %{WITH_DBUS}
|
%if %{WITH_DBUS}
|
||||||
%patch15 -p1 -b .dbus
|
%patch15 -p1 -b .dbus
|
||||||
%patch23 -p1 -b .dbus_archdep_libdir
|
%patch23 -p1 -b .dbus_archdep_libdir
|
||||||
@ -248,13 +249,17 @@ cp -fp contrib/dbus/{dbus_mgr.h,dbus_service.h} bin/named/include/named
|
|||||||
%patch85 -p1 -b .libidn3
|
%patch85 -p1 -b .libidn3
|
||||||
%patch87 -p1 -b .parallel
|
%patch87 -p1 -b .parallel
|
||||||
%patch88 -p1 -b .transfer-segv
|
%patch88 -p1 -b .transfer-segv
|
||||||
|
%patch89 -p0 -b .mudflap
|
||||||
:;
|
:;
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CFLAGS="$CFLAGS $RPM_OPT_FLAGS -O0"
|
%if %{DEBUG}
|
||||||
|
export CFLAGS="$CFLAGS $RPM_OPT_FLAGS -O0 -fmudflapth"
|
||||||
|
export LDFLAGS="$LDFLAGS -lmudflapth -lpthread"
|
||||||
|
%endif
|
||||||
export CPPFLAGS="$CPPFLAGS -D_GNU_SOURCE"
|
export CPPFLAGS="$CPPFLAGS -D_GNU_SOURCE"
|
||||||
export STD_CDEFINES="$CPPFLAGS $STD_CDEFINES"
|
export STD_CDEFINES="$CPPFLAGS"
|
||||||
|
|
||||||
libtoolize --copy --force; aclocal; autoconf
|
libtoolize --copy --force; aclocal; autoconf
|
||||||
cp -f /usr/share/libtool/config.{guess,sub} .
|
cp -f /usr/share/libtool/config.{guess,sub} .
|
||||||
@ -270,24 +275,21 @@ if pkg-config openssl ; then
|
|||||||
export CPPFLAGS="$CPPFLAGS `pkg-config --cflags-only-I openssl`"
|
export CPPFLAGS="$CPPFLAGS `pkg-config --cflags-only-I openssl`"
|
||||||
export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
|
export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
|
||||||
fi
|
fi
|
||||||
%if %{efence}
|
|
||||||
export LDFLAGS=-lefence
|
|
||||||
%endif
|
|
||||||
%configure \
|
%configure \
|
||||||
--with-libtool \
|
--with-libtool \
|
||||||
--localstatedir=/var \
|
--localstatedir=/var \
|
||||||
--enable-threads \
|
--disable-threads \
|
||||||
--enable-ipv6 \
|
--enable-ipv6 \
|
||||||
--with-pic \
|
--with-pic \
|
||||||
|
--disable-openssl-version-check \
|
||||||
|
--disable-linux-caps \
|
||||||
%if %{LIBBIND}
|
%if %{LIBBIND}
|
||||||
--enable-libbind \
|
--enable-libbind \
|
||||||
%endif
|
%endif
|
||||||
%if %{DLZ}
|
%if %{SDB}
|
||||||
--disable-openssl-version-check \
|
|
||||||
--with-dlz-ldap=yes \
|
--with-dlz-ldap=yes \
|
||||||
--with-dlz-postgres=yes \
|
--with-dlz-postgres=yes \
|
||||||
--with-dlz-mysql=yes \
|
--with-dlz-mysql=yes \
|
||||||
--with-dlz-bdb=yes \
|
|
||||||
--with-dlz-filesystem=yes \
|
--with-dlz-filesystem=yes \
|
||||||
--with-dlz-odbc=yes \
|
--with-dlz-odbc=yes \
|
||||||
%endif
|
%endif
|
||||||
@ -657,6 +659,13 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%{_sbindir}/bind-chroot-admin
|
%{_sbindir}/bind-chroot-admin
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 19 2008 Adam Tkac <atkac redhat com> 32:9.5.0-27.b2
|
||||||
|
- removed conditional build with libefence (use -fmudflapth instead)
|
||||||
|
- fixed building of DLZ stuff (#432497)
|
||||||
|
- do not build Berkeley DB DLZ backend
|
||||||
|
- temporary build with --disable-linux-caps and without threads (#433102)
|
||||||
|
- update named.ca file to affect IPv6 changes in root zone
|
||||||
|
|
||||||
* Mon Feb 11 2008 Adam Tkac <atkac redhat com> 32:9.5.0-26.b2
|
* Mon Feb 11 2008 Adam Tkac <atkac redhat com> 32:9.5.0-26.b2
|
||||||
- build with -D_GNU_SOURCE (#431734)
|
- build with -D_GNU_SOURCE (#431734)
|
||||||
- improved fix for #253537, posttrans script is now used
|
- improved fix for #253537, posttrans script is now used
|
||||||
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
|||||||
d64e5ac8b5d98508b450bf999c33e7df bind-9.5.0b2.tar.gz
|
d64e5ac8b5d98508b450bf999c33e7df bind-9.5.0b2.tar.gz
|
||||||
4faa4395b955e5f8a3d50f308b9fabc8 bind-chroot.tar.bz2
|
4faa4395b955e5f8a3d50f308b9fabc8 bind-chroot.tar.bz2
|
||||||
9c3905b6aece5b4aa0deba6029437483 config-2.tar
|
d4bc7234a0d7b93328335ed9c076c6e9 config-3.tar.bz2
|
||||||
13fef79f99fcefebb51d84b08805de51 libbind-man.tar.gz
|
13fef79f99fcefebb51d84b08805de51 libbind-man.tar.gz
|
||||||
|
Loading…
Reference in New Issue
Block a user