Update to 9.7.3rc1.
- bind97-krb5-self.patch merged Signed-off-by: Adam Tkac <atkac@redhat.com>
This commit is contained in:
parent
bbaece96c1
commit
2ccdf60e3a
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@ bind-9.7.2b1.tar.gz
|
||||
/bind-9.7.2-P2.tar.gz
|
||||
/bind-9.7.2-P3.tar.gz
|
||||
/bind-9.7.3b1.tar.gz
|
||||
/bind-9.7.3rc1.tar.gz
|
||||
|
10
bind.spec
10
bind.spec
@ -3,7 +3,7 @@
|
||||
#
|
||||
|
||||
#%define PATCHVER P3
|
||||
%define PREVER b1
|
||||
%define PREVER rc1
|
||||
#%define VERSION %{version}
|
||||
#%define VERSION %{version}-%{PATCHVER}
|
||||
%define VERSION %{version}%{PREVER}
|
||||
@ -22,7 +22,7 @@ Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) serv
|
||||
Name: bind
|
||||
License: ISC
|
||||
Version: 9.7.3
|
||||
Release: 0.4.%{PREVER}%{?dist}
|
||||
Release: 0.5.%{PREVER}%{?dist}
|
||||
Epoch: 32
|
||||
Url: http://www.isc.org/products/BIND/
|
||||
Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -61,7 +61,6 @@ Patch109:bind97-rh478718.patch
|
||||
Patch110:bind97-rh570851.patch
|
||||
Patch111:bind97-exportlib.patch
|
||||
Patch112:bind97-rh645544.patch
|
||||
Patch113:bind97-krb5-self.patch
|
||||
|
||||
# SDB patches
|
||||
Patch11: bind-9.3.2b2-sdbsrc.patch
|
||||
@ -297,7 +296,6 @@ mkdir m4
|
||||
%patch110 -p1 -b .rh570851
|
||||
%patch111 -p1 -b .exportlib
|
||||
%patch112 -p1 -b .rh645544
|
||||
%patch113 -p1 -b .krb5-self
|
||||
|
||||
# Sparc and s390 arches need to use -fPIE
|
||||
%ifarch sparcv9 sparc64 s390 s390x
|
||||
@ -766,6 +764,10 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Jan 25 2011 Adam Tkac <atkac redhat com> 32:9.7.3-0.5.rc1
|
||||
- update to 9.7.3rc1
|
||||
- bind97-krb5-self.patch merged
|
||||
|
||||
* Wed Jan 12 2011 Adam Tkac <atkac redhat com> 32:9.7.3-0.4.b1
|
||||
- fix typo in initscript
|
||||
|
||||
|
@ -69,7 +69,7 @@ diff -up bind-9.7.2-P2/lib/export/dns/Makefile.in.exportlib bind-9.7.2-P2/lib/ex
|
||||
|
||||
install:: timestamp installdirs
|
||||
- ${LIBTOOL_MODE_INSTALL} ${INSTALL_DATA} libdns.@A@ \
|
||||
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_DATA} libdns-export.@A@ \
|
||||
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} libdns-export.@A@ \
|
||||
${DESTDIR}${export_libdir}
|
||||
|
||||
clean distclean::
|
||||
@ -121,7 +121,7 @@ diff -up bind-9.7.2-P2/lib/export/irs/Makefile.in.exportlib bind-9.7.2-P2/lib/ex
|
||||
|
||||
install:: timestamp installdirs
|
||||
- ${LIBTOOL_MODE_INSTALL} ${INSTALL_DATA} libirs.@A@ \
|
||||
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_DATA} libirs-export.@A@ \
|
||||
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} libirs-export.@A@ \
|
||||
${DESTDIR}${export_libdir}
|
||||
|
||||
clean distclean::
|
||||
@ -172,7 +172,7 @@ diff -up bind-9.7.2-P2/lib/export/isccfg/Makefile.in.exportlib bind-9.7.2-P2/lib
|
||||
|
||||
install:: timestamp installdirs
|
||||
- ${LIBTOOL_MODE_INSTALL} ${INSTALL_DATA} libisccfg.@A@ \
|
||||
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_DATA} libisccfg-export.@A@ \
|
||||
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} libisccfg-export.@A@ \
|
||||
${DESTDIR}${export_libdir}
|
||||
|
||||
clean distclean::
|
||||
@ -219,7 +219,7 @@ diff -up bind-9.7.2-P2/lib/export/isc/Makefile.in.exportlib bind-9.7.2-P2/lib/ex
|
||||
|
||||
install:: timestamp installdirs
|
||||
- ${LIBTOOL_MODE_INSTALL} ${INSTALL_DATA} libisc.@A@ \
|
||||
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_DATA} libisc-export.@A@ \
|
||||
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} libisc-export.@A@ \
|
||||
${DESTDIR}${export_libdir}
|
||||
|
||||
clean distclean::
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up bind-9.7.2-P3/lib/dns/gssapictx.c.krb5-self bind-9.7.2-P3/lib/dns/gssapictx.c
|
||||
--- bind-9.7.2-P3/lib/dns/gssapictx.c.krb5-self 2010-12-20 11:18:36.459176676 +0100
|
||||
+++ bind-9.7.2-P3/lib/dns/gssapictx.c 2010-12-20 11:18:42.263376643 +0100
|
||||
@@ -358,7 +358,7 @@ dst_gssapi_identitymatchesrealmkrb5(dns_
|
||||
if (rname == NULL)
|
||||
return (isc_boolean_false);
|
||||
*rname = '\0';
|
||||
- rname += 2;
|
||||
+ rname++;
|
||||
|
||||
/*
|
||||
* Find the host portion of the signer's name. We do this by
|
Loading…
Reference in New Issue
Block a user