Fix multilib conflict after 9.11 rebase

Conflict with devel headers reappeared after rebase to 9.11. Fix
socklen_t in a way that would generate the same types on 32 and 64 bit
architectures.
This commit is contained in:
Petr Menšík 2018-09-19 19:17:58 +02:00
parent aeea22afaa
commit 2ac37f7a75
3 changed files with 55 additions and 22 deletions

View File

@ -1,8 +1,8 @@
diff --git a/config.h.in b/config.h.in diff --git a/config.h.in b/config.h.in
index 0c340db..dbeecd7 100644 index e1364dd921..1dc65cfb21 100644
--- a/config.h.in --- a/config.h.in
+++ b/config.h.in +++ b/config.h.in
@@ -520,7 +520,7 @@ int sigwait(const unsigned int *set, int *sig); @@ -588,7 +588,7 @@ int sigwait(const unsigned int *set, int *sig);
#undef PREFER_GOSTASN1 #undef PREFER_GOSTASN1
/* The size of `void *', as computed by sizeof. */ /* The size of `void *', as computed by sizeof. */
@ -12,28 +12,41 @@ index 0c340db..dbeecd7 100644
/* Define to 1 if you have the ANSI C header files. */ /* Define to 1 if you have the ANSI C header files. */
#undef STDC_HEADERS #undef STDC_HEADERS
diff --git a/configure.in b/configure.in diff --git a/configure.in b/configure.in
index 6b875ba..c39477c 100644 index 73b1c8ccbb..129fc3f311 100644
--- a/configure.in --- a/configure.in
+++ b/configure.in +++ b/configure.in
@@ -3065,8 +3065,11 @@ int getnameinfo(const struct sockaddr *, size_t, char *, @@ -3523,14 +3523,14 @@ AC_TRY_COMPILE([
size_t, char *, size_t, int);], #include <sys/socket.h>
#include <netdb.h>
int getnameinfo(const struct sockaddr *, socklen_t, char *,
- socklen_t, char *, socklen_t, unsigned int);],
+ socklen_t, char *, socklen_t, int);],
[ return (0);], [ return (0);],
[AC_MSG_RESULT(size_t for buflen; int for flags) - [AC_MSG_RESULT(socklen_t for buflen; u_int for flags)
- AC_DEFINE(IRS_GETNAMEINFO_SOCKLEN_T, size_t) + [AC_MSG_RESULT(socklen_t for buflen; int for flags)
- AC_DEFINE(IRS_GETNAMEINFO_BUFLEN_T, size_t) AC_DEFINE(IRS_GETNAMEINFO_SOCKLEN_T, socklen_t,
+ # Changed to solve multilib conflict on Fedora [Define to the sockaddr length type used by getnameinfo(3).])
+ # AC_DEFINE(IRS_GETNAMEINFO_SOCKLEN_T, size_t) AC_DEFINE(IRS_GETNAMEINFO_BUFLEN_T, socklen_t,
+ # AC_DEFINE(IRS_GETNAMEINFO_BUFLEN_T, size_t) [Define to the buffer length type used by getnameinfo(3).])
+ AC_DEFINE(IRS_GETNAMEINFO_SOCKLEN_T, socklen_t) - AC_DEFINE(IRS_GETNAMEINFO_FLAGS_T, unsigned int,
+ AC_DEFINE(IRS_GETNAMEINFO_BUFLEN_T, socklen_t) + AC_DEFINE(IRS_GETNAMEINFO_FLAGS_T, int,
AC_DEFINE(IRS_GETNAMEINFO_FLAGS_T, int)], [Define to the flags type used by getnameinfo(3).])],
[AC_TRY_COMPILE([
#include <sys/types.h>
@@ -3557,7 +3557,7 @@ int getnameinfo(const struct sockaddr *, size_t, char *,
[AC_MSG_RESULT(not match any subspecies; assume standard definition) [AC_MSG_RESULT(not match any subspecies; assume standard definition)
AC_DEFINE(IRS_GETNAMEINFO_SOCKLEN_T, socklen_t) AC_DEFINE(IRS_GETNAMEINFO_SOCKLEN_T, socklen_t)
AC_DEFINE(IRS_GETNAMEINFO_BUFLEN_T, socklen_t)
-AC_DEFINE(IRS_GETNAMEINFO_FLAGS_T, int)])])])
+AC_DEFINE(IRS_GETNAMEINFO_FLAGS_T, unsigned int)])])])
#
# ...and same for gai_strerror().
diff --git a/isc-config.sh.in b/isc-config.sh.in diff --git a/isc-config.sh.in b/isc-config.sh.in
index 04a9e5c..67400d8 100644 index a8a0a89e88..b5e94ed13e 100644
--- a/isc-config.sh.in --- a/isc-config.sh.in
+++ b/isc-config.sh.in +++ b/isc-config.sh.in
@@ -21,7 +21,18 @@ prefix=@prefix@ @@ -13,7 +13,18 @@ prefix=@prefix@
exec_prefix=@exec_prefix@ exec_prefix=@exec_prefix@
exec_prefix_set= exec_prefix_set=
includedir=@includedir@ includedir=@includedir@
@ -53,7 +66,7 @@ index 04a9e5c..67400d8 100644
usage() usage()
{ {
@@ -140,6 +151,16 @@ if test x"$echo_libs" = x"true"; then @@ -132,6 +143,16 @@ if test x"$echo_libs" = x"true"; then
if test x"${exec_prefix_set}" = x"true"; then if test x"${exec_prefix_set}" = x"true"; then
libs="-L${exec_prefix}/lib" libs="-L${exec_prefix}/lib"
else else

View File

@ -1437,6 +1437,7 @@ rm -rf ${RPM_BUILD_ROOT}
* Fri Aug 24 2018 Petr Menšík <pemensik@redhat.com> - 32:9.11.4-7.P1 * Fri Aug 24 2018 Petr Menšík <pemensik@redhat.com> - 32:9.11.4-7.P1
- Add support for OpenSSL provided random data - Add support for OpenSSL provided random data
- Replace unoptimized code by OpenSSL counterparts - Replace unoptimized code by OpenSSL counterparts
- Fix multilib conflicts of devel package
* Mon Aug 13 2018 Petr Menšík <pemensik@redhat.com> - 32:9.11.4-6.P1 * Mon Aug 13 2018 Petr Menšík <pemensik@redhat.com> - 32:9.11.4-6.P1
- Fix sdb-chroot devices upgrade (#1592873) - Fix sdb-chroot devices upgrade (#1592873)

View File

@ -1,8 +1,8 @@
diff --git a/configure.in b/configure.in diff --git a/configure.in b/configure.in
index 97d9d15..999040d 100644 index 896e81c1ce..73b1c8ccbb 100644
--- a/configure.in --- a/configure.in
+++ b/configure.in +++ b/configure.in
@@ -4041,6 +4041,10 @@ if test "yes" = "$use_atomic"; then @@ -4275,6 +4275,10 @@ if test "yes" = "$use_atomic"; then
AC_MSG_RESULT($arch) AC_MSG_RESULT($arch)
fi fi
@ -14,19 +14,38 @@ index 97d9d15..999040d 100644
AC_MSG_CHECKING([compiler support for inline assembly code]) AC_MSG_CHECKING([compiler support for inline assembly code])
diff --git a/lib/isc/include/isc/platform.h.in b/lib/isc/include/isc/platform.h.in diff --git a/lib/isc/include/isc/platform.h.in b/lib/isc/include/isc/platform.h.in
index 24b61db..28f49c8 100644 index 2ff522342f..58df86adb3 100644
--- a/lib/isc/include/isc/platform.h.in --- a/lib/isc/include/isc/platform.h.in
+++ b/lib/isc/include/isc/platform.h.in +++ b/lib/isc/include/isc/platform.h.in
@@ -286,7 +286,11 @@ @@ -289,19 +289,25 @@
* If the "xaddq" operation (64bit xadd) is available on this architecture, * If the "xaddq" operation (64bit xadd) is available on this architecture,
* ISC_PLATFORM_HAVEXADDQ will be defined. * ISC_PLATFORM_HAVEXADDQ will be defined.
*/ */
-@ISC_PLATFORM_HAVEXADDQ@ -@ISC_PLATFORM_HAVEXADDQ@
/*
- * If the 32-bit "atomic swap" operation is available on this
- * architecture, ISC_PLATFORM_HAVEATOMICSTORE" will be defined.
+ * If the 64-bit "atomic swap" operation is available on this
+ * architecture, ISC_PLATFORM_HAVEATOMICSTOREQ" will be defined.
*/
-@ISC_PLATFORM_HAVEATOMICSTORE@
+
+#ifdef __x86_64__ +#ifdef __x86_64__
+#define ISC_PLATFORM_HAVEXADDQ 1 +#define ISC_PLATFORM_HAVEXADDQ 1
+#define ISC_PLATFORM_HAVEATOMICSTOREQ 1
+#else +#else
+#undef ISC_PLATFORM_HAVEXADDQ +#undef ISC_PLATFORM_HAVEXADDQ
+#undef ISC_PLATFORM_HAVEATOMICSTOREQ
+#endif +#endif
/* /*
* If the 32-bit "atomic swap" operation is available on this - * If the 64-bit "atomic swap" operation is available on this
+ * If the 32-bit "atomic swap" operation is available on this
* architecture, ISC_PLATFORM_HAVEATOMICSTORE" will be defined.
*/
-@ISC_PLATFORM_HAVEATOMICSTOREQ@
+@ISC_PLATFORM_HAVEATOMICSTORE@
/*
* If the "compare-and-exchange" operation is available on this architecture,