Install manpages generated by build
Upstream code will always install manual pages of upstream. Manuals generated on build will be again installed. Broken by out-of-tree build to support export-lib.
This commit is contained in:
parent
3fdc82d222
commit
20ccb888af
@ -14,7 +14,7 @@ index f0c504a..ce7a2da 100644
|
|||||||
|
|
||||||
@BIND9_MAKE_RULES@
|
@BIND9_MAKE_RULES@
|
||||||
diff --git a/bin/dnssec-pkcs11/Makefile.in b/bin/dnssec-pkcs11/Makefile.in
|
diff --git a/bin/dnssec-pkcs11/Makefile.in b/bin/dnssec-pkcs11/Makefile.in
|
||||||
index 1be1d5f..0f09216 100644
|
index 1d0c4ce..7b7f89b 100644
|
||||||
--- a/bin/dnssec-pkcs11/Makefile.in
|
--- a/bin/dnssec-pkcs11/Makefile.in
|
||||||
+++ b/bin/dnssec-pkcs11/Makefile.in
|
+++ b/bin/dnssec-pkcs11/Makefile.in
|
||||||
@@ -17,18 +17,18 @@ VERSION=@BIND9_VERSION@
|
@@ -17,18 +17,18 @@ VERSION=@BIND9_VERSION@
|
||||||
@ -110,15 +110,18 @@ index 1be1d5f..0f09216 100644
|
|||||||
${LIBTOOL_MODE_LINK} ${PURIFY} ${CC} ${CFLAGS} ${LDFLAGS} -o $@ \
|
${LIBTOOL_MODE_LINK} ${PURIFY} ${CC} ${CFLAGS} ${LDFLAGS} -o $@ \
|
||||||
dnssec-importkey.@O@ ${OBJS} ${LIBS}
|
dnssec-importkey.@O@ ${OBJS} ${LIBS}
|
||||||
|
|
||||||
@@ -108,14 +108,11 @@ docclean manclean maintainer-clean::
|
@@ -108,16 +108,14 @@ docclean manclean maintainer-clean::
|
||||||
|
|
||||||
installdirs:
|
installdirs:
|
||||||
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${sbindir}
|
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${sbindir}
|
||||||
- $(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man8
|
- $(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man8
|
||||||
|
|
||||||
install:: ${TARGETS} installdirs
|
install-man8: ${MANPAGES}
|
||||||
|
${INSTALL_DATA} $^ ${DESTDIR}${mandir}/man8
|
||||||
|
|
||||||
|
-install:: ${TARGETS} installdirs install-man8
|
||||||
|
+install:: ${TARGETS} installdirs
|
||||||
for t in ${TARGETS}; do ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} $$t ${DESTDIR}${sbindir}; done
|
for t in ${TARGETS}; do ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} $$t ${DESTDIR}${sbindir}; done
|
||||||
- for m in ${MANPAGES}; do ${INSTALL_DATA} ${srcdir}/$$m ${DESTDIR}${mandir}/man8; done
|
|
||||||
|
|
||||||
uninstall::
|
uninstall::
|
||||||
- for m in ${MANPAGES}; do rm -f ${DESTDIR}${mandir}/man8/$$m ; done
|
- for m in ${MANPAGES}; do rm -f ${DESTDIR}${mandir}/man8/$$m ; done
|
||||||
@ -126,7 +129,7 @@ index 1be1d5f..0f09216 100644
|
|||||||
|
|
||||||
clean distclean::
|
clean distclean::
|
||||||
diff --git a/bin/dnssec/Makefile.in b/bin/dnssec/Makefile.in
|
diff --git a/bin/dnssec/Makefile.in b/bin/dnssec/Makefile.in
|
||||||
index 1be1d5f..fc983bf 100644
|
index 1d0c4ce..11538cf 100644
|
||||||
--- a/bin/dnssec/Makefile.in
|
--- a/bin/dnssec/Makefile.in
|
||||||
+++ b/bin/dnssec/Makefile.in
|
+++ b/bin/dnssec/Makefile.in
|
||||||
@@ -19,7 +19,7 @@ VERSION=@BIND9_VERSION@
|
@@ -19,7 +19,7 @@ VERSION=@BIND9_VERSION@
|
||||||
@ -139,7 +142,7 @@ index 1be1d5f..fc983bf 100644
|
|||||||
CWARNINGS =
|
CWARNINGS =
|
||||||
|
|
||||||
diff --git a/bin/named-pkcs11/Makefile.in b/bin/named-pkcs11/Makefile.in
|
diff --git a/bin/named-pkcs11/Makefile.in b/bin/named-pkcs11/Makefile.in
|
||||||
index e1f85a9..2effa69 100644
|
index d92bc9a..a8c42a4 100644
|
||||||
--- a/bin/named-pkcs11/Makefile.in
|
--- a/bin/named-pkcs11/Makefile.in
|
||||||
+++ b/bin/named-pkcs11/Makefile.in
|
+++ b/bin/named-pkcs11/Makefile.in
|
||||||
@@ -43,26 +43,26 @@ DLZDRIVER_INCLUDES = @DLZ_DRIVER_INCLUDES@
|
@@ -43,26 +43,26 @@ DLZDRIVER_INCLUDES = @DLZ_DRIVER_INCLUDES@
|
||||||
@ -233,19 +236,13 @@ index e1f85a9..2effa69 100644
|
|||||||
|
|
||||||
doc man:: ${MANOBJS}
|
doc man:: ${MANOBJS}
|
||||||
|
|
||||||
@@ -173,22 +171,12 @@ statschannel.@O@: bind9.xsl.h
|
@@ -184,16 +182,11 @@ install-man8: named.8 lwresd.8
|
||||||
|
|
||||||
installdirs:
|
install-man: install-man5 install-man8
|
||||||
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${sbindir}
|
|
||||||
- $(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man5
|
|
||||||
- $(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man8
|
|
||||||
|
|
||||||
-install:: named@EXEEXT@ lwresd@EXEEXT@ installdirs
|
-install:: named@EXEEXT@ lwresd@EXEEXT@ installdirs install-man
|
||||||
- ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} named@EXEEXT@ ${DESTDIR}${sbindir}
|
- ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} named@EXEEXT@ ${DESTDIR}${sbindir}
|
||||||
- (cd ${DESTDIR}${sbindir}; rm -f lwresd@EXEEXT@; @LN@ named@EXEEXT@ lwresd@EXEEXT@)
|
- (cd ${DESTDIR}${sbindir}; rm -f lwresd@EXEEXT@; @LN@ named@EXEEXT@ lwresd@EXEEXT@)
|
||||||
- ${INSTALL_DATA} ${srcdir}/named.8 ${DESTDIR}${mandir}/man8
|
|
||||||
- ${INSTALL_DATA} ${srcdir}/lwresd.8 ${DESTDIR}${mandir}/man8
|
|
||||||
- ${INSTALL_DATA} ${srcdir}/named.conf.5 ${DESTDIR}${mandir}/man5
|
|
||||||
+install:: named-pkcs11@EXEEXT@ installdirs
|
+install:: named-pkcs11@EXEEXT@ installdirs
|
||||||
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} named-pkcs11@EXEEXT@ ${DESTDIR}${sbindir}
|
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} named-pkcs11@EXEEXT@ ${DESTDIR}${sbindir}
|
||||||
|
|
||||||
@ -260,7 +257,7 @@ index e1f85a9..2effa69 100644
|
|||||||
@DLZ_DRIVER_RULES@
|
@DLZ_DRIVER_RULES@
|
||||||
|
|
||||||
diff --git a/bin/named/Makefile.in b/bin/named/Makefile.in
|
diff --git a/bin/named/Makefile.in b/bin/named/Makefile.in
|
||||||
index e1f85a9..b7493c5 100644
|
index d92bc9a..6d2bfd1 100644
|
||||||
--- a/bin/named/Makefile.in
|
--- a/bin/named/Makefile.in
|
||||||
+++ b/bin/named/Makefile.in
|
+++ b/bin/named/Makefile.in
|
||||||
@@ -47,7 +47,7 @@ CINCLUDES = -I${srcdir}/include -I${srcdir}/unix/include -I. \
|
@@ -47,7 +47,7 @@ CINCLUDES = -I${srcdir}/include -I${srcdir}/unix/include -I. \
|
||||||
@ -273,7 +270,7 @@ index e1f85a9..b7493c5 100644
|
|||||||
CWARNINGS =
|
CWARNINGS =
|
||||||
|
|
||||||
diff --git a/bin/pkcs11/Makefile.in b/bin/pkcs11/Makefile.in
|
diff --git a/bin/pkcs11/Makefile.in b/bin/pkcs11/Makefile.in
|
||||||
index ae90616..4bc1256 100644
|
index 70ee8b5..0fd8644 100644
|
||||||
--- a/bin/pkcs11/Makefile.in
|
--- a/bin/pkcs11/Makefile.in
|
||||||
+++ b/bin/pkcs11/Makefile.in
|
+++ b/bin/pkcs11/Makefile.in
|
||||||
@@ -15,13 +15,13 @@ top_srcdir = @top_srcdir@
|
@@ -15,13 +15,13 @@ top_srcdir = @top_srcdir@
|
||||||
|
@ -14,7 +14,7 @@ index ce7a2da..4e6a824 100644
|
|||||||
|
|
||||||
@BIND9_MAKE_RULES@
|
@BIND9_MAKE_RULES@
|
||||||
diff --git a/bin/named-sdb/Makefile.in b/bin/named-sdb/Makefile.in
|
diff --git a/bin/named-sdb/Makefile.in b/bin/named-sdb/Makefile.in
|
||||||
index b7493c5..93f9a33 100644
|
index 6d2bfd1..d3f42e8 100644
|
||||||
--- a/bin/named-sdb/Makefile.in
|
--- a/bin/named-sdb/Makefile.in
|
||||||
+++ b/bin/named-sdb/Makefile.in
|
+++ b/bin/named-sdb/Makefile.in
|
||||||
@@ -30,10 +30,10 @@ VERSION=@BIND9_VERSION@
|
@@ -30,10 +30,10 @@ VERSION=@BIND9_VERSION@
|
||||||
@ -49,20 +49,23 @@ index b7493c5..93f9a33 100644
|
|||||||
export MAKE_SYMTABLE="yes"; \
|
export MAKE_SYMTABLE="yes"; \
|
||||||
export BASEOBJS="${OBJS} ${UOBJS}"; \
|
export BASEOBJS="${OBJS} ${UOBJS}"; \
|
||||||
${FINALBUILDCMD}
|
${FINALBUILDCMD}
|
||||||
@@ -173,22 +173,12 @@ statschannel.@O@: bind9.xsl.h
|
@@ -173,8 +173,6 @@ statschannel.@O@: bind9.xsl.h
|
||||||
|
|
||||||
installdirs:
|
installdirs:
|
||||||
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${sbindir}
|
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${sbindir}
|
||||||
- $(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man5
|
- $(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man5
|
||||||
- $(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man8
|
- $(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man8
|
||||||
|
|
||||||
-install:: named@EXEEXT@ lwresd@EXEEXT@ installdirs
|
install-man5: named.conf.5
|
||||||
|
${INSTALL_DATA} $^ ${DESTDIR}${mandir}/man5
|
||||||
|
@@ -184,16 +182,11 @@ install-man8: named.8 lwresd.8
|
||||||
|
|
||||||
|
install-man: install-man5 install-man8
|
||||||
|
|
||||||
|
-install:: named@EXEEXT@ lwresd@EXEEXT@ installdirs install-man
|
||||||
- ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} named@EXEEXT@ ${DESTDIR}${sbindir}
|
- ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} named@EXEEXT@ ${DESTDIR}${sbindir}
|
||||||
- (cd ${DESTDIR}${sbindir}; rm -f lwresd@EXEEXT@; @LN@ named@EXEEXT@ lwresd@EXEEXT@)
|
- (cd ${DESTDIR}${sbindir}; rm -f lwresd@EXEEXT@; @LN@ named@EXEEXT@ lwresd@EXEEXT@)
|
||||||
- ${INSTALL_DATA} ${srcdir}/named.8 ${DESTDIR}${mandir}/man8
|
+install:: ${TARGETS} installdirs
|
||||||
- ${INSTALL_DATA} ${srcdir}/lwresd.8 ${DESTDIR}${mandir}/man8
|
|
||||||
- ${INSTALL_DATA} ${srcdir}/named.conf.5 ${DESTDIR}${mandir}/man5
|
|
||||||
+install:: named-sdb@EXEEXT@ installdirs
|
|
||||||
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} named-sdb@EXEEXT@ ${DESTDIR}${sbindir}
|
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} named-sdb@EXEEXT@ ${DESTDIR}${sbindir}
|
||||||
|
|
||||||
uninstall::
|
uninstall::
|
||||||
@ -76,7 +79,7 @@ index b7493c5..93f9a33 100644
|
|||||||
@DLZ_DRIVER_RULES@
|
@DLZ_DRIVER_RULES@
|
||||||
|
|
||||||
diff --git a/bin/named-sdb/main.c b/bin/named-sdb/main.c
|
diff --git a/bin/named-sdb/main.c b/bin/named-sdb/main.c
|
||||||
index 1227ea9..febbdf5 100644
|
index bb639d9..555c4d9 100644
|
||||||
--- a/bin/named-sdb/main.c
|
--- a/bin/named-sdb/main.c
|
||||||
+++ b/bin/named-sdb/main.c
|
+++ b/bin/named-sdb/main.c
|
||||||
@@ -91,6 +91,10 @@
|
@@ -91,6 +91,10 @@
|
||||||
@ -102,7 +105,7 @@ index 1227ea9..febbdf5 100644
|
|||||||
isc_log_write(ns_g_lctx, NS_LOGCATEGORY_GENERAL, NS_LOGMODULE_MAIN,
|
isc_log_write(ns_g_lctx, NS_LOGCATEGORY_GENERAL, NS_LOGMODULE_MAIN,
|
||||||
ISC_LOG_NOTICE, "starting %s %s%s%s <id:%s>",
|
ISC_LOG_NOTICE, "starting %s %s%s%s <id:%s>",
|
||||||
ns_g_product, ns_g_version,
|
ns_g_product, ns_g_version,
|
||||||
@@ -1182,6 +1191,75 @@ setup(void) {
|
@@ -1261,6 +1270,75 @@ setup(void) {
|
||||||
isc_result_totext(result));
|
isc_result_totext(result));
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@ -178,7 +181,7 @@ index 1227ea9..febbdf5 100644
|
|||||||
ns_server_create(ns_g_mctx, &ns_g_server);
|
ns_server_create(ns_g_mctx, &ns_g_server);
|
||||||
|
|
||||||
#ifdef HAVE_LIBSECCOMP
|
#ifdef HAVE_LIBSECCOMP
|
||||||
@@ -1224,6 +1302,11 @@ cleanup(void) {
|
@@ -1303,6 +1381,11 @@ cleanup(void) {
|
||||||
|
|
||||||
dns_name_destroy();
|
dns_name_destroy();
|
||||||
|
|
||||||
@ -191,7 +194,7 @@ index 1227ea9..febbdf5 100644
|
|||||||
ISC_LOG_NOTICE, "exiting");
|
ISC_LOG_NOTICE, "exiting");
|
||||||
ns_log_shutdown();
|
ns_log_shutdown();
|
||||||
diff --git a/bin/named/Makefile.in b/bin/named/Makefile.in
|
diff --git a/bin/named/Makefile.in b/bin/named/Makefile.in
|
||||||
index b7493c5..8231d24 100644
|
index 6d2bfd1..86f8587 100644
|
||||||
--- a/bin/named/Makefile.in
|
--- a/bin/named/Makefile.in
|
||||||
+++ b/bin/named/Makefile.in
|
+++ b/bin/named/Makefile.in
|
||||||
@@ -45,9 +45,9 @@ DLZDRIVER_LIBS = @DLZ_DRIVER_LIBS@
|
@@ -45,9 +45,9 @@ DLZDRIVER_LIBS = @DLZ_DRIVER_LIBS@
|
||||||
@ -240,7 +243,7 @@ index b7493c5..8231d24 100644
|
|||||||
|
|
||||||
MANPAGES = named.8 lwresd.8 named.conf.5
|
MANPAGES = named.8 lwresd.8 named.conf.5
|
||||||
|
|
||||||
@@ -190,7 +188,5 @@ uninstall::
|
@@ -195,7 +193,5 @@ uninstall::
|
||||||
rm -f ${DESTDIR}${sbindir}/lwresd@EXEEXT@
|
rm -f ${DESTDIR}${sbindir}/lwresd@EXEEXT@
|
||||||
${LIBTOOL_MODE_UNINSTALL} rm -f ${DESTDIR}${sbindir}/named@EXEEXT@
|
${LIBTOOL_MODE_UNINSTALL} rm -f ${DESTDIR}${sbindir}/named@EXEEXT@
|
||||||
|
|
||||||
|
256
bind-9.11-oot-manual.patch
Normal file
256
bind-9.11-oot-manual.patch
Normal file
@ -0,0 +1,256 @@
|
|||||||
|
From e462d022a9dc52c40aece6f8ba3123ff3ffa59ed Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Petr=20Men=C5=A1=C3=ADk?= <pemensik@redhat.com>
|
||||||
|
Date: Wed, 25 Jul 2018 12:24:16 +0200
|
||||||
|
Subject: [PATCH] Use make automatic variables to install updated manuals
|
||||||
|
|
||||||
|
Make will choose modified manual from build directory or original from source
|
||||||
|
directory automagically. Take advantage of install tool feature.
|
||||||
|
Install all files in single command instead of iterating on each of them.
|
||||||
|
---
|
||||||
|
bin/check/Makefile.in | 8 +++++---
|
||||||
|
bin/confgen/Makefile.in | 9 +++++----
|
||||||
|
bin/delv/Makefile.in | 6 ++++--
|
||||||
|
bin/dig/Makefile.in | 8 ++++----
|
||||||
|
bin/dnssec/Makefile.in | 6 ++++--
|
||||||
|
bin/named/Makefile.in | 13 +++++++++----
|
||||||
|
bin/pkcs11/Makefile.in | 9 ++++-----
|
||||||
|
bin/python/Makefile.in | 8 ++++----
|
||||||
|
bin/tools/Makefile.in | 25 +++++++++++++++----------
|
||||||
|
9 files changed, 54 insertions(+), 38 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/bin/check/Makefile.in b/bin/check/Makefile.in
|
||||||
|
index 12f48d2d23..d8eac4c714 100644
|
||||||
|
--- a/bin/check/Makefile.in
|
||||||
|
+++ b/bin/check/Makefile.in
|
||||||
|
@@ -83,12 +83,14 @@ installdirs:
|
||||||
|
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${sbindir}
|
||||||
|
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man8
|
||||||
|
|
||||||
|
-install:: named-checkconf@EXEEXT@ named-checkzone@EXEEXT@ installdirs
|
||||||
|
+install-man8: ${MANPAGES}
|
||||||
|
+ ${INSTALL_DATA} $^ ${DESTDIR}${mandir}/man8
|
||||||
|
+ (cd ${DESTDIR}${mandir}/man8; rm -f named-compilezone.8; ${LINK_PROGRAM} named-checkzone.8 named-compilezone.8)
|
||||||
|
+
|
||||||
|
+install:: named-checkconf@EXEEXT@ named-checkzone@EXEEXT@ installdirs install-man8
|
||||||
|
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} named-checkconf@EXEEXT@ ${DESTDIR}${sbindir}
|
||||||
|
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} named-checkzone@EXEEXT@ ${DESTDIR}${sbindir}
|
||||||
|
(cd ${DESTDIR}${sbindir}; rm -f named-compilezone@EXEEXT@; ${LINK_PROGRAM} named-checkzone@EXEEXT@ named-compilezone@EXEEXT@)
|
||||||
|
- for m in ${MANPAGES}; do ${INSTALL_DATA} ${srcdir}/$$m ${DESTDIR}${mandir}/man8; done
|
||||||
|
- (cd ${DESTDIR}${mandir}/man8; rm -f named-compilezone.8; ${LINK_PROGRAM} named-checkzone.8 named-compilezone.8)
|
||||||
|
|
||||||
|
uninstall::
|
||||||
|
rm -f ${DESTDIR}${mandir}/man8/named-compilezone.8
|
||||||
|
diff --git a/bin/confgen/Makefile.in b/bin/confgen/Makefile.in
|
||||||
|
index 87f13dda4b..7865c0c73e 100644
|
||||||
|
--- a/bin/confgen/Makefile.in
|
||||||
|
+++ b/bin/confgen/Makefile.in
|
||||||
|
@@ -95,13 +95,14 @@ installdirs:
|
||||||
|
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${sbindir}
|
||||||
|
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man8
|
||||||
|
|
||||||
|
-install:: rndc-confgen@EXEEXT@ ddns-confgen@EXEEXT@ installdirs
|
||||||
|
+install-man8: rndc-confgen.8 ddns-confgen.8
|
||||||
|
+ ${INSTALL_DATA} $^ ${DESTDIR}${mandir}/man8
|
||||||
|
+ (cd ${DESTDIR}${mandir}/man8; rm -f tsig-keygen.8; ${LINK_PROGRAM} ddns-confgen.8 tsig-keygen.8)
|
||||||
|
+
|
||||||
|
+install:: rndc-confgen@EXEEXT@ ddns-confgen@EXEEXT@ installdirs install-man8
|
||||||
|
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} rndc-confgen@EXEEXT@ ${DESTDIR}${sbindir}
|
||||||
|
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} ddns-confgen@EXEEXT@ ${DESTDIR}${sbindir}
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/rndc-confgen.8 ${DESTDIR}${mandir}/man8
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/ddns-confgen.8 ${DESTDIR}${mandir}/man8
|
||||||
|
(cd ${DESTDIR}${sbindir}; rm -f tsig-keygen@EXEEXT@; ${LINK_PROGRAM} ddns-confgen@EXEEXT@ tsig-keygen@EXEEXT@)
|
||||||
|
- (cd ${DESTDIR}${mandir}/man8; rm -f tsig-keygen.8; ${LINK_PROGRAM} ddns-confgen.8 tsig-keygen.8)
|
||||||
|
|
||||||
|
uninstall::
|
||||||
|
rm -f ${DESTDIR}${mandir}/man8/tsig-keygen.8
|
||||||
|
diff --git a/bin/delv/Makefile.in b/bin/delv/Makefile.in
|
||||||
|
index e2d2802262..19361a83ea 100644
|
||||||
|
--- a/bin/delv/Makefile.in
|
||||||
|
+++ b/bin/delv/Makefile.in
|
||||||
|
@@ -63,10 +63,12 @@ installdirs:
|
||||||
|
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${bindir}
|
||||||
|
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man1
|
||||||
|
|
||||||
|
-install:: delv@EXEEXT@ installdirs
|
||||||
|
+install-man1: delv.1
|
||||||
|
+ ${INSTALL_DATA} $^ ${DESTDIR}${mandir}/man1
|
||||||
|
+
|
||||||
|
+install:: delv@EXEEXT@ installdirs install-man1
|
||||||
|
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} \
|
||||||
|
delv@EXEEXT@ ${DESTDIR}${bindir}
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/delv.1 ${DESTDIR}${mandir}/man1
|
||||||
|
|
||||||
|
uninstall::
|
||||||
|
rm -f ${DESTDIR}${mandir}/man1/delv.1
|
||||||
|
diff --git a/bin/dig/Makefile.in b/bin/dig/Makefile.in
|
||||||
|
index 773ac46395..3edd951e7e 100644
|
||||||
|
--- a/bin/dig/Makefile.in
|
||||||
|
+++ b/bin/dig/Makefile.in
|
||||||
|
@@ -91,16 +91,16 @@ installdirs:
|
||||||
|
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${bindir}
|
||||||
|
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man1
|
||||||
|
|
||||||
|
-install:: dig@EXEEXT@ host@EXEEXT@ nslookup@EXEEXT@ installdirs
|
||||||
|
+install-man1: ${MANPAGES}
|
||||||
|
+ ${INSTALL_DATA} $^ ${DESTDIR}${mandir}/man1
|
||||||
|
+
|
||||||
|
+install:: dig@EXEEXT@ host@EXEEXT@ nslookup@EXEEXT@ installdirs install-man1
|
||||||
|
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} \
|
||||||
|
dig@EXEEXT@ ${DESTDIR}${bindir}
|
||||||
|
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} \
|
||||||
|
host@EXEEXT@ ${DESTDIR}${bindir}
|
||||||
|
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} \
|
||||||
|
nslookup@EXEEXT@ ${DESTDIR}${bindir}
|
||||||
|
- for m in ${MANPAGES}; do \
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/$$m ${DESTDIR}${mandir}/man1; \
|
||||||
|
- done
|
||||||
|
|
||||||
|
uninstall::
|
||||||
|
for m in ${MANPAGES}; do \
|
||||||
|
diff --git a/bin/dnssec/Makefile.in b/bin/dnssec/Makefile.in
|
||||||
|
index 1be1d5ffc6..1d0c4ce5c1 100644
|
||||||
|
--- a/bin/dnssec/Makefile.in
|
||||||
|
+++ b/bin/dnssec/Makefile.in
|
||||||
|
@@ -110,9 +110,11 @@ installdirs:
|
||||||
|
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${sbindir}
|
||||||
|
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man8
|
||||||
|
|
||||||
|
-install:: ${TARGETS} installdirs
|
||||||
|
+install-man8: ${MANPAGES}
|
||||||
|
+ ${INSTALL_DATA} $^ ${DESTDIR}${mandir}/man8
|
||||||
|
+
|
||||||
|
+install:: ${TARGETS} installdirs install-man8
|
||||||
|
for t in ${TARGETS}; do ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} $$t ${DESTDIR}${sbindir}; done
|
||||||
|
- for m in ${MANPAGES}; do ${INSTALL_DATA} ${srcdir}/$$m ${DESTDIR}${mandir}/man8; done
|
||||||
|
|
||||||
|
uninstall::
|
||||||
|
for m in ${MANPAGES}; do rm -f ${DESTDIR}${mandir}/man8/$$m ; done
|
||||||
|
diff --git a/bin/named/Makefile.in b/bin/named/Makefile.in
|
||||||
|
index 1c413973d0..03e4cb849b 100644
|
||||||
|
--- a/bin/named/Makefile.in
|
||||||
|
+++ b/bin/named/Makefile.in
|
||||||
|
@@ -172,12 +172,17 @@ installdirs:
|
||||||
|
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man5
|
||||||
|
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man8
|
||||||
|
|
||||||
|
-install:: named@EXEEXT@ lwresd@EXEEXT@ installdirs
|
||||||
|
+install-man5: named.conf.5
|
||||||
|
+ ${INSTALL_DATA} $^ ${DESTDIR}${mandir}/man5
|
||||||
|
+
|
||||||
|
+install-man8: named.8 lwresd.8
|
||||||
|
+ ${INSTALL_DATA} $^ ${DESTDIR}${mandir}/man8
|
||||||
|
+
|
||||||
|
+install-man: install-man5 install-man8
|
||||||
|
+
|
||||||
|
+install:: named@EXEEXT@ lwresd@EXEEXT@ installdirs install-man
|
||||||
|
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} named@EXEEXT@ ${DESTDIR}${sbindir}
|
||||||
|
(cd ${DESTDIR}${sbindir}; rm -f lwresd@EXEEXT@; @LN@ named@EXEEXT@ lwresd@EXEEXT@)
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/named.8 ${DESTDIR}${mandir}/man8
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/lwresd.8 ${DESTDIR}${mandir}/man8
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/named.conf.5 ${DESTDIR}${mandir}/man5
|
||||||
|
|
||||||
|
uninstall::
|
||||||
|
rm -f ${DESTDIR}${mandir}/man5/named.conf.5
|
||||||
|
diff --git a/bin/pkcs11/Makefile.in b/bin/pkcs11/Makefile.in
|
||||||
|
index ae9061626c..a058c91214 100644
|
||||||
|
--- a/bin/pkcs11/Makefile.in
|
||||||
|
+++ b/bin/pkcs11/Makefile.in
|
||||||
|
@@ -71,7 +71,10 @@ installdirs:
|
||||||
|
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${sbindir}
|
||||||
|
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man8
|
||||||
|
|
||||||
|
-install:: ${TARGETS} installdirs
|
||||||
|
+install-man8: ${MANPAGES}
|
||||||
|
+ ${INSTALL_DATA} $^ ${DESTDIR}${mandir}/man8
|
||||||
|
+
|
||||||
|
+install:: ${TARGETS} installdirs install-man8
|
||||||
|
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} pkcs11-list@EXEEXT@ \
|
||||||
|
${DESTDIR}${sbindir}
|
||||||
|
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} pkcs11-destroy@EXEEXT@ \
|
||||||
|
@@ -80,10 +83,6 @@ install:: ${TARGETS} installdirs
|
||||||
|
${DESTDIR}${sbindir}
|
||||||
|
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} pkcs11-tokens@EXEEXT@ \
|
||||||
|
${DESTDIR}${sbindir}
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/pkcs11-list.8 ${DESTDIR}${mandir}/man8
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/pkcs11-destroy.8 ${DESTDIR}${mandir}/man8
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/pkcs11-keygen.8 ${DESTDIR}${mandir}/man8
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/pkcs11-tokens.8 ${DESTDIR}${mandir}/man8
|
||||||
|
|
||||||
|
uninstall::
|
||||||
|
rm -f ${DESTDIR}${mandir}/man8/pkcs11-tokens.8
|
||||||
|
diff --git a/bin/python/Makefile.in b/bin/python/Makefile.in
|
||||||
|
index aa678d47ab..064c404e2f 100644
|
||||||
|
--- a/bin/python/Makefile.in
|
||||||
|
+++ b/bin/python/Makefile.in
|
||||||
|
@@ -47,13 +47,13 @@ installdirs:
|
||||||
|
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${sbindir}
|
||||||
|
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man8
|
||||||
|
|
||||||
|
-install:: ${TARGETS} installdirs
|
||||||
|
+install-man8: ${MANPAGES}
|
||||||
|
+ ${INSTALL_DATA} $^ ${DESTDIR}${mandir}/man8
|
||||||
|
+
|
||||||
|
+install:: ${TARGETS} installdirs install-man8
|
||||||
|
${INSTALL_SCRIPT} dnssec-checkds ${DESTDIR}${sbindir}
|
||||||
|
${INSTALL_SCRIPT} dnssec-coverage ${DESTDIR}${sbindir}
|
||||||
|
${INSTALL_SCRIPT} dnssec-keymgr ${DESTDIR}${sbindir}
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/dnssec-checkds.8 ${DESTDIR}${mandir}/man8
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/dnssec-coverage.8 ${DESTDIR}${mandir}/man8
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/dnssec-keymgr.8 ${DESTDIR}${mandir}/man8
|
||||||
|
if test -n "${PYTHON}" ; then \
|
||||||
|
if test -n "${DESTDIR}" ; then \
|
||||||
|
${PYTHON} ${srcdir}/setup.py install --root=${DESTDIR} --prefix=${prefix} @PYTHON_INSTALL_LIB@ ; \
|
||||||
|
diff --git a/bin/tools/Makefile.in b/bin/tools/Makefile.in
|
||||||
|
index 7bf2af4cea..c395bc7462 100644
|
||||||
|
--- a/bin/tools/Makefile.in
|
||||||
|
+++ b/bin/tools/Makefile.in
|
||||||
|
@@ -119,17 +119,27 @@ installdirs:
|
||||||
|
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man1
|
||||||
|
$(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man8
|
||||||
|
|
||||||
|
-nzd:
|
||||||
|
+nzd-man: named-nzd2nzf.8
|
||||||
|
+ ${INSTALL_DATA} $^ ${DESTDIR}${mandir}/man8
|
||||||
|
+
|
||||||
|
+nzd: nzd-man
|
||||||
|
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} named-nzd2nzf@EXEEXT@ \
|
||||||
|
${DESTDIR}${sbindir}
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/named-nzd2nzf.8 ${DESTDIR}${mandir}/man8
|
||||||
|
|
||||||
|
-dnstap:
|
||||||
|
+dnstap-man: dnstap-read.1
|
||||||
|
+ ${INSTALL_DATA} $^ ${DESTDIR}${mandir}/man1
|
||||||
|
+
|
||||||
|
+dnstap: dnstap-man
|
||||||
|
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} dnstap-read@EXEEXT@ \
|
||||||
|
${DESTDIR}${bindir}
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/dnstap-read.1 ${DESTDIR}${mandir}/man1
|
||||||
|
|
||||||
|
-install:: ${TARGETS} installdirs @DNSTAP@ @NZD_TOOLS@
|
||||||
|
+install-man1: arpaname.1 named-rrchecker.1 mdig.1
|
||||||
|
+ ${INSTALL_DATA} $^ ${DESTDIR}${mandir}/man1
|
||||||
|
+
|
||||||
|
+install-man8: named-journalprint.8 nsec3hash.8
|
||||||
|
+ ${INSTALL_DATA} $^ ${DESTDIR}${mandir}/man8
|
||||||
|
+
|
||||||
|
+install:: ${TARGETS} installdirs @DNSTAP@ @NZD_TOOLS@ install-man1 install-man8
|
||||||
|
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} arpaname@EXEEXT@ \
|
||||||
|
${DESTDIR}${bindir}
|
||||||
|
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} named-journalprint@EXEEXT@ \
|
||||||
|
@@ -144,13 +154,8 @@ install:: ${TARGETS} installdirs @DNSTAP@ @NZD_TOOLS@
|
||||||
|
${DESTDIR}${sbindir}
|
||||||
|
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} mdig@EXEEXT@ \
|
||||||
|
${DESTDIR}${bindir}
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/arpaname.1 ${DESTDIR}${mandir}/man1
|
||||||
|
${INSTALL_DATA} ${srcdir}/isc-hmac-fixup.8 ${DESTDIR}${mandir}/man8
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/named-journalprint.8 ${DESTDIR}${mandir}/man8
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/named-rrchecker.1 ${DESTDIR}${mandir}/man1
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/nsec3hash.8 ${DESTDIR}${mandir}/man8
|
||||||
|
${INSTALL_DATA} ${srcdir}/genrandom.8 ${DESTDIR}${mandir}/man8
|
||||||
|
- ${INSTALL_DATA} ${srcdir}/mdig.1 ${DESTDIR}${mandir}/man1
|
||||||
|
|
||||||
|
uninstall::
|
||||||
|
rm -f ${DESTDIR}${mandir}/man1/mdig.1
|
||||||
|
--
|
||||||
|
2.14.4
|
||||||
|
|
@ -52,7 +52,7 @@ Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) serv
|
|||||||
Name: bind
|
Name: bind
|
||||||
License: MPLv2.0
|
License: MPLv2.0
|
||||||
Version: 9.11.4
|
Version: 9.11.4
|
||||||
Release: 1%{?PATCHVER:.%{PATCHVER}}%{?PREVER:.%{PREVER}}%{?dist}
|
Release: 2%{?PATCHVER:.%{PATCHVER}}%{?PREVER:.%{PREVER}}%{?dist}
|
||||||
Epoch: 32
|
Epoch: 32
|
||||||
Url: http://www.isc.org/products/BIND/
|
Url: http://www.isc.org/products/BIND/
|
||||||
#
|
#
|
||||||
@ -110,6 +110,7 @@ Patch145:bind-9.11-rh1205168.patch
|
|||||||
# [ISC-Bugs #46853] commit cb616c6d5c2ece1fac37fa6e0bca2b53d4043098 ISC 4851
|
# [ISC-Bugs #46853] commit cb616c6d5c2ece1fac37fa6e0bca2b53d4043098 ISC 4851
|
||||||
Patch149:bind-9.11-kyua-pkcs11.patch
|
Patch149:bind-9.11-kyua-pkcs11.patch
|
||||||
Patch153:bind-9.11-export-suffix.patch
|
Patch153:bind-9.11-export-suffix.patch
|
||||||
|
Patch154:bind-9.11-oot-manual.patch
|
||||||
|
|
||||||
# SDB patches
|
# SDB patches
|
||||||
Patch11: bind-9.3.2b2-sdbsrc.patch
|
Patch11: bind-9.3.2b2-sdbsrc.patch
|
||||||
@ -443,6 +444,7 @@ are used for building ISC DHCP.
|
|||||||
%patch140 -p1 -b .rh1410433
|
%patch140 -p1 -b .rh1410433
|
||||||
%patch145 -p1 -b .rh1205168
|
%patch145 -p1 -b .rh1205168
|
||||||
%patch153 -p1 -b .export_suffix
|
%patch153 -p1 -b .export_suffix
|
||||||
|
%patch154 -p1 -b .oot-man
|
||||||
|
|
||||||
%if %{with PKCS11}
|
%if %{with PKCS11}
|
||||||
cp -r bin/named{,-pkcs11}
|
cp -r bin/named{,-pkcs11}
|
||||||
@ -1400,6 +1402,9 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 31 2018 Petr Menšík <pemensik@redhat.com> - 32:9.11.4-2
|
||||||
|
- Install generated manual pages
|
||||||
|
|
||||||
* Thu Jul 12 2018 Petr Menšík <pemensik@redhat.com> - 32:9.11.4-1
|
* Thu Jul 12 2018 Petr Menšík <pemensik@redhat.com> - 32:9.11.4-1
|
||||||
- Update to 9.11.4
|
- Update to 9.11.4
|
||||||
- Use kyua instead of kyua-cli for unit tests
|
- Use kyua instead of kyua-cli for unit tests
|
||||||
|
Loading…
Reference in New Issue
Block a user