- updated patches due new rpm (--fuzz=0 patch parameter)

This commit is contained in:
Adam Tkac 2008-07-21 10:47:18 +00:00
parent 73e3d597bb
commit 1e57f4955e
4 changed files with 73 additions and 67 deletions

View File

@ -1,6 +1,7 @@
--- bind-9.2.0rc3/bin/named/include/named/globals.h.varrun Thu Sep 13 01:59:38 2001
+++ bind-9.2.0rc3/bin/named/include/named/globals.h Fri Sep 14 12:45:42 2001
@@ -102,9 +102,9 @@
diff -up bind-9.5.1b1/bin/named/include/named/globals.h.varrun bind-9.5.1b1/bin/named/include/named/globals.h
--- bind-9.5.1b1/bin/named/include/named/globals.h.varrun 2007-09-26 05:22:43.000000000 +0200
+++ bind-9.5.1b1/bin/named/include/named/globals.h 2008-07-21 12:13:33.000000000 +0200
@@ -107,9 +107,9 @@ EXTERN isc_boolean_t ns_g_foreground I
EXTERN isc_boolean_t ns_g_logstderr INIT(ISC_FALSE);
EXTERN const char * ns_g_defaultpidfile INIT(NS_LOCALSTATEDIR
@ -11,4 +12,4 @@
+ "/run/named/lwresd.pid");
EXTERN const char * ns_g_username INIT(NULL);
#undef EXTERN
EXTERN int ns_g_listen INIT(3);

View File

@ -1,6 +1,7 @@
--- bind-9.3.2b1/bin/sdb_tools/Makefile.in.fix_sdb_ldap 2005-02-17 01:43:28.000000000 -0500
+++ bind-9.3.2b1/bin/sdb_tools/Makefile.in 2005-10-06 18:57:32.000000000 -0400
@@ -30,11 +30,11 @@
diff -up bind-9.5.1b1/bin/sdb_tools/Makefile.in.fix_sdb_ldap bind-9.5.1b1/bin/sdb_tools/Makefile.in
--- bind-9.5.1b1/bin/sdb_tools/Makefile.in.fix_sdb_ldap 2008-07-21 12:14:00.000000000 +0200
+++ bind-9.5.1b1/bin/sdb_tools/Makefile.in 2008-07-21 12:17:51.000000000 +0200
@@ -30,11 +30,11 @@ DEPLIBS = ${LWRESDEPLIBS} ${DNSDEPLIBS}
LIBS = ${LWRESLIBS} ${DNSLIBS} ${BIND9LIBS} \
${ISCCFGLIBS} ${ISCCCLIBS} ${ISCLIBS} ${DBDRIVER_LIBS} @LIBS@
@ -15,25 +16,26 @@
MANPAGES = zone2ldap.1
@@ -54,6 +54,9 @@
zonetodb@EXEEXT@: zonetodb.@O@ ${DEPLIBS}
${LIBTOOL_MODE_LINK} ${PURIFY} ${CC} ${ALL_CFLAGS} ${LDFLAGS} -o $@ zonetodb.@O@ -lpq ${LIBS}
@@ -48,6 +48,9 @@ zone2ldap@EXEEXT@: zone2ldap.@O@ ${DEPLI
zonetodb@EXEEXT@: zonetodb.@O@ ${DEPLIBS}
${LIBTOOL_MODE_LINK} ${PURIFY} ${CC} ${CFLAGS} ${LDFLAGS} -o $@ zonetodb.@O@ -lpq ${LIBS}
+ldap2zone@EXEEXT@: ldap2zone.@O@ ${DEPLIBS}
+ldap2zone@EXEEXT@: ldap2zone.@O@ ${DEPLIBS}
+ ${LIBTOOL_MODE_LINK} ${PURIFY} ${CC} ${ALL_CFLAGS} ${LDFLAGS} -o $@ ldap2zone.@O@ -lldap -llber ${LIBS}
+
clean distclean manclean maintainer-clean::
rm -f ${TARGETS} ${OBJS}
@@ -63,5 +66,6 @@
@@ -57,5 +60,6 @@ installdirs:
install:: ${TARGETS} installdirs
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} zone2ldap@EXEEXT@ ${DESTDIR}${sbindir}
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} ldap2zone@EXEEXT@ ${DESTDIR}${sbindir}
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} zonetodb@EXEEXT@ ${DESTDIR}${sbindir}
${INSTALL_DATA} ${srcdir}/zone2ldap.1 ${DESTDIR}${mandir}/man1/zone2ldap.1
--- bind-9.3.2b1/bin/sdb_tools/zone2ldap.c.fix_sdb_ldap 2005-10-06 18:57:32.000000000 -0400
+++ bind-9.3.2b1/bin/sdb_tools/zone2ldap.c 2005-10-06 18:57:32.000000000 -0400
diff -up bind-9.5.1b1/bin/sdb_tools/zone2ldap.c.fix_sdb_ldap bind-9.5.1b1/bin/sdb_tools/zone2ldap.c
--- bind-9.5.1b1/bin/sdb_tools/zone2ldap.c.fix_sdb_ldap 2008-07-21 12:14:00.000000000 +0200
+++ bind-9.5.1b1/bin/sdb_tools/zone2ldap.c 2008-07-21 12:14:00.000000000 +0200
@@ -24,6 +24,7 @@
#include <isc/hash.h>
#include <isc/mem.h>
@ -42,7 +44,7 @@
#include <isc/result.h>
#include <dns/db.h>
@@ -61,6 +62,9 @@
@@ -61,6 +62,9 @@ ldap_info;
/* usage Info */
void usage (void);
@ -52,7 +54,7 @@
/* Add to the ldap dit */
void add_ldap_values (ldap_info * ldinfo);
@@ -77,7 +81,7 @@
@@ -77,7 +81,7 @@ char **hostname_to_dn_list (char *hostna
int get_attr_list_size (char **tmp);
/* Get a DN */
@ -61,7 +63,7 @@
/* Add to RR list */
void add_to_rr_list (char *dn, char *name, char *type, char *data,
@@ -99,11 +103,27 @@
@@ -99,11 +103,27 @@ void
init_ldap_conn ();
void usage();
@ -94,7 +96,7 @@
LDAP *conn;
unsigned int debug = 0;
@@ -119,12 +139,12 @@
@@ -119,12 +139,12 @@ main (int argc, char **argv)
isc_result_t result;
char *basedn;
ldap_info *tmp;
@ -110,7 +112,7 @@
dns_fixedname_t fixedzone, fixedname;
dns_rdataset_t rdataset;
char **dc_list;
@@ -137,7 +157,7 @@
@@ -137,7 +157,7 @@ main (int argc, char **argv)
extern char *optarg;
extern int optind, opterr, optopt;
int create_base = 0;
@ -119,7 +121,7 @@
if ((int) argc < 2)
{
@@ -145,7 +165,7 @@
@@ -145,7 +165,7 @@ main (int argc, char **argv)
exit (-1);
}
@ -128,7 +130,7 @@
{
switch (topt)
{
@@ -164,8 +184,11 @@
@@ -164,8 +184,11 @@ main (int argc, char **argv)
case 'w':
bindpw = strdup (optarg);
break;
@ -141,7 +143,7 @@
break;
case 'z':
argzone = strdup (optarg);
@@ -277,27 +300,62 @@
@@ -277,27 +300,62 @@ main (int argc, char **argv)
{
if (debug)
printf ("Creating base zone DN %s\n", argzone);
@ -214,7 +216,7 @@
}
else
{
@@ -306,8 +364,13 @@
@@ -306,8 +364,13 @@ main (int argc, char **argv)
else
sprintf (fullbasedn, "%s", ctmp);
}
@ -228,7 +230,7 @@
}
}
@@ -383,14 +446,14 @@
@@ -383,14 +446,14 @@ generate_ldap (dns_name_t * dnsname, dns
isc_result_check (result, "dns_rdata_totext");
data[isc_buffer_usedlength (&buff)] = 0;
@ -246,7 +248,7 @@
}
@@ -430,7 +493,8 @@
@@ -430,7 +493,8 @@ add_to_rr_list (char *dn, char *name, ch
int attrlist;
char ldap_type_buffer[128];
char charttl[64];
@ -256,7 +258,7 @@
if ((tmp = locate_by_dn (dn)) == NULL)
{
@@ -465,13 +529,13 @@
@@ -465,13 +529,13 @@ add_to_rr_list (char *dn, char *name, ch
}
}
tmp->attrs[0]->mod_op = LDAP_MOD_ADD;
@ -273,7 +275,7 @@
tmp->attrs[1] = NULL;
tmp->attrcnt = 2;
tmp->next = ldap_info_base;
@@ -480,7 +544,7 @@
@@ -480,7 +544,7 @@ add_to_rr_list (char *dn, char *name, ch
}
tmp->attrs[1]->mod_op = LDAP_MOD_ADD;
@ -282,7 +284,7 @@
tmp->attrs[1]->mod_values = (char **) calloc (sizeof (char *), 2);
if (tmp->attrs[1]->mod_values == (char **)NULL)
@@ -502,7 +566,7 @@
@@ -502,7 +566,7 @@ add_to_rr_list (char *dn, char *name, ch
tmp->attrs[2]->mod_values[1] = NULL;
tmp->attrs[3]->mod_op = LDAP_MOD_ADD;
@ -291,7 +293,7 @@
tmp->attrs[3]->mod_values = (char **) calloc (sizeof (char *), 2);
if (tmp->attrs[3]->mod_values == (char **)NULL)
@@ -512,10 +576,21 @@
@@ -512,10 +576,21 @@ add_to_rr_list (char *dn, char *name, ch
tmp->attrs[3]->mod_values[0] = strdup (charttl);
tmp->attrs[3]->mod_values[1] = NULL;
@ -315,7 +317,7 @@
tmp->attrs[4]->mod_values[1] = NULL;
tmp->attrs[5] = NULL;
@@ -526,7 +601,7 @@
@@ -526,7 +601,7 @@ add_to_rr_list (char *dn, char *name, ch
else
{
@ -324,7 +326,7 @@
{
sprintf (ldap_type_buffer, "%sRecord", type);
if (!strncmp
@@ -595,69 +670,105 @@
@@ -595,69 +670,105 @@ char **
hostname_to_dn_list (char *hostname, char *zone, unsigned int flags)
{
char *tmp;
@ -468,7 +470,7 @@
else
sprintf(tmp,"dc=%s,", dc_list[x]);
}
@@ -683,6 +794,7 @@
@@ -683,6 +794,7 @@ void
init_ldap_conn ()
{
int result;
@ -476,7 +478,7 @@
conn = ldap_open (ldapsystem, LDAP_PORT);
if (conn == NULL)
{
@@ -692,7 +804,7 @@
@@ -692,7 +804,7 @@ init_ldap_conn ()
}
result = ldap_simple_bind_s (conn, binddn, bindpw);
@ -485,7 +487,7 @@
}
/* Like isc_result_check, only for LDAP */
@@ -709,8 +821,6 @@
@@ -709,8 +821,6 @@ ldap_result_check (const char *msg, char
}
}
@ -494,7 +496,7 @@
/* For running the ldap_info run queue. */
void
add_ldap_values (ldap_info * ldinfo)
@@ -718,14 +828,14 @@
@@ -718,14 +828,14 @@ add_ldap_values (ldap_info * ldinfo)
int result;
char dnbuffer[1024];
@ -511,7 +513,7 @@
}
@@ -736,7 +846,7 @@
@@ -736,7 +846,7 @@ void
usage ()
{
fprintf (stderr,

View File

@ -1,23 +1,6 @@
diff -up bind-9.5.0b2/bin/named-sdb/Makefile.in.sdb-sqlite-bld bind-9.5.0b2/bin/named/Makefile.in
--- bind-9.5.0b2/bin/named-sdb/Makefile.in.sdb-sqlite-bld 2008-02-11 17:44:32.000000000 +0100
+++ bind-9.5.0b2/bin/named-sdb/Makefile.in 2008-02-11 17:46:00.000000000 +0100
@@ -26,10 +26,10 @@ top_srcdir = @top_srcdir@
#
# Add database drivers here.
#
-DBDRIVER_OBJS = ldapdb.@O@ pgsqldb.@O@ dirdb.@O@
-DBDRIVER_SRCS = ldapdb.c pgsqldb.c dirdb.c
+DBDRIVER_OBJS = ldapdb.@O@ pgsqldb.@O@ sqlitedb.@O@ dirdb.@O@
+DBDRIVER_SRCS = ldapdb.c pgsqldb.c sqlitedb.c dirdb.c
DBDRIVER_INCLUDES =
-DBDRIVER_LIBS = -lldap -llber -lpq
+DBDRIVER_LIBS = -lldap -llber -lpq -lsqlite3
DLZ_DRIVER_DIR = ${top_srcdir}/contrib/dlz/drivers
diff -up bind-9.5.0b2/bin/named-sdb/main.c.sdb-sqlite-bld bind-9.5.0b2/bin/named/main-sdb.c
--- bind-9.5.0b2/bin/named-sdb/main.c.sdb-sqlite-bld 2008-02-11 17:44:32.000000000 +0100
+++ bind-9.5.0b2/bin/named-sdb/main.c 2008-02-11 17:44:33.000000000 +0100
diff -up bind-9.5.1b1/bin/named-sdb/main.c.sdb-sqlite-bld bind-9.5.1b1/bin/named-sdb/main.c
--- bind-9.5.1b1/bin/named-sdb/main.c.sdb-sqlite-bld 2008-07-21 12:19:50.000000000 +0200
+++ bind-9.5.1b1/bin/named-sdb/main.c 2008-07-21 12:19:50.000000000 +0200
@@ -74,6 +74,7 @@
/* #include "xxdb.h" */
#include "ldapdb.h"
@ -66,9 +49,26 @@ diff -up bind-9.5.0b2/bin/named-sdb/main.c.sdb-sqlite-bld bind-9.5.0b2/bin/named
dirdb_clear();
isc_log_write(ns_g_lctx, NS_LOGCATEGORY_GENERAL, NS_LOGMODULE_MAIN,
diff -up bind-9.5.0b2/bin/sdb_tools/Makefile.in.sdb-sqlite-bld bind-9.5.0b2/bin/sdb_tools/Makefile.in
--- bind-9.5.0b2/bin/sdb_tools/Makefile.in.sdb-sqlite-bld 2008-02-11 17:44:33.000000000 +0100
+++ bind-9.5.0b2/bin/sdb_tools/Makefile.in 2008-02-11 17:44:33.000000000 +0100
diff -up bind-9.5.1b1/bin/named-sdb/Makefile.in.sdb-sqlite-bld bind-9.5.1b1/bin/named-sdb/Makefile.in
--- bind-9.5.1b1/bin/named-sdb/Makefile.in.sdb-sqlite-bld 2008-07-21 12:19:50.000000000 +0200
+++ bind-9.5.1b1/bin/named-sdb/Makefile.in 2008-07-21 12:19:50.000000000 +0200
@@ -26,10 +26,10 @@ top_srcdir = @top_srcdir@
#
# Add database drivers here.
#
-DBDRIVER_OBJS = ldapdb.@O@ pgsqldb.@O@ dirdb.@O@
-DBDRIVER_SRCS = ldapdb.c pgsqldb.c dirdb.c
+DBDRIVER_OBJS = ldapdb.@O@ pgsqldb.@O@ sqlitedb.@O@ dirdb.@O@
+DBDRIVER_SRCS = ldapdb.c pgsqldb.c sqlitedb.c dirdb.c
DBDRIVER_INCLUDES =
-DBDRIVER_LIBS = -lldap -llber -lpq
+DBDRIVER_LIBS = -lldap -llber -lpq -lsqlite3
DLZ_DRIVER_DIR = ${top_srcdir}/contrib/dlz/drivers
diff -up bind-9.5.1b1/bin/sdb_tools/Makefile.in.sdb-sqlite-bld bind-9.5.1b1/bin/sdb_tools/Makefile.in
--- bind-9.5.1b1/bin/sdb_tools/Makefile.in.sdb-sqlite-bld 2008-07-21 12:19:50.000000000 +0200
+++ bind-9.5.1b1/bin/sdb_tools/Makefile.in 2008-07-21 12:22:13.000000000 +0200
@@ -30,11 +30,11 @@ DEPLIBS = ${LWRESDEPLIBS} ${DNSDEPLIBS}
LIBS = ${LWRESLIBS} ${DNSLIBS} ${BIND9LIBS} \
${ISCCFGLIBS} ${ISCCCLIBS} ${ISCLIBS} ${DBDRIVER_LIBS} @LIBS@
@ -84,17 +84,17 @@ diff -up bind-9.5.0b2/bin/sdb_tools/Makefile.in.sdb-sqlite-bld bind-9.5.0b2/bin/
MANPAGES = zone2ldap.1
@@ -54,6 +54,9 @@ zone2ldap: zone2ldap.o ${DEPLIBS}
zonetodb@EXEEXT@: zonetodb.@O@ ${DEPLIBS}
${LIBTOOL_MODE_LINK} ${PURIFY} ${CC} ${ALL_CFLAGS} ${LDFLAGS} -o $@ zonetodb.@O@ -lpq ${LIBS}
@@ -48,6 +48,9 @@ zone2ldap@EXEEXT@: zone2ldap.@O@ ${DEPLI
zonetodb@EXEEXT@: zonetodb.@O@ ${DEPLIBS}
${LIBTOOL_MODE_LINK} ${PURIFY} ${CC} ${CFLAGS} ${LDFLAGS} -o $@ zonetodb.@O@ -lpq ${LIBS}
+zone2sqlite@EXEEXT@: zone2sqlite.@O@ ${DEPLIBS}
+zone2sqlite@EXEEXT@: zone2sqlite.@O@ ${DEPLIBS}
+ ${LIBTOOL_MODE_LINK} ${PURIFY} ${CC} ${ALL_CFLAGS} ${LDFLAGS} -o $@ zone2sqlite.@O@ -lsqlite3 -lssl ${LIBS}
+
ldap2zone@EXEEXT@: ldap2zone.@O@ ${DEPLIBS}
${LIBTOOL_MODE_LINK} ${PURIFY} ${CC} ${CFLAGS} ${LDFLAGS} -o $@ ldap2zone.@O@ -lldap -llber ${LIBS}
ldap2zone@EXEEXT@: ldap2zone.@O@ ${DEPLIBS}
${LIBTOOL_MODE_LINK} ${PURIFY} ${CC} ${ALL_CFLAGS} ${LDFLAGS} -o $@ ldap2zone.@O@ -lldap -llber ${LIBS}
@@ -68,4 +71,5 @@ install:: ${TARGETS} installdirs
@@ -62,4 +65,5 @@ install:: ${TARGETS} installdirs
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} zone2ldap@EXEEXT@ ${DESTDIR}${sbindir}
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} ldap2zone@EXEEXT@ ${DESTDIR}${sbindir}
${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} zonetodb@EXEEXT@ ${DESTDIR}${sbindir}

View File

@ -19,7 +19,7 @@ Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) serv
Name: bind
License: ISC
Version: 9.5.1
Release: 0.1.1.%{PREVER}%{?dist}
Release: 0.2.%{PREVER}%{?dist}
Epoch: 32
Url: http://www.isc.org/products/BIND/
Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -637,6 +637,9 @@ rm -rf ${RPM_BUILD_ROOT}
%{_sbindir}/bind-chroot-admin
%changelog
* Mon Jul 21 2008 Adam Tkac <atkac redhat com> 32:9.5.1-0.2.b1
- updated patches due new rpm (--fuzz=0 patch parameter)
* Mon Jul 14 2008 Adam Tkac <atkac redhat com> 32:9.5.1-0.1.1.b1
- use %%patch0 for Patch0 (#455061)
- correct source address (#455118)