update to 9.9.3
- install dns/update.h header Signed-off-by: Tomas Hozza <thozza@redhat.com>
This commit is contained in:
parent
2cc782fdff
commit
1bf060007d
1
.gitignore
vendored
1
.gitignore
vendored
@ -33,3 +33,4 @@ bind-9.7.2b1.tar.gz
|
|||||||
/bind-9.9.3rc1.tar.gz
|
/bind-9.9.3rc1.tar.gz
|
||||||
/config-11.tar.bz2
|
/config-11.tar.bz2
|
||||||
/bind-9.9.3rc2.tar.gz
|
/bind-9.9.3rc2.tar.gz
|
||||||
|
/bind-9.9.3.tar.gz
|
||||||
|
@ -1,51 +0,0 @@
|
|||||||
From 75f51e2f14d9fce2001aa91ad444e327321a19c3 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Tomas Hozza <thozza@redhat.com>
|
|
||||||
Date: Thu, 2 May 2013 15:05:51 +0200
|
|
||||||
Subject: [PATCH] Table name should be quoted when used in SQL commands
|
|
||||||
|
|
||||||
Table name should be quoted when dropping/creating/inserting in
|
|
||||||
some table. Currently zone2sqlite is unable to handle table
|
|
||||||
names starting with ".", "-", number, etc.
|
|
||||||
|
|
||||||
This can be solved by using "%Q" instead of "%q" in sqlite3_mprintf()
|
|
||||||
calls when inserting table name.
|
|
||||||
|
|
||||||
Signed-off-by: Tomas Hozza <thozza@redhat.com>
|
|
||||||
---
|
|
||||||
contrib/sdb/sqlite/zone2sqlite.c | 6 +++---
|
|
||||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/contrib/sdb/sqlite/zone2sqlite.c b/contrib/sdb/sqlite/zone2sqlite.c
|
|
||||||
index b583d2b..7b9260a 100644
|
|
||||||
--- a/contrib/sdb/sqlite/zone2sqlite.c
|
|
||||||
+++ b/contrib/sdb/sqlite/zone2sqlite.c
|
|
||||||
@@ -129,7 +129,7 @@ addrdata(dns_name_t *name, dns_ttl_t ttl, dns_rdata_t *rdata)
|
|
||||||
dataarray[isc_buffer_usedlength(&b)] = 0;
|
|
||||||
|
|
||||||
sql = sqlite3_mprintf(
|
|
||||||
- "INSERT INTO %q (NAME, TTL, RDTYPE, RDATA)"
|
|
||||||
+ "INSERT INTO %Q (NAME, TTL, RDTYPE, RDATA)"
|
|
||||||
" VALUES ('%q', %d, '%q', '%q') ",
|
|
||||||
dbi.table,
|
|
||||||
namearray, ttl, typearray, dataarray);
|
|
||||||
@@ -208,7 +208,7 @@ main(int argc, char *argv[])
|
|
||||||
closeandexit(1);
|
|
||||||
}
|
|
||||||
|
|
||||||
- sql = sqlite3_mprintf("DROP TABLE %q ", dbi.table);
|
|
||||||
+ sql = sqlite3_mprintf("DROP TABLE %Q ", dbi.table);
|
|
||||||
printf("%s\n", sql);
|
|
||||||
res = sqlite3_exec(dbi.db, sql, NULL, NULL, &errmsg);
|
|
||||||
sqlite3_free(sql);
|
|
||||||
@@ -231,7 +231,7 @@ main(int argc, char *argv[])
|
|
||||||
#endif
|
|
||||||
|
|
||||||
sql = sqlite3_mprintf(
|
|
||||||
- "CREATE TABLE %q "
|
|
||||||
+ "CREATE TABLE %Q "
|
|
||||||
"(NAME TEXT, TTL INTEGER, RDTYPE TEXT, RDATA TEXT) ",
|
|
||||||
dbi.table);
|
|
||||||
printf("%s\n", sql);
|
|
||||||
--
|
|
||||||
1.8.1.4
|
|
||||||
|
|
12
bind-9.9.3-include-update-h.patch
Normal file
12
bind-9.9.3-include-update-h.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up bind-9.9.3/lib/dns/include/dns/Makefile.in.update bind-9.9.3/lib/dns/include/dns/Makefile.in
|
||||||
|
--- bind-9.9.3/lib/dns/include/dns/Makefile.in.update 2013-06-03 09:29:41.049197873 +0200
|
||||||
|
+++ bind-9.9.3/lib/dns/include/dns/Makefile.in 2013-06-03 09:30:09.229213170 +0200
|
||||||
|
@@ -30,7 +30,7 @@ HEADERS = acl.h adb.h byaddr.h cache.h c
|
||||||
|
rdata.h rdataclass.h rdatalist.h rdataset.h rdatasetiter.h \
|
||||||
|
rdataslab.h rdatatype.h request.h resolver.h result.h \
|
||||||
|
rootns.h rpz.h sdb.h sdlz.h secalg.h secproto.h soa.h ssu.h \
|
||||||
|
- tcpmsg.h time.h tkey.h tsig.h ttl.h types.h \
|
||||||
|
+ tcpmsg.h time.h tkey.h tsig.h ttl.h types.h update.h\
|
||||||
|
validator.h version.h view.h xfrin.h zone.h zonekey.h zt.h \
|
||||||
|
forward.h rrl.h
|
||||||
|
|
18
bind.spec
18
bind.spec
@ -3,9 +3,9 @@
|
|||||||
#
|
#
|
||||||
|
|
||||||
#%%global PATCHVER P2
|
#%%global PATCHVER P2
|
||||||
%global PREVER rc2
|
#%%global PREVER rc2
|
||||||
%global VERSION %{version}%{PREVER}
|
#%%global VERSION %{version}%{PREVER}
|
||||||
#%%global VERSION %{version}
|
%global VERSION %{version}
|
||||||
#%%global VERSION %{version}-%{PATCHVER}
|
#%%global VERSION %{version}-%{PATCHVER}
|
||||||
|
|
||||||
%{?!SDB: %global SDB 1}
|
%{?!SDB: %global SDB 1}
|
||||||
@ -26,7 +26,7 @@ Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) serv
|
|||||||
Name: bind
|
Name: bind
|
||||||
License: ISC
|
License: ISC
|
||||||
Version: 9.9.3
|
Version: 9.9.3
|
||||||
Release: 0.7.%{PREVER}%{?dist}
|
Release: 1%{?PREVER}%{?dist}
|
||||||
Epoch: 32
|
Epoch: 32
|
||||||
Url: http://www.isc.org/products/BIND/
|
Url: http://www.isc.org/products/BIND/
|
||||||
Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot:%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -81,13 +81,13 @@ Patch133:bind99-rh640538.patch
|
|||||||
Patch134:bind97-rh669163.patch
|
Patch134:bind97-rh669163.patch
|
||||||
Patch136:rl-9.9.3rc2.patch
|
Patch136:rl-9.9.3rc2.patch
|
||||||
Patch137:bind99-rrl.patch
|
Patch137:bind99-rrl.patch
|
||||||
|
# Install dns/update.h header for bind-dyndb-ldap plugin
|
||||||
|
Patch138:bind-9.9.3-include-update-h.patch
|
||||||
|
|
||||||
# SDB patches
|
# SDB patches
|
||||||
Patch11: bind-9.3.2b2-sdbsrc.patch
|
Patch11: bind-9.3.2b2-sdbsrc.patch
|
||||||
Patch12: bind-9.5-sdb.patch
|
Patch12: bind-9.5-sdb.patch
|
||||||
Patch62: bind-9.5-sdb-sqlite-bld.patch
|
Patch62: bind-9.5-sdb-sqlite-bld.patch
|
||||||
# ISC-Bugs #33375
|
|
||||||
Patch139:bind-9.9-sdb-zone2sqlite-table-name.patch
|
|
||||||
|
|
||||||
# needs inpection
|
# needs inpection
|
||||||
Patch17: bind-9.3.2b1-fix_sdb_ldap.patch
|
Patch17: bind-9.3.2b1-fix_sdb_ldap.patch
|
||||||
@ -281,6 +281,7 @@ popd
|
|||||||
%patch131 -p1 -b .multlib-conflict
|
%patch131 -p1 -b .multlib-conflict
|
||||||
%patch136 -p1 -b .rl
|
%patch136 -p1 -b .rl
|
||||||
%patch137 -p1 -b .rrl
|
%patch137 -p1 -b .rrl
|
||||||
|
%patch138 -p1 -b .update
|
||||||
|
|
||||||
%if %{SDB}
|
%if %{SDB}
|
||||||
%patch101 -p1 -b .old-api
|
%patch101 -p1 -b .old-api
|
||||||
@ -292,7 +293,6 @@ cp -fp contrib/sdb/ldap/ldapdb.[ch] bin/named-sdb
|
|||||||
# SDB postgreSQL
|
# SDB postgreSQL
|
||||||
cp -fp contrib/sdb/pgsql/pgsqldb.[ch] bin/named-sdb
|
cp -fp contrib/sdb/pgsql/pgsqldb.[ch] bin/named-sdb
|
||||||
# SDB sqlite
|
# SDB sqlite
|
||||||
%patch139 -p1 -b .table_name
|
|
||||||
cp -fp contrib/sdb/sqlite/sqlitedb.[ch] bin/named-sdb
|
cp -fp contrib/sdb/sqlite/sqlitedb.[ch] bin/named-sdb
|
||||||
# SDB Berkeley DB - needs to be ported to DB4!
|
# SDB Berkeley DB - needs to be ported to DB4!
|
||||||
#cp -fp contrib/sdb/bdb/bdb.[ch] bin/named_sdb
|
#cp -fp contrib/sdb/bdb/bdb.[ch] bin/named_sdb
|
||||||
@ -779,6 +779,10 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 03 2013 Tomas Hozza <thozza@redhat.com> 32:9.9.3-1
|
||||||
|
- update to 9.9.3
|
||||||
|
- install dns/update.h header
|
||||||
|
|
||||||
* Fri May 17 2013 Tomas Hozza <thozza@redhat.com> 32:9.9.3-0.7.rc2
|
* Fri May 17 2013 Tomas Hozza <thozza@redhat.com> 32:9.9.3-0.7.rc2
|
||||||
- Fix segfault in host/nslookup (#878139)
|
- Fix segfault in host/nslookup (#878139)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user