Update to 9.16.19
Remove support for PREVER and PATCHVER, since upstream no longer releases them. Simplifies a bit versioning. Resolves: rhbz##1956777
This commit is contained in:
parent
91c5e974dc
commit
09ac3e24ac
2
.gitignore
vendored
2
.gitignore
vendored
@ -148,3 +148,5 @@ bind-9.7.2b1.tar.gz
|
||||
/bind-9.16.15.tar.xz.asc
|
||||
/bind-9.16.16.tar.xz
|
||||
/bind-9.16.16.tar.xz.asc
|
||||
/bind-9.16.19.tar.xz
|
||||
/bind-9.16.19.tar.xz.asc
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff --git a/lib/dns/dyndb.c b/lib/dns/dyndb.c
|
||||
index fdc8ea5..d638777 100644
|
||||
--- a/lib/dns/dyndb.c
|
||||
+++ b/lib/dns/dyndb.c
|
||||
@@ -131,7 +131,7 @@ load_library(isc_mem_t *mctx, const char *filename, const char *instname,
|
||||
instname, filename);
|
||||
|
||||
flags = RTLD_NOW | RTLD_LOCAL;
|
||||
-#if defined(RTLD_DEEPBIND) && !__SANITIZE_ADDRESS__
|
||||
+#if 0 && defined(RTLD_DEEPBIND) && !__SANITIZE_ADDRESS__
|
||||
flags |= RTLD_DEEPBIND;
|
||||
#endif /* if defined(RTLD_DEEPBIND) && !__SANITIZE_ADDRESS__ */
|
||||
|
21
bind.spec
21
bind.spec
@ -1,12 +1,8 @@
|
||||
#
|
||||
# Red Hat BIND package .spec file
|
||||
# Red Hat BIND9 package .spec file
|
||||
#
|
||||
# vim:expandtab ts=2:
|
||||
|
||||
#%%global PATCHVER P1
|
||||
#%%global PREVER rc1
|
||||
%global BINDVERSION %{version}%{?PREVER}%{?PATCHVER:-%{PATCHVER}}
|
||||
|
||||
# bcond_without is built by default, unless --without X is passed
|
||||
# bcond_with is built only when --with X is passed to build
|
||||
%bcond_with SYSTEMTEST
|
||||
@ -54,14 +50,14 @@
|
||||
Summary: The Berkeley Internet Name Domain (BIND) DNS (Domain Name System) server
|
||||
Name: bind
|
||||
License: MPLv2.0
|
||||
Version: 9.16.16
|
||||
Release: 1%{?PATCHVER:.%{PATCHVER}}%{?PREVER:.%{PREVER}}%{?dist}
|
||||
Version: 9.16.19
|
||||
Release: 1%{?dist}
|
||||
Epoch: 32
|
||||
Url: https://www.isc.org/downloads/bind/
|
||||
#
|
||||
Source0: https://downloads.isc.org/isc/bind9/%{BINDVERSION}/bind-%{BINDVERSION}.tar.xz
|
||||
Source0: https://downloads.isc.org/isc/bind9/%{version}/bind-%{version}.tar.xz
|
||||
Source1: named.sysconfig
|
||||
Source2: https://downloads.isc.org/isc/bind9/%{BINDVERSION}/bind-%{BINDVERSION}.tar.xz.asc
|
||||
Source2: https://downloads.isc.org/isc/bind9/%{version}/bind-%{version}.tar.xz.asc
|
||||
Source3: named.logrotate
|
||||
Source4: https://downloads.isc.org/isc/pgpkeys/codesign2021.txt
|
||||
Source16: named.conf
|
||||
@ -102,7 +98,6 @@ Patch136:bind-9.10-dist-native-pkcs11.patch
|
||||
# Do not use isc-pkcs11.
|
||||
Patch149:bind-9.11-kyua-pkcs11.patch
|
||||
|
||||
Patch140:bind-9.11-rh1410433.patch
|
||||
Patch157:bind-9.11-fips-tests.patch
|
||||
Patch164:bind-9.11-rh1666814.patch
|
||||
Patch170:bind-9.11-feature-test-named.patch
|
||||
@ -397,7 +392,7 @@ in HTML and PDF format.
|
||||
# RHEL does not yet support this verification
|
||||
%{gpgverify} --keyring='%{SOURCE4}' --signature='%{SOURCE2}' --data='%{SOURCE0}'
|
||||
%endif
|
||||
%setup -q -n %{name}-%{BINDVERSION}
|
||||
%setup -q
|
||||
|
||||
# Common patches
|
||||
%patch10 -p1 -b .PIE
|
||||
@ -406,7 +401,6 @@ in HTML and PDF format.
|
||||
%patch106 -p1 -b .rh490837
|
||||
%patch112 -p1 -b .rh645544
|
||||
%patch130 -p1 -b .libdb
|
||||
%patch140 -p1 -b .rh1410433
|
||||
%patch157 -p1 -b .fips-tests
|
||||
%patch164 -p1 -b .rh1666814
|
||||
%patch170 -p1 -b .featuretest-named
|
||||
@ -1131,6 +1125,9 @@ fi;
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jul 21 2021 Petr Menšík <pemensik@redhat.com> - 32:9.16.19-1
|
||||
- Update to 9.16.19 (#1956777)
|
||||
|
||||
* Thu Jun 24 2021 Petr Menšík <pemensik@redhat.com> - 32:9.16.16-1
|
||||
- Update to 9.16.16 (#1956777)
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (bind-9.16.16.tar.xz) = 264aa70d0d111ddb2a62c65f57e3eeb7eb93afdebcc523166d236e8f23d61d1e4f91b5a2df8dffa49e6f8e3c7101a2689c38dd6d77ecdedb79e2b163990e6093
|
||||
SHA512 (bind-9.16.16.tar.xz.asc) = 60cd60267553a2cff2055c431d69d3d6a72bf31ee123ef1af82c000ed6732e34a8f552c5b0f15cf74294dea17e9a251684820a3889ecd8eaf51c77ddd8411203
|
||||
SHA512 (bind-9.16.19.tar.xz) = 47a0867a34c73dd939f6e24ab63e1a9cc7ba3e4d42987dbf1be424afe320734587b09b26c3b3371861fe79e3ddc08a81a019bba0cadecf76e20f717103578dca
|
||||
SHA512 (bind-9.16.19.tar.xz.asc) = 91f35ce1eb53d874653f3bf56412cc8f90400e2064b1e0f5c9978f16a61a3eac0c19f80843fef49f4db0f4bc5e3df62458a6f09cada8f923ab8ea296165f4f2e
|
||||
|
Loading…
Reference in New Issue
Block a user